Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to change the interface to different language?

  • 12 replies
  • 6 have this problem
  • 10435 views
  • Last reply by cor-el

more options

continuation of this thread - https://support.mozilla.org/en-US/questions/1223137

I've followed the https://support.mozilla.org/en-US/kb/use-firefox-interface-other-languages-language-pack. However it doesn't change the interface language. They are still all in English.

I've just updated it to the latest version in order to use the language pack.

I do this instead of using an edition of the language I want because I suppose I could change the language on the fly, instead of installing two editions of different languages on the same system.

Attached screenshots

Modified by the-edmeister

Chosen solution

It appears that support for -UILocale has been removed (#1347306) and this switch is no longer mentioned in the command line article on MDN. There is a UI planned for switching the language (#1425941) via about:preferences, but there needs a lot to be done before it is ready, so the only way to switch the language is by modifying intl.locale.requested on the about:config page. You need to close and restart Firefox to make the change effective.

Read this answer in context 👍 0

All Replies (12)

more options

Hi, actually it does : https://support.mozilla.org/en-US/kb/use-firefox-interface-other-languages-language-pack#w_how-to-change-the-language-of-the-user-interface

You may want the dictionary for the language also so it spell checks.

Please let us know if this solved your issue or if need further assistance.

more options

Separate Security Issue, please update your Flash 27.0 r0 Flash Player Version: 30.0.0.113 Current Version https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, . . . .) Note: Other software is offered in the download. <Windows Only>

more options

You need to modify/create a string pref on the about:config page like written in the knowledge base article

  • intl.locale.requested = "ja"
    (without the quotes)

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.


Type intl.locale.requested in the Search field. Double-click the intl.locale.requested preference, if found, or add it as a new preference (see Configuration Editor for Firefox for details). Enter the code of the language you want to use as the string value or leave it blank to use the language of your system.

more options

Doesn't this setting refers to where one resides so that the browser brings up the local contents? I don't reside there. I just want to use the language.

more options

Pkshadow said

You may want the dictionary for the language also so it spell checks.

Does it help with the Japanese language?

more options

Pkshadow said

Separate Security Issue, please update your Flash 27.0 r0

Is the Flash update global or is it browser specific? I've just updated the Flash the other day.

more options

I've read https://developer.mozilla.org/en-US/docs/Mozilla/Command_Line_Options for the sake of being able to switch between two languages.

However it seems to be beyond my depth. I wish there was a much simpler way.

Never mind I might have to leave it at that for the time being.

more options

You can create copies of the Firefox desktop shortcut and add the parameter set set the language to each of them.

Firefox en-US version:

  • (64-bit Firefox)
    "C:\Program Files\Mozilla Firefox\firefox.exe" -UILocale en-US

Firefox 'ja' version:

  • (64-bit Firefox)
    "C:\Program Files\Mozilla Firefox\firefox.exe" -UILocale ja
more options

Thanks, I've tried both commands. Both open the Firefox.

However they don't bring up version of different language. They just follow the language setting of the intl.locale.

Thanks for your effort and help.

more options

Chosen Solution

It appears that support for -UILocale has been removed (#1347306) and this switch is no longer mentioned in the command line article on MDN. There is a UI planned for switching the language (#1425941) via about:preferences, but there needs a lot to be done before it is ready, so the only way to switch the language is by modifying intl.locale.requested on the about:config page. You need to close and restart Firefox to make the change effective.

more options

Thanks for all yours help.

more options

You're welcome.