X
Tap here to go to the mobile version of the site.

Support Forum

Firefox is freezing during flash videos, from anywebsite youtube or whatever, I dont know what to do..

Posted

Happened a few days ago, every time I play a flash video on my Firefox only! chrome and explorer works fine , the image freezes I need to start clicking around and all my icons turn black and it returns to normal and then freezes again, what the hell? this is my favorite browser and I don't want to move to chrome, so please help :(

Happened a few days ago, every time I play a flash video on my Firefox only! chrome and explorer works fine , the image freezes I need to start clicking around and all my icons turn black and it returns to normal and then freezes again, what the hell? this is my favorite browser and I don't want to move to chrome, so please help :(

Chosen solution

You can try to disable hardware acceleration in Firefox.

Close and restart Firefox after modifying the setting to make the change effective.

You can check if there is an update for your graphics display driver and check for hardware acceleration related issues.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 28.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0

More Information

FredMcD
  • Top 10 Contributor
4220 solutions 58899 answers

Helpful Reply

Note that some websites now use the HTML5 player.

Make sure you are not blocking content.

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


https://support.mozilla.org/en-US/kb/fix-video-audio-problems-firefox-windows

https://support.mozilla.org/en-US/kb/fix-common-audio-and-video-issues

https://support.mozilla.org/en-US/kb/html5-audio-and-video-firefox

Note that some websites now use the HTML5 player. Make sure you are not blocking content. [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there? https://support.mozilla.org/en-US/kb/fix-video-audio-problems-firefox-windows https://support.mozilla.org/en-US/kb/fix-common-audio-and-video-issues https://support.mozilla.org/en-US/kb/html5-audio-and-video-firefox
cor-el
  • Top 10 Contributor
  • Moderator
17407 solutions 157253 answers

Chosen Solution

You can try to disable hardware acceleration in Firefox.

Close and restart Firefox after modifying the setting to make the change effective.

You can check if there is an update for your graphics display driver and check for hardware acceleration related issues.

You can try to disable hardware acceleration in Firefox. *Options/Preferences -> General: Performance<br>remove checkmark: [ ] "Use recommended performance settings"<br>remove checkmark: [ ] "Use hardware acceleration when available" *https://support.mozilla.org/en-US/kb/performance-settings Close and restart Firefox after modifying the setting to make the change effective. *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems You can check if there is an update for your graphics display driver and check for hardware acceleration related issues. *https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration