Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

When scrolling/mouse over items in drop down menus, lines are added between.

  • 7 replies
  • 2 have this problem
  • 114 views
  • Last reply by anev942

more options

When scrolling/mouse over items in browser drop down menus, lines are added between. Also in right click window.

Really distracting. As mouse passes over link, it highlights, but when I scroll past leaves the separating lines behind, randomly. Large list like bookmarks the lines between items jump around, depending whether scrolling up or down. If I move mouse off drop down window lines go away. As soon as mouse is moved back onto list lines reappear...

Coincidentally, same time this started couple of weeks ago, web site pages that had selection drop down, list items were double spaced. I found fix for that - layers.acceleration.disabled;true which fixed the double spacing but had no effect on browser menu drop down Firefox 56 -windows 7/64

Attached screenshots

Chosen solution

Found it! Copying/overwriting file by file to new profile, restarting firefox and checking, it was copying over the prefs.js issue started. With 2 copies of the prefs.js, Alternatley renaming clean prefs.js file and copied over prefs.js default file, reloading firefox in new porfile, changed line by line modified values in about:config. It was layout.css.devPixelsPerPx, reset modified value to default and instant issue gone-clean drop downs in bookmarks drop downs etc. Happy scrolling.

That for the moment fixed. Problem is the layout.css.devPixelsPerPx value was modified quite a long time ago to address the text size of the menu bar. Unsure why it started acting up now, adding the scrolling issue. Can only assume that some other change in conjuntion simply didnt play well together. I hadnt made any about:config changes recently or systemprefs? though the double spacing of web site drop downs was fixed by changing browser.tabs.remote.autostart.2 value to false. That one happend on 3 machinces at the same time, so outside cause.

Anyway, reloaded FF with default profile, went into about:config reset the layout.css.devPixelsPerPx to default -1.0 and were good. Be nice if modified values had date field, curious what or why the layout value became problem.

Read this answer in context 👍 0

All Replies (7)

more options

Does it happen in FF57? As that is the support version here.

more options

I did not see that a question could only be related to most current FF version... I have no idea if this happens in 57- Sooo my question will not be addressed because I'm still using 56? Interesting...

more options

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

You can try to disable hardware acceleration in Firefox.

Close and restart Firefox after toggling this setting to make the change effective.

You can check if there is an update for your graphics display driver and check for hardware acceleration related issues.

more options

Thanks cor-el Went thru all suggestions. No affect safe-mode, disabling add-ons etc., themes, options/preferences All that were select-able options were already as noted. To make sure, changed each option individually-close/reboot and then unchecked-close reboot. Unchanged. Checked all drivers-current. Only thing I did note was under tools/add on manager shows default as 57. incompatible? In 3-bar menu I can and did change themes in & out of default-closing and opening FF. No change


Last resort I did reopen FF under new profile, added bunch of book marks. Nether the bookmarks, any menu pull downs, right click window or web site drop down menu showed the highlight lines...so something in my default profile...So I guess I'll try to back up and create a new profile. Think Ill try the copy of individual files over to new profile one at a time-see if/when issue returns.

Appreciate the response, making jpg of about:config- noted not all prefs are shown in Troubleshooting Info to print bumbling along...

more options

Were you using code in userChrome.css that might be causing this?

more options

No I wasnt- it just kinda started, not really even sure when, couple of weeks ago. Did note at same time the double spacing on web drop downs also on different cpu, but not the random hightlite lines.

more options

Chosen Solution

Found it! Copying/overwriting file by file to new profile, restarting firefox and checking, it was copying over the prefs.js issue started. With 2 copies of the prefs.js, Alternatley renaming clean prefs.js file and copied over prefs.js default file, reloading firefox in new porfile, changed line by line modified values in about:config. It was layout.css.devPixelsPerPx, reset modified value to default and instant issue gone-clean drop downs in bookmarks drop downs etc. Happy scrolling.

That for the moment fixed. Problem is the layout.css.devPixelsPerPx value was modified quite a long time ago to address the text size of the menu bar. Unsure why it started acting up now, adding the scrolling issue. Can only assume that some other change in conjuntion simply didnt play well together. I hadnt made any about:config changes recently or systemprefs? though the double spacing of web site drop downs was fixed by changing browser.tabs.remote.autostart.2 value to false. That one happend on 3 machinces at the same time, so outside cause.

Anyway, reloaded FF with default profile, went into about:config reset the layout.css.devPixelsPerPx to default -1.0 and were good. Be nice if modified values had date field, curious what or why the layout value became problem.