X
Tap here to go to the mobile version of the site.

Support Forum

The last update, 57.0, broke my browser, it is now impossible to use for more than 10 seconds without it not responding.

Posted

I have updated my browser to 57.0 and when I launch it, it immediately uses 4 Gb of ram. After opening 1 or 2 tabs, it gets slower and slower and eventually stops reponding after a few seconds, forcing me to end the task. I use a few add-ons: Dashlane, New tab tools, uBlock origin, Disconnect, Dashlane, Internet Download Manager. Than you for reading this, i hope there is a solution.

I have updated my browser to 57.0 and when I launch it, it immediately uses 4 Gb of ram. After opening 1 or 2 tabs, it gets slower and slower and eventually stops reponding after a few seconds, forcing me to end the task. I use a few add-ons: Dashlane, New tab tools, uBlock origin, Disconnect, Dashlane, Internet Download Manager. Than you for reading this, i hope there is a solution.

Chosen solution

That was supposed to be fixed. I use 1,155MB's with 9 tabs at the moment.

Since this was a update how about this : Please uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files and C:\Program Files(x86) Then restart system. Then run Windows Disk Cleanup. Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved.

Reinstall with Current Release Firefox 57.0 with a Full Version Installer https://www.mozilla.org/firefox/all/

Your video card drivers are not old driverDate: 6-7-2017 but wonder why it is not updating or are you ignoring it when says there is a update for your NVIDIA GeForce GTX 1070 (is a gaming card). Should always keep drivers up to date these days. https://www.geforce.com/drivers fyi : Firefox looks at the HTML and CSS and the engine renders it into CSS and displays it as pixels.

Please let us know if this solved your issue or if need further assistance.

Read this answer in context 5

Additional System Details

Application

  • Firefox 57.0
  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:57.0) Gecko/20100101 Firefox/57.0
  • Support URL: https://support.mozilla.org/1/firefox/57.0/WINNT/fr/

Extensions

  • Alldebrid extension 8.1.4 (alldebrid@alldebrid.com) (Inactive)
  • Dashlane 5.5.2 (jetpack-extension@dashlane.com) (Inactive)
  • Disconnect 5.18.21 (2.0@disconnect.me) (Inactive)
  • Greasemonkey 4.0 ({e4a8a97b-f2ed-450b-b12d-ee082ba24781}) (Inactive)
  • IDM Integration Module 6.29.2 (mozilla_cc3@internetdownloadmanager.com) (Inactive)
  • McAfee WebAdvisor 6.0.0.118 ({4ED1F68A-5463-4931-9384-8FFF5ED91D92}) (Inactive)
  • New Tab Tools 85 (newtabtools@darktrojan.net) (Inactive)
  • uBlock Origin 1.14.18 (uBlock0@raymondhill.net) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce GTX 1070
  • adapterDescription2:
  • adapterDeviceID: 0x1be1
  • adapterDeviceID2:
  • adapterDrivers: C:\WINDOWS\System32\DriverStore\FileRepository\nvam.inf_amd64_f37a34fb6c3c65de\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nvam.inf_amd64_f37a34fb6c3c65de\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nvam.inf_amd64_f37a34fb6c3c65de\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nvam.inf_amd64_f37a34fb6c3c65de\nvldumdx.dll C:\WINDOWS\System32\DriverStore\FileRepository\nvam.inf_amd64_f37a34fb6c3c65de\nvldumd.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nvam.inf_amd64_f37a34fb6c3c65de\nvldumd.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nvam.inf_amd64_f37a34fb6c3c65de\nvldumd.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nvam.inf_amd64_f37a34fb6c3c65de\nvldumd.dll
  • adapterDrivers2:
  • adapterRAM: 8192
  • adapterRAM2:
  • adapterSubsysID: 18001043
  • adapterSubsysID2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • crashGuards: []
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: True
  • directWriteVersion: 10.0.15063.674
  • driverDate: 6-7-2017
  • driverDate2:
  • driverVersion: 22.21.13.8253
  • driverVersion2:
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'blocked', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'blocked', u'message': u'Acceleration blocked by safe-mode', u'type': u'runtime'}], u'name': u'HW_COMPOSITING'}, {u'status': u'unavailable', u'description': u'Direct3D11 Compositing', u'log': [{u'status': u'unavailable', u'message': u'Hardware compositing is disabled', u'type': u'default'}], u'name': u'D3D11_COMPOSITING'}, {u'status': u'unavailable', u'description': u'Direct2D', u'log': [{u'status': u'unavailable', u'message': u'Direct2D requires Direct3D 11 compositing', u'type': u'default'}], u'name': u'DIRECT2D'}, {u'status': u'disabled', u'description': u'Direct3D11 hardware ANGLE', u'log': [{u'status': u'unavailable', u'message': u'D3D11 compositing is disabled', u'type': u'default'}, {u'status': u'disabled', u'message': u'D3D11 compositing is disabled', u'type': u'env'}], u'name': u'D3D11_HW_ANGLE'}, {u'status': u'blocked', u'description': u'GPU Process', u'log': [{u'status': u'available', u'type': u'default'}, {u'status': u'blocked', u'message': u'Safe-mode is enabled', u'type': u'runtime'}], u'name': u'GPU_PROCESS'}, {u'status': u'unavailable', u'description': u'WebRender', u'log': [{u'status': u'opt-in', u'message': u'WebRender is an opt-in feature', u'type': u'default'}, {u'status': u'unavailable', u'message': u'ANGLE is disabled', u'type': u'runtime'}], u'name': u'WEBRENDER'}]}
  • info: {u'ApzWheelInput': 1, u'ApzDragInput': 1, u'ApzKeyboardInput': 1, u'ApzAutoscrollInput': 1, u'AzureFallbackCanvasBackend': u'cairo', u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'skia', u'AzureContentBackend': u'skia'}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • offMainThreadPaintEnabled: False
  • webgl1DriverExtensions: -
  • webgl1Extensions: -
  • webgl1Renderer: WebGL is currently disabled.
  • webgl1Version: -
  • webgl1WSIInfo: -
  • webgl2DriverExtensions: -
  • webgl2Extensions: -
  • webgl2Renderer: WebGL is currently disabled.
  • webgl2Version: -
  • webgl2WSIInfo: -
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic
  • windowUsingAdvancedLayers: False

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
Mkll 313 solutions 1967 answers

Try Refreshing Firefox:

Hello,

The Refresh feature (called "Reset" in older Firefox versions) can fix many issues by restoring Firefox to its factory default state while saving your bookmarks, history, passwords, cookies, and other essential information.

Note: When you use this feature, you will lose any extensions, toolbar customizations, and some preferences. See the Refresh Firefox - reset add-ons and settings article for more information.

To Refresh Firefox:

  1. Open the Troubleshooting Information page using one of these methods:
    • Click the menu button New Fx Menu , click help Help-29 and select Troubleshooting Information. A new tab containing your troubleshooting information should open.
    • If you're unable to access the Help menu, type about:support in your address bar to bring up the Troubleshooting Information page.
  2. At the top right corner of the page, you should see a button that says "Refresh Firefox" ("Reset Firefox" in older Firefox versions). Click on it.
  3. Firefox will close. After the refresh process is completed, Firefox will show a window with the information that is imported.
  4. Click Finish and Firefox will reopen.

Did this fix the problem? Please report back to us!

Thank you.

Try Refreshing Firefox: Hello, The Refresh feature (called "Reset" in older Firefox versions) can fix many issues by restoring Firefox to its factory default state while saving your bookmarks, history, passwords, cookies, and other essential information. '''''Note:''' When you use this feature, you will lose any extensions, toolbar customizations, and some preferences.'' See the [[Refresh Firefox - reset add-ons and settings]] article for more information. To Refresh Firefox: # Open the Troubleshooting Information page using one of these methods: #*Click the menu button [[Image:New Fx Menu]], click help [[Image:Help-29]] and select ''Troubleshooting Information''. A new tab containing your troubleshooting information should open. #*If you're unable to access the Help menu, type '''about:support''' in your address bar to bring up the Troubleshooting Information page. #At the top right corner of the page, you should see a button that says "Refresh Firefox" ("Reset Firefox" in older Firefox versions). Click on it. #Firefox will close. After the refresh process is completed, Firefox will show a window with the information that is imported. #Click Finish and Firefox will reopen. Did this fix the problem? Please report back to us! Thank you.

Question owner

It works at first, but when i slowly reinstall my add-ons and use the browser for 2 minutes, it begins to slow down and doesn't respond.

It works at first, but when i slowly reinstall my add-ons and use the browser for 2 minutes, it begins to slow down and doesn't respond.
Mkll 313 solutions 1967 answers

Install only the add-ons you're SURE you need. Try using a limited set of add-ons for now until you believe the problem will no longer occur.

Install only the add-ons you're SURE you need. Try using a limited set of add-ons for now until you believe the problem will no longer occur.

Helpful Reply

This new update is really disappointing, even in safe mode, the browser acts jittery. I think i'm better off rolling back to 56.0.2 or go to Chrome even though i hate it. The problem is i'm already using the very basic add-ons I can't skip.

This new update is really disappointing, even in safe mode, the browser acts jittery. I think i'm better off rolling back to 56.0.2 or go to Chrome even though i hate it. The problem is i'm already using the very basic add-ons I can't skip.
Mkll 313 solutions 1967 answers

Instead of rolling back to an insecure version -- use Firefox 52 ESR, which can be downloaded from here: https://www.mozilla.org/en-US/firefox/organizations/all/

I'm sorry to hear that you are disappointed with Firefox 57.

Instead of rolling back to an insecure version -- use Firefox 52 ESR, which can be downloaded from here: https://www.mozilla.org/en-US/firefox/organizations/all/ I'm sorry to hear that you are disappointed with Firefox 57.

Helpful Reply

Thanks for your help anyway. I was expecting a lot from this version, but this has just rendered it unusable.

Thanks for your help anyway. I was expecting a lot from this version, but this has just rendered it unusable.
Pkshadow
  • Top 10 Contributor
1067 solutions 14836 answers

Chosen Solution

That was supposed to be fixed. I use 1,155MB's with 9 tabs at the moment.

Since this was a update how about this : Please uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files and C:\Program Files(x86) Then restart system. Then run Windows Disk Cleanup. Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved.

Reinstall with Current Release Firefox 57.0 with a Full Version Installer https://www.mozilla.org/firefox/all/

Your video card drivers are not old driverDate: 6-7-2017 but wonder why it is not updating or are you ignoring it when says there is a update for your NVIDIA GeForce GTX 1070 (is a gaming card). Should always keep drivers up to date these days. https://www.geforce.com/drivers fyi : Firefox looks at the HTML and CSS and the engine renders it into CSS and displays it as pixels.

Please let us know if this solved your issue or if need further assistance.

That was supposed to be fixed. I use 1,155MB's with 9 tabs at the moment. Since this was a update how about this : Please uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files and C:\Program Files(x86) Then restart system. Then run Windows Disk Cleanup. Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. Reinstall with Current Release Firefox 57.0 with a Full Version Installer https://www.mozilla.org/firefox/all/ Your video card drivers are not old driverDate: 6-7-2017 but wonder why it is not updating or are you ignoring it when says there is a update for your NVIDIA GeForce GTX 1070 (is a gaming card). Should always keep drivers up to date these days. https://www.geforce.com/drivers fyi : Firefox looks at the HTML and CSS and the engine renders it into CSS and displays it as pixels. Please let us know if this solved your issue or if need further assistance.

Question owner

Reinstalling did the job, thank you guys for your help and have a good day.

Reinstalling did the job, thank you guys for your help and have a good day.
jmajacobs 0 solutions 3 answers

Tried the clean install after deleting the Program Files folder. Tried the refresh. Video card drivers are the latest. Lagging persists. This is just awful. Rolled back to 56.02 but checking "About" caused it to update again. Dell Intel i7 3.40 Ghz 32 Gb RAM. Windows 10 Pro. All windows updates. Please help. This is a huge loss.

Tried the clean install after deleting the Program Files folder. Tried the refresh. Video card drivers are the latest. Lagging persists. This is just awful. Rolled back to 56.02 but checking "About" caused it to update again. Dell Intel i7 3.40 Ghz 32 Gb RAM. Windows 10 Pro. All windows updates. Please help. This is a huge loss.

Modified by jmajacobs

DocCovington 0 solutions 4 answers

Jedimehmet said

I have updated my browser to 57.0 and when I launch it, it immediately uses 4 Gb of ram. After opening 1 or 2 tabs, it gets slower and slower [...]

It is extremely laggy for me as well, and a fresh re-installation of the browser doesn't solve the problem. It has 2-seconds freezes every few seconds, which is majorly annoying.

I went back to version 56.0.2, which was great (performance- and design-wise). I also hate the new FF 57 design, but would have learnt to live with it if it had a good performance like its predecessors and didn't install new feature nobody wants or needs (which might be the actual cause for the lag issue - telemetry, anyone?).


P.S. on the new design:

- Flat grey folder icons make reading the favorites less comfortable.

- The old FF icon was so much prettier. The new one looks cartoony.

- I want to be able to choose the look of my "New tab" home page (I prefer the big preview windows of the pinned sites from before).

- In general, let people choose between the beautiful old design and the simplistic (and downright ugly) new design, thank you.

''Jedimehmet [[#question-1184407|said]]'' <blockquote> I have updated my browser to 57.0 and when I launch it, it immediately uses 4 Gb of ram. After opening 1 or 2 tabs, it gets slower and slower [...]</blockquote> It is extremely laggy for me as well, and a fresh re-installation of the browser doesn't solve the problem. It has 2-seconds freezes every few seconds, which is majorly annoying. I went back to version 56.0.2, which was great (performance- ''and'' design-wise). I also hate the new FF 57 design, but would have learnt to live with it if it had a good performance like its predecessors and didn't install new feature nobody wants or needs (which might be the actual cause for the lag issue - telemetry, anyone?). P.S. on the new design: - Flat grey folder icons make reading the favorites less comfortable. - The old FF icon was so much prettier. The new one looks cartoony. - I want to be able to choose the look of my "New tab" home page (I prefer the big preview windows of the pinned sites from before). - In general, let people choose between the beautiful old design and the simplistic (and downright ugly) new design, thank you.

Modified by DocCovington

chrisrushlau 0 solutions 19 answers

I just reinstalled 57.0 per instructions above and it took one second to install. That doesn't sound right. I'll launch Firefox and see. No help, it's up to 3200MB of RAM after two minutes. Now 3800 after another thirty seconds. I use 10 tabs as homepage. 4600MB after one more minute. Next day: it's three weather.com pages that are sending Firefox haywire. I opened the ten pages as usual, immediately closed the three weather.com pages, RAM leveled off at 800 MB. I reopened the three trouble sites, back to the total of ten, and RAM usage took off into several thousand MB in a few seconds. Well, without them, it's crept up to 1600, but much more slowly. Generally leveled off. Ten minutes later, holding steady at 1600 MB RAM without the three weather.com pages.

I just reinstalled 57.0 per instructions above and it took one second to install. That doesn't sound right. I'll launch Firefox and see. No help, it's up to 3200MB of RAM after two minutes. Now 3800 after another thirty seconds. I use 10 tabs as homepage. 4600MB after one more minute. Next day: it's three weather.com pages that are sending Firefox haywire. I opened the ten pages as usual, immediately closed the three weather.com pages, RAM leveled off at 800 MB. I reopened the three trouble sites, back to the total of ten, and RAM usage took off into several thousand MB in a few seconds. Well, without them, it's crept up to 1600, but much more slowly. Generally leveled off. Ten minutes later, holding steady at 1600 MB RAM without the three weather.com pages.

Modified by chrisrushlau

Mike 0 solutions 6 answers

I updated to FF57.0 on both my Macs and one older PC. The Macs seem to be fine but the PC running Win7 is not.

After the installation of 57.0, the browser will not fully initialize. Peripheral items on the task bar show up but the Firefox homepage does not and the software freezes. Closing FF57.0 results in an apparent incomplete shut down of the software; while the browser closes on the monitor it is still running in the background and needs a "force quit" (or whatever it's called on Win7).

I have subsequently uninstalled FF57.0 and this article has been helpful in pointing out other files needing to be removed. I will try a fresh reinstall today.

I am sadly disappointed in the new "flat" look of the browser. It appears Mozilla has taken a page from the Apple playbook in graphics; incorporating highly bland, highly simplistic cartoon-like colors and graphics ...as if this final version is some kind of beta release rather than a full release. What gives? Even the Fox icon looks cheap. BTW, I hate the latest Apple flat look that appeared shortly after Jobs' death; I'm sure he's rolling in his grave with the current display of OS and iOS software. So why did Firefox have to follow suit?

I updated to FF57.0 on both my Macs and one older PC. The Macs seem to be fine but the PC running Win7 is not. After the installation of 57.0, the browser will not fully initialize. Peripheral items on the task bar show up but the Firefox homepage does not and the software freezes. Closing FF57.0 results in an apparent incomplete shut down of the software; while the browser closes on the monitor it is still running in the background and needs a "force quit" (or whatever it's called on Win7). I have subsequently uninstalled FF57.0 and this article has been helpful in pointing out other files needing to be removed. I will try a fresh reinstall today. I am sadly disappointed in the new "flat" look of the browser. It appears Mozilla has taken a page from the Apple playbook in graphics; incorporating highly bland, highly simplistic cartoon-like colors and graphics ...as if this final version is some kind of beta release rather than a full release. What gives? Even the Fox icon looks cheap. BTW, I hate the latest Apple flat look that appeared shortly after Jobs' death; I'm sure he's rolling in his grave with the current display of OS and iOS software. So why did Firefox have to follow suit?
jmajacobs 0 solutions 3 answers

I have installed the 52.5.0 ESR version. I'll keep an eye on this discussion until there's a fixed release of version 57 before trying it again. Trying to use it and fix it now in its current condition is too dispiriting after relying on Firefox for all these years.

I have installed the 52.5.0 ESR version. I'll keep an eye on this discussion until there's a fixed release of version 57 before trying it again. Trying to use it and fix it now in its current condition is too dispiriting after relying on Firefox for all these years.
Bob.E.K 0 solutions 4 answers

Could this be an answer for some of you.

enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for the preference named accessibility.force_disabled. double-click it, change its value to 1 and restart firefox once. I did this and now all is well.

Above is copied from another post. I never checked memory usage when I was having the problem with scroll and text commands but the browser was just about unusable now it works fine. Hope this works.

Update: Just found the normal way into this setting

    Click the menu button Fx57Menu and choose Options.
   Select the Privacy and Security panel.
   Go to the "Permissions" section.
   Check the Prevent accessibility services from accessing your browser checkbox.
   Restart Firefox.
Could this be an answer for some of you. enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for the preference named accessibility.force_disabled. double-click it, change its value to 1 and restart firefox once. I did this and now all is well. Above is copied from another post. I never checked memory usage when I was having the problem with scroll and text commands but the browser was just about unusable now it works fine. Hope this works. Update: Just found the normal way into this setting Click the menu button Fx57Menu and choose Options. Select the Privacy and Security panel. Go to the "Permissions" section. Check the Prevent accessibility services from accessing your browser checkbox. Restart Firefox.

Modified by Bob.E.K

chrisrushlau 0 solutions 19 answers

The first warning you get when you enter about:config tells you you could void your warranty. So I Googled, found a Mozilla item about it, which says only, in rare circumstances, you could foul up Firefox or the like. So I tried it, the instructions were proper, and now Firefox has been running for ten minutes with my 10-tab home page, including three weather.com pages which seem, by a process of elimination, to be a large part of the problem, but not all: the typing still had a time lag even without those three weather.com pages, but now, come to notice it, the typing is real-time responsive. Before the fix, ten minutes of Firefox would have had RAM consumption up above six thousand MB and everything would have been constantly "not responding". Now RAM usage is 1821 at this moment, and at this moment it's 1793. So I guess it worked. Thank you, but if I wake up dead I'll have to retract that. Half hour later, typing is still real-time responsive, but RAM is up to 4600 MB, so those two aren't linked, but more importantly it's responding in general, and that's including the three weather.com pages. Maybe Firefox always did creep up the RAM usage the longer you stayed on it, and only lately, this version and the previous one, did that lead to "not responding". I have a faint recollection of high RAM in the past, purely a curiosity since everything kept working. And in the time it took me to type up to the previous sentence, update (save) it, and look around a little, RAM came back down to 3600 or so. I closed Firefox and opened it again, typing is still real-time responsive, but two of the weather.com pages won't complete loading, and RAM is up to 5000. Maybe weather.com learned something and is trying to compensate. I seem to see "vidible" and "springserve" a lot in the items being "waited" on. Just about to 6000 MB. Is this what they call artificial intelligence? The Algorithm That Couldn't? RAM went to 98% and Firefox stopped responding. The disk has to clean up the aftermath by going to 100% usage itself; that's died down now and typing is now real-time responsive again except for right now. I was only able to recover by closing the two weather.com tabs that wouldn't finish loading. But it's still touch and go. The clean-up as I call it by 100% disk usage seems to be in "superfetch", whatever that is. It takes a couple of minutes to clear the debris away, I guess. The weather.com national map ("current weather") loads after about a minute, but "Portland ME Weather" and "Hourly Weather Forecast" just keep pinging and pinging, RAM is up to 3600 MB, ping, ping, ping, ping, ping. Shut off and later restarted computer, opened Firefox, two of my three weather.com pages would not completely load, I wrote an email for almost an hour, and one of the recalcitrant tabs loads, the other is still pinging away, that being the hourly forecast, and RAM usage at the moment was only 2600 MB.

The first warning you get when you enter about:config tells you you could void your warranty. So I Googled, found a Mozilla item about it, which says only, in rare circumstances, you could foul up Firefox or the like. So I tried it, the instructions were proper, and now Firefox has been running for ten minutes with my 10-tab home page, including three weather.com pages which seem, by a process of elimination, to be a large part of the problem, but not all: the typing still had a time lag even without those three weather.com pages, but now, come to notice it, the typing is real-time responsive. Before the fix, ten minutes of Firefox would have had RAM consumption up above six thousand MB and everything would have been constantly "not responding". Now RAM usage is 1821 at this moment, and at this moment it's 1793. So I guess it worked. Thank you, but if I wake up dead I'll have to retract that. Half hour later, typing is still real-time responsive, but RAM is up to 4600 MB, so those two aren't linked, but more importantly it's responding in general, and that's including the three weather.com pages. Maybe Firefox always did creep up the RAM usage the longer you stayed on it, and only lately, this version and the previous one, did that lead to "not responding". I have a faint recollection of high RAM in the past, purely a curiosity since everything kept working. And in the time it took me to type up to the previous sentence, update (save) it, and look around a little, RAM came back down to 3600 or so. I closed Firefox and opened it again, typing is still real-time responsive, but two of the weather.com pages won't complete loading, and RAM is up to 5000. Maybe weather.com learned something and is trying to compensate. I seem to see "vidible" and "springserve" a lot in the items being "waited" on. Just about to 6000 MB. Is this what they call artificial intelligence? The Algorithm That Couldn't? RAM went to 98% and Firefox stopped responding. The disk has to clean up the aftermath by going to 100% usage itself; that's died down now and typing is now real-time responsive again except for right now. I was only able to recover by closing the two weather.com tabs that wouldn't finish loading. But it's still touch and go. The clean-up as I call it by 100% disk usage seems to be in "superfetch", whatever that is. It takes a couple of minutes to clear the debris away, I guess. The weather.com national map ("current weather") loads after about a minute, but "Portland ME Weather" and "Hourly Weather Forecast" just keep pinging and pinging, RAM is up to 3600 MB, ping, ping, ping, ping, ping. Shut off and later restarted computer, opened Firefox, two of my three weather.com pages would not completely load, I wrote an email for almost an hour, and one of the recalcitrant tabs loads, the other is still pinging away, that being the hourly forecast, and RAM usage at the moment was only 2600 MB.

Modified by chrisrushlau

Bob.E.K 0 solutions 4 answers

Hi chrisrushlau Sounds as though your excessive ram usage is not part of the typing and scrolling problem. My ram usage on pages is only up to and around 200mb A quick Google shows 'vidible' as a AOL element (Never liked any AOL stuff they used to be very system hogging). 'springserve' comes up as being a video advertising server. Have you got any unwanted stuff that has creeped in and is trying to load in the background? If you haven't done so already I would suggest running malwarebytes and possibly housecall to see if you have any (possibly unwanted programs running) and trying to redirect things in your browser. Weather.com dose kick my ram up to just over 300mb on that page. The page also has plenty of adds on it and if you have add ware trying to redirect them it could be a bottleneck for your ram? Excuse me if I am trying to teach you how to suck eggs. All the best Bob.

Hi chrisrushlau Sounds as though your excessive ram usage is not part of the typing and scrolling problem. My ram usage on pages is only up to and around 200mb A quick Google shows 'vidible' as a AOL element (Never liked any AOL stuff they used to be very system hogging). 'springserve' comes up as being a video advertising server. Have you got any unwanted stuff that has creeped in and is trying to load in the background? If you haven't done so already I would suggest running malwarebytes and possibly housecall to see if you have any (possibly unwanted programs running) and trying to redirect things in your browser. Weather.com dose kick my ram up to just over 300mb on that page. The page also has plenty of adds on it and if you have add ware trying to redirect them it could be a bottleneck for your ram? Excuse me if I am trying to teach you how to suck eggs. All the best Bob.
chrisrushlau 0 solutions 19 answers

Maybe not a coincidence then that I used to have Dell concierge service do a clean-up every three months, it used malwarebytes as one of its services, but they raised the price so I didn't renew. That's how much I know about sucking eggs. I have, I think, the general concept that a modern dynamic website that is advertisement-funded is going to try very hard to get my attention and rather assumes I have infinite machine-capacity for their distractions. But I didn't used to have this degree of difficulty, and it did seem (famous last words?) to start well after I lost Dell Concierge and in fact (famous last words) seemed to come on in Firefox and in its last incarnation or two, and I'd got it sorted out somehow, then 57.0 has just, as one or two have said here, about finished me off on using Firefox. I'll check those two services, malwarebytes and housecall,. Thank you. My only maintenance these days is a weekly "quick clean" from McAfee. This computer is four years old. I was going to say, time for a new one. Not after only four years. It's got enough horses: 3.4 Ghz CPU, 8 GB RAM, x64.

Maybe not a coincidence then that I used to have Dell concierge service do a clean-up every three months, it used malwarebytes as one of its services, but they raised the price so I didn't renew. That's how much I know about sucking eggs. I have, I think, the general concept that a modern dynamic website that is advertisement-funded is going to try very hard to get my attention and rather assumes I have infinite machine-capacity for their distractions. But I didn't used to have this degree of difficulty, and it did seem (famous last words?) to start well after I lost Dell Concierge and in fact (famous last words) seemed to come on in Firefox and in its last incarnation or two, and I'd got it sorted out somehow, then 57.0 has just, as one or two have said here, about finished me off on using Firefox. I'll check those two services, malwarebytes and housecall,. Thank you. My only maintenance these days is a weekly "quick clean" from McAfee. This computer is four years old. I was going to say, time for a new one. Not after only four years. It's got enough horses: 3.4 Ghz CPU, 8 GB RAM, x64.
Bob.E.K 0 solutions 4 answers

Hi chrisrushlau I just use the free version of malwarebytes. When you first install it you will get a 14 day trial of the full version, during that time I would suggest turning off real time protection on one of you anti viruses as you will have two running which can clash. After that period just run malwarebytes scan when needed. Housecall is just an online scan. I just cleaned up a friends laptop running Avast anti virus he had 180 unwanted item in the background found by malwarebytes.

Hi chrisrushlau I just use the free version of malwarebytes. When you first install it you will get a 14 day trial of the full version, during that time I would suggest turning off real time protection on one of you anti viruses as you will have two running which can clash. After that period just run malwarebytes scan when needed. Housecall is just an online scan. I just cleaned up a friends laptop running Avast anti virus he had 180 unwanted item in the background found by malwarebytes.
chrisrushlau 0 solutions 19 answers

You gave me what I need to get started there. Thank you. Downloaded the premium malwarebytes for 14 day trial, nothing found. On to the housecall. I ran it, no threats found. The malwarebytes will replace my McAfee for the trial period. Thanks again.

You gave me what I need to get started there. Thank you. Downloaded the premium malwarebytes for 14 day trial, nothing found. On to the housecall. I ran it, no threats found. The malwarebytes will replace my McAfee for the trial period. Thanks again.

Modified by chrisrushlau

DocCovington 0 solutions 4 answers

Bob.E.K said

Could this be an answer for some of you. enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for the preference named accessibility.force_disabled. double-click it, change its value to 1 and restart firefox once. I did this and now all is well. Above is copied from another post. I never checked memory usage when I was having the problem with scroll and text commands but the browser was just about unusable now it works fine. Hope this works. [...]

This I recommend with any version of Firefox. It always speeds up the browsing process. :)

I still hope that there will be a proper update for FF soon, one that not only solves any issues but also allows you to keep your old-style New Tab page with its proper sized pinned preview sites.

''Bob.E.K [[#answer-1035373|said]]'' <blockquote> Could this be an answer for some of you. enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for the preference named accessibility.force_disabled. double-click it, change its value to 1 and restart firefox once. I did this and now all is well. Above is copied from another post. I never checked memory usage when I was having the problem with scroll and text commands but the browser was just about unusable now it works fine. Hope this works. [...] </blockquote> This I recommend with any version of Firefox. It always speeds up the browsing process. :) I still hope that there will be a proper update for FF soon, one that not only solves any issues but also allows you to keep your old-style New Tab page with its proper sized pinned preview sites.

Modified by DocCovington