Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Some Videos Online Won't Work with FireFox

  • 43 replies
  • 17 have this problem
  • 9348 views
  • Last reply by cor-el

more options

To refresh everyone's memory, I'm using Windows XP Service Pack 3 with FireFox 52.4.0 (32-bit) ESR and I have been having a problem only on a few selective websites where their online videos won't play, I have no trouble with the big websites like You Tube for most of their stuff. Anyway, just a reminder, I'm no computer wiz and I know I need to get better educated about computers, I hope to able to afford a new computer by some time in 2018 Everyone has been so nice here, tried to help me but I found some of the directions too complicated which is on me. Anyway, this is the website you guys were helping me on with videos that won't play with Firefox. http://www.cbc.ca/player/news/Canada/North

Now here's the thing that doesn't make any sense to me, on an older, outdated browser that is no longer supported tried Google Chrome 49 and the videos on http://www.cbc.ca/player/news/Canada/North all work on that old, outsdated browser but not on Firefox 52.4.0 Does this make any sense to anyone? I really hate the idea of having that old Google Chrome 49 especially knowing how Firefox is safer and has more respect for the privacy of others with their browser. Is there are more simple way I can fix Firefox or am I stuck for now using Chrome 49 for that website until I get a new computer? 3 weeks ago I didn't have this problem that's why makes no sense to me. Should someone also know a detailed answer for that CBC website you can report it to them support@cbchelp.zendesk.com Thank you again everyone for being so kind and patient with me, I'm not trying to be a pest to anyone.

When I try to watch those videos on that CBC website I get a blank, black screen and it says the selected item is currently not available. Maybe Firefox is blocking an ad?

Chosen solution

Here is my understanding: anyone distributing a decoder for H.264 video needs to pay royalties to the owner of the patent on that codec. Mozilla believes that is inconsistent with an open web and refuses to enter into such a license. Therefore decoding in (open source) Firefox needs to be done through external components that are properly licensed. Google pays for a license, and therefore it gets to include the decoder directly in (not open source) Chrome.

Read this answer in context 👍 2

All Replies (20)

more options

I tried the link you posted and had no problem. Normally when you right-click on the player, it identifies itself. But this player did not.


Make sure you are not blocking content

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


https://support.mozilla.org/en-US/kb/fix-common-audio-and-video-issues

more options

FredMcD said

I tried the link you posted and had no problem. Normally when you right-click on the player, it identifies itself. But this player did not.

Make sure you are not blocking content

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


https://support.mozilla.org/en-US/kb/fix-common-audio-and-video-issues

No luck but thanks for trying. I can go through the link you posted again to make certain I didn't overlook anything. That website CBC gave me this info, not sure if this will mean anything to you but this is what they said. "For video we use segmented MP4s delivered using HLS.

For support you therefore need a Browser / OS that supports the HLS or the Media Source Extensions (MSE) Standard."

more options

Firefox relies on built-in OS support to play media files via the HTML5 media player. On the Windows XP platform you do not have native support for playing MP4 files with the HTML5 media player.

You can try if the solution posted here to add support for playing MP4 files works for you.

more options

What cor-el said.

Which was also the only known-to-work workaround mentioned in your previous thread: https://support.mozilla.org/questions/1180689

more options

cor-el said

Firefox relies on built-in OS support to play media files via the HTML5 media player. On the Windows XP platform you do not have native support for playing MP4 files with the HTML5 media player. You can try if the solution posted here to add support for playing MP4 files works for you.

'What I don't understand if I don't have the support to play those MP4 files with the HTML5 player why is it on that CBC.ca website do the videos work if I switch to the old Google Chrome 49 browser with no problem? It makes no sense to me. Those directions on that website on how to do this are a bit tricky meaning for someone who doesn't know a great deal about computers like me have a little trouble with. I will try to study it better again. If I can't figure out then I guess I'm stuck with having to use the Google Chrome until I can try and save up some money for a new computer for some time in 2018. I can see that I have a lot to learn when it comes to computers, I thank everyone who has been trying to help me, I'm sorry if I bothered anyone, again, I wasn't trying to be a pest to anyone.

more options

Chosen Solution

Here is my understanding: anyone distributing a decoder for H.264 video needs to pay royalties to the owner of the patent on that codec. Mozilla believes that is inconsistent with an open web and refuses to enter into such a license. Therefore decoding in (open source) Firefox needs to be done through external components that are properly licensed. Google pays for a license, and therefore it gets to include the decoder directly in (not open source) Chrome.

more options

cor-el said

Firefox relies on built-in OS support to play media files via the HTML5 media player. On the Windows XP platform you do not have native support for playing MP4 files with the HTML5 media player. You can try if the solution posted here to add support for playing MP4 files works for you.

Getting the FF profile is no problem, following the rest of these directions and it's either not working or I'm not 100% doing something right. Open your FF profile folder. An easy way to navigate to it is by opening about:support in FF and clicking the Open Folder button next to Profile Folder.

   Inside the profile folder, create subfolder gmp-eme-adobe and open it.
   Inside gmp-eme-adobe, create subfolder 17 and open it.
   Unpack the Primetime ZIP archive into folder 17.
   Folder [your FF profile path]\gmp-eme-adobe\17 should now contain three files: eme-adobe.dll, eme-adobe.info, eme-adobe.voucher.
more options

Here's a little more on those steps:

(1) Inside the profile folder, create subfolder gmp-eme-adobe and open it.

First, select and copy (Ctrl+c) the following new folder name:

gmp-eme-adobe

Right-click a blank area of the folder, choose New, then Folder. Windows should select the name. Use Paste (Ctrl+v) to change it to gmp-eme-adobe and click away to complete the edit.

(2) Inside gmp-eme-adobe, create subfolder 17 and open it.

Double-click the new gmp-eme-adobe folder to open it. Then create a new folder here named 17 (literally, the number 17) using the same method: right-click a blank area of the folder, choose New, then Folder. Windows should select the name, type 17 and click away to complete the edit.

(3) Unpack the Primetime ZIP archive into folder 17.

If you have an archiving program like WinZip, 7zip, WinRAR, etc., you can copy the .zip file you downloaded into the 17 folder, then "extract" all of its contents into the folder. Often this will be a choice if you right-click the .zip file, for example "Extract Here". Alternately, you can open the .zip file in your archiving program and use the extract feature to put the files into the 17 folder.

(4) Folder [your FF profile path]\gmp-eme-adobe\17 should now contain three files: eme-adobe.dll, eme-adobe.info, eme-adobe.voucher.

After extracting, those three files should be found in the folder.

If you copied the .zip file here, you won't need it any more. Perhaps put it in your Downloads folder or somewhere else for safekeeping.

more options

jscher2000 said

Here's a little more on those steps: (1) Inside the profile folder, create subfolder gmp-eme-adobe and open it. First, select and copy (Ctrl+c) the following new folder name: gmp-eme-adobe Right-click a blank area of the folder, choose New, then Folder. Windows should select the name. Use Paste (Ctrl+v) to change it to gmp-eme-adobe and click away to complete the edit. (2) Inside gmp-eme-adobe, create subfolder 17 and open it. Double-click the new gmp-eme-adobe folder to open it. Then create a new folder here named 17 (literally, the number 17) using the same method: right-click a blank area of the folder, choose New, then Folder. Windows should select the name, type 17 and click away to complete the edit. (3) Unpack the Primetime ZIP archive into folder 17. If you have an archiving program like WinZip, 7zip, WinRAR, etc., you can copy the .zip file you downloaded into the 17 folder, then "extract" all of its contents into the folder. Often this will be a choice if you right-click the .zip file, for example "Extract Here". Alternately, you can open the .zip file in your archiving program and use the extract feature to put the files into the 17 folder. (4) Folder [your FF profile path]\gmp-eme-adobe\17 should now contain three files: eme-adobe.dll, eme-adobe.info, eme-adobe.voucher. After extracting, those three files should be found in the folder. If you copied the .zip file here, you won't need it any more. Perhaps put it in your Downloads folder or somewhere else for safekeeping.

I thank you very much for trying to help me. Yes, I did all of this, the folders are all there just as you say but it did nothing for the videos in this link: http://www.cbc.ca/news/canada/newfoundland-labrador/programs/hereandnow I still get a black screen and it says the selected item is not currently available, so I tried to disable Flash Player to see if that would help, it didn't so I turned it back on. I refreshed the website, still won't work, the videos on that website still won't work, the only time it will ever work is when there's a Live Stream but the only reason why is because when it goes on Live Stream CBC seems to be using a different media player/format. Now when I go on to Google Chrome 49 to that link that I mentioned above the videos play fine without me having to do anything but you explained that to me the difference between Fire Fox and Chrome so I now get that. I know there's nothing wrong with those files I added to that new folder/17 as you instructed because my Norton/Symantec would've told me. I don't see how I could've messed this one up, you made the directions simple/easy to understand. Again, I'm on Windows XP 32bit Firefox 52.4.0 ESR I do thank you for all of your efforts, it was very kind of you to try again. What's strange is that I don't see this program in the adds on. I went to tools, add ons. Something is telling me I might have goofed but I don't see how, I can see the files when I go to the Fire Fox profile folder. Why could I have possibly done wrong this time?

more options

Could you try something simpler first... could you scroll down this page and try the H.264/MP4 test video:

https://www.quirksmode.org/html5/tests/video.html

more options

jscher2000 said

Could you try something simpler first... could you scroll down this page and try the H.264/MP4 test video: https://www.quirksmode.org/html5/tests/video.html

I just came back from rebooting the computer but no luck. I just clicked on this link to test video you posted and it says no video with supported format and MIME found. I don't understand how I could've messed up, you made the directions quite clear. Do you think I did something wrong again?

more options

I just checked my add ons and I don't see the Primetime Content Decryption Module plugin by Adobe. Perhaps there are more steps I need to do in addition to the directions already given? I really thank you for going the extra mile trying to help me. Well, at least I got the part to where those files are in my Fire Fox profile so that's some progress anyway. I'll wait for any possible further instructions. Thank you so very much again for being so kind and patient with me.

more options

This is very strange, now this video link doesn't work at all on both Fire Fox and Google Chrome49 http://www.cbc.ca/player/play/2641927757 Yet all the videos in the link below do Not work at on Fire Fox but still work just fine on Google Chrome 49. It seems like CBC is messing around with websites. Maybe different formats. http://www.cbc.ca/player/news/Canada/North

Anyway, I'll check back again and wait to see if there are any possible further instructions, thanks again, at least those files are in the Fire Fox profile.

more options

Did you modify all the prefs as described in the link of that website?

more options

cor-el said

Did you modify all the prefs as described in the link of that website?

I followed the directions that were posted to me. That website isn't 100% clear, it has lines crossed off some things, therefore it's not 100% clear on how to modify all the prefs. The folders however are there, I checked the Fire Fox profile so I know at least that part is right.

more options

These prefs look like the most important:

  • media.gmp-eme-adobe.enabled (boolean, true)
  • media.gmp-eme-adobe.forceSupported (boolean, true; FF 49.0+)
  • media.gmp-eme-adobe.visible (boolean, true; FF 49.0+)
  • media.gmp-eme-adobe.version (string, 17; required for manual install now that automatic install is no longer an option)
  • media.gmp.decoder.enabled (boolean, true)
  • media.eme.enabled (boolean, true; defaults to false if you downloaded a DRM-free version of FF; thanks @heinoganda for pointing this out)

Can you post the path to the "17" folder and possibly provide a screenshot to confirm that the files are in the correct location?

more options

cor-el said

These prefs look like the most important:
  • media.gmp-eme-adobe.enabled (boolean, true)
  • media.gmp-eme-adobe.forceSupported (boolean, true; FF 49.0+)
  • media.gmp-eme-adobe.visible (boolean, true; FF 49.0+)
  • media.gmp-eme-adobe.version (string, 17; required for manual install now that automatic install is no longer an option)
  • media.gmp.decoder.enabled (boolean, true)
  • media.eme.enabled (boolean, true; defaults to false if you downloaded a DRM-free version of FF; thanks @heinoganda for pointing this out)
Can you post the path to the "17" folder and possibly provide a screenshot to confirm that the files are in the correct location?

How do I go about trying to do this? It says root directory and local directory under about profile. Remember, I'm not a computer wiz, my knowledge here is limited. The folders were created in the exact place where jscher2000 told me to do it as this person has been very kind trying to break things down to make it simple for me. I'm not sure how to take a screenshot but one thing I do know for sure when I click on the profile folder on Fire Fox those folders that he told me to put are there, I just checked it again now.

more options

It is probably OK, but a screenshot of this folder in Windows File Explorer for confirmation never hurts. Proper Troubleshooting includes verifying that everything is correct (files and prefs in this case).

more options

These prefs look like the most important:

       media.gmp-eme-adobe.enabled (boolean, true)
       media.gmp-eme-adobe.forceSupported (boolean, true; FF 49.0+)
       media.gmp-eme-adobe.visible (boolean, true; FF 49.0+)
       media.gmp-eme-adobe.version (string, 17; required for manual install now that automatic install is no longer an option)
       media.gmp.decoder.enabled (boolean, true)
       media.eme.enabled (boolean, true; defaults to false if you downloaded a DRM-free version of FF; thanks @heinoganda for pointing this out) 
   Can you post the path to the "17" folder and possibly provide a screenshot to confirm that the files are in the correct location? 

How do I go about trying to do this? It says root directory and local directory under about profile. Remember, I'm not a computer wiz, my knowledge here is limited. The folders were created in the exact place where jscher2000 told me to do it as this person has been very kind trying to break things down to make it simple for me. I'm not sure how to take a screenshot but one thing I do know for sure when I click on the profile folder on Fire Fox those folders that he told me to put are there, I just checked it again. I want to make sure I have understand and follow any directions 100% so that I don't mess anything up.

more options

Those are two completely separate things, actually. Preferences are settings inside of Firefox.

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste gmp and pause while the list is filtered -- any preferences starting with media.gmp should appear.

(3) If a preference is missing, then you need to create it. That is why the information in parentheses is there. For example:

  • media.gmp-eme-adobe.enabled (boolean, true)

To create that preference:

(A) Select and copy the preference name

media.gmp-eme-adobe.enabled

(B) In a blank area of the about:config screen, right-click and choose new, then the "type" listed in parentheses, which is Boolean

(C) Firefox will display a little form to paste in the preference name, then click OK

(D) Firefox will display a form for the preference type, so for Boolean, you can choose between true and false (in this case, you want true) then click OK.

Then repeat with any other missing preferences:

  • media.gmp-eme-adobe.forceSupported (boolean, true)
  • media.gmp-eme-adobe.visible (boolean, true)
  • media.gmp-eme-adobe.version (string, 17)
  • media.gmp.decoder.enabled (boolean, true)

(5) In the search box above the list, type or paste eme. and pause while the list is filtered

(6) If needed, change the value of the following preference to true, or create it:

  • media.eme.enabled (boolean, true)

Someday you will be teaching this to other people. Or someday XP will cease to exist and we can all stop talking about it.

Modified by jscher2000

  1. 1
  2. 2
  3. 3