X
Tap here to go to the mobile version of the site.

Support Forum

Thanks for no longer supporting Java, now no one using Firefox can use my WordPress blog, which REQUIRES Java. Good job. Opera is now my default browser.

Posted

Thanks for all the great work over the years, FireFox was truly the best around. It still would be if you hadn't stopped supporting Java, which is probably used on a few billion pages. By dropping Java you've rendered Firefox almost irrelevant and, while not useless, close to it. So I can either start going back and forth between FireFox and Opera now, or save myself all that hassle, as most are going to do, and just get used to Opera and stay there.

But... if you ever make FireFox fully functional again, I'll be back. I hope you do before I get too used to Opera to want to make the switch again.

Thanks for all the great work over the years, FireFox was truly the best around. It still would be if you hadn't stopped supporting Java, which is probably used on a few billion pages. By dropping Java you've rendered Firefox almost irrelevant and, while not useless, close to it. So I can either start going back and forth between FireFox and Opera now, or save myself all that hassle, as most are going to do, and just get used to Opera and stay there. But... if you ever make FireFox fully functional again, I'll be back. I hope you do before I get too used to Opera to want to make the switch again.

Chosen solution

Surprise, surprise. It was all a WordPress problem after all. I take back all those mean thoughts about Firefox. When WP tried to auto-update to the latest version it conflicted with a plugin and failed to update, while at the same time corrupting the plugin, which caused the login and comment problem.

A tech on my service provider shut down all the plugins, updated WP for me and then, later after more problems, I had another tech re-enable my ability do download and activate plugins. There's still an obvious glitch or two but at least it's functioning mostly normally now. I don't think they're hiring the brightest and best at my service provider......

Ennyhoo, thanks for all the help and suggestions. I'm glad it was WP and not Firefox, which really is the best of all the available browsers.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • CANON iMAGE GATEWAY Album Plugin Utility Module for IJ
  • DivX Web Player version 3.7.3.15
  • GEPlugin
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 10.17.2 for Mozilla browsers
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object
  • Windows Multimedia Services DRM Store Plug-In
  • Winamp Application Detector
  • Npdsplay dll
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:52.0) Gecko/20100101 Firefox/52.0

More Information

FredMcD
  • Top 10 Contributor
4188 solutions 58461 answers

Hi,

The people who answer questions here, for the most part, are other Firefox users volunteering their time (like me), not Mozilla employees or Firefox developers.

If you want to leave feedback for Firefox developers, you can go to the Firefox Help menu and select Submit Feedback... or use this link. Your feedback gets collected at http://input.mozilla.org/, where a team of people read it and gather data about the most common issues.


Install Older Version Of Firefox {web link} Be sure to read everything here.

If you still want to downgrade, look under; I still want to downgrade. Click the Directory of other versions and languages link. Look for the directory of the version that you want. But, remember that old versions may have security issues.

You should also check out Firefox; Extended Support Release {web link} ESR Notes System Requirements

Hi, The people who answer questions here, for the most part, are other Firefox users volunteering their time (like me), not Mozilla employees or Firefox developers. If you want to leave feedback for Firefox developers, you can go to the Firefox ''Help'' menu and select ''Submit Feedback...'' or use [https://input.mozilla.org/feedback this link]. Your feedback gets collected at http://input.mozilla.org/, where a team of people read it and gather data about the most common issues. ---------------------------- [https://support.mozilla.org/en-US/kb/install-older-version-of-firefox?cache=no Install Older Version Of Firefox] {web link} Be sure to read everything here. If you still want to downgrade, look under; '''I still want to downgrade. ''' Click the '''Directory of other versions and languages''' link. Look for the directory of the version that you want. But, remember that '''old versions may have security issues. ''' You should also check out [https://www.mozilla.org/en-US/firefox/organizations/ Firefox; Extended Support Release] {web link} [https://www.mozilla.org/en-US/firefox/organizations/notes/ ESR Notes] [https://www.mozilla.org/en-US/firefox/organizations/system-requirements/ System Requirements]
jscher2000
  • Top 10 Contributor
8575 solutions 70112 answers

Helpful Reply

Why does your WordPress blog require the Java plugin? Do you use it for a custom uploader or some special widget??

Lots of sites require support for JavaScript, no relation to the Java plugin. Browsers handle JavaScript on their own without a plugin. If your Firefox has problems with JavaScript, it could be due to an interfering extension.

If you are interested in attempting to troubleshoot the problem further:

(1) Are you getting any specific error messages from sites that you could copy/paste into a reply?

(2) Does Firefox work any better in its Safe Mode?

In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement? (More info: Troubleshoot Firefox issues using Safe Mode)


If you think it would help to be able to run the Java plugin, you can use the Extended Support Release (ESR) of Firefox 52. It runs the same plugins that ran in Firefox 51.

More information on this change and ESR: Why do Java, Silverlight, Adobe Acrobat and other plugins no longer work?

Windows Users: When you get to the ESR installer list, you'll notice at least two different downloads for Windows:

  • Windows installer is the standard version for Windows that runs on both 32-bit and 64-bit Windows Vista through 10 (and 32-bit XP), the best choice for most users
  • Windows 64-bit installer ONLY runs the Flash and Silverlight plugins, so that is not what you're looking for. (If someone reading this only needs Silverlight and is considering switching to 64-bit, there may be some extra file cleanup to do on your system. See: How to switch from 32-bit to 64-bit Firefox)
Why does your WordPress blog require the Java plugin? Do you use it for a custom uploader or some special widget?? Lots of sites require support for JavaScript, no relation to the Java plugin. Browsers handle JavaScript on their own without a plugin. If your Firefox has problems with JavaScript, it could be due to an interfering extension. If you are interested in attempting to troubleshoot the problem further: (1) Are you getting any specific error messages from sites that you could copy/paste into a reply? (2) Does Firefox work any better in its Safe Mode? In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem. ''If Firefox is not running:'' Hold down the Shift key when starting Firefox. ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" button > Restart with Add-ons Disabled * Help menu > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Any improvement? (More info: [[Troubleshoot Firefox issues using Safe Mode]]) ---- If you think it would help to be able to run the Java plugin, you can use the <em>Extended Support Release</em> (ESR) of Firefox 52. It runs the same plugins that ran in Firefox 51. <p>More information on this change and ESR: [[Why do Java, Silverlight, Adobe Acrobat and other plugins no longer work?]]</p> <p><em>Windows Users:</em> When you get to [https://www.mozilla.org/firefox/organizations/all/ the ESR installer list], you'll notice at least two different downloads for Windows:</p> <ul> <li><strong>Windows</strong> installer is the <strong>standard version for Windows</strong> that runs on both 32-bit and 64-bit Windows Vista through 10 (and 32-bit XP), the best choice for most users</li> <li><strong>Windows 64-bit</strong> installer ONLY runs the Flash and Silverlight plugins, so that is not what you're looking for. (If someone reading this only needs Silverlight and is considering switching to 64-bit, there may be some extra file cleanup to do on your system. See: [[How to switch from 32-bit to 64-bit Firefox]])</li> </ul>

Helpful Reply

WordPress requires Java in browsers to function on browsers. It uses Java for logging onto blogs and for leaving comments. If a person's browser does not support Java, they can't interact on my blog. I notice too that newer posted articles don't appear for a full day without Java.

The only solution is for users to either try to delete Firefox and install an older version that supported Java, which almost no one is going to bother to do just to get on my blog, or to switch to a different browser like Opera or Chrome, and Chrome works poorly with Java. Because of this I may end up having to shut down my blog, I hate to do it, I've had it for 11 years now, it's like an old friend.

FireFox was the best, I don't understand why they did this. I will try running the Extended Support Release (ESR) of Firefox 52. Thanks for that.

WordPress requires Java in browsers to function on browsers. It uses Java for logging onto blogs and for leaving comments. If a person's browser does not support Java, they can't interact on my blog. I notice too that newer posted articles don't appear for a full day without Java. The only solution is for users to either try to delete Firefox and install an older version that supported Java, which almost no one is going to bother to do just to get on my blog, or to switch to a different browser like Opera or Chrome, and Chrome works poorly with Java. Because of this I may end up having to shut down my blog, I hate to do it, I've had it for 11 years now, it's like an old friend. FireFox was the best, I don't understand why they did this. I will try running the Extended Support Release (ESR) of Firefox 52. Thanks for that.

Question owner

FredMcD said

Hi, The people who answer questions here, for the most part, are other Firefox users volunteering their time (like me), not Mozilla employees or Firefox developers. If you want to leave feedback for Firefox developers, you can go to the Firefox Help menu and select Submit Feedback... or use this link. Your feedback gets collected at http://input.mozilla.org/, where a team of people read it and gather data about the most common issues.

Install Older Version Of Firefox {web link} Be sure to read everything here.

If you still want to downgrade, look under; I still want to downgrade. Click the Directory of other versions and languages link. Look for the directory of the version that you want. But, remember that old versions may have security issues.

You should also check out Firefox; Extended Support Release {web link} ESR Notes System Requirements

''FredMcD [[#answer-964247|said]]'' <blockquote> Hi, The people who answer questions here, for the most part, are other Firefox users volunteering their time (like me), not Mozilla employees or Firefox developers. If you want to leave feedback for Firefox developers, you can go to the Firefox ''Help'' menu and select ''Submit Feedback...'' or use [https://input.mozilla.org/feedback this link]. Your feedback gets collected at http://input.mozilla.org/, where a team of people read it and gather data about the most common issues. ---------------------------- [https://support.mozilla.org/en-US/kb/install-older-version-of-firefox?cache=no Install Older Version Of Firefox] {web link} Be sure to read everything here. If you still want to downgrade, look under; '''I still want to downgrade. ''' Click the '''Directory of other versions and languages''' link. Look for the directory of the version that you want. But, remember that '''old versions may have security issues. ''' You should also check out [https://www.mozilla.org/en-US/firefox/organizations/ Firefox; Extended Support Release] {web link} [https://www.mozilla.org/en-US/firefox/organizations/notes/ ESR Notes] [https://www.mozilla.org/en-US/firefox/organizations/system-requirements/ System Requirements] </blockquote>
jscher2000
  • Top 10 Contributor
8575 solutions 70112 answers

BlackSheep123. said

WordPress requires Java in browsers to function on browsers. It uses Java for logging onto blogs and for leaving comments. If a person's browser does not support Java, they can't interact on my blog. I notice too that newer posted articles don't appear for a full day without Java.

This seems to be peculiarity of your blog. I run a WordPress blog (not on WordPress.com, on my own site) which has no dependency on the Java plugin.

Also, Chrome doesn't run the Java plugin, so that would mean no one who uses Chrome could administer or comment on a WordPress blog. I think I would have heard of that.

There may be some other issue with your Firefox that is affecting interaction with your blog completely unrelated to the Java plugin. If you want to explore that hypothesis, let us know.


By the way, your browser shared this information when you posted your question:

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:52.0) Gecko/20100101 Firefox/52.0

That's Firefox 52 on Windows XP.

Installed Plug-ins... Next Generation Java Plug-in 10.17.2 for Mozilla browsers

Since your Firefox reported that you have Java installed, you must already be running the Extended Support Release. However, that is a very old version of Java. Perhaps Oracle won't let you install a newer version? You could try this page: https://www.java.com/en/download/manual.jsp

''BlackSheep123. [[#answer-964275|said]]'' <blockquote> WordPress requires Java in browsers to function on browsers. It uses Java for logging onto blogs and for leaving comments. If a person's browser does not support Java, they can't interact on my blog. I notice too that newer posted articles don't appear for a full day without Java.</blockquote> This seems to be peculiarity of your blog. I run a WordPress blog (not on WordPress.com, on my own site) which has no dependency on the Java plugin. Also, Chrome doesn't run the Java plugin, so that would mean no one who uses Chrome could administer or comment on a WordPress blog. I think I would have heard of that. There may be some other issue with your Firefox that is affecting interaction with your blog completely unrelated to the Java plugin. If you want to explore that hypothesis, let us know. ---- By the way, your browser shared this information when you posted your question: User Agent: Mozilla/5.0 (Windows NT 5.1; rv:52.0) Gecko/20100101 Firefox/52.0 That's Firefox 52 on Windows XP. Installed Plug-ins... Next Generation Java Plug-in 10.17.2 for Mozilla browsers Since your Firefox reported that you have Java installed, you must already be running the Extended Support Release. However, that is a very old version of Java. Perhaps Oracle won't let you install a newer version? You could try this page: https://www.java.com/en/download/manual.jsp

Modified by jscher2000

Question owner

I'm new here so I didn't know that this isn't a developers forum. Thanks for that information.

Downgrading to an earlier version of Firefox would no doubt return what I do with my blog to normal, but it won't do a thing to fix the problem for everyone else who uses the latest version of Firefox. The only other browser I've found that works right with WordPress blogs is Opera.

Internet Explorer will provided its users keep their ActiveX up to date, as outdated ActiveX blocks Java from functioning, or at least that's what I'm reading off the Web, and one frequenter of my blog has been reporting this issue with IE.

Firefox is the most used browser, so this pretty much kills WordPress blogs.

I'm new here so I didn't know that this isn't a developers forum. Thanks for that information. Downgrading to an earlier version of Firefox would no doubt return what I do with my blog to normal, but it won't do a thing to fix the problem for everyone else who uses the latest version of Firefox. The only other browser I've found that works right with WordPress blogs is Opera. Internet Explorer will provided its users keep their ActiveX up to date, as outdated ActiveX blocks Java from functioning, or at least that's what I'm reading off the Web, and one frequenter of my blog has been reporting this issue with IE. Firefox is the most used browser, so this pretty much kills WordPress blogs.

Question owner

jscher2000 said

BlackSheep123. said
WordPress requires Java in browsers to function on browsers. It uses Java for logging onto blogs and for leaving comments. If a person's browser does not support Java, they can't interact on my blog. I notice too that newer posted articles don't appear for a full day without Java.

This seems to be peculiarity of your blog. I run a WordPress blog (not on WordPress.com, on my own site) which has no dependency on the Java plugin.

Also, Chrome doesn't run the Java plugin, so that would mean no one who uses Chrome could administer or comment on a WordPress blog. I think I would have heard of that.

There may be some other issue with your Firefox that is affecting interaction with your blog completely unrelated to the Java plugin. If you want to explore that hypothesis, let us know.


By the way, your browser shared this information when you posted your question:

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:52.0) Gecko/20100101 Firefox/52.0

That's Firefox 52 on Windows XP.

Installed Plug-ins... Next Generation Java Plug-in 10.17.2 for Mozilla browsers

Since your Firefox reported that you have Java installed, you must already be running the Extended Support Release. However, that is a very old version of Java. Perhaps Oracle won't let you install a newer version? You could try this page: https://www.java.com/en/download/manual.jsp

''jscher2000 [[#answer-964277|said]]'' <blockquote> ''BlackSheep123. [[#answer-964275|said]]'' <blockquote> WordPress requires Java in browsers to function on browsers. It uses Java for logging onto blogs and for leaving comments. If a person's browser does not support Java, they can't interact on my blog. I notice too that newer posted articles don't appear for a full day without Java.</blockquote> This seems to be peculiarity of your blog. I run a WordPress blog (not on WordPress.com, on my own site) which has no dependency on the Java plugin. Also, Chrome doesn't run the Java plugin, so that would mean no one who uses Chrome could administer or comment on a WordPress blog. I think I would have heard of that. There may be some other issue with your Firefox that is affecting interaction with your blog completely unrelated to the Java plugin. If you want to explore that hypothesis, let us know. ---- By the way, your browser shared this information when you posted your question: User Agent: Mozilla/5.0 (Windows NT 5.1; rv:52.0) Gecko/20100101 Firefox/52.0 That's Firefox 52 on Windows XP. Installed Plug-ins... Next Generation Java Plug-in 10.17.2 for Mozilla browsers Since your Firefox reported that you have Java installed, you must already be running the Extended Support Release. However, that is a very old version of Java. Perhaps Oracle won't let you install a newer version? You could try this page: https://www.java.com/en/download/manual.jsp </blockquote>
jscher2000
  • Top 10 Contributor
8575 solutions 70112 answers

BlackSheep123. said

The only other browser I've found that works right with WordPress blogs is Opera.

Can you give a link to a blog post where you can't comment without the Java plugin?

Firefox is the most used browser, so this pretty much kills WordPress blogs.

Firefox 52 -- the first version that completely blocks the Java plugin -- was released on March 7, 2017. Now, about 8 weeks later, this is the first thread I've seen that says it affects WordPress. So something is not adding up here.

''BlackSheep123. [[#answer-964279|said]]'' <blockquote> The only other browser I've found that works right with WordPress blogs is Opera.</blockquote> Can you give a link to a blog post where you can't comment without the Java plugin? <blockquote>Firefox is the most used browser, so this pretty much kills WordPress blogs.</blockquote> Firefox 52 -- the first version that completely blocks the Java plugin -- was released on March 7, 2017. Now, about 8 weeks later, this is the first thread I've seen that says it affects WordPress. So something is not adding up here.

Question owner

My blog is hosted on Bluehost, always has been, and on the day that Firefox did it's automatic update, that no longer supports Java, and I got that auto update, my blog stopped logging me or anyone else in. I checked with WordPress and YES, they require Java on the browser. I may have a version that does and yours may not, I don't know. You say Opera doesn't use Java but I disagree, and offer this quote from techhelpkb.com: "For users running the Windows and Mac operating systems, Opera uses the Java plug-in to run Java applets." And I do have Java installed.

There is a Wordpress upgrade available but the last 2 times I upgraded it, it was a nightmare each time, with files and past history being garbled and deleted all over the place and I'm loathe to do it again in the HOPE, no certainty at all, that it would fix this.

What would fix this would be for Firefox to use Java again.

My blog is hosted on Bluehost, always has been, and on the day that Firefox did it's automatic update, that no longer supports Java, and I got that auto update, my blog stopped logging me or anyone else in. I checked with WordPress and YES, they require Java on the browser. I may have a version that does and yours may not, I don't know. You say Opera doesn't use Java but I disagree, and offer this quote from techhelpkb.com: "For users running the Windows and Mac operating systems, Opera uses the Java plug-in to run Java applets." And I do have Java installed. There is a Wordpress upgrade available but the last 2 times I upgraded it, it was a nightmare each time, with files and past history being garbled and deleted all over the place and I'm loathe to do it again in the HOPE, no certainty at all, that it would fix this. What would fix this would be for Firefox to use Java again.

Question owner

jscher2000 said

BlackSheep123. said
The only other browser I've found that works right with WordPress blogs is Opera.

Can you give a link to a blog post where you can't comment without the Java plugin?

Firefox is the most used browser, so this pretty much kills WordPress blogs.

Firefox 52 -- the first version that completely blocks the Java plugin -- was released on March 7, 2017. Now, about 8 weeks later, this is the first thread I've seen that says it affects WordPress. So something is not adding up here.

''jscher2000 [[#answer-964282|said]]'' <blockquote> ''BlackSheep123. [[#answer-964279|said]]'' <blockquote> The only other browser I've found that works right with WordPress blogs is Opera.</blockquote> Can you give a link to a blog post where you can't comment without the Java plugin? <blockquote>Firefox is the most used browser, so this pretty much kills WordPress blogs.</blockquote> Firefox 52 -- the first version that completely blocks the Java plugin -- was released on March 7, 2017. Now, about 8 weeks later, this is the first thread I've seen that says it affects WordPress. So something is not adding up here. </blockquote>

Question owner

Nothing is not adding up here. I blocked the Firefox update until April 27, and then allowed it.

Nothing is not adding up here. I blocked the Firefox update until April 27, and then allowed it.

Question owner

The blog is www.newsbleat.com You can check it out yourself if you want to, see what happens.

The blog is www.newsbleat.com You can check it out yourself if you want to, see what happens.
jscher2000
  • Top 10 Contributor
8575 solutions 70112 answers

I was able to post a couple comments using Firefox 53 on Windows 7. But there is a problem viewing the comments, as you mentioned. For example, on this post: http://newsbleat.com/2017/04/30/take-a-number/

  • I saw it after I posted. When I came back to the post after reading a different one, I didn't see it.
  • A regular Ctrl+r reload didn't show it.
  • A reload bypassing Firefox's cache (Ctrl+Shift+r) did show it.
  • Ctrl+r right after that, it's gone again.

W T F

When I look at the server response in Firefox's Network Monitor, it includes this interesting HTTP header exchange:

Firefox Regular page load:

Firefox request (after first request): Cache-Control: max-age=0

Server response: X-Acc-Exp: 3600 X-Proxy-Cache: HIT

Firefox Reload bypassing cache:

Firefox request: Pragma: no-cache Cache-Control: no-cache

Server response: X-Acc-Exp: 3600 X-Proxy-Cache: BYPASS

So there's a cache on the server, and it is not getting refreshed immediately after comments are posted, and Firefox is getting the old version.

Now... when I compare Chrome, it's slightly different:

Chrome Regular page load:

Chrome request (after first request): Cache-Control: max-age=0

Server response: X-Acc-Exp: 3600 X-Proxy-Cache: MISS

Chrome Reload bypassing cache:

Chrome request: Pragma: no-cache Cache-Control: no-cache

Server response: X-Acc-Exp: 3600 X-Proxy-Cache: BYPASS

Why does Chrome get a fresh page -- cache MISS -- on a regular load??

More generally: can you ask Bluehost to disabling caching on your site as a test?

I was able to post a couple comments using Firefox 53 on Windows 7. But there is a problem viewing the comments, as you mentioned. For example, on this post: http://newsbleat.com/2017/04/30/take-a-number/ * I saw it after I posted. When I came back to the post after reading a different one, I didn't see it. * A regular Ctrl+r reload didn't show it. * A reload bypassing Firefox's cache (Ctrl+Shift+r) did show it. * Ctrl+r right after that, it's gone again. W T F When I look at the server response in Firefox's Network Monitor, it includes this interesting HTTP header exchange: '''Firefox Regular page load:''' ''Firefox request (after first request):'' Cache-Control: max-age=0 ''Server response:'' X-Acc-Exp: 3600 X-Proxy-Cache: '''HIT''' '''Firefox Reload bypassing cache:''' ''Firefox request:'' Pragma: no-cache Cache-Control: no-cache ''Server response:'' X-Acc-Exp: 3600 X-Proxy-Cache: '''BYPASS''' So there's a cache on the server, and it is not getting refreshed immediately after comments are posted, and Firefox is getting the old version. Now... when I compare Chrome, it's slightly different: '''Chrome Regular page load:''' ''Chrome request (after first request):'' Cache-Control: max-age=0 ''Server response:'' X-Acc-Exp: 3600 X-Proxy-Cache: '''MISS''' '''Chrome Reload bypassing cache:''' ''Chrome request:'' Pragma: no-cache Cache-Control: no-cache ''Server response:'' X-Acc-Exp: 3600 X-Proxy-Cache: '''BYPASS''' Why does Chrome get a fresh page -- cache MISS -- on a regular load?? More generally: can you ask Bluehost to disabling caching on your site as a test?

Question owner

Your interest in this is much appreciated. Thank you! I have similar problems with Chrome. With Opera, however, no problems at all, it remembers that I'm logged on, so I'm not constantly logging in, and I have no problem posting articles or comments, or reading those of others.

Why Chrome acts the way it does, I've no clue. I saw the comments you left on the blog, so you can see that Chrome at least lets you leave them.

I wondered if it might be a cache problem but not in Bluehost, as I would have had to make some change in Bluehost to cause that, and I had not logged in with them until well after this started, looking to see if I could find any problem there. Which I didn't.

So I did all the other things, deleting cache, cookies, all of it. Finally I started searching Google for answers and it was then that I realized that my WordPress.org installation for this sort of blog requires Java functions, and that Firefox no longer supported those functions.

Chrome sort of does, and Opera does very well. IE also does if everything is kept updated.

I may be wrong that this is all a Firefox problem, I'm no techie and I don't know code. Everything points to it so far, tho.

Your interest in this is much appreciated. Thank you! I have similar problems with Chrome. With Opera, however, no problems at all, it remembers that I'm logged on, so I'm not constantly logging in, and I have no problem posting articles or comments, or reading those of others. Why Chrome acts the way it does, I've no clue. I saw the comments you left on the blog, so you can see that Chrome at least lets you leave them. I wondered if it might be a cache problem but not in Bluehost, as I would have had to make some change in Bluehost to cause that, and I had not logged in with them until well after this started, looking to see if I could find any problem there. Which I didn't. So I did all the other things, deleting cache, cookies, all of it. Finally I started searching Google for answers and it was then that I realized that my WordPress.org installation for this sort of blog requires Java functions, and that Firefox no longer supported those functions. Chrome sort of does, and Opera does very well. IE also does if everything is kept updated. I may be wrong that this is all a Firefox problem, I'm no techie and I don't know code. Everything points to it so far, tho.
jscher2000
  • Top 10 Contributor
8575 solutions 70112 answers

Just to clarify, I posted the comments using Firefox and then when I saw the weird behavior trying to view them, I compared viewing them in Chrome. As for the root cause, all I can say is that Firefox gets served cached pages and Chrome doesn't, and the cached pages didn't contain my comments.

If you want to see how Firefox 51 does, you can download the "portable" version from here:

https://sourceforge.net/projects/portableapps/files/Mozilla%20Firefox%2C%20Portable%20Ed./Mozilla%20Firefox%2C%20Portable%20Edition%2051.0.1/

That is a self-contained installation you can launch right from the Downloads folder. I think you probably need to close your regular Firefox while using it.

Just to clarify, I posted the comments using Firefox and then when I saw the weird behavior trying to view them, I compared viewing them in Chrome. As for the root cause, all I can say is that Firefox gets served cached pages and Chrome doesn't, and the cached pages didn't contain my comments. If you want to see how Firefox 51 does, you can download the "portable" version from here: https://sourceforge.net/projects/portableapps/files/Mozilla%20Firefox%2C%20Portable%20Ed./Mozilla%20Firefox%2C%20Portable%20Edition%2051.0.1/ That is a self-contained installation you can launch right from the Downloads folder. I think you probably need to close your regular Firefox while using it.

Question owner

It wouldn't install, got a window with a detailed explanation I didn't read because I wouldn't have understood all that stuff anyway. Getting pretty late, I'm going to hit the sack. Thanks for your help and interest.

It wouldn't install, got a window with a detailed explanation I didn't read because I wouldn't have understood all that stuff anyway. Getting pretty late, I'm going to hit the sack. Thanks for your help and interest.

Question owner

I went through every accessible item in my WordPress admin files and found nothing changed. I ran Firefox in Safe Mode and still have the same problem, that didn't change. I did Refresh on Firefox the day this started happening and that fixed nothing. Made for a lot of extra work trying to put things back like they were, tho. This problem started the day I went ahead and let Firefox update itself. I hate program updates, half the time they screw themselves or something else all up, and this is no exception. I have no problems with Firefox at all, with the update, as long as what I'm doing or accessing doesn't use Java.

I went through every accessible item in my WordPress admin files and found nothing changed. I ran Firefox in Safe Mode and still have the same problem, that didn't change. I did Refresh on Firefox the day this started happening and that fixed nothing. Made for a lot of extra work trying to put things back like they were, tho. This problem started the day I went ahead and let Firefox update itself. I hate program updates, half the time they screw themselves or something else all up, and this is no exception. I have no problems with Firefox at all, with the update, as long as what I'm doing or accessing doesn't use Java.
jscher2000
  • Top 10 Contributor
8575 solutions 70112 answers

I tested Firefox 45 "portable edition" and it has the same problem with the Bluehost caching. I assume it's Bluehost, and not a WordPress caching plugin.

I tested Firefox 45 "portable edition" and it has the same problem with the Bluehost caching. I assume it's Bluehost, and not a WordPress caching plugin.

Question owner

It might be some change in Bluehost. I'm still digging into it. Thanks for your efforts but I think we've hit the wall on this.

It might be some change in Bluehost. I'm still digging into it. Thanks for your efforts but I think we've hit the wall on this.

Chosen Solution

Surprise, surprise. It was all a WordPress problem after all. I take back all those mean thoughts about Firefox. When WP tried to auto-update to the latest version it conflicted with a plugin and failed to update, while at the same time corrupting the plugin, which caused the login and comment problem.

A tech on my service provider shut down all the plugins, updated WP for me and then, later after more problems, I had another tech re-enable my ability do download and activate plugins. There's still an obvious glitch or two but at least it's functioning mostly normally now. I don't think they're hiring the brightest and best at my service provider......

Ennyhoo, thanks for all the help and suggestions. I'm glad it was WP and not Firefox, which really is the best of all the available browsers.

Surprise, surprise. It was all a WordPress problem after all. I take back all those mean thoughts about Firefox. When WP tried to auto-update to the latest version it conflicted with a plugin and failed to update, while at the same time corrupting the plugin, which caused the login and comment problem. A tech on my service provider shut down all the plugins, updated WP for me and then, later after more problems, I had another tech re-enable my ability do download and activate plugins. There's still an obvious glitch or two but at least it's functioning mostly normally now. I don't think they're hiring the brightest and best at my service provider...... Ennyhoo, thanks for all the help and suggestions. I'm glad it was WP and not Firefox, which really is the best of all the available browsers.