Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox won`t play flash player

  • 28 replies
  • 5 have this problem
  • 114 views
  • Last reply by FredMcD

more options

I`m reading shown below, to solve this, NPSWF32DLL should be deleted in Firefox program files folder by looking for a plugins folder, but i cant find "Firefox program files folder". It also says to delete corresponding flash player.xpt, Could you help please?. My computer is Windows 10-Firefox 49.0.2

""Go into the Firefox program files folder and look for a plugins folder. If you find a folder by that name, open it and see if there is a NPSWF32.DLL file in there. If so, delete that file and delete the corresponding flashplayer.xpt file from that folder. Actually, you can delete that folder altogether - Firefox hasn't had that folder for a number of years now, but will use whatever files might be in there from years ago.""

All Replies (20)

more options

Flash is in its own folder in Programs Folder.


Flash: Grab the uninstaller from here: Uninstall Flash Player | Windows Uninstall Flash Player | Mac

Then reinstall the latest version.

Note: Windows users should download the active_x for Internet Explorer. and the plugin for Plugin-based browsers (like Firefox).

Note: Windows 8 and Windows 10 have built-in flash players and Adobe will cause a conflict. Install the plugin only. Not the active_x.

Flash Player Version: 23.0.0. 205 Flash Player (Linux) Version 11.2. 202.643

https://get.adobe.com/flashplayer/ Direct link scans current system and browser Note: Other software is offered in the download.

https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, Win IE . . . .) Note: Other software is offered in the download.

more options

The solution should never start with having to delete a DLL file. What is the problem, exactly, and what steps are you following to address it?

more options

jscher2000 said

The solution should never start with having to delete a DLL file. What is the problem, exactly, and what steps are you following to address it?
The following was posted on Mozilla forum>>""Go into the Firefox program files folder and look for a plugins folder. If you find a folder by that name, open it and see if there is a NPSWF32.DLL file in there. If so, delete that file and delete the corresponding flashplayer.xpt file from that folder. Actually, you can delete that folder altogether - Firefox hasn't had that folder for a number of years now, but will use whatever files might be in there from years ago.""On Microsoft Edge (IE) browser, videos on the news home page will play. On Firefox they won`t play."""ed-meister posted in Feb 2015 to delete NPSWF32.DLL""" AGAIN, in my original post>>>""""On Microsoft Edge (IE) browser, videos on the news home page will play. On Firefox they won`t play."""

Modified by Terry

more options

https://support.mozilla.org/en-US/questions/1046232

That user was showing two different Flash DLL files in his "More System Details".

I responded with this.

Looks like you have 2 Flash DLL files for Firefox. Shockwave Flash 9.0 r45 Shockwave Flash 16.0 r0

Then that user responded be mentioning he couldn't find two of then in the expected location. It was then that I came up with the eventual "fix", from the days of Firefox 2.0 - like 10 years ago during the reign of WinXP.

We rarely saw a problem like that with Vista or newer Windows OS's, and especially not with Windows 10. So that was an answer for that particular questions thread and for that particular user who was using WinXP. And it is out of context for your problem with Flash. Your "More System Details" doesn't show two Flash DLL files.


Please explain the problem you are having with Firefox and Flash. Let's deal with what you have going on, and not try to use answers for other problems that are no where near what's wrong with your Firefox installation.

more options

the-edmeister said

https://support.mozilla.org/en-US/questions/1046232 That user was showing two different Flash DLL files in his "More System Details". I responded with this.
Looks like you have 2 Flash DLL files for Firefox. Shockwave Flash 9.0 r45 Shockwave Flash 16.0 r0

Then that user responded be mentioning he couldn't find two of then in the expected location. It was then that I came up with the eventual "fix", from the days of Firefox 2.0 - like 10 years ago during the reign of WinXP.

We rarely saw a problem like that with Vista or newer Windows OS's, and especially not with Windows 10. So that was an answer for that particular questions thread and for that particular user who was using WinXP. And it is out of context for your problem with Flash. Your "More System Details" doesn't show two Flash DLL files.


Please explain the problem you are having with Firefox and Flash. Let's deal with what you have going on, and not try to use answers for other problems that are no where near what's wrong with your Firefox installation.

I have explained what is happening in my original post, """"flash will play videos on Microsoft edge browser but not on Firefox 49 and got no answer to solve it."""" disabling protection is not the way it`s unsafe.. People search the internet to try and solve problems and i don`t need someone telling me what i can and can`t do. If you don`t know just forget it. I have asked about this before and it seems nobody knows the answer.
more options

Terry said

the-edmeister said
https://support.mozilla.org/en-US/questions/1046232 That user was showing two different Flash DLL files in his "More System Details". I responded with this.
Looks like you have 2 Flash DLL files for Firefox. Shockwave Flash 9.0 r45 Shockwave Flash 16.0 r0

Then that user responded be mentioning he couldn't find two of then in the expected location. It was then that I came up with the eventual "fix", from the days of Firefox 2.0 - like 10 years ago during the reign of WinXP.

We rarely saw a problem like that with Vista or newer Windows OS's, and especially not with Windows 10. So that was an answer for that particular questions thread and for that particular user who was using WinXP. And it is out of context for your problem with Flash. Your "More System Details" doesn't show two Flash DLL files.


Please explain the problem you are having with Firefox and Flash. Let's deal with what you have going on, and not try to use answers for other problems that are no where near what's wrong with your Firefox installation.

I have explained what is happening in my original post, """"flash will play videos on Microsoft edge browser but not on Firefox 49 and got no answer to solve it."""" disabling protection is not the way it`s unsafe.. People search the internet to try and solve problems and i don`t need someone telling me what i can and can`t do. If you don`t know just forget it. I have asked about this before and it seems nobody knows the answer.
Well?
more options

You're saying that videos will play on Edge, but won't play on Firefox, and you mentioned this happening with videos on the news home page. Is this news home page a BBC website, by any chance   ?
Do you get sound, but no picture,   ?
(trying to narrow the problem down)

more options

Happy112 said

You're saying that videos will play on Edge, but won't play on Firefox, and you mentioned this happening with videos on the news home page. Is this news home page a BBC website, by any chance   ?
Do you get sound, but no picture,   ?
(trying to narrow the problem down)
Thank You, Australia website homepage. No sound no picture just doesn`t play. Latest version of Adobe/Shockwave flash is installed.
more options

Thank you   ! Yes;   your Flash is up to date;   so that's not the problem.
Don't mean to be a pain in the you-know-where;   but could you possibly give us a link to that website   ? (been looking for 'Australia' websites,   but there are a number of them   .......)

more options

....... forgot to ask: The heading of your question says:   'Firefox won't play Flash Player';   what makes you say that   ? Do you get some message that tells you that   Firefox won't play
Flash Player   ? (still trying to narrow things down   ....... )

more options

Please post a public link that we can check out.

more options

Happy112 said

Thank you   ! Yes;   your Flash is up to date;   so that's not the problem.
Don't mean to be a pain in the you-know-where;   but could you possibly give us a link to that website   ? (been looking for 'Australia' websites,   but there are a number of them   .......)

It has an f symbol on the video screen as well asin my attachment. The website is "nine.com.au" a tv channel. I appreciate of course all help.

more options

Thank you so much for that screenshot and the link   !
'Been looking around and found a few things, like: The Flash plugin could be crashing because of an extension or hardware acceleration in Firefox. To see if one of these is causing the problem; please go through the steps in the article   'Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems' :
        http://mzl.la/1xKrH3y

The above is part of the article   'Adobe Flash plugin crashed - Prevent it from happening again' :     http://mzl.la/14Ad7Md

Modified by Happy112

more options

Tried all that, no change.

more options

I tried several links to player pages. My download managers showed there were no clips on those pages. I used Inspect Element on;

http://pickle.nine.com.au/2016/11/08/08/00/planet-earth-2-iguana-vs-snake-chase-scene-could-rival-a-mel-gibson-movie

I did not see any link information. Just this; November 08, 2016: This segment from BBC’s Planet Earth II is being lauded as one of the most intense scenes in nature documentary history

Note: The page works using Win IE. (Adobe Flash)


Solved: Load the web page. After the page is loaded, click the down arrow next to the AdBlock icon. Now select Disable on <website>. Reload the page.

more options

FredMcD said

I tried several links to player pages. My download managers showed there were no clips on those pages. I used Inspect Element on; http://pickle.nine.com.au/2016/11/08/08/00/planet-earth-2-iguana-vs-snake-chase-scene-could-rival-a-mel-gibson-movie I did not see any link information. Just this; November 08, 2016: This segment from BBC’s Planet Earth II is being lauded as one of the most intense scenes in nature documentary history Note: The page works using Win IE. (Adobe Flash)

Solved: Load the web page. After the page is loaded, click the down arrow next to the AdBlock icon. Now select Disable on <website>. Reload the page.

Thank You Fred. I have Ublock on this computer as you see in my azttachments. I tried to disable while on Firefox and tried to play video clips but it still shows the "f" and doesn`t play.

Modified by Terry

more options

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh).

Is the problem still there?


Start your Computer in safe mode with networking. Then start Firefox. Try Safe websites. Is the problem still there?

Starting The Computer In Safe Mode;
Free Online Encyclopedia

more options

Terry said:

Thank You Fred. I have Ublock on this computer as you see in my azttachments. I tried to disable while on Firefox and tried to play video clips but it still shows the "f" and doesn`t play.

That f isn't a default features in Firefox. It sounds like the Flash Control extension might be involved. https://addons.mozilla.org/en-US/firefox/addon/flash-control/ Check the screenshots and verify if that is the f you are seeing. That f (or v for HTML video files) needs to be clicked for the video file to be played.

more options

Thanks to all for attention. I started in Safe mode by holding down the shift key when starting Firefox. The "f" is usually black with a white background in a circle. I disabled Flash Block and no result there either. My attachments show what happened. My other computer doesn`t have "Flash Block" and this problem is not on it.

Modified by Terry

more options

The button with the 'F' is from FlashBlock. Press the button to play the clip.

Press the arrow next to the FlashBlock icon and select Allow On This Site.

If there is still a problem, do the same with Ublock.

  1. 1
  2. 2