X
Tap here to go to the mobile version of the site.

Support Forum

why does firefox look fuzzy and blurry after a windows 10 update?

Posted

I am an expert windows user, not advanced....expert. I recently upgraded to windows 10 64bit from windows 8.1 64 bit. Now Firefox is blurry. The tabs are blurry and the icons are blurry. I did not change anything in the about:config and other windows look fine when I open them. Why is Firefox looking horrible? How do I fix this? I have uploaded an image of the desktop with a normal window and Firefox so you can see the difference.

I am an expert windows user, not advanced....expert. I recently upgraded to windows 10 64bit from windows 8.1 64 bit. Now Firefox is blurry. The tabs are blurry and the icons are blurry. I did not change anything in the about:config and other windows look fine when I open them. Why is Firefox looking horrible? How do I fix this? I have uploaded an image of the desktop with a normal window and Firefox so you can see the difference.
Attached screenshots

Chosen solution

I'll just highlight the protected mode issue: That feature has security benefits, but seems to have serious compatibility issues on some systems. You can disable it using the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Plugins. On the right side, find "Shockwave Flash" and click the More link. Then uncheck the box for "Enable Adobe Flash protected mode" and try that for a day to see whether it helps.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 15.9.20069
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.16
  • Amazon MP3 Downloader Plugin 1.0.17
  • CANON iMAGE GATEWAY Album Plugin Utility Module for IJ
  • Version 5.41.2.0
  • Google Update
  • Intel web components updater - Installs and updates the Intel web components
  • Intel web components for Intel® Identity Protection Technology
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.66.2 for Mozilla browsers
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • The plugin allows you to have a better experience with Microsoft Lync
  • CANON iMAGE GATEWAY Mycamera Plugin
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • Plug-in for detecting Nero Kwik Media.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 20.0 r0
  • 5.1.41105.0
  • SumatraPDF Browser Plugin
  • VLC media player Web Plugin
  • iTunes Detector Plug-in

Application

  • Firefox 42.0
  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:42.0) Gecko/20100101 Firefox/42.0
  • Support URL: https://support.mozilla.org/1/firefox/42.0/WINNT/en-US/

Extensions

  • Adobe Acrobat - Create PDF 1.2 (web2pdfextension@web2pdf.adobedotcom) (Inactive)
  • Norton Identity Safe 2015.5.6.78 ({C1A2A613-35F1-4FCF-B27F-2840527B6556}) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce GTX 650
  • adapterDescription2:
  • adapterDeviceID: 0x0fc6
  • adapterDeviceID2:
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um,nvwgf2um
  • adapterDrivers2:
  • adapterRAM: 1024
  • adapterRAM2:
  • adapterSubsysID: 00000000
  • adapterSubsysID2:
  • adapterVendorID: 0x10de
  • adapterVendorID2:
  • clearTypeParameters: D [ Gamma: 1800 Pixel Structure: R ClearType Level: 100 Enhanced Contrast: 300 ] D [ Gamma: 2200 Pixel Structure: R ClearType Level: 50 Enhanced Contrast: 300 ]
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: False
  • directWriteVersion: 10.0.10586.0
  • driverDate: 11-24-2015
  • driverDate2:
  • driverVersion: 10.18.13.5906
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'cairo', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • supportsHardwareH264: False
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 650 Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

Modified Preferences

Misc

  • User JS: No
  • Accessibility: Yes
FredMcD
  • Top 10 Contributor
3668 solutions 50315 answers

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. Is the problem still there?


Separate Issue; Your System Details shows;

Installed Plug-ins

Adobe PDF Plug-In For Firefox and Netscape 15.9.20069 Adobe PDF Plug-In For Firefox and Netscape 10.1.16
Having more than one version of a program may cause issues. You must remove the older programs. Then get the current full installer.

Adobe PDF Plug-In For Firefox and Netscape: Adobe Reader Version 2015.009.20069 Note: McAfee Security is offered in the download.

Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac=Options)'' ''' key, and then starting Firefox. Is the problem still there? ------ Separate Issue; Your System Details shows; Installed Plug-ins Adobe PDF Plug-In For Firefox and Netscape 15.9.20069 Adobe PDF Plug-In For Firefox and Netscape 10.1.16 <br>Having more than one version of a program may cause issues. You must remove the older programs. Then get the current full installer. Adobe PDF Plug-In For Firefox and Netscape: '''[http://get.adobe.com/reader/ Adobe Reader Version 2015.009.20069]''' '''Note: McAfee Security''' is offered in the download.

Helpful Reply

Safe mode didn't change anything. There is a compatibility setting in windows that allows you to "disable display scaling on high DPI settings". This makes everything a bit clearer but makes the Firefox window display settings to be 125% instead of the normal 100%.(programs/right click/properties/compatibility). I disabled this setting for Adobe Photoshop where I was having this same issue and it fixed it there perfectly, but in Firefox it just changes the resolution. I can also set it to run in compatibility mode for windows 8 but that did nothing. I feel it is a compatibility mode problem with Firefox, not with Windows 10. I have also upgraded my graphics driver so that is not the issue.

note: I went to adobe pdf and it says a newer version is already installed so I don't know where that comes from but that is not an issue or problem for me

Safe mode didn't change anything. There is a compatibility setting in windows that allows you to "disable display scaling on high DPI settings". This makes everything a bit clearer but makes the Firefox window display settings to be 125% instead of the normal 100%.(programs/right click/properties/compatibility). I disabled this setting for Adobe Photoshop where I was having this same issue and it fixed it there perfectly, but in Firefox it just changes the resolution. I can also set it to run in compatibility mode for windows 8 but that did nothing. I feel it is a compatibility mode problem with Firefox, not with Windows 10. I have also upgraded my graphics driver so that is not the issue. note: I went to adobe pdf and it says a newer version is already installed so I don't know where that comes from but that is not an issue or problem for me
cor-el
  • Top 10 Contributor
  • Moderator
16397 solutions 147969 answers

You can open the Properties of the Firefox desktop shortcut via the right-click context menu and check the "Compatibility" tab. Make sure that all items are deselected in the "Compatibility" tab of the Properties window.


Try to set layout.css.devPixelsPerPx to 1.0 (default is -1) on the about:config page. If necessary adjust its value in 0.1 or 0.05 steps (1.1 or 0.9) until icons or text looks right.

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

You can open the Properties of the Firefox desktop shortcut via the right-click context menu and check the "Compatibility" tab. Make sure that all items are deselected in the "Compatibility" tab of the Properties window. ---- Try to set layout.css.devPixelsPerPx to 1.0 (default is -1) on the <b>about:config</b> page. If necessary adjust its value in 0.1 or 0.05 steps (1.1 or 0.9) until icons or text looks right. You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I'll be careful" to continue. *http://kb.mozillazine.org/about:config
FredMcD
  • Top 10 Contributor
3668 solutions 50315 answers

Type about:plugins<enter> in the address bar. Now search for the plugin.

Example; Adobe Acrobat File: nppdf32.dll,nppdf32.dll Path: C:\Program Files (x86)\Adobe\Reader 11.0\Reader\browser\nppdf32.dll,C:\Program Files (x86)\Adobe\Reader 11.0\Reader\AIR\nppdf32.dll Version: 11.0.9.29 State: Enabled Adobe PDF Plug-In For Firefox and Netscape 11.0.9

This will show you the path to that program. Copy the Path Only. Also note the name of the file, and remember it. Now Close Firefox. Open your file browser and paste the path in the address bar. Find the file, and delete it. Now you can restart Firefox. Warning ! Remember to delete the right program.

To be safe, remove all of them. Then install the current.

Type '''about:plugins'''<enter> in the address bar. Now search for the plugin. Example; '''Adobe Acrobat''' '''File:''' nppdf32.dll,nppdf32.dll '''Path:''' C:\Program Files (x86)\Adobe\Reader 11.0\Reader\browser\nppdf32.dll,C:\Program Files (x86)\Adobe\Reader 11.0\Reader\AIR\nppdf32.dll '''Version:''' 11.0.9.29 '''State:''' Enabled Adobe PDF Plug-In For Firefox and Netscape 11.0.9 This will show you the path to that program. Copy the '''Path Only.''' Also note the name of the file, and remember it. Now '''Close Firefox.''' Open your file browser and paste the path in the address bar. Find the file, and delete it. Now you can restart Firefox. '''Warning !''' Remember to delete the right program. To be safe, remove all of them. Then install the current.

Question owner

cor-el said

You can open the Properties of the Firefox desktop shortcut via the right-click context menu and check the "Compatibility" tab. Make sure that all items are deselected in the "Compatibility" tab of the Properties window.

Try to set layout.css.devPixelsPerPx to 1.0 (default is -1) on the about:config page. If necessary adjust its value in 0.1 or 0.05 steps (1.1 or 0.9) until icons or text looks right.

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

''cor-el [[#answer-817390|said]]'' <blockquote> You can open the Properties of the Firefox desktop shortcut via the right-click context menu and check the "Compatibility" tab. Make sure that all items are deselected in the "Compatibility" tab of the Properties window. ---- Try to set layout.css.devPixelsPerPx to 1.0 (default is -1) on the <b>about:config</b> page. If necessary adjust its value in 0.1 or 0.05 steps (1.1 or 0.9) until icons or text looks right. You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I'll be careful" to continue. *http://kb.mozillazine.org/about:config </blockquote>
jscher2000
  • Top 10 Contributor
7448 solutions 60790 answers

Unfortunately, your troubleshooting information (next to your question: Question Details > More System Details) shows that Firefox not using hardware acceleration. Without hardware acceleration, some fonts are not smoothed properly, so I suspect that is the problem. Since your driver date is 11-24-2015, I doubt this is a problem with the software being out of date, although you could check for updates (Upgrade your graphics drivers to use hardware acceleration and WebGL). Instead, it could be one of these:

  • Hardware acceleration is set to disabled on the Options page (Advanced panel, General mini-tab)
  • Firefox is blocking hardware acceleration with your graphics card because of stability problems (crashing)
Unfortunately, your troubleshooting information (next to your question: Question Details > More System Details) shows that Firefox not using hardware acceleration. Without hardware acceleration, some fonts are not smoothed properly, so I suspect that is the problem. Since your driver date is 11-24-2015, I doubt this is a problem with the software being out of date, although you could check for updates ([[Upgrade your graphics drivers to use hardware acceleration and WebGL]]). Instead, it could be one of these: * Hardware acceleration is set to disabled on the Options page (Advanced panel, General mini-tab) * Firefox is blocking hardware acceleration with your graphics card because of stability problems (crashing)

Question owner

It changes the font size but everything is still blurry. This is odd because I have other computers that I have done this upgrade to and have not had this issue. Also like I said I opened photoshop and it looked bad as well but by changing the compatibility in the properties it fixed everything just fine. I have the newest graphics driver but I may have to check the monitor makers website to see if they have a new driver (which would seem odd) that might change things. I might be able to disable compatibility and then change the pixel setting and get that to work.

It changes the font size but everything is still blurry. This is odd because I have other computers that I have done this upgrade to and have not had this issue. Also like I said I opened photoshop and it looked bad as well but by changing the compatibility in the properties it fixed everything just fine. I have the newest graphics driver but I may have to check the monitor makers website to see if they have a new driver (which would seem odd) that might change things. I might be able to disable compatibility and then change the pixel setting and get that to work.

Question owner

jscher2000 said

Unfortunately, your troubleshooting information (next to your question: Question Details > More System Details) shows that Firefox not using hardware acceleration. Without hardware acceleration, some fonts are not smoothed properly, so I suspect that is the problem. Since your driver date is 11-24-2015, I doubt this is a problem with the software being out of date, although you could check for updates (Upgrade your graphics drivers to use hardware acceleration and WebGL). Instead, it could be one of these:
  • Hardware acceleration is set to disabled on the Options page (Advanced panel, General mini-tab)
  • Firefox is blocking hardware acceleration with your graphics card because of stability problems (crashing)
''jscher2000 [[#answer-817401|said]]'' <blockquote> Unfortunately, your troubleshooting information (next to your question: Question Details > More System Details) shows that Firefox not using hardware acceleration. Without hardware acceleration, some fonts are not smoothed properly, so I suspect that is the problem. Since your driver date is 11-24-2015, I doubt this is a problem with the software being out of date, although you could check for updates ([[Upgrade your graphics drivers to use hardware acceleration and WebGL]]). Instead, it could be one of these: * Hardware acceleration is set to disabled on the Options page (Advanced panel, General mini-tab) * Firefox is blocking hardware acceleration with your graphics card because of stability problems (crashing) </blockquote>

Question owner

I turned off hardware deceleration because it was suggested in a forum. It didn't work; it looks the same either way.

I turned off hardware deceleration because it was suggested in a forum. It didn't work; it looks the same either way.

Question owner

Graphics driver is the latest. Hardware is NOT disabled.

Graphics driver is the latest. Hardware is NOT disabled.
jscher2000
  • Top 10 Contributor
7448 solutions 60790 answers

mbfield2004 said

Graphics driver is the latest. Hardware is NOT disabled.

Could you check the support information page, Graphics section, to see whether it shows that hardware acceleration is currently being applied? Usually this is indicated by "true" for direct2d and a non-zero numerator for the number of accelerated windows.

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

If you have dual graphics on your system, that sometimes causes issues for Firefox in using acceleration.

''mbfield2004 [[#answer-817407|said]]'' <blockquote> Graphics driver is the latest. Hardware is NOT disabled. </blockquote> Could you check the support information page, Graphics section, to see whether it shows that hardware acceleration is currently being applied? Usually this is indicated by "true" for direct2d and a non-zero numerator for the number of accelerated windows. * "3-bar" menu button > "?" button > Troubleshooting Information * (menu bar) Help > Troubleshooting Information * type or paste about:support in the address bar and press Enter If you have dual graphics on your system, that sometimes causes issues for Firefox in using acceleration.

Question owner

I had turned off acceleration before and it did nothing. It is back on now with no changes. included is the settings in about :config....image file. I don't like messing with this much because it is hard to keep track of to put back when it doesn't work.

I had turned off acceleration before and it did nothing. It is back on now with no changes. included is the settings in about :config....image file. I don't like messing with this much because it is hard to keep track of to put back when it doesn't work.
jscher2000
  • Top 10 Contributor
7448 solutions 60790 answers

Thanks.

It's interesting that Windows 10 shows ClearType parameters and Windows 7 doesn't (at least on this fairly recent installation), so I don't know how to evaluate that line. Either way, ClearType should not affect icons.

The compression artifacts in your images are making it hard to judge the situation. They were uploaded as PNGs, but were they initially captured to JPEG, or does your display show those same kind of artifacts (e.g., distorted pixel colors around the words on the menu bar and elsewhere)?

Thanks. It's interesting that Windows 10 shows ClearType parameters and Windows 7 doesn't (at least on this fairly recent installation), so I don't know how to evaluate that line. Either way, ClearType should not affect icons. The compression artifacts in your images are making it hard to judge the situation. They were uploaded as PNGs, but were they initially captured to JPEG, or does your display show those same kind of artifacts (e.g., distorted pixel colors around the words on the menu bar and elsewhere)?

Question owner

Everything is blurry as far as the text and the icons. I uploaded the image as a jpeg so I hope you can see it clearly. You should be able to see the difference between the Firefox window and the windows explorer window. I don't have odd artifacts just blurry text and icons. Hope the new image helps. I will say this. I don't have an issue on my older sony laptop, a different custom built PC monitor or my surface pro 4 all of which run windows 10 now. It is just this monitor and firefox (the new internet explorer...Edge does not have this issue). Photoshop did have an issue but is no longer a problem. none of the auto:config changes that were suggested or hardware acceleration changes had any affect. One person told me I had an old adobe reader dc driver and to update it. That didn't work but I knew it wouldn't because it has nothing to do with this issue. I find it odd also that I had no problems with windows 8.1 but now I am having issues. I have installed the latest graphics driver and checked the driver for the monitor and they all are the latest. I can use Firefox as it is but the blurriness is an issue and strains the eyes and looks bad. If you can think of anything else let me know. As of now I am hoping it will resolve itself with some update or something. I can't think of any Firefox settings that I can change either.

Everything is blurry as far as the text and the icons. I uploaded the image as a jpeg so I hope you can see it clearly. You should be able to see the difference between the Firefox window and the windows explorer window. I don't have odd artifacts just blurry text and icons. Hope the new image helps. I will say this. I don't have an issue on my older sony laptop, a different custom built PC monitor or my surface pro 4 all of which run windows 10 now. It is just this monitor and firefox (the new internet explorer...Edge does not have this issue). Photoshop did have an issue but is no longer a problem. none of the auto:config changes that were suggested or hardware acceleration changes had any affect. One person told me I had an old adobe reader dc driver and to update it. That didn't work but I knew it wouldn't because it has nothing to do with this issue. I find it odd also that I had no problems with windows 8.1 but now I am having issues. I have installed the latest graphics driver and checked the driver for the monitor and they all are the latest. I can use Firefox as it is but the blurriness is an issue and strains the eyes and looks bad. If you can think of anything else let me know. As of now I am hoping it will resolve itself with some update or something. I can't think of any Firefox settings that I can change either.
cor-el
  • Top 10 Contributor
  • Moderator
16397 solutions 147969 answers

Helpful Reply

Try to set layout.css.devPixelsPerPx to 1.0 (default is -1) on the about:config page. If necessary adjust its value in 0.1 or 0.05 steps (1.1 or 0.9) until icons or text looks right. Modifying layout.css.devPixelsPerPx acts as a global zoom and affects the user interface and web pages and you may have to adjust the appearance of web pages.

You can open the about:config page via the location/address bar. You can accept the warning and click "I'll be careful" to continue.

You can look at the Default FullZoom Level or NoSquint extension to set a default font size and page zoom on web pages.

Try to set layout.css.devPixelsPerPx to 1.0 (default is -1) on the <b>about:config</b> page. If necessary adjust its value in 0.1 or 0.05 steps (1.1 or 0.9) until icons or text looks right. Modifying layout.css.devPixelsPerPx acts as a global zoom and affects the user interface and web pages and you may have to adjust the appearance of web pages. You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I'll be careful" to continue. *http://kb.mozillazine.org/about:config You can look at the Default FullZoom Level or NoSquint extension to set a default font size and page zoom on web pages. *Default FullZoom Level: https://addons.mozilla.org/firefox/addon/default-fullzoom-level/ *NoSquint: https://addons.mozilla.org/firefox/addon/nosquint/

Question owner

NONE OF THESE SUGGESTIONS WORK. This suggestion was made hours ago and does not fix the problem. However. I just shutdown the computer for the 4th time in a couple hours and rebooted it and Firefox is back the way it should have been when I did the update. This must have been a windows 10 issue or some app. I wish they did not tell me to uninstall adobe reader dc though. Now it says I have an outdated plug in but adobe says I have the latest one installed. So you have only made it worse by accident because firefox now crashes when I use it

NONE OF THESE SUGGESTIONS WORK. This suggestion was made hours ago and does not fix the problem. However. I just shutdown the computer for the 4th time in a couple hours and rebooted it and Firefox is back the way it should have been when I did the update. This must have been a windows 10 issue or some app. I wish they did not tell me to uninstall adobe reader dc though. Now it says I have an outdated plug in but adobe says I have the latest one installed. So you have only made it worse by accident because firefox now crashes when I use it
jscher2000
  • Top 10 Contributor
7448 solutions 60790 answers

Had you done Windows updates, restarted once, but not restarted again? Lots of users seem to be having completely random problems in Firefox in that scenario, although this is the strangest one by far.

You're not stuck with DC. If you prefer Adobe Reader XI, you can switch back.

I suspect you need to uninstall DC first. Then, this page has the Reader 11.0.10 download:

https://get.adobe.com/reader/enterprise/

After installing the main program, use its Help menu to Check for Updates to get the current patch (11.0.13). If Reader won't pull the patch, you can download it from here:

http://www.adobe.com/devnet-docs/acrobatetk/tools/ReleaseNotes/11/11.0.13.html

Had you done Windows updates, restarted once, but not restarted again? Lots of users seem to be having completely random problems in Firefox in that scenario, although this is the strangest one by far. You're not stuck with DC. If you prefer Adobe Reader XI, you can switch back. I suspect you need to uninstall DC first. Then, this page has the Reader 11.0.10 download: https://get.adobe.com/reader/enterprise/ After installing the main program, use its Help menu to Check for Updates to get the current patch (11.0.13). If Reader won't pull the patch, you can download it from here: http://www.adobe.com/devnet-docs/acrobatetk/tools/ReleaseNotes/11/11.0.13.html
jscher2000
  • Top 10 Contributor
7448 solutions 60790 answers

I may have misread your comment.

If you like Reader DC but the plugin check page is wrong, that could be because that page has been wrong a lot with that particular plugin. If Reader's Help > Check for Updates is satisfied, then that should be sufficient.

I may have misread your comment. If you like Reader DC but the plugin check page is wrong, that could be because that page has been wrong a lot with that particular plugin. If Reader's Help > Check for Updates is satisfied, then that should be sufficient.

Question owner

This is what I had installed in the first place. I have the latest install. https://get.adobe.com/reader/enterprise/ That is where I upgraded adobe after you told me to uninstall, download and update. I installed it and now firefox says I have an outdated version. I went to get the latest version and adobe says it is already installed....which it is....this version above....that you told me to uninstall and then reinstall..................... Your advice is bad and now firefox crashes every time I use it. it says that I dont have the latest version of flash...WHICH I JUST INSTALLED!!!! I have shut down and restarted firefox 20 times and it now crashes all the time...THanks a lot!

This is what I had installed in the first place. I have the latest install. https://get.adobe.com/reader/enterprise/ That is where I upgraded adobe after you told me to uninstall, download and update. I installed it and now firefox says I have an outdated version. I went to get the latest version and adobe says it is already installed....which it is....this version above....that you told me to uninstall and then reinstall..................... Your advice is bad and now firefox crashes every time I use it. it says that I dont have the latest version of flash...WHICH I JUST INSTALLED!!!! I have shut down and restarted firefox 20 times and it now crashes all the time...THanks a lot!
jscher2000
  • Top 10 Contributor
7448 solutions 60790 answers

mbfield2004 said

I installed it and now firefox says I have an outdated version. I went to get the latest version and adobe says it is already installed....which it is....this version above....that you told me to uninstall and then reinstall..................... Your advice is bad and now firefox crashes every time I use it. it says that I dont have the latest version of flash...WHICH I JUST INSTALLED!!!! I have shut down and restarted firefox 20 times and it now crashes all the time...THanks a lot!

Well, let's try to disentangle those things.

  • Adobe Reader DC: if the internal Help > Check for Updates says there are no updates, there are no updates. What you have is what there is. As I said before, please ignore the plugin check site for this particular plugin.
  • Crashes: You changed a lot of settings in the course of this thread. Can you pin down when the problems started? Was it allowing hardware acceleration?

    If you are getting the Mozilla Crash Reporter form, your Firefox may have logged some data that would help track down the cause of the problem. You can submit that data to Mozilla and share it with forum volunteers to see whether it points to the solution. Please check the support article "Firefox crashes - asking for support" for steps to get those crash report IDs from the about:crashes page, and then post some of the recent ones here.
''mbfield2004 [[#answer-817502|said]]'' <blockquote> I installed it and now firefox says I have an outdated version. I went to get the latest version and adobe says it is already installed....which it is....this version above....that you told me to uninstall and then reinstall..................... Your advice is bad and now firefox crashes every time I use it. it says that I dont have the latest version of flash...WHICH I JUST INSTALLED!!!! I have shut down and restarted firefox 20 times and it now crashes all the time...THanks a lot! </blockquote> Well, let's try to disentangle those things. * Adobe Reader DC: if the internal Help > Check for Updates says there are no updates, there are no updates. What you have is what there is. As I said before, please ignore the plugin check site for this particular plugin. * Flash (Shockwave Flash plugin): This updates from a completely different place: https://www.adobe.com/products/flashplayer/distribution3.html or https://get.adobe.com/flashplayer/ and the plugin check site should be able to assess this one accurately. * Crashes: You changed a lot of settings in the course of this thread. Can you pin down when the problems started? Was it allowing hardware acceleration?<br><br>If you are getting the Mozilla Crash Reporter form, your Firefox may have logged some data that would help track down the cause of the problem. You can submit that data to Mozilla and share it with forum volunteers to see whether it points to the solution. Please check the support article "[[Firefox crashes - asking for support]]" for steps to get those crash report IDs from the about:crashes page, and then post some of the recent ones here.