X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Why does Firefox seem to zoom web pages in by default?

Posted

Whenever I open firefox the browser seems to be zoomed in by two steps away from normal.

It causes images to look blurry and web pages to look different from how I see them in my other browsers.

Why does this occur? Thanks.

Chosen solution

If you press Command+0 or use View > Zoom > Reset, does the zoom level reset to the expected size?

To set your default zoom level higher than the one specified by the site's style sheet, you usually need an add-on. For example, there is one named Default FullZoom Level and another named NoSquint that have this feature. Do you have either of those installed?

Tools > Add-ons > Extensions category


If you haven't already tried disabling Firefox's use of hardware accelerated graphics, go ahead and try that as well.

You usually need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Firefox > Preferences > Advanced > General

Uncheck the box for "Use hardware acceleration when available"

If you restart Firefox, is the clarity improved?


On Windows, you can set screen dimension compatibility modes in your Firefox shortcut, and this will make everything appear larger. I don't know whether that same concept applies to the Mac.

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Version 3.7.1.9330
  • Google Talk Plugin Video Accelerator version:0.1.44.16
  • Displays Java applet content, or a placeholder if Java is not installed.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 10.3 r183
  • WebEx64 General Plugin Container Version 202
  • 6.2.0.0
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • LogMeIn remote control components
  • Picasa plugin.
  • DivX Web Player version 2.0.0.263
  • iPhoto6

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:14.0) Gecko/20100101 Firefox/14.0.1

More Information

jscher2000
  • Top 10 Contributor
2366 solutions 20923 answers

Chosen Solution

If you press Command+0 or use View > Zoom > Reset, does the zoom level reset to the expected size?

To set your default zoom level higher than the one specified by the site's style sheet, you usually need an add-on. For example, there is one named Default FullZoom Level and another named NoSquint that have this feature. Do you have either of those installed?

Tools > Add-ons > Extensions category


If you haven't already tried disabling Firefox's use of hardware accelerated graphics, go ahead and try that as well.

You usually need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Firefox > Preferences > Advanced > General

Uncheck the box for "Use hardware acceleration when available"

If you restart Firefox, is the clarity improved?


On Windows, you can set screen dimension compatibility modes in your Firefox shortcut, and this will make everything appear larger. I don't know whether that same concept applies to the Mac.

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

You can rename the content-prefs.sqlite file to content-prefs.sqlite.old (or delete the file) in the Profile Folder to reset the page zoom on all sites.

You can use this button to go to the Firefox profile folder:

  • Help > Troubleshooting Information > Profile Directory: Show Folder

Question owner

Hi and thanks for the replies.

I found out that I had nosquint installed (didn't even realize it!)

Removed it and it's all good again. :)