X
Tap here to go to the mobile version of the site.

Support Forum

How do I unblock Youtube videos and videos in general?

Posted

I have uninstalled and reinstalled Adobe Flash and that didn't help. I think it must be a setting I'm missing in Firefox because I can view them using other browsers. My settings for Shockwave are 'Always Activate" and the box for Enable Adobe Flash mode is unchecked. I can't watch Youtube, MSN or any other videos. It just shows a black box with a clickable "F" button but clicking it does nothing. I remember when Adobe became an issue, it was asking me to block or allow sites I visited but I don't think I clicked Block on any of them. I've tried everything short of un and reinstalling FF. Help please?

I have uninstalled and reinstalled Adobe Flash and that didn't help. I think it must be a setting I'm missing in Firefox because I can view them using other browsers. My settings for Shockwave are 'Always Activate" and the box for Enable Adobe Flash mode is unchecked. I can't watch Youtube, MSN or any other videos. It just shows a black box with a clickable "F" button but clicking it does nothing. I remember when Adobe became an issue, it was asking me to block or allow sites I visited but I don't think I clicked Block on any of them. I've tried everything short of un and reinstalling FF. Help please?

Chosen solution

Hi Spuds13, could you right-click that "f" and if you get Firefox's right-click context menu (not the Flash player menu), choose Inspect Element (Q). That will open the Inspector in the lower part of the tab and may help identify what is inserting that layer in front of the video. Or maybe not, but that's what I would try.

With respect to:

I don't have either of these - FlashBlock or Flash Control. Everything is set not disable and always activate.

Could you provide a list of your extensions? You can copy/paste a list from the following page, either:

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

Scroll down to the Extensions heading, and you can select the entire table that follows and Ctrl+c (or right-click>Copy) and paste into a reply. It may look a little messy, but we're used to it.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 19.0 r0
  • 5.1.20513.0
  • NPWLPG

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0

More Information

jscher2000
  • Top 10 Contributor
8758 solutions 71658 answers

Firefox's plugin approval message isn't that fancy. Could you check whether you have any extensions like FlashBlock or Flash Control that might be generating that approval screen? You can review your extensions on the Add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then take a close look at what is listed on the right side. If in doubt, disable.

Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

Any improvement?

Firefox's plugin approval message isn't that fancy. Could you check whether you have any extensions like FlashBlock or Flash Control that might be generating that approval screen? You can review your extensions on the Add-ons page. Either: * Ctrl+Shift+a * "3-bar" menu button (or Tools menu) > Add-ons In the left column, click Extensions. Then take a close look at what is listed on the right side. If in doubt, disable. Often a link will appear above at least one disabled extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step. Any improvement?
FredMcD
  • Top 10 Contributor
4254 solutions 59583 answers

Helpful Reply

After the above,

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac Options)
key, and then starting Firefox. Is the problem still there?


check this:

  • see if there are updates for your graphics drive drivers

https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration

  • disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later)

https://forums.adobe.com/message/4468493#TemporaryWorkaround

  • disable hardware acceleration in the Flash plugin

https://forums.adobe.com/thread/891337 See also:

After the above, Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac Options)'' ''' key, and then starting Firefox. Is the problem still there? ----------------- check this: * see if there are updates for your graphics drive drivers '''https://support.mozilla.org/kb/upgrade-graphics-drivers-use-hardware-acceleration''' * disable protected mode in the Flash plugin (Flash 11.3+ on Windows Vista and later) '''https://forums.adobe.com/message/4468493#TemporaryWorkaround''' * disable hardware acceleration in the Flash plugin '''https://forums.adobe.com/thread/891337''' See also: * '''http://kb.mozillazine.org/Flash#Troubleshooting'''

Helpful Reply

I don't have either of these - FlashBlock or Flash Control. Everything is set not disable and always activate.

There are no updates available. I already did this - disable protected mode.

With Youtube, the video box is like I said, Black with a clickable 'F' in the middle. It is actually playing the video and if I put the mouse on the playing timeline, I can see the thumbs of the video. This is what I see.

I don't have either of these - FlashBlock or Flash Control. Everything is set not disable and always activate. There are no updates available. I already did this - disable protected mode. With Youtube, the video box is like I said, Black with a clickable 'F' in the middle. It is actually playing the video and if I put the mouse on the playing timeline, I can see the thumbs of the video. This is what I see.
jscher2000
  • Top 10 Contributor
8758 solutions 71658 answers

Chosen Solution

Hi Spuds13, could you right-click that "f" and if you get Firefox's right-click context menu (not the Flash player menu), choose Inspect Element (Q). That will open the Inspector in the lower part of the tab and may help identify what is inserting that layer in front of the video. Or maybe not, but that's what I would try.

With respect to:

I don't have either of these - FlashBlock or Flash Control. Everything is set not disable and always activate.

Could you provide a list of your extensions? You can copy/paste a list from the following page, either:

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

Scroll down to the Extensions heading, and you can select the entire table that follows and Ctrl+c (or right-click>Copy) and paste into a reply. It may look a little messy, but we're used to it.

Hi Spuds13, could you right-click that "f" and if you get Firefox's right-click context menu (not the Flash player menu), choose Inspect Element (Q). That will open the Inspector in the lower part of the tab and may help identify what is inserting that layer in front of the video. Or maybe not, but that's what I would try. With respect to: <blockquote>I don't have either of these - FlashBlock or Flash Control. Everything is set not disable and always activate. </blockquote> Could you provide a list of your extensions? You can copy/paste a list from the following page, either: * "3-bar" menu button > "?" button > Troubleshooting Information * (menu bar) Help > Troubleshooting Information * type or paste about:support in the address bar and press Enter Scroll down to the Extensions heading, and you can select the entire table that follows and Ctrl+c (or right-click>Copy) and paste into a reply. It may look a little messy, but we're used to it.

Question owner

Here's my right click options, looks like just Youtube options.

But you did solve my problem. When I was going into Adds, I was only looking at Plugins. When I went to Extensions, I saw that Flashblock WAS on. I disabled it and now Youtube works.

Thanks guys!!

Here's my right click options, looks like just Youtube options. But you did solve my problem. When I was going into Adds, I was only looking at Plugins. When I went to Extensions, I saw that Flashblock WAS on. I disabled it and now Youtube works. Thanks guys!!
FredMcD
  • Top 10 Contributor
4254 solutions 59583 answers

That was very good work. Well Done. Please flag your last post as Solved Problem so others will know.


The way Flashblock works is, it prevents videos from playing until you press that arrow in the player area. Very useful.

Load the web page. After the page is loaded, click the down arrow next to the Flashblock icon. Now select Allow Flash On This Site.

That was very good work. Well Done. Please flag your last post as '''Solved Problem''' so others will know. ---------- The way Flashblock works is, it prevents videos from playing until you press that arrow in the player area. Very useful. Load the web page. After the page is loaded, click the down arrow next to the Flashblock icon. Now select '''Allow Flash On This Site.'''