Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why does the Firefox start page come up instead of the homepage I've designated?d

  • 8 replies
  • 3 have this problem
  • 117 views
  • Last reply by dirtball2

more options

Every time I start my computer the FF start page comes up instead of the homepage I've designated? This wouldn't be a problem if I were a computer whiz but the truth is, I am a cyber-challeneged Auld Phart with no formal computer training.

Chosen solution

hi again dirtball2! in reply to your PM - if you suspect an issue with adware on your system, then please perform all these steps:

  1. reset firefox (this will keep your bookmarks and passwords)
  2. afterwards go to the firefox menu ≡ > addons > extensions and in case there are still extensions listed there, disable them.
  3. finally run a full scan of your system with different security tools like the free version of malwarebytes and adwcleaner to make sure that adware isn't present in other places of your system as well.

Troubleshoot Firefox issues caused by malware

Read this answer in context 👍 0

All Replies (8)

more options

hi dirtball2, could you go to the firefox menu ≡ > help ? > troubleshooting information, copy the contents of that page and paste them here into a reply on the forum? this might give us a clue what is going on...

more options

You can use the SearchReset extension to reset some preferences to the default values.

Note that the SearchReset extension only runs once and then uninstalls automatically, so it won't show on the "Firefox > Add-ons" page (about:addons).


You can check the home page setting:

  • Tools > Options > General > Startup: Home page

Firefox supports multiple home pages separated by '|' (pipe) symbols.

If you do not keep changes after a restart or otherwise have problems with preferences, see:

more options

As long as you're getting a number of things to think about, could you test something?

After you re-establish the correct home page, and confirm that it works using either of these methods:

  • Ctrl+n to launch a new window
  • Click the Home button on the toolbar

Could you exit out of Firefox and start it up again? The goal is to determine whether the setting gets lost right away, or only when you completely shut down Windows and start Windows up again.

To make sure you get a good exit, you can use the menu. Either:

  • "3-bar" menu button > "power" button
  • (menu bar) File > Exit

I suggest that instead of using the red "X" button since sometimes Firefox doesn't shut down cleanly using that button.

Please let us know the results of this experiment.

more options

Chosen Solution

hi again dirtball2! in reply to your PM - if you suspect an issue with adware on your system, then please perform all these steps:

  1. reset firefox (this will keep your bookmarks and passwords)
  2. afterwards go to the firefox menu ≡ > addons > extensions and in case there are still extensions listed there, disable them.
  3. finally run a full scan of your system with different security tools like the free version of malwarebytes and adwcleaner to make sure that adware isn't present in other places of your system as well.

Troubleshoot Firefox issues caused by malware

more options

Good morning jscher2000! Thank you for your response and for trying to help me! Since I am new to the Mozilla Support Forum, I am uncertain as to how I should properly proceed. I received 2 other response's beside yours. So as to not confuse myself any more than I already am, I've decided to try working with only one response at a time. I've already started trying to work with phillip. If we can't come up with a resolution, then I will get back to you in turn. Would that be OK? I hope I'm not doing everything wrong! Thanks again for trying to help! dirtball2

more options

Good morning cor-el! Thank you for your response and for trying to help me! Beside yours, I received 2 other response's this morning. Currently I am working with phillip. If we can't come up with resolution, then I will get back to you. Would that be OK? Thank you again for trying to help me! dirtball2

more options

Hi phillip, I have already taken all the steps you listed in your email! Just to be sure I went to the FF menu and checked for add-ons. Everything had been disabled, Next I am going to follow the link posted at the end of your message. Thanks again! dirtball2

more options

Exciting news phillip! While following instructions on the link you posted about dealing with adware, I was able to come up with a solution to my original question! I'm not sure about what I did or how I did it, I just know that I no longer have the problem! Thanks again for your help phillip! I've decided to vote for you as President!LOL! dirtball2