Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox v38.0.1 image loading problems with google (and, most likely, other websites...)

  • 11 replies
  • 26 have this problem
  • 4358 views
  • Last reply by mrdefender

more options

My partner just recently brought this to my attention since this is his prefered method of googling...

if we search using google's image tab, some of the images don't load and we can't see the usual "view image / visit site" when we click on said image....

He's noticed it for the last few days, and it works fine using google chrome or (shrug) internet explorer.

Attached screenshots

Chosen solution

Hmm. WamJam seems to have been the source of the problem. My partner said it was needed to play a flash game yesterday and I found that suspicious. Obviously, that turned out to be the case. Googling it resulted in multiple malware results...

So removed, tripple cleaned, shredded and 3 decades of cleaning later, it works again.

Thanks for the assistance and your patience everyone.

Read this answer in context 👍 4

All Replies (11)

more options
  • Step 1

Many site issues can be caused by corrupt cookies or cache.

  • Clear the Cache and
  • Remove Cookies
    Warning ! ! This will log you out of sites you're logged in to.

Type about:preferences<Enter> in the address bar.

  • Cookies; Select Privacy. Under History, select Firefox will Use Custom Settings. Press the button on the right side called Show Cookies. Use the search bar to look for the site. Note; There may be more than one entry. Remove All of them.
  • Cache; Select Advanced > Network. Across from Cached Web Content, Press Clear Now.

If there is still a problem, Start Firefox in Safe Mode {web link} While you are in safe mode;

Type about:preferences#advanced<Enter> in the address bar.

Under Advanced, Select General. Look for and turn off Use Hardware Acceleration.

Poke around safe web sites. Are there any problems?

Then restart.


  • Step 2

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac Options)
key, and then starting Firefox. Is the problem still there?

more options

Sorry fred, that didn't fix anything. :(

more options

Your System Details shows;

Installed Plug-ins

Shockwave Flash 16.0 r0 Shockwave Flash 17.0 r0 Shockwave Flash 13.0 r0
Having more than one version of a program may cause issues. You must remove the older programs. Then get the current full installer.

Flash: Grab the uninstaller from here: Uninstall Flash Player | Windows Uninstall Flash Player | Mac

Then reinstall the latest version.

Flash Player Version 17.0.0.188
https://www.adobe.com/products/flashplayer/distribution3.html

more options

Dang it. that one looked promising. didn't notice there was more than one instance of flash installed. I fixed that problem (thanks for noticing, btw) but the problem still occurs on google.

(
more options

Remove History For One Site Open the History Manager <Control><Shift> H. In the search bar, enter the name of the site. Right click on one of the listings and select Forget About This Site. This should remove all information, including any passwords / settings.

more options

nope, that didn't work either. :(

more options

You can check the Net log and the Network log in the Web Console (Firefox/Tools > Web Developer) to see what content is blocked (file size is zero) or otherwise fails to load.


If images are missing then check that you do not block images from some domains.

  • Tap the Alt key or press F10 to show the Menu Bar

Check the permissions for the domain in the currently selected tab in "Tools > Page Info > Permissions"

Check "Tools > Page Info > Media" for blocked images

  • Select the first image link and use the cursor Down key to scroll through the list.
  • If an image in the list is grayed and "Block Images from..." has a checkmark then remove this checkmark to unblock images from this domain.

Make sure that you do not block (third-party) images, the permissions.default.image pref on the about:config page should be 1.


There are extensions like Adblock Plus (Firefox/Tools > Add-ons > Extensions) and security software (firewall, anti-virus) that can block images and other content.

See also:

more options

The web console gives me this:

In [Console] alot of these: "This site makes use of a SHA-1 Certificate; it's recommended you use certificates with signature algorithms that use hash functions stronger than SHA-1.1 images"

one of these (each): "SyntaxError: unterminated string literal1 rs=ACT90oHrkp0u27-kfObgJBO6Eh037tWJUg:917:24"

"14:30:34.120 Use of getPreventDefault() is deprecated. Use defaultPrevented instead.1 google:63:0"

As for page and default permissions, those check out. Same goes for software and addons. I've tried with these disabled in the past and the error still occurs.

more options

Did you try Safe Mode?

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window

Try to rename (or delete) the permissions.sqlite file in the Firefox profile folder.

You can use this button to go to the currently used Firefox profile folder:

more options

sadly those two have not yielded any results :(

more options

Chosen Solution

Hmm. WamJam seems to have been the source of the problem. My partner said it was needed to play a flash game yesterday and I found that suspicious. Obviously, that turned out to be the case. Googling it resulted in multiple malware results...

So removed, tripple cleaned, shredded and 3 decades of cleaning later, it works again.

Thanks for the assistance and your patience everyone.