X
Tap here to go to the mobile version of the site.

Support Forum

Plugin container for firefox always plays audio ads. I delete it and it comes back without permission. How do I get rid of it?

Posted

I've deleted it from the file location several times. The only solution I have found is to stop the process in task manager but that is a pain and has to be repeated several times within minutes of each other. How do I safely get rid of this forever without it somehow being added again. Thank You

I've deleted it from the file location several times. The only solution I have found is to stop the process in task manager but that is a pain and has to be repeated several times within minutes of each other. How do I safely get rid of this forever without it somehow being added again. Thank You

Chosen solution

Hi, you mentioned the Plugin container process, so I suppose you are actually talking about Flash ads. In that case you have at least a few options to choose from: 1) you could uninstall the Adobe Flash plugin . Doing this will get rid of the actual plugin, which the Plugin container "contains", but it will very likely have unwanted side-effects: you won't be able to play Flash games nor watch Flash videos on websites that use them (e.g. Facebook). 2) You could install an ad blocking extension into Firefox, such as AdBlock Plus. These extensions block lots of advertisements, not only Flash ones, but they can not and do not block all ads. If this is the path that you choose, just head to the Addon Manager, enter "Adblock" in the search field, and install one of the extensions that the search returns. I'm not using any of them myself, so I won't give my advice on which one of them you should install. 3) My personal favorite path: Set Adobe Flash to "click to play" on Firefox. This will keep the Flash Plugin on your computer, but will allow you to opt in for each page to see the actual content that the plugin is set to display (you can still allow the websites you want to activate Flash automatically, it just won't be the default behavior anymore).

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.10
  • CANON iMAGE GATEWAY Album Plugin Utility Module
  • NPWLPG
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • RealPlayer Download Plugin
  • This plug-in enables downloading of HTML5 videos
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • Shockwave Flash 17.0 r0
  • 5.1.30514.0
  • iTunes Detector Plug-in

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:37.0) Gecko/20100101 Firefox/37.0

More Information

user293 39 solutions 279 answers

This is probably caused by malware. You will need to start firefox in safe mode and remove the addon.

To do this, the Shift key when you open the Firefox desktop or Start menu shortcut.

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

Type "about:addons" in the url bar and look in the "extensions" and "plugins" sections. If you see anything you do not recognize and did not install, remove it.

Also, what file fixes the problem when it is deleted?

If it comes back after being deleted, you should scan your computer for malware. See the article Troubleshoot Firefox issues caused by malware for instructions on how to do this.

This is probably caused by malware. You will need to start firefox in safe mode and remove the addon. To do this, the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. When the Firefox Safe Mode window appears, select "Start in Safe Mode". ;[[Image:SafeMode-Fx35]] Type "about:addons" in the url bar and look in the "extensions" and "plugins" sections. If you see anything you do not recognize and did not install, remove it. Also, what file fixes the problem when it is deleted? If it comes back after being deleted, you should scan your computer for malware. See the article [[Troubleshoot Firefox issues caused by malware|Troubleshoot Firefox issues caused by malware]] for instructions on how to do this.
Rimas Kudelis
  • Locale Leader
3 solutions 28 answers

Chosen Solution

Hi, you mentioned the Plugin container process, so I suppose you are actually talking about Flash ads. In that case you have at least a few options to choose from: 1) you could uninstall the Adobe Flash plugin . Doing this will get rid of the actual plugin, which the Plugin container "contains", but it will very likely have unwanted side-effects: you won't be able to play Flash games nor watch Flash videos on websites that use them (e.g. Facebook). 2) You could install an ad blocking extension into Firefox, such as AdBlock Plus. These extensions block lots of advertisements, not only Flash ones, but they can not and do not block all ads. If this is the path that you choose, just head to the Addon Manager, enter "Adblock" in the search field, and install one of the extensions that the search returns. I'm not using any of them myself, so I won't give my advice on which one of them you should install. 3) My personal favorite path: Set Adobe Flash to "click to play" on Firefox. This will keep the Flash Plugin on your computer, but will allow you to opt in for each page to see the actual content that the plugin is set to display (you can still allow the websites you want to activate Flash automatically, it just won't be the default behavior anymore).

Hi, you mentioned the Plugin container process, so I suppose you are actually talking about Flash ads. In that case you have at least a few options to choose from: 1) you could [https://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html uninstall the Adobe Flash plugin] . Doing this will get rid of the actual plugin, which the Plugin container "contains", but it will very likely have unwanted side-effects: you won't be able to play Flash games nor watch Flash videos on websites that use them (e.g. Facebook). 2) You could install an ad blocking extension into Firefox, such as AdBlock Plus. These extensions block lots of advertisements, not only Flash ones, but they can not and do not block all ads. If this is the path that you choose, just [[Find and install add-ons to add features to Firefox|head to the Addon Manager]], enter "Adblock" in the search field, and install one of the extensions that the search returns. I'm not using any of them myself, so I won't give my advice on which one of them you should install. 3) My personal favorite path: [[Set Adobe Flash to "click to play" on Firefox]]. This will keep the Flash Plugin on your computer, but will allow you to opt in for each page to see the actual content that the plugin is set to display (you can still allow the websites you want to activate Flash automatically, it just won't be the default behavior anymore).

Modified by Rimas Kudelis

Helpful Reply

User 293 I added a screenshot of the file that I delete to fix it. The one that always comes back. I have looked in Mozilla add-ons and it is not included in that area.

Rimas Kudelis I am now trying your idea. I have Shockwave Flash. I changed it to ask to activate. Hope it works. Thank you

User 293 I added a screenshot of the file that I delete to fix it. The one that always comes back. I have looked in Mozilla add-ons and it is not included in that area. Rimas Kudelis I am now trying your idea. I have Shockwave Flash. I changed it to ask to activate. Hope it works. Thank you

Question owner

Setting Shockwave Flash to ask to activate did not work

Setting Shockwave Flash to ask to activate did not work
user293 39 solutions 279 answers

Try going to "about:addons" and selecting "plugins". Disable each plugin one-by-one until the problem goes away.

Try going to "about:addons" and selecting "plugins". Disable each plugin one-by-one until the problem goes away.
jscher2000
  • Top 10 Contributor
8763 solutions 71700 answers

Helpful Reply

QuickTime seems like a logical candidate for playing audio media on web pages.

QuickTime seems like a logical candidate for playing audio media on web pages.

Question owner

I will try that user293 Thank you. I do have QuickTime user jscher 2000 Guess I'll disable that one first. Thank you

Also I tried uninstalling Adobe Flash and reinstalling. Didn't work.

I will try that user293 Thank you. I do have QuickTime user jscher 2000 Guess I'll disable that one first. Thank you Also I tried uninstalling Adobe Flash and reinstalling. Didn't work.
Rimas Kudelis
  • Locale Leader
3 solutions 28 answers

shari.anton: can you share a link of the page which plays the audio ads? If you could, we should be able to figure out how audio is played on that page and provide you with better guidance.

By the way, plugin-container.exe is NOT an add-on, it's a component of Firefox, which hosts (runs) certain add-ons. Not seeing it in the addon manager is the correct behavior, and its automatic recovery is probably a feature of Firefox.

I suggest you to set all plug-ins (not just Flash) into click-to-play mode, then restart your browser and see if that helps.

If that still does not help, and you know which the offending page is, you may want to visit that page's Page Info dialog's Permissions tab and make sure that you haven't overriden the default behavior in terms of plugin activation for that page (be advised that the current Windows screenshot of that tab on this website seems a bit outdated – you can tweak these settings per-plugin now).

shari.anton: can you share a link of the page which plays the audio ads? If you could, we should be able to figure out how audio is played on that page and provide you with better guidance. By the way, plugin-container.exe is NOT an add-on, it's a component of Firefox, which hosts (runs) certain add-ons. Not seeing it in the addon manager is the correct behavior, and its automatic recovery is probably a feature of Firefox. I suggest you to set all plug-ins (not just Flash) into click-to-play mode, then restart your browser and see if that helps. If that still does not help, and you know which the offending page is, you may want to [[Page Info window - View technical details about the page you are on|visit that page's Page Info dialog]]'s Permissions tab and make sure that you haven't overriden the default behavior in terms of plugin activation for that page (be advised that the current Windows screenshot of that tab on this website seems a bit outdated – you can tweak these settings per-plugin now).
James
  • Top 25 Contributor
  • Moderator
1598 solutions 11287 answers

from https://support.mozilla.org/en-US/kb/what-is-plugin-container

What is plugin-container.exe? Each plugin are loaded separately from Firefox in a plugin-container.exe process, allowing the main Firefox process (firefox.exe) to stay open if a plugin crashes. There are as many plugin-container.exe processes as plugins launched since the Firefox session startup.


shari.anton this explains what the Plugin-container is as it has been a part of Firefox ever since 3.6.4 (three.six.four) released back in June 2010.

from https://support.mozilla.org/en-US/kb/what-is-plugin-container <blockquote>What is plugin-container.exe? Each plugin are loaded separately from Firefox in a plugin-container.exe process, allowing the main Firefox process (firefox.exe) to stay open if a plugin crashes. There are as many plugin-container.exe processes as plugins launched since the Firefox session startup.</blockquote> '''shari.anton''' this explains what the Plugin-container is as it has been a part of Firefox ever since 3.6.4 (three.six.four) released back in June 2010.

Question owner

James I included a screenshot of the file location. Sorry that is the best I can do for you.

Rimas Kudelis. The add plays on any and every page but thanks to your answer I was able to remember where I heard that add. It is from PCHLOTTO.COM I will just unsubscribe from them. I haven't heard it again since not allowing Flash for this site. Thank you to everyone. I will now close this as answered. :)

James I included a screenshot of the file location. Sorry that is the best I can do for you. Rimas Kudelis. The add plays on any and every page but thanks to your answer I was able to remember where I heard that add. It is from PCHLOTTO.COM I will just unsubscribe from them. I haven't heard it again since not allowing Flash for this site. Thank you to everyone. I will now close this as answered. :)
Rimas Kudelis
  • Locale Leader
3 solutions 28 answers

shari.anton: if you indeed see the same ad on each and every webpage, I suggest you check your computer for unwanted bundled software and malware in general. Even if you had previously subscribed to a particular website, I'd say it's highly unlikely that you would see advertisements for that single website on every page you visit. For starters, you may want to check the list of your installed programs for "best offers", "search assistants", "very useful toolbars" and other shady crap (please pardon my language) and uninstall all of that.

shari.anton: if you indeed see the same ad on each and every webpage, I suggest you check your computer for unwanted bundled software and malware in general. Even if you had previously subscribed to a particular website, I'd say it's highly unlikely that you would see advertisements for that single website on '''every''' page you visit. For starters, you may want to check the list of your installed programs for "best offers", "search assistants", "very useful toolbars" and other shady crap (please pardon my language) and uninstall all of that.

Modified by Rimas Kudelis

Question owner

Thanks Rimas. You are right. I think I was too quick to say it was pchlotto.com I have not opened their mail or activated flash for them. I'm watching my task manager and this dang plugin container for firefox opens up every time I open a new tab. It plays a little add. I don't see anything that should not be there in my control panel. I use microsoft security essentials and it comes up clean. Grr

Thanks Rimas. You are right. I think I was too quick to say it was pchlotto.com I have not opened their mail or activated flash for them. I'm watching my task manager and this dang plugin container for firefox opens up every time I open a new tab. It plays a little add. I don't see anything that should not be there in my control panel. I use microsoft security essentials and it comes up clean. Grr
James
  • Top 25 Contributor
  • Moderator
1598 solutions 11287 answers

shari.anton said

James I included a screenshot of the file location. Sorry that is the best I can do for you.

I saw your screen shot, I posted the quoted part from article to explain what the plugin-container is used for as you thought it was the problem and tried to delete it. The sound was coming from one of your Plugins as said.

''shari.anton [[#answer-714233|said]]'' <blockquote> James I included a screenshot of the file location. Sorry that is the best I can do for you. </blockquote> I saw your screen shot, I posted the quoted part from article to explain what the plugin-container is used for as you thought it was the problem and tried to delete it. The sound was coming from one of your Plugins as said.
jscher2000
  • Top 10 Contributor
8763 solutions 71700 answers

Hi shari.anton, did you ever try Firefox's Safe Mode, in case one of your extensions is responsible for the sounds?

Firefox's Safe Mode is a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Troubleshoot Firefox issues using Safe Mode.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Is Firefox any quieter in Safe Mode?

Hi shari.anton, did you ever try Firefox's Safe Mode, in case one of your extensions is responsible for the sounds? Firefox's Safe Mode is a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: [[Troubleshoot Firefox issues using Safe Mode]]. ''If Firefox is not running:'' Hold down the Shift key when starting Firefox. ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" button > Restart with Add-ons Disabled * Help menu > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Is Firefox any quieter in Safe Mode?

Question owner

Sorry James. I didn't understand. Thank you so much for your help.

Sorry James. I didn't understand. Thank you so much for your help.

Question owner

Hi jscher 2000 Thank you. I opened in safe mode and then opened task manager as well. I opened a new tab because this is when the plugin container opens. It opened and indeed played the audio add when the new tab was opened. Is this helpful? I don't know what my next step is. sorry I am trying to learn and understand everyone. I hope this helps you help me lol

Hi jscher 2000 Thank you. I opened in safe mode and then opened task manager as well. I opened a new tab because this is when the plugin container opens. It opened and indeed played the audio add when the new tab was opened. Is this helpful? I don't know what my next step is. sorry I am trying to learn and understand everyone. I hope this helps you help me lol
jscher2000
  • Top 10 Contributor
8763 solutions 71700 answers

Sorry, I missed the new tab part.

What page is set as your new tab page? Here's how you can change it if you want to do that:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste newtab and pause while the list is filtered

(3) Double-click the browser.newtab.url preference and enter your preferred page:

  • Page thumbnails (default) => about:newtab
  • Blank tab => about:blank
  • Built-in Firefox home page => about:home
  • Any other page => full URL to the page

Press Ctrl+t to open a new tab and verify that it worked. Fixed?

If problems persist, some potential diagnoses and remedies:

If Firefox won't let you edit this setting: you may have something called SearchProtect on your system. This needs to be removed from the Windows Control Panel.

If Firefox lets you save your change but ignores it: one of your extensions may be overriding it. You can review, disable, and/or remove extensions on the add-ons page. Either:

  • Ctrl+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then cast a critical eye over the list on the right and disable (or remove) anything unknown.

If the change works during your session, but at the next startup is back to the unwanted page: you might have a user.js file in your personal Firefox settings folder (your Firefox profile folder). This article describes how to track down and remove the file: How to fix preferences that won't save.

Any luck?

Sorry, I missed the new tab part. What page is set as your new tab page? Here's how you can change it if you want to do that: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button promising to be careful. (2) In the search box above the list, type or paste '''newtab''' and pause while the list is filtered (3) Double-click the '''browser.newtab.url''' preference and enter your preferred page: * ''Page thumbnails (default)'' => about:newtab * ''Blank tab'' => about:blank * ''Built-in Firefox home page'' => about:home * ''Any other page'' => full URL to the page Press Ctrl+t to open a new tab and verify that it worked. Fixed? If problems persist, some potential diagnoses and remedies: ''If Firefox won't let you edit this setting:'' you may have something called SearchProtect on your system. This needs to be removed from the Windows Control Panel. ''If Firefox lets you save your change but ignores it:'' one of your extensions may be overriding it. You can review, disable, and/or remove extensions on the add-ons page. Either: * Ctrl+Shift+a * "3-bar" menu button (or Tools menu) > Add-ons In the left column, click Extensions. Then cast a critical eye over the list on the right and disable (or remove) anything unknown. ''If the change works during your session, but at the next startup is back to the unwanted page:'' you might have a user.js file in your personal Firefox settings folder (your Firefox profile folder). This article describes how to track down and remove the file: [[How to fix preferences that won't save]]. Any luck?

Question owner

jscher2000 Oh my gosh IT WORKED IT WORKED!! I am so happy!! Thank you so so so much. I can't tell you how amazing it is to be rid of that dang sound haha I am so grateful! THANK YOU

jscher2000 Oh my gosh IT WORKED IT WORKED!! I am so happy!! Thank you so so so much. I can't tell you how amazing it is to be rid of that dang sound haha I am so grateful! THANK YOU