X
Tap here to go to the mobile version of the site.

Support Forum

Cannot find "Tools"

Posted

In an attempt to find out why Firefox keeps logging me out of my email and Facebook three or four times a day, I have search the internet as well as the Firefox forum. Everything seems to depend on my being able to find "tools." I have the version of Firefox (34?) that has the three bars in the upper right-hand corner which, when clicked, opens a menu of icons, none of which is "tools."

In an attempt to find out why Firefox keeps logging me out of my email and Facebook three or four times a day, I have search the internet as well as the Firefox forum. Everything seems to depend on my being able to find "tools." I have the version of Firefox (34?) that has the three bars in the upper right-hand corner which, when clicked, opens a menu of icons, none of which is "tools."

Chosen solution

FredMcD said

You may be in Private Browsing mode, or told Firefox not to remember. Type about:preferences#privacy<enter> in the address bar. The button next to History, select Use Custom Settings. Turn off Always use private browsing mode Turn on Remember my browsing and download history At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on ONLY Cache and Form And Search History leaving the others off.

History can be removed or not recorded several ways;

  • 1) Running Firefox in Private Mode (nothing is recorded)
  • 2) Privacy settings
    (Type about:preferences#privacy<enter>
    in the address bar.)
  • 3) Many disk cleaners and anti-virus type programs can remove data from browsers. Open their settings and have them leave the browsers alone.
  • 4) Mal-ware.
Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.10
  • Intel web components updater - Installs and updates the Intel web components
  • Intel web components for Intel® Identity Protection Technology
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.25.2 for Mozilla browsers
  • Shockwave Flash 16.0 r0
  • 5.1.30514.0
  • iTunes Detector Plug-in

Application

  • Firefox 35.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:35.0) Gecko/20100101 Firefox/35.0
  • Support URL: https://support.mozilla.org/1/firefox/35.0/WINNT/en-US/

Extensions

  • Default Full Zoom Level 7.5 ({D9A7CBEC-DE1A-444f-A092-844461596C4D})
  • Tab Utilities 1.5.28.1 (tabutils@ithinc.cn)
  • Theme Font & Size Changer 35.0 ({f69e22c7-bc50-414a-9269-0f5c344cd94c})

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics 4600
  • adapterDescription2:
  • adapterDeviceID: 0x0412
  • adapterDeviceID2:
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 00000000
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16492
  • driverDate: 9-29-2014
  • driverDate2:
  • driverVersion: 10.18.10.3960
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 2
  • numTotalWindows: 2
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 4600 Direct3D9Ex vs_3_0 ps_3_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
Scribe 731 solutions 3480 answers

Helpful Reply

Hi, press Alt to temporarily bring up the menu bar which has Tools on it. If you wish the menu bar to remain there all the time, right click at the top of the page (not on a tab) and tick/check Menu Bar. Hope that helps.

Hi, press Alt to temporarily bring up the menu bar which has Tools on it. If you wish the menu bar to remain there all the time, right click at the top of the page (not on a tab) and tick/check Menu Bar. Hope that helps.
FredMcD
  • Top 10 Contributor
4259 solutions 59635 answers

You may be in Private Browsing mode, or told Firefox not to remember.

Type about:preferences#privacy<enter> in the address bar.

The button next to History, select Use Custom Settings.

Turn off Always use private browsing mode Turn on Remember my browsing and download history At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on ONLY Cache and Form And Search History leaving the others off.


History can be removed or not recorded several ways;

  • 1) Running Firefox in Private Mode (nothing is recorded)
  • 2) Privacy settings
    (Type about:preferences#privacy<enter>
    in the address bar.)
  • 3) Many disk cleaners and anti-virus type programs can remove data from browsers. Open their settings and have them leave the browsers alone.
  • 4) Mal-ware.
You may be in Private Browsing mode, or told Firefox not to remember. Type '''about:preferences#privacy'''<enter> in the address bar. The button next to '''History,''' select '''Use Custom Settings'''. Turn off '''Always use private browsing mode''' Turn on '''Remember my browsing and download history''' At the bottom of the page, turn on '''Clear History When Firefox Closes.''' At the far right, press the '''Settings''' button. Turn on ONLY '''Cache''' and '''Form And Search History''' leaving the others off. ---------------------- History can be removed or not recorded several ways; * 1) Running Firefox in Private Mode (nothing is recorded) * 2) Privacy settings<br>(Type '''about:preferences#privacy'''<enter><BR> in the address bar.) * 3) Many disk cleaners and anti-virus type programs can remove data from browsers. Open their settings and have them leave the browsers alone. * 4) Mal-ware.
cor-el
  • Top 10 Contributor
  • Moderator
17536 solutions 158573 answers

You should also see an Options/Preferences button in the "3-bar" Firefox menu button drop-down list.

See also:

You should also see an Options/Preferences button in the "3-bar" Firefox menu button drop-down list. See also: *https://support.mozilla.org/kb/learn-more-about-the-design-of-new-firefox *https://support.mozilla.org/kb/common-questions-after-updating-to-new-firefox
cor-el
  • Top 10 Contributor
  • Moderator
17536 solutions 158573 answers

Details like websites remembering you (log you in automatically) are stored in a cookie.

  • Create a cookie 'allow' exception to keep such cookies, especially in case of secure websites and when cookies expire when Firefox is closed.
  • Tools > Options > Privacy > "Use custom settings for history" > Cookies: Exceptions

This issue can be caused by corrupted cookies or cookies that are blocked.

  • check the permissions on the about:permissions page and in "Tools > Page Info > Permissions"
Details like websites remembering you (log you in automatically) are stored in a cookie. *Create a cookie 'allow' exception to keep such cookies, especially in case of secure websites and when cookies expire when Firefox is closed. *Tools > Options > Privacy > "Use custom settings for history" > Cookies: Exceptions This issue can be caused by corrupted cookies or cookies that are blocked. *check the permissions on the about:permissions page and in "Tools > Page Info > Permissions" *https://support.mozilla.org/kb/fix-login-issues-on-websites-require-passwords

Chosen Solution

FredMcD said

You may be in Private Browsing mode, or told Firefox not to remember. Type about:preferences#privacy<enter> in the address bar. The button next to History, select Use Custom Settings. Turn off Always use private browsing mode Turn on Remember my browsing and download history At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on ONLY Cache and Form And Search History leaving the others off.

History can be removed or not recorded several ways;

  • 1) Running Firefox in Private Mode (nothing is recorded)
  • 2) Privacy settings
    (Type about:preferences#privacy<enter>
    in the address bar.)
  • 3) Many disk cleaners and anti-virus type programs can remove data from browsers. Open their settings and have them leave the browsers alone.
  • 4) Mal-ware.
''FredMcD [[#answer-681029|said]]'' <blockquote> You may be in Private Browsing mode, or told Firefox not to remember. Type '''about:preferences#privacy'''<enter> in the address bar. The button next to '''History,''' select '''Use Custom Settings'''. Turn off '''Always use private browsing mode''' Turn on '''Remember my browsing and download history''' At the bottom of the page, turn on '''Clear History When Firefox Closes.''' At the far right, press the '''Settings''' button. Turn on ONLY '''Cache''' and '''Form And Search History''' leaving the others off. ---------------------- History can be removed or not recorded several ways; * 1) Running Firefox in Private Mode (nothing is recorded) * 2) Privacy settings<br>(Type '''about:preferences#privacy'''<enter><BR> in the address bar.) * 3) Many disk cleaners and anti-virus type programs can remove data from browsers. Open their settings and have them leave the browsers alone. * 4) Mal-ware. </blockquote>

Question owner

Thank you , everyone. I appreciate the help as it must be obvious that I am a novice.

I must be pressing "Alt" in the wrong place to bring up "tools." I have tried pressing it while in the drip-down icon menu to no avail.

"about:preferences#privacy" took me to a page which let me know lots of useful information, but I did not find "custom" among the list of items there.

Obviously, I am doing something wrong! I have run Malwarebytes (I have Pro), and found no problems. I use Bitdefender also.

Thank you , everyone. I appreciate the help as it must be obvious that I am a novice. I must be pressing "Alt" in the wrong place to bring up "tools." I have tried pressing it while in the drip-down icon menu to no avail. "about:preferences#privacy" took me to a page which let me know lots of useful information, but I did not find "custom" among the list of items there. Obviously, I am doing something wrong! I have run Malwarebytes (I have Pro), and found no problems. I use Bitdefender also.

Question owner

OK, I put all the answers y'all gave me together, and I think I may have figured out what to do. I kept clicking "Alt" all over the top of my page, and finally found "tools" as scribe.uk said I would.

I got into the "Privacy" settings & set them as Fred McD instructed. I also saved the two pages from cor-el to study.

I never did find "permissions," however. I did end up stumbling across a list of my cookies and was amazed at how many there were. I deleted some obvious stuff (Macy's, for example), but didn't mess with anything I didn't understand. I was tempted to delete some of them that seemed like ad cookies, but since I can get myself into a lot of trouble by fooling around on my computer, I resisted the urge.

We'll see tomorrow if I have to keep signing in and out. Am I to assume that I should not use the privacy browsing feature in order to remain signed in?

OK, I put all the answers y'all gave me together, and I think I may have figured out what to do. I kept clicking "Alt" all over the top of my page, and finally found "tools" as scribe.uk said I would. I got into the "Privacy" settings & set them as Fred McD instructed. I also saved the two pages from cor-el to study. I never did find "permissions," however. I did end up stumbling across a list of my cookies and was amazed at how many there were. I deleted some obvious stuff (Macy's, for example), but didn't mess with anything I didn't understand. I was tempted to delete some of them that seemed like ad cookies, but since I can get myself into a lot of trouble by fooling around on my computer, I resisted the urge. We'll see tomorrow if I have to keep signing in and out. Am I to assume that I should not use the privacy browsing feature in order to remain signed in?

Helpful Reply

cor-el -- When I click on"options," I see the following choices:

General Tabs Search Content Applications Privacy Security Sync Advanced

No Tools.  ??? Am I looking in the wrong place?

cor-el -- When I click on"options," I see the following choices: General Tabs Search Content Applications Privacy Security Sync Advanced No Tools. ??? Am I looking in the wrong place?
FredMcD
  • Top 10 Contributor
4259 solutions 59635 answers

nocluewhatsoever said

I never did find "permissions"

Try typing about:permissions<enter> in the address bar.

When I click on"options," I see the following choices: General-Tabs- Search-Content-Applications-Privacy-Security-Sync-Advanced No Tools.  ??? Am I looking in the wrong place?

Those are the tools. Not everything is accessible, so we use the about:config page. Take a look at this; about:about

''nocluewhatsoever [[#answer-681320|said]]'' <blockquote> I never did find "permissions" </blockquote> Try typing '''about:permissions'''<enter> in the address bar. <blockquote> When I click on"options," I see the following choices: General-Tabs- Search-Content-Applications-Privacy-Security-Sync-Advanced No Tools. ??? Am I looking in the wrong place? </blockquote> Those are the tools. Not everything is accessible, so we use the '''about:config''' page. Take a look at this; '''about:about'''

Modified by guigs

cor-el
  • Top 10 Contributor
  • Moderator
17536 solutions 158573 answers

You are already in "Tools > Options" when you see the Option window with the tabs you posted above, so you do not need to look for the Tools menu.

You can tap the Alt key or press F10 to show the Menu Bar with the Tools menu if that bar is hidden. You can also find the Options/Preferences button in the "3-bar" Firefox menu button drop-down list like posted above. So there is more than one way to open this options window. Future Firefox versions open the Options/Preferences window in a tab as the about:preferences page. This is also possible in current releases, but I'm not sure if that page supports all features properly. This can be controlled by the browser.preferences.inContent pref (see about:config) that currently defaults to false.


You are already in "Tools > Options" when you see the Option window with the tabs you posted above, so you do not need to look for the Tools menu. You can tap the Alt key or press F10 to show the Menu Bar with the Tools menu if that bar is hidden. You can also find the Options/Preferences button in the "3-bar" Firefox menu button drop-down list like posted above. So there is more than one way to open this options window. Future Firefox versions open the Options/Preferences window in a tab as the about:preferences page. This is also possible in current releases, but I'm not sure if that page supports all features properly. This can be controlled by the browser.preferences.inContent pref (see about:config) that currently defaults to false. ---- *https://support.mozilla.org/kb/Options+window
FredMcD
  • Top 10 Contributor
4259 solutions 59635 answers

cor-el said

https://support.mozilla.org/kb/Options+window

Firefox options, preferences and settings (Redirected from Options window) https://support.mozilla.org/en-US/kb/Options%20window?redirect=no

This article is no longer maintained, so its content might be out of date.

''cor-el [[#answer-681502|said]]'' <blockquote> https://support.mozilla.org/kb/Options+window </blockquote> Firefox options, preferences and settings (Redirected from Options window) https://support.mozilla.org/en-US/kb/Options%20window?redirect=no '''This article is no longer maintained, so its content might be out of date.'''

Question owner

I may be getting into "overload" territory as I am trying to learn a lot all at once... I did get into "permissions," and I found the cookies. I am not clear about what I need to change, if anything. "Third party cookies" and "allow cookies" are enabled. "Manage cookies" is that infinite list; am I supposed to to something there?

I may be getting into "overload" territory as I am trying to learn a lot all at once... I did get into "permissions," and I found the cookies. I am not clear about what I need to change, if anything. "Third party cookies" and "allow cookies" are enabled. "Manage cookies" is that infinite list; am I supposed to to something there?
FredMcD
  • Top 10 Contributor
4259 solutions 59635 answers

From about:permissions you have control over the cookies. Look them over, or even remove them for a site or all of them.

From '''about:permissions''' you have control over the cookies. Look them over, or even remove them for a site or all of them.

Question owner

Some of them aren't necessary?

Some of them aren't necessary?
FredMcD
  • Top 10 Contributor
4259 solutions 59635 answers

Some web sites, or some cookies?  ;-)

If you are having trouble with cookies, they can be removed from here. Otherwise just let them be.

Some web sites, or some cookies? ;-) If you are having trouble with cookies, they can be removed from here. Otherwise just let them be.

Question owner

Well, it's hard to figure out who solved this question as I slipped in so many extra ones on you guys. This is my first adventure on the Mozilla support forum, so I'm still learning the ropes. I do know that I am motivated to leave IE behind!

Can I give a "solve" to more than one person? Everyone actually helped me.

Well, it's hard to figure out who solved this question as I slipped in so many extra ones on you guys. This is my first adventure on the Mozilla support forum, so I'm still learning the ropes. I do know that I am motivated to leave IE behind! Can I give a "solve" to more than one person? Everyone actually helped me.
FredMcD
  • Top 10 Contributor
4259 solutions 59635 answers

Select what ever you want. Safe Surfing.

Select what ever you want. Safe Surfing.