X
Tap here to go to the mobile version of the site.

Support Forum

Firefox window UI is tiny on MacBook Pro retina screen

Posted

I have Firefox 33.1.1 installed on a 13" MacBook Pro with retina display, and the UI is always tiny when viewing on the in-buillt retina screen. I often have the MacBook plugged into an additional 27" Dell display and firefox looks fine on this display, but when moving the same window on to the retina screen, it redraws like the attached screenshot. If I don't have the external display plugged in at all, and open Firefox after a restart, the same issue still occurs.

Example screenshot is uploaded here: http://imgur.com/WpCIMGN

I have Firefox 33.1.1 installed on a 13" MacBook Pro with retina display, and the UI is always tiny when viewing on the in-buillt retina screen. I often have the MacBook plugged into an additional 27" Dell display and firefox looks fine on this display, but when moving the same window on to the retina screen, it redraws like the attached screenshot. If I don't have the external display plugged in at all, and open Firefox after a restart, the same issue still occurs. Example screenshot is uploaded here: http://imgur.com/WpCIMGN

Additional System Details

Installed Plug-ins

  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Provides information about the default web browser
  • 5.1.30514.0

Application

  • Firefox 33.1.1
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:33.0) Gecko/20100101 Firefox/33.0
  • Support URL: https://support.mozilla.org/1/firefox/33.1.1/Darwin/en-GB/

Extensions

  • 1Password 4.2.5 (onepassword4@agilebits.com)
  • DOM Inspector 2.0.14 (inspector@mozilla.org)
  • Firebug 2.0.6 (firebug@software.joehewitt.com)
  • Stylish 1.4.3 ({46551EC9-40F0-4e47-8E18-8E5CF550CFB8})
  • Tamper Data 11.0.1 ({9c51bd27-6ed8-4000-a2bf-36cb95c0c947})
  • Theme Font & Size Changer 33.1 ({f69e22c7-bc50-414a-9269-0f5c344cd94c})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription:
  • adapterDeviceID: 0x a2e
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x8086
  • driverDate:
  • driverVersion:
  • info: {u'AzureCanvasBackend': u'quartz', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'quartz', u'AzureSkiaAccelerated': 0}
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Intel Inc. -- Intel Iris OpenGL Engine
  • windowLayerManagerRemote: True
  • windowLayerManagerType: OpenGL

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.frecency_experiment: 4
  • browser.places.smartBookmarksVersion: 7
  • browser.sessionstore.restore_on_demand: False
  • browser.sessionstore.upgradeBackup.latestBuildID: 20141113143407
  • browser.startup.homepage: http://www.lyst.com/
  • browser.startup.homepage_override.buildID: 20141113143407
  • browser.startup.homepage_override.mstone: 33.1.1
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 33.1.1
  • font.internaluseonly.changed: False
  • font.language.group: x-western
  • media.gmp-gmpopenh264.lastUpdate: 1415702075
  • media.gmp-gmpopenh264.version: 1.1
  • media.gmp-manager.lastCheck: 1416673931
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1416673932
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugins.notifyMissingFlash: False
  • privacy.donottrackheader.enabled: True
  • privacy.donottrackheader.value: 0
  • privacy.sanitize.migrateFx3Prefs: True
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1415715787

Misc

  • User JS: No
  • Accessibility: No
FredMcD
  • Top 10 Contributor
4230 solutions 59026 answers

I've called the big guys to help you. Good luck.

I've called the big guys to help you. Good luck.
guigs 1072 solutions 11697 answers

There are two things that can be tried:

  1. Reset the zoom feature from the Firefox Menu (Ctrl+0 (that is a zero) should reset it, )
  • To make things bigger, press Ctrl and + at the same time.
  • To make things smaller, press Ctrl and - at the same time.
  • To reset the size back to normal, press Ctrl and 0 at the same time.
  1. Do you clear the cache on quit? If so the zoom percentage may not be saved because it is only remembered for the current session.

Also make sure that its not an add on, by starting Firefox in Safe Mode Troubleshoot Firefox issues using Safe Mode

There are two things that can be tried: # Reset the zoom feature from the Firefox Menu (Ctrl+0 (that is a zero) should reset it, ) * To make things bigger, press '''Ctrl''' and '''&#43''' at the same time. * To make things smaller, press '''Ctrl''' and '''-''' at the same time. * To reset the size back to normal, press '''Ctrl''' and '''0''' at the same time. # Do you clear the cache on quit? If so the zoom percentage may not be saved because it is only remembered for the current session. Also make sure that its not an add on, by starting Firefox in Safe Mode [[Troubleshoot Firefox issues using Safe Mode]]

Question owner

1. This is a Mac, so it'd be Cmd+0 instead of Ctrl+0. It's not a zoom issue; I can use the zoom functionality fine, and as I say everything appears correctly in the non-retina screen. This issue only affects a window on the retina screen. If I use the zoom in a problem window, the content zooms in as normal, but the issue with the UI stays the same.

2. I don't clear the cache on quit, no.

1. This is a Mac, so it'd be Cmd+0 instead of Ctrl+0. It's not a zoom issue; I can use the zoom functionality fine, and as I say everything appears correctly in the non-retina screen. This issue only affects a window on the retina screen. If I use the zoom in a problem window, the content zooms in as normal, but the issue with the UI stays the same. 2. I don't clear the cache on quit, no.