X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

right-click menu on the wrong screen

Posted

Using FireFox 18 on OSx Mountain Lion MacBook Pro with Retina & second screen attached.

Using FireFox on the second screen, whenever I click for a menu to popup, the menu pops up on the main retina screen.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Adobe® Acrobat® Plug-in for Web Browsers, Version 10.1.5
  • Displays Java applet content, or a placeholder if Java is not installed.
  • WebEx64 General Plugin Container Version 205
  • LastPass Plugin
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Plugin that detects installed Citrix Online products (visit www.citrixonline.com).
  • LogMeIn remote control components
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • 5.1.10411.0
  • Microsoft Lync 2010 Meeting Join Plug-in

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

cossorn 0 solutions 2 answers

Same here. Current Mountain Lion 10.8.2, Firefox 18.0 Retina on macbook pro retina, second monitor is LED Cinema Display. Firefox window NOT in fullscreen (and smaller than retina full screen)

With firefox on main laptop screen, extras like suggestions from typing in URL-box appear in correct location, correct scaling. Drag firefox to 2nd monitor, firefox operations appear OK EXCEPT for said prompts.. which appear on main retina screen at some arbitrary location but 1/2-size (i.e. point sizes are for non-retina)

Dragging firefox back to main screen, back to normal good functionality.

cor-el
  • Top 10 Contributor
  • Moderator
10737 solutions 96600 answers

Try to disable hardware acceleration in Firefox.


You can also check for problems with the localstore.rdf file.

cossorn 0 solutions 2 answers

Tried turning off hardware acceleration as recommended. No improvement. Leaving it turned off, and restarting firefox in safe mode, no improvement.

I have been using this config of monitors with previous Firefox 16, 17 etc.. just goes wrong since 18.0

Question owner

Disabling Hardware Acceleration made no difference.

(

Other ideas?

cor-el
  • Top 10 Contributor
  • Moderator
10737 solutions 96600 answers

Helpful Reply

There are issues with retina (HiDPI) support that will be fixed in an upcoming Firefox 18.0.1 version, so keep an eye on that.

Helpful Reply

I just got 18.0.1 - It fixed the issue.