Identificar e diagnosticar problemas do Firefox

A maioria dos problemas com o Firefox podem ser resolvidos seguindo os passos abaixo. Tente estes passos por ordem. Se um não resultar, tente o próximo. Se precisar de mais ajuda, temos uma comunidade de voluntários à sua espera.

1. Reinicie o computador

Por vezes os problemas podem ser resolvidos apenas reiniciando o computador e abrindo o Firefox novamente.

2. Limpe os seus cookies e cache

Muitos problemas com o carregamento de páginas podem ser solucionados limpando a cache e cookies do Firefox:

  1. No topo da janela do Firefox, clique no botão Firefox, aceda ao menu do Histórico e selecione Limpar histórico recente....Na barra de menu, clique no menu Ferramentas e selecione Limpar histórico recente....No topo da janela do Firefox, clique no menu Ferramentas e selecione Limpar histórico recente....
  2. Na lista pendente Intervalo de tempo a remover:, selecione Tudo.
  3. Clique na seta perto de Detalhes para mostrar a lista de itens a ser removidos.
  4. Selecione Cookies e Cache.
  5. Clique Limpar agora.
  1. No topo da janela do Firefox, clique no botão Firefox, aceda ao menu do Histórico e selecione Limpar histórico recente....Na barra de menu, clique no menuHistórico e selecione Limpar histórico recente....No topo da janela do Firefox, clique no menu Histórico e selecione Limpar histórico recente....
  2. Na lista pendente Intervalo de tempo a remover:, selecione Tudo.
  3. Clique na seta perto de Detalhes para mostrar a lista de itens a ser removidos.
  4. Selecione Cookies e Cache.
  5. Clique Limpar agora.
  1. Clique no botão do menu New Fx Menu , escolha Histórico e selecione Limpar histórico recente....
  2. Na lista pendente Intervalo de tempo a remover:, selecione Tudo.
  3. Clique na seta perto de Detalhes para mostrar a lista de itens a ser removidos.
  4. Selecione Cookies e Cache.
  5. Clique Limpar agora.
Para mais informações, consulte eliminar histórico de navegação, pesquisa e transferências no Firefox.

3. Reiniciar o Firefox em Modo Seguro

O Modo seguro é um modo de diagnóstico que desativa todas as extensões, utiliza o tema padrão, desliga a aceleração por hardware e utiliza as definições por omissão para a barra de ferramentas e controlos, entre outras coisas. Para iniciar o Firefox no Modo Seguro :

  1. No topo da janela do Firefox, clique no botão Firefox, aceda ao menu AjudaNa barra de menu, clique no menu AjudaNo topo da janela do Firefox, clique no menu Ajuda e selecione Reiniciar com os extras desativados.... O Firefox irá ser iniciado com a janela de modo seguro do Firefox.
    Nota: Pode também iniciar o Firefox no modo seguro pressionando a tecla shift ao iniciar o Firefox.pressionando a tecla option ao iniciar o Firefox.saindo do Firefox e indo ao seu Terminal e digitando: firefox -safe-mode
    Pode precisar de especificar o caminho de instalação do Firefox (por exemplo, /usr/lib/firefox)
    Clique no botão de menu New Fx Menu , clique ajuda Help-29 e selecione Reiniciar com os extras desativados.... O Firefox irá ser iniciado com a janela de modo seguro do Firefox.
    Nota: Pode também iniciar o Firefox no modo seguro pressionando a tecla shift ao iniciar o Firefox.pressionando a tecla option ao iniciar o Firefox.saindo do Firefox e indo ao seu Terminal e digitando: firefox -safe-mode
    Pode precisar de especificar o caminho de instalação do Firefox (por exemplo, /usr/lib/firefox)
  2. Na janela do Modo Seguro, clique em Continuar no modo seguroIniciar no modo seguro.
  3. Verifique se o seu problema continua a ocorrer no Modo Seguro.

4. Diagnosticar os plugins

Por vezes, os plugins para o Firefox (como o Adobe Reader, Flash, Java, QuickTime, RealPlayes e Windows Media Player) causam problemas que podem ser resolvidos com a última versão. Para verificar se tem a última versão de todos os plugin, visite a página de verificação de plugins. Se algum dos plugins estiver desatualizado, clique em Atualizar e siga as instruções para o atualizar. Após atualizar todos os plugin, reinicie o Firefox:

No topo da janela do Firefox, clique no botão Firefox e selecione SairNo topo da janela do Firefox, clique no menu Ficheiro e selecione SairNa barra de menu, clique no menu Firefox e selecione Sair do FirefoxNo topo da janela do Firefox, clique no menu Ficheiro e selecione Sair

Clique no botão de menu New Fx Menu e clique SairSair Close 29

. Se o problema se mantiver, pode desativar todos os plugins para ver se a causa está em algum destes:

  1. No topo da janela do Firefox, clique no botão FirefoxNa barra de menu, clique no menu FerramentasNo topo da janela do Firefox, clique no menu Ferramentas e clique em Extras. O separador Gestor de extras será apresentado. Clique no botão do menu New Fx Menu e escolha Extras. O separador Gestor de extras será apresentado.

  2. No separador Gestor de extras, selecione o painel Plugins.
  3. Clique em cada plugin na lista e depois em Desativar.
  4. Verifique se o problema ocorre quando todos os plugins estão desativados.
  1. No topo da janela do Firefox, clique no botão FirefoxNa barra de menu, clique no menu FerramentasNo topo da janela do Firefox, clique no menu Ferramentas e clique em Extras. O separador Gestor de extras será apresentado. Clique no botão do menu New Fx Menu e escolha Extras. O separador Gestor de extras será apresentado.

  2. No separador Gestor de extras, selecione o painel Plugins.
  3. Clique em cada plugin da lista e selecione Nunca ativar a partir do respetivo menu.
  4. Verifique se o problema ocorre com todos os plugins desativados.

Se o problema desaparecer com todos os plugins desativados, consulte o artigo Diagnosticar problemas com plugins como o Flash ou o Java para corrigir problemas comuns no Firefox para saber como encontrar o plugin que causa o problema.

5. Reinstalar o Firefox

Alguns problemas do Firefox podem ser causados por um dos ficheiros do programa. Siga estes passos para remover e reinstalar completamente o Firefox. Este processo não irá remover os dados do seu perfil do Firefox (tais como marcadores e palavras-passe), desde que essa informação seja guardada numa localização diferente.

Nota: Poderá querer imprimir estes passos ou consultar os mesmos noutro navegador.
  1. Faça a transferência da última versão oficial do Firefox em mozilla.org.
  2. Feche o Firefox:

    No topo da janela do Firefox, clique no botão Firefox e selecione SairNo topo da janela do Firefox, clique no menu Ficheiro e selecione SairNa barra de menu, clique no menu Firefox e selecione Sair do FirefoxNo topo da janela do Firefox, clique no menu Ficheiro e selecione Sair

    Clique no botão de menu New Fx Menu e clique SairSair Close 29

  3. Desinstale o Firefox do seu computador.
  4. Elimine a pasta de instalação do Firefox que, por omissão, se encontra numa destas localizações:
    • (Windows de 32-bits) C:\Programas\Mozilla Firefox
    • (Windows de 64-bits) C:\Programas (x86)\Mozilla Firefox
  5. Reinstale o Firefox - para instruções consulte Instalar o Firefox no Windows.
  1. Faça a transferência da última versão oficial do Firefox em mozilla.org.
  2. Saia do Firefox:

    No topo da janela do Firefox, clique no botão Firefox e selecione SairNo topo da janela do Firefox, clique no menu Ficheiro e selecione SairNa barra de menu, clique no menu Firefox e selecione Sair do FirefoxNo topo da janela do Firefox, clique no menu Ficheiro e selecione Sair

    Clique no botão de menu New Fx Menu e clique SairSair Close 29

  3. Desinstale o Firefox do seu computador abrindo o ficheiro Aplicações no Finder e arrastando a aplicação Firefox até ao Lixo.
  4. Reinstale o Firefox - para instruções consulte Instalar o Firefox no Mac.
  1. Faça a transferência da última versão oficial do Firefox em mozilla.org.
  2. Saia do Firefox:

    No topo da janela do Firefox, clique no botão Firefox e selecione SairNo topo da janela do Firefox, clique no menu Ficheiro e selecione SairNa barra de menu, clique no menu Firefox e selecione Sair do FirefoxNo topo da janela do Firefox, clique no menu Ficheiro e selecione Sair

    Clique no botão de menu New Fx Menu e clique SairSair Close 29

  3. Desinstale o Firefox - Se instalou o Firefox com o gestor de pacote de distribuição, deverá utilizar o mesmo método para o desinstalar - consulte Instalar o Firefox no Linux para detalhes. Se fez a transferência e instalou o pacote binário da página de transferências do Firefox, basta remover a pasta firefox do seu diretório para desinstalar o Firefox.
  4. Reinstale o Firefox - para instruções consulte Instalar o Firefox no Linux.

Inicie agora o Firefox e verifique se o seu problema foi resolvido. Caso contrário, continue para o próximo método de diagnóstico.

6. Restaurar as definições de fábrica do Firefox

A funcionalidade Repor o Firefox pode resolver muitos problemas, repondo o seu perfil do Firefox ao seu estado original mantendo os dados essenciais.

Nota: Ao utilizar a funcionalidade de renovação, os seus marcadores, histórico de navegação, separadores abertos, janelas, senhas, cookies e informações de auto-preenchimento de formulários web serão guardadas. No entanto, as suas extensões e temas serão removidos e as suas preferências repostas.Ao utilizar a funcionalidade de reposição, os seus marcadores, histórico de navegação, separadores abertos, janelas, senhas, cookies e informações de auto-preenchimento de formulários web serão guardadas. No entanto, as suas extensões e temas serão removidos e as suas preferências repostas.Ao utilizar a funcionalidade de reposição, os seus marcadores, histórico de navegação, senhas, cookies e informações de auto-preenchimento de formulários web serão guardadas. No entanto, as suas extensões e temas serão removidos; os separadores abertos, janelas e grupos de separadores não serão guardados; e as suas preferências serão repostas. Saber mais.
  1. No topo da janela do Firefox, clique no menu Ajuda e selecione Informação para resolução de problemas.No topo da janela do Firefox, clique no botão do Firefox, aceda ao sub-menu Ajuda e selecione Informação para resolução de problemas.Na barra de menu, clique no menu Ajuda e selecione Informação para resolução de problemas.
    Reset Firefox 1 - WinXP Troubleshooting info - win Troubleshooting info - mac Troubleshooting info - lin
    Se não foi possível ao menu Ajuda, escreva about:support na sua barra de endereço para carregar a página Informação para resolução de problemas.
  2. Clique no botão Repor o Firefox no canto superior direito da página Informação para resolução de problemas.
    Reset Firefox 2 - WinXP Reset Firefox - Win - 1 Reset Firefox - Mac - 1 Reset Firefox - Lin - 1
  3. Para continuar, clique em Repor o Firefox na janela de confirmação que é apresentada.Para continuar, clique em Repor o Firefox na folha de confirmação que desliza para baixo.
  4. O Firefox irá ser fechado e reposto. Quanto esta operação estiver concluída, uma janela irá listar a informação que foi importada. Clique em Concluir e o Firefox será aberto.O Firefox irá ser fechado e reposto. Quanto esta operação estiver concluída, uma janela irá listar a informação que foi importada. Clique em Feito e o Firefox será aberto.
  1. Clique no botão de menu New Fx Menu e depois clique em ajuda Help-29 .
  2. Do menu de Ajuda escolha Informação para resolução de problemas.
    Se não for possível aceder ao menu Ajuda, escreva about:support na sua barra de endereço para carregar a página Informação para resolução de problemas.
  3. Clique no botão Repor o Firefox… no canto superior direito da página Informação para resolução de problemas.
    Reset 29 Win Reset 29 Mac Reset 29 Lin
  4. Para continuar, clique em Repor o Firefox na janela de confirmação que é apresentada.
  5. O Firefox irá ser fechado e reposto. Quanto esta operação estiver concluída, uma janela irá listar a informação que foi importada. Clique em Concluir e o Firefox será aberto.
  1. Clique diretamente neste botão Atualizar o Firefox, se estiver a ver esta página no Firefox (não irá funcionar se estiver a utilizar um navegador diferente). Irá também encontrar um botão Renovar no canto superior direito da página do Firefox Informação para resolução de problemas about:support.
  2. Para continuar, clique em Renovar o Firefox na janela de confirmação que é apresentada.
  3. O Firefox irá fechar para se auto-renovar. Quanto esta operação estiver concluída, uma janela irá listar a informação que foi importada. Clique em Concluir e o Firefox será aberto.

Nota: Existe também um botão Renovar o Firefox Repor o Firefox na janela do modo de segurança do Firefox, se não conseguir iniciar o Firefox normalmente.

6. Renovar o Firefox

A funcionalidade Renovar o Firefox pode resolver muitos problemas, repondo o seu perfil do Firefox ao seu estado original mantendo os dados essenciais.

Nota: Ao utilizar a funcionalidade de renovação, os seus marcadores, histórico de navegação, separadores abertos, janelas, senhas, cookies e informações de auto-preenchimento de formulários web serão guardadas. No entanto, as suas extensões e temas serão removidos e as suas preferências repostas.Ao utilizar a funcionalidade de reposição, os seus marcadores, histórico de navegação, separadores abertos, janelas, senhas, cookies e informações de auto-preenchimento de formulários web serão guardadas. No entanto, as suas extensões e temas serão removidos e as suas preferências repostas.Ao utilizar a funcionalidade de reposição, os seus marcadores, histórico de navegação, senhas, cookies e informações de auto-preenchimento de formulários web serão guardadas. No entanto, as suas extensões e temas serão removidos; os separadores abertos, janelas e grupos de separadores não serão guardados; e as suas preferências serão repostas. Saber mais.
  1. No topo da janela do Firefox, clique no menu Ajuda e selecione Informação para resolução de problemas.No topo da janela do Firefox, clique no botão do Firefox, aceda ao sub-menu Ajuda e selecione Informação para resolução de problemas.Na barra de menu, clique no menu Ajuda e selecione Informação para resolução de problemas.
    Reset Firefox 1 - WinXP Troubleshooting info - win Troubleshooting info - mac Troubleshooting info - lin
    Se não foi possível ao menu Ajuda, escreva about:support na sua barra de endereço para carregar a página Informação para resolução de problemas.
  2. Clique no botão Repor o Firefox no canto superior direito da página Informação para resolução de problemas.
    Reset Firefox 2 - WinXP Reset Firefox - Win - 1 Reset Firefox - Mac - 1 Reset Firefox - Lin - 1
  3. Para continuar, clique em Repor o Firefox na janela de confirmação que é apresentada.Para continuar, clique em Repor o Firefox na folha de confirmação que desliza para baixo.
  4. O Firefox irá ser fechado e reposto. Quanto esta operação estiver concluída, uma janela irá listar a informação que foi importada. Clique em Concluir e o Firefox será aberto.O Firefox irá ser fechado e reposto. Quanto esta operação estiver concluída, uma janela irá listar a informação que foi importada. Clique em Feito e o Firefox será aberto.
  1. Clique no botão de menu New Fx Menu e depois clique em ajuda Help-29 .
  2. Do menu de Ajuda escolha Informação para resolução de problemas.
    Se não for possível aceder ao menu Ajuda, escreva about:support na sua barra de endereço para carregar a página Informação para resolução de problemas.
  3. Clique no botão Repor o Firefox… no canto superior direito da página Informação para resolução de problemas.
    Reset 29 Win Reset 29 Mac Reset 29 Lin
  4. Para continuar, clique em Repor o Firefox na janela de confirmação que é apresentada.
  5. O Firefox irá ser fechado e reposto. Quanto esta operação estiver concluída, uma janela irá listar a informação que foi importada. Clique em Concluir e o Firefox será aberto.
  1. Clique diretamente neste botão Atualizar o Firefox, se estiver a ver esta página no Firefox (não irá funcionar se estiver a utilizar um navegador diferente). Irá também encontrar um botão Renovar no canto superior direito da página do Firefox Informação para resolução de problemas about:support.
  2. Para continuar, clique em Renovar o Firefox na janela de confirmação que é apresentada.
  3. O Firefox irá fechar para se auto-renovar. Quanto esta operação estiver concluída, uma janela irá listar a informação que foi importada. Clique em Concluir e o Firefox será aberto.

Nota: Existe também um botão Renovar o Firefox Repor o Firefox na janela do modo de segurança do Firefox, se não conseguir iniciar o Firefox normalmente.

7. Criar um novo perfil para o Firefox

Por vezes, ficheiros da pasta de perfil do seu Firefox que correspondem a informações essenciais que uma ReposiçãoRenovação do Firefox não remove (tais como marcadores e histórico de navegação) podem estar na origem do problema. Por criar um novo perfil adicional que pode não conter todos os dados antigos do seu Firefox. Consulte Utilizar o Gestor de Perfis para criar e remover perfis do Firefox para instruções.

Outras soluções

Se já tentou todos estes métodos e o problema se mantém, o problema poderá ser de outro software ou hardware.

Esta secção não contém instruções passo-a-passo. Para mais informação sobre cada uma destas soluções, por favor consulte a documentação relacionada.

Verificar se existem conflitos com o software de segurança para a Internet

Alguns softwares de segurança para a Internet (incluindo programas de anti-vírus, anti-spyware e firewall) podem causar problemas com o Firefox, como impedir o mesmo de abrir sítios, encerramentos bruscos, entre outros. Geralmente, é possível abrir as definições do programa e remover o Firefox da lista de programas permitidos ou de confiança. Ao voltar a ser detetado, deverá voltar a funcionar normalmente. Se o seu problema está listado no artigo Configurar firewalls para que o Firefox possa aceder à Internet é possível obter instruções específicas para uma correta reconfiguração.

Fazer uma análise ao sistema por vírus e spyware

Deverá fazer uma análise periódica ao seu sistema para detetar vírus, spyware, assim como outro software malicioso. Estas ferramentas de remoção de software malicioso costumam ser úteis:

Se precisa de mais ajuda para remover software malicioso, consulte Diagnosticar problemas com o Firefox causados por software malicioso.

Procure erros no seu disco rígido e RAM

Um problema com o disco rígido ou RAM do seu computador podem impedir o Firefox de funcionar, ou fazê-lo encerrar repetidamente. Estas são instruções ou ferramentas de diagnóstico:



Baseado na informação de Diagnóstico base - Firefox (mozillaZine KB)


Partilhar este artigo: http://mzl.la/16zLrEU

Este artigo foi útil? Por favor, aguarde...

Essas pessoas maravilhosas ajudaram a escrever este artigo: cesperanc, Y4zata. Você também pode ajudar - descubra como.