Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

After clicking on link, Firefox opens 2 duplicate address tabs of that link.

  • 7 replies
  • 11 have this problem
  • 9941 views
  • Last reply by jscher2000

more options

After clicking on link, Firefox opens 2 duplicate address tabs of that link. Here is the the website: http://www.hifishark.com/search?q=sony

On the right side of page, When I click on SHOW, 2 duplicate address tabs of that link open. I have been on this site before and 1 tab would normally open.

I think this started to happen when I clicked on "Restore Default Set" in the Customize Toolbar window.

This does not happen with IE or Chrome browsers.

The SHOW link from above website, seems to be the only link that this is happening. When I right click on SHOW and click on "Open Link in New Tab" 1 tab opens.

No change when in safe mode.

Does this happen for anyone else?

Any ideas appreciated.

Thanks,

Modified by jorb

Chosen solution

Hi jorb, it doesn't surprise me that scripts sometimes work differently in different browsers. Unfortunately, the scripts are hard to follow, so I can't suggest any specific solution.

Read this answer in context 👍 0

All Replies (7)

more options

For me, the Show buttons appears on the right side of each item row. But that may not be relevant... anyway, I am not getting two tabs.


When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Bypass Firefox's Cache

Use Ctrl+Shift+r to reload the page fresh from the server.

Alternately, you also can clear Firefox's cache completely using:

orange Firefox button (or Tools menu) > Options > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click and choose View Page Info > Security > "View Cookies"
  • Alt+t (open the classic Tools menu) > Page Info > Security > "View Cookies"

In the dialog that opens, you can remove the site's cookies individually.

Then try reloading the page. Does that help?


In case one of your extensions is involved, could you test the page in Firefox's Safe Mode? That's a standard diagnostic tool to deactivate extensions and some advanced features of Firefox. More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using

Help > Restart with Add-ons Disabled (Flash and other plugins still run)

In the dialog, click "Start in Safe Mode" (not Reset)

Any difference?

more options

Hello jscher2000,

You are correct the SHOW button is on the right side of the page.Typo

Reloaded the page fresh from the server.

"Cleared Now" Cached Web Content.

Removed the site's cookies.

Restarted Firefox in Safe Mode.

Results: No Change

This works https://support.mozilla.org/en-US/questions/970999 but does not open a new tab. After clicking SHOW, FF changes address in same tab. Where as before FF would open new tab for the new link.

Any other ideas

Thanks,

Modified by jorb

more options

Hi jorb, I'm confused about your reference to the other thread. You should not need to change any settings to open a link in a new tab.

To open a link in a new tab, you can use one of these:

  • Ctrl+click the link
  • middle-click the link (using the scroll wheel)
  • right-click the link > Open Link in New Tab

Are you still getting two tabs for the first method, and one tab for the others?

more options

Hello jscher2000,

Q1. My reference to the other thread, was to show that if I changed settings, I can get FF to change address in same tab. But like you said I should not have to change any settings to open a link in a new tab.

Q2. Are you still getting two tabs for the first method, and one tab for the others? Yes

more options

Sorry, I didn't see the problem before because I have an extension which blocks scripts from google-analytics.com. The problem seems to be an error in their tracking script that for some reason launches the new window twice instead of once. You see the same two tabs whether you hold down Ctrl or not. If you leave those two tabs open and click a different Show button, the two tabs are reused.

I think the best workaround is to block google-analytics.com. If you are a NoScript user, you probably already know how to do this. If you do not use any script blocking extensions, try the simpler YesScript. https://addons.mozilla.org/en-us/firefox/addon/yesscript/

You might also mention it to the site in case they are motivated to make this less annoying.

more options

Hello jscher2000,

I suspected the site was the culprit.

They must of recently changed something with the SHOW link, because this just started happening.

I will mention it to the site to let them know what the SHOW link is doing.

It is interesting that IE and Chrome open 1 tab and Firefox opens 2 tabs.

Thanks,

more options

Chosen Solution

Hi jorb, it doesn't surprise me that scripts sometimes work differently in different browsers. Unfortunately, the scripts are hard to follow, so I can't suggest any specific solution.