X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Open links in the same tab?

Posted

Whenever I browse on Firefox and click on a link it opens in a new tab, I want it to open in the same tab. Is that possible? Because every time I open up a link, then my tabs gets longer, like ten in one window.

Chosen solution

Hello iSkyiera

  1. In the Location bar, type about:config and press Enter. The about:config "This might void your warranty!" warning page may appear.
  2. Click I'll be careful, I promise!, to continue to the about:config page.
  3. At the Search area type(or copy/paste the next) browser.link.open_newwindow.restriction then, double-click on it and change the value to 0 (zero)
  4. click OK.

Do the same with the : browser.link.open_newwindow and change the value to 1 (one)

see for more info :

http://kb.mozillazine.org/Browser.link.open_newwindow.restriction

http://kb.mozillazine.org/Browser.link.open_newwindow


thank you

Read this answer in context 12

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.8 r800
  • Next Generation Java Plug-in 10.25.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Roblox Launcher Plugin
  • WildTangent Games App V2 Presence Detector
  • Google Update
  • Unity Player 4.2.0f4
  • kanevapatch
  • iTunes Detector Plug-in
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • ExitReality Browser plugin
  • ExitReality Online browser plugin

Application

  • Firefox 23.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:23.0) Gecko/20100101 Firefox/23.0
  • Support URL: http://support.mozilla.org/1/firefox/23.0.1/WINNT/en-US/

Extensions

  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • EROnline 1.1 (support@exitreality.com) (Inactive)
  • Norton Toolbar 2013.4.2.2 ({2D3F3651-74B9-4795-BDEC-6DA2F431CB62}) (Inactive)
  • Norton Vulnerability Protection 12.0.0.380 - 1 ({BBDA0591-3099-440a-AA10-41764D9DB4DB}) (Inactive)
  • Oovoo Toolbar 21.51121 (toolbar_OVO2V7@apn.ask.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics
  • adapterDescription2:
  • adapterDeviceID: 0x0106
  • adapterDeviceID2:
  • adapterDrivers: igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16581
  • driverDate: 9-26-2012
  • driverDate2:
  • driverVersion: 9.17.10.2867
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics)
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • browser.cache.disk.capacity: 92160
  • browser.cache.disk.smart_size.enabled: False
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.search.useDBForOrder: True
  • browser.startup.homepage: http://www.search.ask.com/?p2=%5EAOF%5EYYYYYY%5EYY%5EUS&gct=hp&o=APN10523&apn_ptnrs=%5EAOF&apn_dtid=%5EYYYYYY%5EYY%5EUS&tpid=OVO2V7&apn_dbr=ff_23.0&trgb=CR&apn_uid=9D1A05D2-6968-4578-9515-21FE8F4A7636&itbv=12.3.0.1000&doi=2013-09-04&psv=
  • browser.startup.homepage_override.buildID: 20130814063812
  • browser.startup.homepage_override.mstone: 23.0.1
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 23.0.1
  • font.internaluseonly.changed: True
  • gfx.direct3d.last_used_feature_level_idx: 0
  • keyword.enabled: False
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1378948637
  • places.history.expiration.transient_current_max_pages: 102480
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • security.mixed_content.block_active_content: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1378063351

Misc

  • User JS: Yes
  • Accessibility: No
cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

Helpful Reply

You can set the browser.link.open_newwindow to 1 on the about:config page

See:

This pref set the behavior for JavaScript links:

ideato
  • Top 25 Contributor
617 solutions 4263 answers

Chosen Solution

Hello iSkyiera

  1. In the Location bar, type about:config and press Enter. The about:config "This might void your warranty!" warning page may appear.
  2. Click I'll be careful, I promise!, to continue to the about:config page.
  3. At the Search area type(or copy/paste the next) browser.link.open_newwindow.restriction then, double-click on it and change the value to 0 (zero)
  4. click OK.

Do the same with the : browser.link.open_newwindow and change the value to 1 (one)

see for more info :

http://kb.mozillazine.org/Browser.link.open_newwindow.restriction

http://kb.mozillazine.org/Browser.link.open_newwindow


thank you