X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Since August 2013, Firefox is lagging and using too much PF Usage after 1 hour

Posted

For roughly the last two months(Since August 2013), Firefox has been sucking really bad! Once I have a Firefox window open and running, it always uses more and more PF Usage and CPU usage. It eventually gets to the point where CPU usage is always at 50% or more. After 1-2 hours, PF usage goes up over 1GB.

I never ever had a problem like this with Firefox until early August 2013. What happened?!?!?!? What has changed with Firefox in the last 2-3 months?

Lastly....what is the PERMANENT fix for this ongoing problem? One time recently, I reset Firefox to factory settings and it seemed to help....for about a week to 10 days. Not doing that again as I lost too many settings in the process! I am tired of having to "End Task" every 2 hours and start over!!!!

Additional System Details

Installed Plug-ins

  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Next Generation Java Plug-in 10.40.2 for Mozilla browsers
  • Shockwave Flash 11.8 r800
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.04
  • iTunes Detector Plug-in
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • DRM Netscape Network Object
  • Npdsplay dll
  • DRM Store Netscape Plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:21.0) Gecko/20100101 Firefox/21.0

More Information

Tobbi
  • Moderator
67 solutions 450 answers

You should possibly try to create a new profile using this: Creating a profile

--Tobbi

Question owner

What does creating a profile have to do with Firefox MALFUNCTIONING and chewing up CPU usage and PF usage?

That has nothing to do with the Firefox problem unless I'm missing the linkage here. Thank you.

Tyler Downer
  • Administrator
  • Moderator
1165 solutions 6641 answers

Please first update to Firefox 24 Update Firefox to the latest version

And then Reset Firefox to ensure that the issue isn't caused by a third-party program or corrupt files, Reset Firefox – easily fix most problems

Question owner

I updated to FF24 yesterday after I posted the first thread, but the problem still persists today. I just had to End Task for firefox because it was hanging a lot, & using too much PF and CPU after one hour of having FF open and running.

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96800 answers

Did you install any (new) extensions in Firefox?

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.

Which security software (firewall, anti-virus) do you have?

Boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps.

Helpful Reply

I've installed nothing new on to Firefox. Firefox had been GREAT up until August 2013. I changed nothing on my end, but Firefox has changed something for the worse. In a typical 8 hour day I have to "End Task" on Firefox at least 3 times otherwise it becomes too slow to use.

I have Microsoft Security Essentials and Windows Firewall.

I tried booting in Firefox Safe Mode with extensions disabled. Might have been a tad better, but not as good as it used to be.

Anyone have additional info on this problem? I see I'm not the only person experiencing this when searching!

Helpful Reply

This problem still continues to this day! I used to think Firefox was great....but now it has become a big P.O.S!!!!!!!! Firefox SUCKS!!!!!!!!!!!!

I have reset Firefox to factory specs and the problem is not getting any better. I have to "End Task" on this P.O.S. Firefox at least 4 times per day....because it bogs down so bad!!!!!!!!!!!

C'MON FIREFOX, GET YOUR HEAD OUT OF YOUR @$$ AND RETURN FIREFOX BROWSER TO IT'S FORMERLY GREAT SELF. WHAT IS THE FIX FOR THIS ALREADY?!?!?!?!?!?!?!?!?!?!?!?!?!

Question owner

Problem STILL persists. What the H Firefox? Why have you gone from a top rate browser that worked flawlessly to a POS browser that uses too much memory and PF.

I have reset Firefox to factory settings and the problem is still here!


WHAT IS THE FIX FOR THIS?

moderator removed the excessive punctuation

Modified by the-edmeister

Tobbi
  • Moderator
67 solutions 450 answers

mattt,

The people who answer questions here, for the most part, are other Firefox users volunteering their time (like me), not Mozilla employees or Firefox developers. Please treat people like you'd want to be treated yourself!

You could try creating a new profile by following this: Creating a profile

Question owner

Thank you....sorry the frustration level has been on the ups lately with how poorly Firefox is operating. I figured most of the replies here come from Firefox. Sorry again.

What would creating a new profile do for this problem??

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96800 answers

Do you know which files are taking the space in the profile folder?

If the problem is caused by the current Firefox profile folder where Firefox stores personal data and installed extensions then it wouldn't be there in a new profile.

Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

Try this new profile for a day without making modifications and if the new profile works better then you can transfer some files from an existing profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over the problem.

Question owner

I dont think this has anything to do with profile using space.

PF usage = Page File usage

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96800 answers

Sorry, I misunderstood.

If the OS starts paging excessively then this will slow down the computer considerably.

How much physical memory do you have installed?

The about:memory page should show details about what is using this memory (also see resident-unique near the bottom).

In the time that XP was released then a few GB (>= 2 GB or better 4 GB) wasn't common and less than 2 GB can cause some problems with swapping to the page file.
Current Firefox versions can easily reserve about 1.5 GB virtual memory, but that usually wouldn't cause a problem.
Windows XP isn't very good in memory management and that may contribute to the problem(s).
It is best to have as less programs as possible running in the background in cases like this.

Question owner

I have 2gb of RAM in the computer. I realize this is something using up memory, but something changed with Firefox that is causing this problem. I have been using Firefox on this exact computer with no problems whatsoever for the last 4+ years. This problem only started recently, August 2013.

I have reset Firefox again and the problem now rears it's ugly head within 2 hours of the reset. Last time I reset Firefox, the problem went away for a day or two.

Where do I find this? "The about:memory page should show details about what is using this memory (also see resident-unique near the bottom). "


I've noticed once the PF usage gets to 1.0 GB, the computer becomes so slow as to not be useful. Then I have to end task on Firefox and start over.

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96800 answers

You can open the about:memory page via the location bar like you open a web page.

The about: protocol is used to access special built-in pages.

Question owner

I brought up the page about:memory, but I have no idea what I'm looking for on that page?

The problem persists and it's now affecting my laptop at home as well. Previously it was only affecting my desktop at work. I did catch this over the weekend on my laptop at home, and from previous experience I know that slow running scripts can cause this slow down problem. See below......

A script is running slow or not responding, Script: file:///C:/Documents%20and%20Settings/Administrator/Application%20Data/Mozilla/Firefox/Profiles/ckgambf0.default/extensions/%7B635abd67-4fe9-1b23-4f01-e679fa7484c1%7D/components/nsYahooAlertManager.js:3

I use Yahoo Mail for my email address and I'm now wondering if the new and unimproved Yahoo Mail(READ: sucky new Yahoo Mail platform) is causing this vs. Firefox?

Question owner

Is there a way to turn off or disable running scripts?

Waka_Flocka_Flame
  • Top 25 Contributor
529 solutions 5045 answers

Not sure why you would want to disable javascript, but you may be interested in turning off the JIT compiler.

Set these to false on the about:config page.

  • javascript.options.baselinejit.chrome
  • javascript.options.baselinejit.content
  • javascript.options.jit_hardening

For more info or help in using about:config, refer to the Mozillazine KB article on kb.mozillazine.org/About:config

Tyler Downer
  • Administrator
  • Moderator
1165 solutions 6641 answers

Don't turn JIT off, it will lead to increased memory usage and slower JS perf.

In the about:memory page, click the minimize memory usage button, does that help?

Question owner

Waka.....Shows how much I know about computing.....I'm only trying to get a handle on this issue I'm dealing with. What specifically does making those changes do? When I went to that about: page it warned me to not make changes unless I knew exactly what I was doing.

Tyler....I just minimized memory usage so I'll see if it makes any difference.


One other thing I noticed on the desktop I'm having problems with.....when I have Task Manager open, I noticed that the CPU usage for Firefox never exceeds 50%....this is when I have the processes tab pulled up. Is there some way to limit CPU usage to only 50%?