Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Website automatically resizes too large for the browser window without creating scroll bars.

  • 22 replies
  • 21 have this problem
  • 13209 views
  • Last reply by jimandme

more options

I have recently installed FF. There is a specific website I go to often that works fine in the other major browsers. However, when I access it in FF, the window appears properly for a split second and then automatically re-sizes to a size that doesn't fit within the confines of the browser window. I am unable to use "CTRL -" to bring it back into full view. In addition, there are no scroll bars available after the resize. I have reset FF to its default state and I have restarted with add-ons disabled to no avail. This is a Silverlight-based site, if that has any bearing on the situation. Any suggestions?

Chosen solution

I just discovered a simple solution that fixed my problem.

Although CTRL + and CTRL - don't work on this specific website, I made the Menu Bar visible ("Firefox | Options | Menu Bar") and was then able to utilize "View | Zoom | Zoom Out" to get the website to fit properly within the browser window.

For whatever reason, the website was being automatically zoomed in when first accessed with a newer version of FF. Once I zoomed out using the menu instead of CTRL -, I was able to close the browser and then reopen it and it "remembered" the zoom level for the website.

Read this answer in context 👍 0

All Replies (20)

more options

What is the web page you have trouble with?

more options

Interestingly, for gits and shiggles, I downgraded to version 22 and got the same problem. So, I downgraded once more to version 3.6.28 and the problem went away. I can only assume that it is version specific to the two newest versions.

more options

Are you aware that nothing (other than the prompt to install Silverlight) is displayed on that web page when Silverlight isn't installed on the PC attempting to view that page?

I suspect that Silverlight is a big part of your problem. Sorry, I can't offer a suggestion installing Silverlight is out.

more options

Yes, I am aware of that. Silverlight sucks, but the primary jail that I deal with decided to redo their main inmate database interface with it. So, I am stuck with it.

As far as Silverlight goes, though, there are no adjustments within its settings that would affect the resizing of the page. In addition, since it DOESN'T occur in previous versions of FF, I think it is safe to assume that it is specific to the newer versions of FF, not Silverlight.

more options

Try to use the window resize icon in the bottom right corner to resize this window to see if that helps to redraw its content.

more options

When you go to that webpage, As soon as it gets to that too-large point, you click "Ctrl. -" to minimize the screen.

more options

I don't see a window resize icon in the lower right corner...

more options

As was stated in the original post, CTRL - doesn't accomplish anything.

more options

I have same problem since first versions of firefox till now. Thanks for reporting problem.

@the-edmeister:

   Its not related to silverlight because I never had silverlight plugin on my PC.

and its not possible to correct it by ctrl+minus. In this condition current tab's width is extended more than monitor's width and 3 buttons of (minimize maximize exit) are invisible.


any help please?

Modified by espand

more options

Chosen Solution

I just discovered a simple solution that fixed my problem.

Although CTRL + and CTRL - don't work on this specific website, I made the Menu Bar visible ("Firefox | Options | Menu Bar") and was then able to utilize "View | Zoom | Zoom Out" to get the website to fit properly within the browser window.

For whatever reason, the website was being automatically zoomed in when first accessed with a newer version of FF. Once I zoomed out using the menu instead of CTRL -, I was able to close the browser and then reopen it and it "remembered" the zoom level for the website.

Modified by RDiPesa

more options

@RDiPesa

  That is not a proper solution. I remember that I had this problem with some particular pages of a web site. If you change zoom level of a special page, It will be applied to other pages of that web site (domain) too and it will make other proper pages, ugly!

still waiting for a good solution...

Modified by espand

more options

Can't you drag the border of the window to resize it?

You can try to open the system menu via Alt+Space and use the Resize and Move entries to resize the window and position it correctly. Silverlight automatically resize the content when I resize the window to make the content fit.

more options

@espand: Actually, it worked properly. Before I posted that I had found a solution, I tested it. I zoomed my problem website and then opened up a few new tabs and checked other sites. The zooming of my problem website had no effect on the zoom level of the new tabs. I then closed out of FF, restarted it, and went to my problem website. The desirable zoom level remained. I then opened other websites and their zoom levels were correct.

more options

@espand: I also tested with a new tab from the same domain, different page and that page's zoom was correct.

more options

Does that page still zoom correctly if you reset the zoom after Silverlight has adjusted the content to fit?

more options

@cor-el: If I reset zoom, it zooms the content to the original size that gave me the problem.

more options

@RDiPesa

  Its odd, because normally changing zoom level of a certain page will change zoom level for all pages of that domain-name.


Anyway obviously, there's a problem in rendering of these pages by firefox. I wish one of firefox developers could read this thread and analyse the URL you reported; Then we may have a real solution and better firefox...

Modified by espand

more options

If I reload the page then I get a small content window although right clicking on empty area gives me a Moonlight context menu (I'm on Linux). I only need to open and close the Find bar (Ctrl+F; ESC) to make Silverlight automatically adjust to available height.

more options

@espand: Agreed about the rendering. I also have to assume that the developer of the website has also somehow turned off any shortcut methods of adjusting the page. Luckily, the menu adjustments are still functional.

@cor-el: All I get with a right-click is a basic Silverlight menu that brings up a window that, from what I can tell, does not allow for (auto)adjustment of the website content.

  1. 1
  2. 2