X
Tap here to go to the mobile version of the site.

Support Forum

New Tab problems

Posted

V. 21.0 I have turned off the "New Tab Page" feature because i don't want all the history i just want my home page. How do i get each NEW TAB to only show my HomePage?

V. 21.0 I have turned off the "New Tab Page" feature because i don't want all the history i just want my home page. How do i get each NEW TAB to only show my HomePage?

Chosen solution

Here is how you can reset what the tab does. If this setting does not stick, one of your add-ons might be overriding it.

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste newtab and pause while the list is filtered

(3) Double-click the browser.newtab.url preference and enter the desired value:

(i) Page thumbnails (default)

about:newtab

(ii) Blank tab

about:blank

(iii) Built-in Firefox home page

about:home

(iv) Any other page

full URL to the page

Press Ctrl+t to open a new tab and verify that it worked. Fixed?

Read this answer in context 75

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 10.21.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.7 r700
  • 5.1.20125.0

Application

  • Firefox 21.0
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20100101 Firefox/21.0
  • Support URL: http://support.mozilla.org/1/firefox/21.0/WINNT/en-US/

Extensions

  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Webroot 2.0.0 ({8ac62a8b-8b3f-43ba-9b1a-90c299b9dfda})

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Standard VGA Graphics Adapter
  • adapterDescription2:
  • adapterDeviceID: 0x9648
  • adapterDeviceID2:
  • adapterDrivers: vga framebuf vga256 vga64k
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'tryNewerDriver', u'10.6']
  • directWriteEnabled: False
  • directWriteVersion: 6.2.9200.16492
  • driverDate: 6-21-2006
  • driverDate2:
  • driverVersion: 6.1.7600.16385
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'none'}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'tryNewerDriver', u'9.6']
  • numTotalWindows: 1
  • webglRendererMessage: [u'tryNewerDriver', u'9.6']
  • windowLayerManagerType: Basic

Modified Preferences

  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.link.open_newwindow: 1
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage: www.google.com
  • browser.startup.homepage_override.buildID: 20130511120803
  • browser.startup.homepage_override.mstone: 21.0
  • browser.tabs.loadInBackground: False
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 21.0
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1370550604
  • places.history.expiration.transient_current_max_pages: 93400
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 4

Misc

  • User JS: No
  • Accessibility: Yes
jscher2000
  • Top 10 Contributor
8787 solutions 71865 answers

Chosen Solution

Here is how you can reset what the tab does. If this setting does not stick, one of your add-ons might be overriding it.

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the filter box, type or paste newtab and pause while the list is filtered

(3) Double-click the browser.newtab.url preference and enter the desired value:

(i) Page thumbnails (default)

about:newtab

(ii) Blank tab

about:blank

(iii) Built-in Firefox home page

about:home

(iv) Any other page

full URL to the page

Press Ctrl+t to open a new tab and verify that it worked. Fixed?

Here is how you can reset what the tab does. If this setting does not stick, one of your add-ons might be overriding it. (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button promising to be careful. (2) In the filter box, type or paste '''newtab''' and pause while the list is filtered (3) Double-click the '''browser.newtab.url''' preference and enter the desired value: ''(i) Page thumbnails (default)'' about:newtab ''(ii) Blank tab'' about:blank ''(iii) Built-in Firefox home page'' about:home ''(iv) Any other page'' full URL to the page Press Ctrl+t to open a new tab and verify that it worked. Fixed?
Ryde Wolf 0 solutions 3 answers
Well none of that worked. This is what I have: http://search.conduit.com/?ctid=CT3310393&octid=EB_ORIGINAL_CTID&SearchSource=69&CUI=&SSPV=EB_SSPV&Lay=1&UM=2&UP=SP421D9305-4F81-45BB-A658-FD35C020C760 After I change it: http://search.conduit.com/?ctid=CT3310393&octid=EB_ORIGINAL_CTID&SearchSource=69&CUI=&SSPV=EB_SSPV&Lay=1&UM=2&UP=SP421D9305-4F81-45BB-A658-FD35C020C760 No different. Can't get rid of it.
kobe 441 solutions 5048 answers

Hi Rydewolf, you must have a user.js file hacking your prefs, heres a article for deleting it.

Hi Rydewolf, you must have a user.js file hacking your prefs, heres a article for deleting it. * https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save#w_user-js-file-overriding-preferences
jscher2000
  • Top 10 Contributor
8787 solutions 71865 answers

Hi RydeWolf, which option did you choose? Did it change back immediately or the next time you started Firefox?

Conduit provides the technology for numerous "Community Toolbar" extensions. Do you have anything like that in the Windows "programs and features" control panel or in your Firefox extensions list? I'm not aware of any other source of changes to Conduit URLs, but perhaps you've encountered one.

Hi RydeWolf, which option did you choose? Did it change back immediately or the next time you started Firefox? Conduit provides the technology for numerous "Community Toolbar" extensions. Do you have anything like that in the Windows "programs and features" control panel or in your Firefox extensions list? I'm not aware of any other source of changes to Conduit URLs, but perhaps you've encountered one.
Ryde Wolf 0 solutions 3 answers

I have tried everything to change it back, nothing is working.

This is what I get on all new tabs.

I have tried everything to change it back, nothing is working. This is what I get on all new tabs.
kobe 441 solutions 5048 answers

The user.js method should have worked if its there, if you havent checked, i would check now/again. If not you may need to reset firefox. Refresh Firefox - reset add-ons and settings

The user.js method should have worked if its there, if you havent checked, i would check now/again. If not you may need to reset firefox. [[Reset Firefox – easily fix most problems]]
cor-el
  • Top 10 Contributor
  • Moderator
17569 solutions 158915 answers

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.

You can check for problems with preferences.
Rename or delete the prefs.js file and possible numbered prefs-##.js files and a possible user.js file to reset all prefs to the default value.

Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Firefox/Tools > Add-ons > Appearance). *Do NOT click the Reset button on the Safe Mode start window. *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes You can check for problems with preferences.<br /> Rename or delete the prefs.js file and possible numbered prefs-##.js files and a possible user.js file to reset all prefs to the default value. *http://kb.mozillazine.org/Preferences_not_saved *http://kb.mozillazine.org/Resetting_preferences
raiderbus 0 solutions 6 answers

Where do I find the filter box? Step 2 reads: "(2) In the filter box, type or paste newtab and pause while the list is filtered ." The top of my browser window looks like this:

https://support.cdn.mozilla.net/media/uploads/images/2013-08-04-16-36-40-e1f661.png

I'd also like to get rid of that Search tab on the right.

Where do I find the filter box? Step 2 reads: "(2) In the filter box, type or paste newtab and pause while the list is filtered ." The top of my browser window looks like this: https://support.cdn.mozilla.net/media/uploads/images/2013-08-04-16-36-40-e1f661.png I'd also like to get rid of that Search tab on the right.
kobe 441 solutions 5048 answers

Remove Keybar Websearch (or something similar) from the control panel, use the search reset tool and delete a possible user.js file.

Remove Keybar Websearch (or something similar) from the control panel, use the search reset tool and delete a possible user.js file. * https://addons.mozilla.org/en-us/firefox/addon/searchreset/ * https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save#w_user-js-file-overriding-preferences
cor-el
  • Top 10 Contributor
  • Moderator
17569 solutions 158915 answers

Those CT pref settings are added by a Conduit Toolbar.

You can rename or delete the prefs.js file and possible numbered prefs-##.js files and a possible user.js file to reset all prefs to the default value.

Those CT pref settings are added by a Conduit Toolbar. You can rename or delete the prefs.js file and possible numbered prefs-##.js files and a possible user.js file to reset all prefs to the default value. *http://kb.mozillazine.org/Preferences_not_saved
jscher2000
  • Top 10 Contributor
8787 solutions 71865 answers

Hi raiderbus, I swear that Search box above the list of preferences used to be labeled Filter... anyway, that is where you type the text to filter by, or search by, as the case may be.

Hi raiderbus, I swear that Search box above the list of preferences used to be labeled Filter... anyway, that is where you type the text to filter by, or search by, as the case may be.
kobe 441 solutions 5048 answers

I assumed he/she is referring to the search bar beside the new tab button.

I assumed he/she is referring to the search bar beside the new tab button.
jscher2000
  • Top 10 Contributor
8787 solutions 71865 answers

Hi Waka_Flocka_Flame, you're right, I was only responding to the part about the error in my earlier instructions.

Hi Waka_Flocka_Flame, you're right, I was only responding to the part about the error in my earlier instructions.
raiderbus 0 solutions 6 answers

Thanks to all. You’re quick and helpful! I had spent 45 minutes unsuccessfully trying to research “filter box” on Mozilla Support. After I posted my comments, I tried the Search box above the Preference Name column, slapped the back of my head, and completed the instructions, changing the browser.newtab.url value to my homepage address, https://www.google.com

My browser.newtab.url value is still https://www.google.com but, just like RydeWolf, I still get that annoying, useless conduit.com page--even after restarting Firefox.

In his 8/3 reply to RydeWolf, jscher2000 is on to something. Concurrent with the usurpation of my new tab page, I was inflicted with not one, but four annoyances:

  1. Conduit.com had replaced my home page. I fixed that easily.
  2. Conduit.com had replaced my home page on all new tab pages.
  3. The Keybar 1.13 Community Toolbar appeared. I immediately unchecked it on the drop-down toolbar menu, but I’d like to get rid of it.
  4. The Search box appeared to the right of the tabs.

Hey! I just discovered this is not an exclusive Firefox phenomenon. All four problems are present on IE and the first two have corrupted Google Chrome and Torch. I suspect RydeWolf and I are victims of stealth installs!

I’ll try Waka_Flocka_Flame’s and cor-el’s suggestions for the Search box when I have some time. At age 73, I’m a bit slow with some of this. And I’ll try the suggestions others have made to RydeWolf for the New Tab page issue--even though they’ve been unsuccessful for him.

In the meantime, there may be a clue to the solution in these Preference settings (filtered for newtab). Note the false values.

Thanks to all. You’re quick and helpful! I had spent 45 minutes unsuccessfully trying to research “'''filter box'''” on Mozilla Support. After I posted my comments, I tried the '''Search box''' above the '''Preference Name''' column, slapped the back of my head, and completed the instructions, changing the '''browser.newtab.url''' value to my homepage address, '''https://www.google.com''' My '''browser.newtab.url''' value is still '''https://www.google.com''' but, just like RydeWolf, I still get that annoying, useless '''conduit.com''' page--even after restarting Firefox. In his 8/3 reply to RydeWolf, jscher2000 is on to something. Concurrent with the usurpation of my new tab page, I was inflicted with not one, but '''''four''''' annoyances: # '''Conduit.com''' had replaced my home page. I fixed that easily. # '''Conduit.com''' had replaced my home page on all new tab pages. # The '''Keybar 1.13 Community Toolbar''' appeared. I immediately unchecked it on the drop-down toolbar menu, but I’d like to get rid of it. # The '''Search box''' appeared to the right of the tabs. '''Hey!''' I just discovered this is not an exclusive Firefox phenomenon. All four problems are present on IE and the first two have corrupted Google Chrome and Torch. I suspect RydeWolf and I are victims of stealth installs! I’ll try Waka_Flocka_Flame’s and cor-el’s suggestions for the '''Search box''' when I have some time. At age 73, I’m a bit slow with some of this. And I’ll try the suggestions others have made to RydeWolf for the '''New Tab page''' issue--even though they’ve been unsuccessful for him. In the meantime, there may be a clue to the solution in these '''Preference''' settings (filtered for '''newtab'''). Note the '''false''' values.

Modified by raiderbus

jscher2000
  • Top 10 Contributor
8787 solutions 71865 answers

This might be somewhere in this thread, but at the risk of repeating:

To disable (and possibly remove) extensions such as Keybar, use the Add-ons page:

orange Firefox button (or Tools menu) > Add-ons > Extensions category

This might be somewhere in this thread, but at the risk of repeating: To disable (and possibly remove) extensions such as Keybar, use the Add-ons page: orange Firefox button (or Tools menu) > Add-ons > Extensions category
cor-el
  • Top 10 Contributor
  • Moderator
17569 solutions 158915 answers

Note that you have or had the "Default Tab" extension that is considered as malware.

Note that you have or had the "Default Tab" extension that is considered as malware. *http://kb.mozillazine.org/Uninstalling_add-ons *http://kb.mozillazine.org/Uninstalling_toolbars *[[/questions/945512]] How do I remove a search bar from Firefox?
raiderbus 0 solutions 6 answers

Thanks, jscher2000, Waka_Flocka_Flame, and cor-el!. Here’s a status report:

  1. I reset my homepage to https://www.google.com since it had occasionally been reverting to conduit.com
  2. I retraced my steps through jscher2000’s Chosen Solution above to be sure browser.newtab.url was still set to https://www.google.com
  3. Using the Add-ons page (Tools > Add-ons > Extensions) I disabled the KeyBar 1.13 toolbar, restarted Firefox, and, for good measure, removed it. The KeyBar 1.13 toolbar no longer appears on the Add-ons page, but KeyBar search bars now appear to the right of my tabs (very annoying) and the address bar (a lesser inconvenience).

So my top three problems have been resolved, but I still want rid of that search bar alongside my tabs, and I’ll work my way through the articles that Waka_Flocka_Flame, and cor-el have kindly linked for me,

Thanks, jscher2000, Waka_Flocka_Flame, and cor-el!. Here’s a status report: # I reset my homepage to '''https://www.google.com''' since it had occasionally been reverting to '''conduit.com''' # I retraced my steps through jscher2000’s Chosen Solution above to be sure '''browser.newtab.url''' was still set to '''https://www.google.com''' # Using the '''Add-ons''' page (Tools > Add-ons > Extensions) I disabled the '''KeyBar 1.13 toolbar,''' restarted Firefox, and, for good measure, removed it. The '''KeyBar 1.13 toolbar''' no longer appears on the '''Add-ons''' page, but '''KeyBar''' search bars now appear to the right of my tabs (very annoying) and the address bar (a lesser inconvenience). So my top three problems have been resolved, but I still want rid of that search bar alongside my tabs, and I’ll work my way through the articles that Waka_Flocka_Flame, and cor-el have kindly linked for me,
cor-el
  • Top 10 Contributor
  • Moderator
17569 solutions 158915 answers

Helpful Reply

Can you attach a screenshot?

Use a compressed image type like PNG or JPG to save the screenshot.

Custom installed search engines are located in the searchplugins folder in the Firefox profile folder.

You can delete the search.json file and possible search-metadata.json and search.sqlite files in the Firefox profile folder to reset the search engines to the default.

Can you attach a screenshot? *http://en.wikipedia.org/wiki/Screenshot *https://support.mozilla.org/kb/how-do-i-create-screenshot-my-problem Use a compressed image type like PNG or JPG to save the screenshot. Custom installed search engines are located in the searchplugins folder in the Firefox profile folder. *Help > Troubleshooting Information > Profile Directory: Show Folder (Linux: Open Directory; Mac: Show in Finder) *http://kb.mozillazine.org/Profile_folder_-_Firefox You can delete the search.json file and possible search-metadata.json and search.sqlite files in the Firefox profile folder to reset the search engines to the default. *http://kb.mozillazine.org/Profile_folder_-_Firefox
jscher2000
  • Top 10 Contributor
8787 solutions 71865 answers

You can clean up those two search areas as follows:

Search bar: click the icon on the left, choose Manage Search Engines, then remove the one you do not want.

Address bar: this article has the steps: Search the web from the address bar or as a shortcut, use this extension: https://addons.mozilla.org/en-US/firefox/addon/searchreset/

Edit: Actually, I don't know whether the search box to the right of your tabs is the normal Firefox search bar moved to a new location, or a box added by the add-on. My steps were for Firefox's search bar.

You can clean up those two search areas as follows: Search bar: click the icon on the left, choose Manage Search Engines, then remove the one you do not want. Address bar: this article has the steps: [[Search the web from the Address Bar]] or as a shortcut, use this extension: https://addons.mozilla.org/en-US/firefox/addon/searchreset/ ''Edit:'' Actually, I don't know whether the search box to the right of your tabs is the normal Firefox search bar moved to a new location, or a box added by the add-on. My steps were for Firefox's search bar.

Modified by jscher2000

Ryde Wolf 0 solutions 3 answers

Thanks for all the help. It seems to have got sorted.

Thanks for all the help. It seems to have got sorted.