X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Unresponsive script

Posted

Hello,

    I am constantly getting the error, "unresponsive script" on allot of web pages. I tried disabling allot of the addons, but I still get this message:


Warning:Unresponsive script

A script on this page may be busy, or it may have stopped responding. You can stop the script now, or you can continue to see if the script will complete.

Script: chrome://viewmarks/content/editmark.js:266

A script on this page may be busy, or it may have stopped responding. You can stop the script now, or you can continue to see if the script will complete.

Script: chrome://viewmarks/content/capture.js:83

Firefox also freezes up when I go to a new page, but if I wait a minute, it will come back. Can anyone assist me concerning this problem? Thank You.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.6 r602
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.02
  • Adobe Shockwave for Director Netscape plug-in, version 12.0
  • 5.1.20125.0
  • The plugin allows you to have a better experience with Microsoft Lync
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • A plugin to detect whether the Adobe Application Manager is installed on this machine.

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:20.0) Gecko/20100101 Firefox/20.0

More Information

Disabling addons,

iamjayakumars
  • Top 10 Contributor
415 solutions 4927 answers

Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  • Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  • In the Firefox options window click the Advanced tab, then select "General".
  • In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  • Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems

Upgrade your graphics drivers to use hardware acceleration and WebGL

Did this fix your problems? Please report back to us!

Thank you. _________________________________________________________________________________

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.


Further information can be found in the Reset Firefox – easily fix most problems article.

Did this fix your problems? Please report back to us!Hello,

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96760 answers

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe mode start window or otherwise make changes.

Question owner

Thank you cor-el, this will assist me in finding out which on of the 27 extensions is giving me the problem. Maybe it could be a combination of extensions, or the settings not correctly configured. I have allot of bookmark extensions, so I'll start with them first. When Firefox restarted in Safe mode, it ran faster and the new windows popped up without freezing up due to the Script: chrome://viewmarks/content/editmark.js:xxxx problem.

Every time when I went to a new site, or just typed in a new link, Firefox would Freeze for about a minuet or two, then a flash, then it went back to normal. I also disabled Hardware acceleration because the text in Firefox was getting a little blurry and yellowishly. Now everything is fine. I'll get back to you to let everyone know what was the actual problem. Plus, I'm only running an Intel Pentium 4 @3.0GHz with 2Gb mem, and an AMD READON 4860 Graphics card. Thank You.

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96760 answers

You didn't list your extensions (Help > Troubleshooting Information), so I'm not able to give suggestions, but the 'viewmarks' in the error message should give an indication of which extension is involved.

Likely this extension:

Question owner

Okay, I've read and done everything in the article and I still get:

Warning: Unresponsive script

A script on this page may be busy, or it may have stopped responding. You can stop the script now, or you can continue to see if the script will complete.

Script: chrome://likethepage/content/smartlinks.xul:353

Then I went to : Options > Advanced > Browsing > Use hardware acceleration when available and I UNCLICKED/UNTICKED this option, disabling it. And I still get this problem, and it's not just with certain webpages, I even get this when I type in about:about . Firefox then freezes up (everything gets ghosted out), and then I receive this message again. Can anyone suggest anything else I can do and/or try? I like using Firefox, but I keep getting : Warning: Unresponsive script

Is there anything else I can do to assist you in helping me with this problem? Thank You. :)

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96760 answers

The name in the chrome URL usually gives a hint which extension is causing the problem, in this case "likethepage"

  • chrome://likethepage/content/smartlinks.xul:353
Limoncello7 0 solutions 2 answers

In my case the "unresponsive script" issue only occurred after recently upgrading to the new Firefox version (21). It causes lots of problems and I have to restart the computer to get rid of it for a while. I had the same problem about a year ago and also after upgrading, then it disappeared with the next FF upgrade. My solution then was switching to Google Chrome and wait for the next FF upgrade.

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96760 answers

Did you try Safe Mode?

souldaddy10 0 solutions 1 answers

comments deleted by a moderator - If you don't have anything positive to contribute which helps the "owner" of a question thread, please refrain from posting anything at all - that includes grammar correction tips. If you need help with a problem of your own, please start your own question thread and ask for help. Otherwise you are interfering with the support process for the "owner" of this thread and that won't be tolerated here.

Modified by the-edmeister

Limoncello7 0 solutions 2 answers

Thanks for suggesting this once more. Yes, I did switch to Safe Mode and it works for a while. But after awaking from sleep FF21 freezes completely, no tab can be opened anymore. Fortunately you can close FF21. A nasty issue I never had with previous versions.

KJKK 0 solutions 1 answers

Helpful Reply

Hi I had this problem for about 3-4 months. And I tried everything even switch from Chrome to Mozilla. Nothing seams to work. When your computer / laptop runs Mozilla or Chrome and don't have enough RAM memory then trays to reach from virtual memory on your hard drive. But if your "C" hard drive is almost full then problems starts. So what you need is clean your hard drive :) I deleted about 80Gb (stuff I didn't need: films, music, audio books etc.) Now unresponsive script is only a memory lol

Hope that will help!


Ps Spreed the word :)

Modified by KJKK

emyndubisi 0 solutions 1 answers

dc1df979-6a76-496d-92e4-61c7a3c9fa14 2f5975ab-f1fa-4a4a-b67b-aba0b4166d54 30b6f232-03b1-41ff-b171-e3f687b5de46 16aa7aee-f7f7-4032-8c84-eec11a52b55d 42855474-671d-49ba-95d6-7b4ec08cec96

Dr Hussein 0 solutions 1 answers

i too had a similar problem and following these simple steps could save me..

https://addons.mozilla.org/en-US/firefox/addon/yesscript/

https://support.mozilla.org/en-US/kb/warning-unresponsive-script?esab=a&s=un+responsive+script&r=1&as=s

the mentioned Yesscript add on is a gem, try it and enjoy butter smooth browsing.

regards

jscher2000
  • Top 10 Contributor
2365 solutions 20922 answers

Hi Limoncello7, the slow-wake-from-sleep problem is said to be fixed in Firefox 23. If you want to try it in advance of the anticipated August 6th release, you can install the current "beta" test version from this page:

https://www.mozilla.org/firefox/beta/

bailey5757 0 solutions 2 answers

I need a proper link that will open ...about:config Mozilla is unresponsive and plus I am getting non responsive reading script, continue or stop.

continuously.  I received a alert message from Mozilla several weeks ago

helping me to go to a page to reset the reading time for script reading. and it worked wonderfully. another problem arose and advised to reset Mozilla and I lost the increase setting for read time of 20 for script. searched everything I can. Did not find the increase time the integer Page. please help me

jscher2000
  • Top 10 Contributor
2365 solutions 20922 answers

Helpful Reply

Hi bailey5757, you have to actually type or paste about:config into the address bar and press Enter, you can't use a link.

If about:config is not working, then you have a different problem that probably requires a different approach. Can you open the about:about page and access about:config from there?

The preference for how long scripts can be unresponsive before you get a warning is

dom.max_script_run_time

By default, it is set to 10 seconds.

If that doesn't resolve your issues, please start a new question with your system info (OS) and add-on info. You can do that here:

https://support.mozilla.org/questions/new/desktop/fix-problems