X
Tap here to go to the mobile version of the site.

Support Forum

Private Browsing mode is not working.

Posted

I am using Firefox 19.0.2 on Win 7.

When I go to private browsing mode all of my history is still recorded.

I tried it in Firefox safe mode and had the same problem.

I am using Firefox 19.0.2 on Win 7. When I go to private browsing mode all of my history is still recorded. I tried it in Firefox safe mode and had the same problem.

Chosen solution

Firefox 20 versions and later have switched to Private Browsing mode per Window.

You can now find Private Browsing in the Firefox menu button drop down and in the File menu as "New Private Window".

Future Firefox versions will also support Private Browsing per tab, this is already available in an extension.


Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window or otherwise make changes.
Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.6 r602
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape "9.5.4"
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • 5.1.20125.0
  • IE Tab 2 Plug-in for Mozilla/Firefox
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.5.635
  • Default Plug-in
  • PlayStation(R)Network Downloader Check Plug-in
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • iTunes Detector Plug-in
  • NPWLPG
  • Version 1.0.3, copyright 1996-2009 The VideoLAN Teamhttp://www.videolan.org/

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0

More Information

Amit Kumar Thakur
  • Locale Leader
70 solutions 859 answers

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.


Further information can be found in the Refresh Firefox - reset add-ons and settings article.

Did this fix your problems? Please report back to us!

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: ''This will cause you to lose any Extensions, Open websites, and some Preferences.'' To Reset Firefox do the following: #Go to Firefox > Help > Troubleshooting Information. #Click the "Reset Firefox" button. #Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish. #Firefox will open with all factory defaults applied. Further information can be found in the [[Reset Firefox – easily fix most problems]] article. Did this fix your problems? Please report back to us!
cor-el
  • Top 10 Contributor
  • Moderator
17212 solutions 155506 answers

Do you mean that you still have the history of visited sites from PB mode after leaving PB mode or restarting Firefox?

Do you mean that you still have the history of visited sites from PB mode after leaving PB mode or restarting Firefox?

Question owner

Amitshree, I would really rather not reset firefox. I just updated from a much earlier version and spent about two hours customizing and finding replacements for all my extensions that are no longer supported etc.

I don't want to have to go through that again, if possible.

Cor-el, I mean that upon leaving private browsing, all history of the private browsing session is still visible. Restarting make no difference. There doesn't seem to be any difference between the private browsing and normal browsing.

Amitshree, I would really rather not reset firefox. I just updated from a much earlier version and spent about two hours customizing and finding replacements for all my extensions that are no longer supported etc. I don't want to have to go through that again, if possible. Cor-el, I mean that upon leaving private browsing, all history of the private browsing session is still visible. Restarting make no difference. There doesn't seem to be any difference between the private browsing and normal browsing.
cor-el
  • Top 10 Contributor
  • Moderator
17212 solutions 155506 answers

This sounds that you are not really in Private Browsing mode.

Try to create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be careful not to copy corrupted files.

Try to boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps.

This sounds that you are not really in Private Browsing mode. Try to create a new profile as a test to check if your current profile is causing the problems. See "Creating a profile": *https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Profile_issues If the new profile works then you can transfer some files from an existing profile to the new profile, but be careful not to copy corrupted files. *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox Try to boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps.

Question owner

Thanks for the suggestion Cor-el, but it didn't work.

I tried both the profile of another user account on this computer and a new one I created.

On both these other profiles, I had exactly the same problem. Start private browsing, go to random address, stop private browsing, can still see that address in history.

Thanks for the suggestion Cor-el, but it didn't work. I tried both the profile of another user account on this computer and a new one I created. On both these other profiles, I had exactly the same problem. Start private browsing, go to random address, stop private browsing, can still see that address in history.
cor-el
  • Top 10 Contributor
  • Moderator
17212 solutions 155506 answers

Try to update to Firefox 20 to see if that helps.

Try to update to Firefox 20 to see if that helps.

Question owner

Thanks a lot.

Firefox 20 fixed the problem.

Thanks a lot. Firefox 20 fixed the problem.
cor-el
  • Top 10 Contributor
  • Moderator
17212 solutions 155506 answers

You're welcome

You're welcome
emmetfb 0 solutions 4 answers

Hi, I am using FireFox 20.1 and I still have the problem.

The difference I see from the older versions is that when I start private browsing now I get a new browser and the original one remains open. Previously when I started private browsing the original browser changed to private - shutting all but one tab.

I have not changed any settings.

Hi, I am using FireFox 20.1 and I still have the problem. The difference I see from the older versions is that when I start private browsing now I get a new browser and the original one remains open. Previously when I started private browsing the original browser changed to private - shutting all but one tab. I have not changed any settings.
cor-el
  • Top 10 Contributor
  • Moderator
17212 solutions 155506 answers

Yes, that is how it now works.
You open a New Private Window and the original window stays open (you can close it yourself if really needed), so you can switch between the two windows (normal and private).
This allows for instance to check another email account without the need to log out first (you can switch back to the normal window with the first account you opened).

Yes, that is how it now works.<br /> You open a New Private Window and the original window stays open (you can close it yourself if really needed), so you can switch between the two windows (normal and private).<br /> This allows for instance to check another email account without the need to log out first (you can switch back to the normal window with the first account you opened).
emmetfb 0 solutions 4 answers

Thank you for the heads up. The new setting makes sense.

However, the privacy history issue still remains in version 20.1.

Thank you for the heads up. The new setting makes sense. However, the privacy history issue still remains in version 20.1.
cor-el
  • Top 10 Contributor
  • Moderator
17212 solutions 155506 answers

You should only see that history while in a private window and it should disappear once all private windows are closed.

You should only see that history while in a private window and it should disappear once all private windows are closed.
emmetfb 0 solutions 4 answers

Yes I understand how it should work but it doesn't. My private browsing history is available in my standard browser after I have finished the private session.

In fact I don't use FF anymore for private browsing it is just not secure.

Yes I understand how it should work but it doesn't. My private browsing history is available in my standard browser after I have finished the private session. In fact I don't use FF anymore for private browsing it is just not secure.
yogos99 0 solutions 1 answers

I'm having a problem too.

I click "tools" and I only see the option to clear recent history.

Private browsing isn't in the tools menu.

I don't think it's possible for someone to remove this option.

Any help?

I'm having a problem too. I click "tools" and I only see the option to clear recent history. Private browsing isn't in the tools menu. I don't think it's possible for someone to remove this option. Any help?
cor-el
  • Top 10 Contributor
  • Moderator
17212 solutions 155506 answers

Chosen Solution

Firefox 20 versions and later have switched to Private Browsing mode per Window.

You can now find Private Browsing in the Firefox menu button drop down and in the File menu as "New Private Window".

Future Firefox versions will also support Private Browsing per tab, this is already available in an extension.


Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window or otherwise make changes.
Firefox 20 versions and later have switched to Private Browsing mode per Window. You can now find Private Browsing in the Firefox menu button drop down and in the File menu as "New Private Window". Future Firefox versions will also support Private Browsing per tab, this is already available in an extension. *Private Tab: https://addons.mozilla.org/firefox/addon/private-tab/ ---- Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance). *Do NOT click the Reset button on the Safe Mode start window or otherwise make changes. *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes
emmetfb 0 solutions 4 answers

Helpful Reply

Not sure which version you are talking ab out there. You should be able to use CTRL+SHIFT+P to start a private session.

Not sure which version you are talking ab out there. You should be able to use CTRL+SHIFT+P to start a private session.
mdg33 0 solutions 5 answers

I have this problem too and am using the latest FF 20.

Basically Private Browsing doesn't work.

Seems like somebody at Mozilla made an almighty f@ck up.

Hope they get it fixed soon.

I have this problem too and am using the latest FF 20. Basically Private Browsing doesn't work. Seems like somebody at Mozilla made an almighty f@ck up. Hope they get it fixed soon.
John99 971 solutions 13138 answers

Helpful Reply

Others are using it ok. I did notice that if you are already in permanent Private Browsing you may not see the mask icon so although selecting PB

  • you may not be aware you are already using it
  • and it may not make a noticeable change.

If reading this thread does not help try

  1. Starting your own thread by asking your own question
    use /questions/new
  2. Remember to include troubleshooting information when prompted
  3. Fully describe the problem. Say what you have done. What you then expected, then what does or does not happen. Consider including a screenshot and detailing any error messsages.
Others are using it ok. I did notice that if you are already in permanent Private Browsing you may not see the mask icon so although selecting PB *you may not be aware you are already using it *and it may not make a noticeable change. If reading this thread does not help try # Starting your own thread by asking your own question <br> use [/questions/new] #Remember to include troubleshooting information when prompted # Fully describe the problem. Say what you have done. What you then expected, then what does or does not happen. Consider including a screenshot and detailing any error messsages.
netscape01 0 solutions 3 answers

As already mentioned [https://support.mozilla.org/fr/questi.../956159#answer-434859] , there remains a problem of sharing cookies between different private windows.

For example (Firefox 20.0.1):

  1. Open a new "clean" window ("Clear recent history..."\"everything").
  2. From the clean window open a first private window (Ctrl+Shift+P).
  3. In the first private window, login in, for example, in a google account.
  4. Return to the "clean" window and open a second private window (Ctrl+Shift+P).
  5. In the second private window go to google.com and you are automatically logged in the same google account than in the first private window.

Of course, I confirm this by checking the HTTP headers (plugin "Live HTTP headers"), and Cookies are actually shared between the two private windows.

If I can not open multiple private windows in different contexts, the feature "Private Browsing Mode per Windows" itself is irrelevant ...

As already mentioned [[https://support.mozilla.org/fr/questions/956159#answer-434859]] , there remains a problem of sharing cookies between different private windows. For example (Firefox 20.0.1): # Open a new "clean" window ("Clear recent history..."\"everything"). # From the clean window open a first private window (Ctrl+Shift+P). # In the first private window, login in, for example, in a google account. # Return to the "clean" window and open a second private window (Ctrl+Shift+P). # In the second private window go to google.com and you are automatically logged in the same google account than in the first private window. Of course, I confirm this by checking the HTTP headers (plugin "Live HTTP headers"), and Cookies are actually shared between the two private windows. If I can not open multiple private windows in different contexts, the feature "Private Browsing Mode '''per Windows'''" itself is irrelevant ...

Modified by netscape01

Ed 82 solutions 595 answers

I've got the same problem in FF 21. For me I think it is caused by Redirect Remover: https://addons.mozilla.org/en-US/firefox/addon/redirect-remover

Once that addon is disabled the history within private browsing is no longer remembered.

I've got the same problem in FF 21. For me I think it is caused by Redirect Remover: https://addons.mozilla.org/en-US/firefox/addon/redirect-remover Once that addon is disabled the history within private browsing is no longer remembered.