Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How can I stop Firefox 's private browsing mode from restricting Netlflix from storing settings on my computer?


I have a Netflix subscription, which is supposed to let me watch movies online, on its website. However, when I selected one of their "Instant Viewing" movies, a page popped up, saying: "Silverlight Application Storage Error -- Firefox's private browsing mode is restricting Netflix from storing settings on your computer. To resolve this problem, perform the following steps: Click the Tools menu at the top of the browser and select Stop Private Browsing " if enabled. There is no such "Tools" tab/menu at the top of my Firefox browser; there's only a drop-down box with various headings, but "Tools" is not among them. How do I fix this thing with Netflix?

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.6 r602
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.6
  • 4.1.10329.0


  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0

More Information

  • Top 25 Contributor
  • Moderator
622 solutions 8022 answers

This will be an old message written before the Firefox button came into common use.

Note there is a further change in Firefox 20, that will provide Private Browsing on a per Window basis, allowing you to use some tabs for Private Browsing, whilst most behave normally and save information. The help (kb) articles should be automatically updated to cover this.

jjcastm 0 solutions 1 answers

to stop private browsing, you mus go to tools click on options. Then go to privacy and undo the box, never remember history and reset fire fox. I hope it works for you jj

  • Top 10 Contributor
  • Moderator
10756 solutions 96800 answers

Plugins that comply to Private Browsing and need local storage won't work properly in PB mode.
This goes for Flash local storage and also for other plugins like Silverlight as you've noticed, so you will have to leave Private Browsing mode in cases like this.