X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Skype says my browser is disabling cookies though it isn't. I have deleted all cookies and cache and disabled AVG temporarily - what to do next?

Posted

I can't login to Skype with my Microsoft account. I think I've tried everything. I have no exceptions for any sites at Tools>Settings>Privacy>History. Using Skype in Windows Safe Mode didn't work either. I think none of my add-ons are affecting this, but you never know, the versions of the add-ons are all old. So should I update all add-ons? Or just switch to Chrome or something? I'd hate to, Firefox has been great until now...

Chosen solution

Hi Folks I had this problem much the same as apparently some of you are having. The combination is Microsoft Messenger, Skype and Mozilla Firefox and signing into your MS account via Skype. The process was for me blocked at third party cookies in my Firefox Browser. That is...not until I asked myself the age old question...What is Microsoft up to... well I think in this case there was no ill will on their part AND it is NOT a Firefox fix...at least for my system. The third party cookie problem was fixed for me...by opening windows 7 control panel - Internet Options - Privacy - Advanced Tab and Accept First Party and Third Party Cookies I checked everything else while I was there just for just. My Skype now works fine with all my friends from Microsoft Messenger Contact list. Go figure, who would have thought it so simple. I do hope this helps at least some who are having the same problem.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape "9.5.4"
  • Google Update
  • Shockwave Flash 11.5 r502
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.5.635
  • 4.1.10329.0
  • GEPlugin
  • CANON iMAGE GATEWAY Album Plugin Utility Module
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

Tyler Downer
  • Administrator
  • Moderator
1165 solutions 6639 answers

Please update to Firefox 19 Päivitä Firefox sen uusimpaan versioon

Then read Websites look wrong or appear differently than they should

Question owner

Thanks a lot, I updated Firefox but unfortunately it didn't fix my problem. I have read a lot of articles here, including the one above, and followed their instructions but few of them have concerned my problem and none of them have really helped me.

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96756 answers

Clear the cache and the cookies from sites that cause problems.

"Clear the Cache":

  • Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Tools > Options > Privacy > Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe mode start window or otherwise make changes.

Question owner

Thanks, but Skype didn't work in Safe Mode, it just kept saying that cookies were disabled. I disabled all plugins, but that didn't work either. I also reset Firefox, but of course, it didn't help me. I wouldn't like to reinstall Firefox cause I'd lose all my bookmarks and so forth... I updated Firefox, but would reinstalling solve my problem? Or should I remove all the cookie files, like cookie.sqlite?

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96756 answers

You can check if DOM Storage is enabled.

Question owner

Thanks again, but the value was true so that didn't cause the problem either.

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96756 answers

You can inspect and manage the permissions for all domains on the about:permissions page.

If clearing cookies doesn't work then it is possible that the cookies.sqlite file that stores the cookies is corrupted.

Rename (or delete) cookies.sqlite (cookies.sqlite.old) and delete other present cookie files like cookies.sqlite-journal in the Firefox Profile Folder in case the file cookies.sqlite got corrupted.

Question owner

Thanks, I deleted all files with names like cookies.sqlite when Firefox was closed. Of course there are now new cookie files, but anyway, Skype isn't working.

I wasn't really sure what to look on the about:permissions, but cookies were enabled on all of the sites listed.

I'll get my new laptop in a few months and I think, and hope, that I won't have any problems with Skype when I'm using it. But it's weird that Skype isn't working on this computer, I feel like I've checked everything...

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96756 answers

Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be careful not to copy corrupted files.

der1 1 solutions 1 answers

Chosen Solution

Hi Folks I had this problem much the same as apparently some of you are having. The combination is Microsoft Messenger, Skype and Mozilla Firefox and signing into your MS account via Skype. The process was for me blocked at third party cookies in my Firefox Browser. That is...not until I asked myself the age old question...What is Microsoft up to... well I think in this case there was no ill will on their part AND it is NOT a Firefox fix...at least for my system. The third party cookie problem was fixed for me...by opening windows 7 control panel - Internet Options - Privacy - Advanced Tab and Accept First Party and Third Party Cookies I checked everything else while I was there just for just. My Skype now works fine with all my friends from Microsoft Messenger Contact list. Go figure, who would have thought it so simple. I do hope this helps at least some who are having the same problem.

Question owner

Hey thanks a lot der1! You really made my day! Skype works perfectly now.