X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox has blocked Facebook on my laptop, what do I do?

Posted

There was a recent update on my system when I shutdown yesterday. When I tried logging into Facebook today, an Unsecured Connection warning popped up. When I clicked on Add Exceptions, the Facebook website was totally blocked on my system.

Additional System Details

Installed Plug-ins

  • np-mswmp
  • Google Update
  • BrowserPlus -- Improve your browser! -- http://browserplus.yahoo.com/
  • Shockwave Flash 10.3 r183
  • iTunes Detector Plug-in
  • Yahoo Application State Plugin version 1.0.0.7
  • Version 1.1.5, copyright 1996-2010 The VideoLAN Teamhttp://www.videolan.org/
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.5"
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:6.0.2) Gecko/20100101 Firefox/6.0.2

More Information

iamjayakumars
  • Top 10 Contributor
412 solutions 4875 answers

Try the Firefox Safe Mode to see how it works there. The Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open the Firefox 4.0+ Safe Mode by holding the Shift key when you use the Firefox desktop or Start menu shortcut.
  • Or use the Help menu item and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Don't select anything right now, just use "'Start in Safe Mode" To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before using the Firefox shortcut (without the Shift key) to open it again. If it is good in the Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one.

Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Helpful Reply

Hi iamjayakumars,

Thank you for your email & suggestion. Unfortunately Facebook remains blocked in Firefox Safe Mode.

I tried restoring my laptop to an earlier date, to no avail. I hate to think I will have to reformat my computer.

Thanks for the effort.

iamjayakumars
  • Top 10 Contributor
412 solutions 4875 answers

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.


Further information can be found in the Reset Firefox – easily fix most problems article.

Did this fix your problems? Please report back to us!

Question owner

There is no Reset Firefox button on the Troubleshooting Information page.

AliceWyman
  • Top 25 Contributor
  • Moderator
190 solutions 1961 answers

The Reset Firefox feature isn't available in your Firefox 6.0.2 version. Firefox 6.0.2 is way outdated and insecure. You should update Firefox to the latest version, which is 17.0.1 - see Update Firefox to the latest version for details.

Your "more system details" shows that you are using a "Browser Plus" plugin, which may be contributing to your problems. If I were you, I would uninstall this software before updating Firefox - see http://browserplus.yahoo.com/support/ for details.

Question owner

Hello AliceWyman,

Thanks for your reply. I've uninstalled Browser Plus & updated to Firefox 17.0.1 & reset my settings. Unfortunately still no joy, Facebook remains blocked. It's really frustrating.

iamjayakumars
  • Top 10 Contributor
412 solutions 4875 answers

Please create a screenshot of the problem you're seeing by following the guide mentioned at How do I create a screenshot of my problem?.

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. This will help us to visualize the problem.

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

rename the cert8.db file in the Firefox profile folder to cert8.db.old or delete the cert8.db file to remove intermediate certificates that Firefox has stored.

If that helped to solve the problem then you can remove the renamed cert8.db.old file. Otherwise you can rename (or copy) the cert8.db.old file to cert8.db to restore the previous intermediate certificates. Firefox will automatically store intermediate certificates when you visit websites that send such a certificate.

If that didn't help then remove or rename secmod.db (secmod.db.old) as well.

Try to disable forcing a secure connection in Facebook.


You can remove a possible cookie exception for www.facebook.com and create an exception for facebook.com instead to include all facebook domains.

You can remove all stored data from a specific domain via "Forget About This Site" in the right-click context menu of an history entry (Show All History or History sidebar) or via the about:permissions page.

Using "Forget About This Site" will remove everything like bookmarks, cookies, passwords, cache, history, and exceptions from that domain, so be cautious and if you have a password or other data from that domain that you do not want to lose then make a note of those passwords and bookmarks. You can't recover from that "forget" unless you have a backup of the affected files.

It doesn't have any lasting effect, so if you revisit such a 'forgotten' website then data from that website will be saved once again.

See also:

You can try to reset (power off/on) the router.

Question owner

Hello iamjayakumars,

Merry Christmas. Attached is the screenshot of the problem I'm encountering.

Helpful Reply

This is the screen shot of the This Connection is Untrusted window. I clicked I Understand the Risk & clicked on Add Exceptions, then it just blocked Facebook.

Question owner

Hello cor-el,

Thank you for your email. I'm not much of a techie, how do I rename the cert8.db file? Likewise, how do I remove secmod.db and go into the Forget About This Site?

Merry Christmas to you.

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96600 answers

Your screenshot shows that you use the OpenDNS service for the connection and that is the problem.
You would probably need to install a root certificate from OpenDNS to make this work.
So you will have to look at their FAQ site or contact them for support about this certificate problem.

rustic.paul 0 solutions 12 answers

I believe the problem is with Java. Ever since updating latest Java, then go to Firefox Tools > Add-Ons > Plugins and you will see latest Java version is having 'compatibility issues'. My FB opens at times but fails to load completely. Actually yesterday Firefox disabled the Java plugin completely, not good!