X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

I haven't been able to run Silverlight to watch Netflix since 11/30/2012

Posted

Running auto updated Firefox 17.0.1 on Windows 7. I used to be able to stream Netflix just fine until late in the evening, 11/30/2012. I tried to stream a movie and Netflix showed a window saying it couldn't due to a problem using Silverlight, code 2103. Netflix suggested I remove and reload Silverlight. I did, twice. I also updated Firefox yesterday, just in case. Still, no joy. I can stream Netflix just fine with Internet Explorer. What gives?

Modified by yzer

Chosen solution

Yes! I cleared everything from only Cache and Cookies. Tested by streaming 30 seconds from two Netflix videos. Everything works fine now. Thanks very much!

Read this answer in context 3

Additional System Details

Installed Plug-ins

  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 11.5 r502
  • Next Generation Java Plug-in 1.6.0_37 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Google Update
  • 5.1.10411.0
  • NPWLPG
  • GEPlugin
  • Version 1.1.11, copyright 1996-2011 The VideoLAN Teamhttp://www.videolan.org/
  • Coupons, Inc. Coupon Printer Plugin
  • Coupons, Inc. Coupon Printer DLL
  • CANON iMAGE GATEWAY Album Plugin Utility Module
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • np-mswmp
  • npRLCT4Player

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/20100101 Firefox/17.0

More Information

My Firefox 17.0.1 shows that it was last modified 11/29/2012.

Jan. 9 solutions 82 answers

Does the problem happen:

Many site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache. Note: This will temporarily log you out of all sites you're logged in to. To clear cache and cookies do the following:


  1. Go to Firefox > History > Clear recent history or (if no Firefox button is shown) go to Tools > Clear recent history.
  2. Under "Time range to clear", select "Everything".
  3. Now, click the arrow next to Details to toggle the Details list active.
  4. From the details list, check Cache and Cookies and uncheck everything else.
  5. Now click the Clear now button.

Further information can be found in the Clear your cache, history and other personal information in Firefox article.

Did this fix your problems? Please report back to us!

Chosen Solution

Yes! I cleared everything from only Cache and Cookies. Tested by streaming 30 seconds from two Netflix videos. Everything works fine now. Thanks very much!

Lowieee 0 solutions 8 answers

I had this problem Netflix too. Here's a sure fix for MAC users:

  1. Access your hard drive (double click the hard drive icon in finder)
  2. Find the silverlight plugin (navigate to your Internet Plug-Ins directory: /Library/Internet Plug-Ins/)
  3. Remove the silverlight plugin (drag any of the following into your trash bin:
      * Silverlight.plugin 
      * WPFe.plugin
  1. Empty your trash bin
  2. Go to www.microsoft.com/getsilverlight/ using your Firefox browser.
  3. Download and install silverlight
  4. Restart Firefox

This removes a bad install of Silverlight and starts fresh. Definitely works!

vkmcgee2 0 solutions 1 answers

OK, I hope this works for you because it just worked for me. Go to tools, options, security and click on remember history. I did that and restarted my computer, logged into Netflix and now it's working, hooray! I hope it works for you.

mbrady1960 0 solutions 4 answers

I am using Windows 7 64bit Ultimate and for some reason I had a problem that I have seen many people on here was having and was blaming Firefox's Plugin Container when watching Netflix or anything using Microsoft's Silverlight. But it isn't the Container that is causing the "Silverlight Plugin Has Crashed" problem. I just talked to Microsoft about it and found the solution on fixing it. The problem is the Computer Browser.

You go to "run", then type in "SERVICES.MSC" when that pops up scroll down to "Computer Browser" highlight it then in the left hand side at the top you will see "Restart the service". That's it. Restart computer. Now Firefox will play Silverlight.

I have read so many posts about this with people coming up with all sorts of things to try to fix this, but none has worked....for me anyway.

So do this and I'm sure you'll be happy again.