X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Javascript won't work on a website

Posted

I always could view my paycheck stubs online, but now the javascript won't open a new window for me to login to do that. I restarted Firefox, tried safe mode, cleared caches, updated firefox, unistalled and reinstalled java, and ran my ccleaner. What gives?

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 10.9.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.5 r502
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • iTunes Detector Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • 5.1.10411.0
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.3
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Plays games at king.com
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:17.0) Gecko/20100101 Firefox/17.0

More Information

Jan. 9 solutions 82 answers
  • Does the problem happen in a new profile?
  • Does the problem happen when security software is temporarily disabled?
  • Does the problem happen in IE as well?
DarrenG 0 solutions 3 answers

I have the same problem with winXPSP3 and Firefox 18.0.2

Here is an example of problem page: http://club.dx.com/reviews/photos/46136/add

the BROWSE button after "select image" returns javascript:void(0);

The problem persists with safe mode and a new profile. It works fine with Chrome Version 24.0.1312.57 and IE version 8.0.6001.18702.

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96757 answers

Quote: the BROWSE button after "select image" returns javascript:void(0);

The javascript:void(0) link text is a placeholder and there should be an onclick event attached to that button to open the file picker window to select a file, so make sure that you aren't blocking JavaScript

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe mode start window or otherwise make changes.
DarrenG 0 solutions 3 answers

As I stated in my post, I have already tried both safe mode and creating a new profile.

DarrenG 0 solutions 3 answers

I'm on my other computer using firefox 17.0.1 for ubuntu linux and have repeated the same problem. Also downloaded the latest firefox 19.0 on my windows xp machine and the problem is still there in that version as well

johnbulll 0 solutions 2 answers

JavaScript does not work on some webpages ( Opera and IE-9 work OK at the same pages). Example: http://rabota.yandex.ru/ try to click at "Регион: Санкт-Петербург" (changing region) - at upper right; a pop-up window will appear ( to change the region) but after specifying the new city - clicking OK give no effect. In Opera and IE-9 putting the city name causes database working and drop down menu is appear - but in Firefox 19.0 - none. WHY? It is only one example - the same Firefox behavior is noticed in very many web-sites. Fix this bug asap!

cor-el
  • Top 10 Contributor
  • Moderator
10751 solutions 96757 answers

Work here.
If I paste Санкт-Петербург in the input field then a drop down list with two entries appears.

Reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • Press and hold Shift and left-click the Reload button.
  • Press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • Press "Command + Shift + R" (MAC)

Clear the cache and the cookies from sites that cause problems.

"Clear the Cache":

  • Tools > Options > Advanced > Network > Cached Web Content: "Clear Now"

"Remove Cookies" from sites causing problems:

  • Tools > Options > Privacy > Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe mode start window or otherwise make changes.
johnbulll 0 solutions 2 answers

Hi cor-el!

   None of the measures listed by you helped.

Helped Firefox RESETTING (in safe mode window). After firefox resetting http://rabota.yandex.ru appeared to work ok. I guess, there were some faulty add-ons in my firefox. Now NO add-ons included and all works ok.