Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Tab Add-ons Affecting Middle Click

  • 4 replies
  • 2 have this problem
  • Last reply by tjdean01

more options

Earlier today I was fine with Firefox 4 and an older version of Tabmix Plus. All I can remember doing besides checking email, etc., is updating AVG virus definitions. But, suddenly, the middle click stopped working to open links in new tabs (I do not thing AVG did this. I update definitions all the time). It works when I want scroll with it and I see the little up/down arrow thingy, but no clicking, not even from one of my bookmarks. Ctrl + right click doesn't open tabs anymore either.

Disable TabMix Plus, however, and it works fine! Download newest version of TabMix Plus and it doesn't work. I've installed and uninstalled at least 5 versions from different time periods and it blocks my middle click ability each time. I've restarted, disabled AVG, tried this, tried that, searched online, everything.

Next, I downloaded the newest Firefox (FF12) and had the same problem. I found a TabMix alternative, Tab Utilities 1.2, yet the issue persists.

I have NO other add-ons enabled. I've never had GreaseMonkey, but today I downloaded an update GreaseMonkey had to try to fix TabMix (GM 0.9.11) but still nothing. And it's working perfectly right now, but that's because I don't have a tab manager enabled. Help!

All Replies (4)

more options

First, you aren't on the newest version of Firefox, the newest version is Firefox 17. The best thing you can do is the following:

Disable TabMix Plus How to disable or remove extensions

Update Firefox to 17.0 Update Firefox to the latest release

Then contact the developers of TabMix Plus and wait for them to release an update.

more options

Nope, none of that worked. You see, it isn't a specific version of FF or TabMix because I've tried several version in combination with each other and I've also tried Tab Utilities 1.2. I'm thinking it has something to do with settings on my computer. I've tried a complete install and uninstall, however, and still no luck.

more options

Have you updated to 17 (it's important to be on the latest release regardless for security reasons).

Try to Reset Firefox as well. Refresh Firefox - reset add-ons and settings

more options

Summary: complete uninstall and reinstall of newest version fixed the problem.

When I clicked "help" and "about Firefox" yesterday and checked for updates, it told me FF12 was the newest and it automatically downloaded it. I didn't know the current version was 17 now (wasn't it just this year I installed 4?).

Anyway, I installed FF17 and it STILL didn't work with any tab manager I added on. So, I completely uninstalled the program and reinstalled it and now it works. So a complete uninstall and reinstall did the trick. Kind of pain though because of all modifications to the toolbars I do, but I think it's about set now. Thanks!