X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox recently stopped letting me middle-click on a link to open it in a new tab.

Posted

Within the last week, Firefox stopped letting me middle-click on a link to open it in a new (background) tab. I've found that there were problems like this with older versions of Firefox, but I have version 14.0.1. I do NOT have Greasemonkey, which apparently was a common cause of this problem. I DO have Tab Mix Plus, and I've uninstalled and reinstalled it, but it didn't fix the problem.

Also, right-clicking on a link and selecting "open link in new tab" doesn't work, but right-clicking on a link and selecting "open link in foreground tab" opens the link in a new (foreground) tab.

This is infuriating because I middle-click on links ALL the time. Please help! :(

Modified by MattUtah

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.3 r300
  • Google Update
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • iTunes Detector Plug-in
  • GEPlugin
  • Pando Web Plugin
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • DLM Netscape Plugin (2.3.10.115)
  • npmnqmp 989898989877
  • My Web Search Plugin Stub for 32-bit Windows
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • Adobe PDF Plug-In For Firefox and Netscape
  • NPWLPG
  • 2.0.31005.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; WOW64; rv:14.0) Gecko/20100101 Firefox/14.0.1

More Information

187TripleOG 1 solutions 8 answers

Helpful Reply

This worked as a solution previously

Under Tabs mix plus

   1 Open the TMP options dialog
   2 Click on "Events" at the top of the dialog
   3 Click on the "Tab Opening" tab
   4 Select "Middle-click or Control-click opens items in current tab"
   5 Unselect "Middle-click or Control-click opens items in current tab"
   6vAt the bottom of the dialog, under the "Inverse Middle-click or Control-click focus of:" section, select "Links"
   7 Click the Apply button
   8 Click the Close button
   9 Middle-click on a link -- it will now open in a new tab
   10 Go back into the TMP options to the same place, unselect the "Links" option that you previously selected in step #6, then Apply and Close.
   11 Middle-click on a link -- it opens in a new tab

Question owner

It didn't work :(

FoxChaser 0 solutions 3 answers

I clicked that this was helpful but it is not the complete solution. The first time I tried to open a link after doing this sequence the link opened in another background tab as correct behavior. However, subsequent attempts all failed - no response at all. When I double middle clicked these same links they open in a new foreground tab.

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

Start Firefox in Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes).

Question owner

Okay, it looks like there's some kind of incompatibility between Firefox 14.0 and Tab Mix Plus; I got rid of TMP and my middle-clicking problem is fixed. Thanks for your help.

Unfortunately, without TMP, my tabs are at the top of the window instead of the bottom, but that's a whole NEW problem....I'll start a new thread for that one....

Modified by MattUtah

cor-el
  • Top 10 Contributor
  • Moderator
10753 solutions 96760 answers

You can try the latest TMP dev build to see if the issue is already solved.

Problems with TMP are best taken to the TMP forum.