X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Font is messed up on Firefox 17.0

Posted

Just updated to FF17.0 and the fonts look awful, something like when the ClearType is enabled in Windows. I have ClearType disabled cause I hate the look of the fonts with it enabled, and now Firefox looks like it's all over it. Font is like bolded. What happened? Can I disable it somewhere in Firefox?

Chosen solution

Hey guys! Thanks to everyone who helped us in troubleshooting this. We are fairly certain it's an azure problem. There is a patch in the works and setting gfx.content.azure.enabled = False seems to work in the meantime. I don't know if the patch will be part of a chemspill or wait until 18. Thanks for your help and patience.

Happy Thanksgiving!

Read this answer in context 17

Additional System Details

This happened

Every time Firefox opened

This started when...

I updated to Firefox 17.0

Installed Plug-ins

  • 2.1.2
  • Next Generation Java Plug-in 10.7.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.2 r202
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.7.637
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • 5.1.10411.0
  • 0.70.4
  • np-mswmp

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0

More Information

Informacje o aplikacji
Nazwa
Firefox
Wersja
17.0
Identyfikator programu
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:17.0) Gecko/17.0 Firefox/17.0
Folder profilu
Pokaż folder
Włączone wtyczki
about:plugins
Konfiguracja kompilacji
about:buildconfig
Zgłoszenia awarii
about:crashes
Zużycie pamięci
about:memory
Rozszerzenia
Nazwa
Wersja
Włączone
ID
Adblock Plus
2.1.2
true
{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
British English Dictionary
1.19.1
true
en-GB@dictionaries.addons.mozilla.org
ColorfulTabs
17.1
true
{0545b830-f0aa-4d7e-8820-50a4629a56fe}
Download Statusbar
0.9.10
true
{D4DD63FA-01E4-46a7-B6B1-EDAB7D6AD389}
Ważne zmodyfikowane ustawienia
Nazwa
Wartość
accessibility.typeaheadfind.flashBar
0
browser.cache.disk.capacity
524288
browser.cache.disk.smart_size.enabled
false
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size_cached_value
1048576
browser.display.background_color
#C0C0C0
browser.display.use_system_colors
true
browser.history_expire_days.mirror
2
browser.history_expire_days_min
2
browser.places.importBookmarksHTML
false
browser.places.importDefaults
false
browser.places.leftPaneFolderId
-1
browser.places.migratePostDataAnnotations
false
browser.places.smartBookmarksVersion
4
browser.places.updateRecentTagsUri
false
browser.privatebrowsing.dont_prompt_on_enter
true
browser.search.useDBForOrder
true
browser.sessionstore.restore_on_demand
false
browser.startup.homepage
http://www.onet.pl/
browser.startup.homepage_override.buildID
20121119183901
browser.startup.homepage_override.mstone
17.0
browser.tabs.loadInBackground
false
extensions.lastAppVersion
17.0
font.internaluseonly.changed
false
gfx.direct3d.prefer_10_1
true
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1353270609
places.history.expiration.transient_current_max_pages
104858
places.history.expiration.transient_optimal_database_size
167772160
places.last_vacuum
1296324654
plugin.disable_full_page_plugin_for_types
print.print_printer
Microsoft XPS Document Writer
print.printer_HP_LaserJet_1022.print_bgcolor
false
print.printer_HP_LaserJet_1022.print_bgimages
false
print.printer_HP_LaserJet_1022.print_command
print.printer_HP_LaserJet_1022.print_downloadfonts
false
print.printer_HP_LaserJet_1022.print_edge_bottom
0
print.printer_HP_LaserJet_1022.print_edge_left
0
print.printer_HP_LaserJet_1022.print_edge_right
0
print.printer_HP_LaserJet_1022.print_edge_top
0
print.printer_HP_LaserJet_1022.print_evenpages
true
print.printer_HP_LaserJet_1022.print_footercenter
print.printer_HP_LaserJet_1022.print_footerleft
&PT
print.printer_HP_LaserJet_1022.print_footerright
&D
print.printer_HP_LaserJet_1022.print_headercenter
print.printer_HP_LaserJet_1022.print_headerleft
&T
print.printer_HP_LaserJet_1022.print_headerright
&U
print.printer_HP_LaserJet_1022.print_in_color
true
print.printer_HP_LaserJet_1022.print_margin_bottom
0.5
print.printer_HP_LaserJet_1022.print_margin_left
0.5
print.printer_HP_LaserJet_1022.print_margin_right
0.5
print.printer_HP_LaserJet_1022.print_margin_top
0.5
print.printer_HP_LaserJet_1022.print_oddpages
true
print.printer_HP_LaserJet_1022.print_orientation
0
print.printer_HP_LaserJet_1022.print_pagedelay
500
print.printer_HP_LaserJet_1022.print_paper_data
9
print.printer_HP_LaserJet_1022.print_paper_height
11,00
print.printer_HP_LaserJet_1022.print_paper_size_type
0
print.printer_HP_LaserJet_1022.print_paper_size_unit
1
print.printer_HP_LaserJet_1022.print_paper_width
8,50
print.printer_HP_LaserJet_1022.print_reversed
false
print.printer_HP_LaserJet_1022.print_scaling
0,50
print.printer_HP_LaserJet_1022.print_shrink_to_fit
true
print.printer_HP_LaserJet_1022.print_to_file
false
print.printer_HP_LaserJet_1022.print_unwriteable_margin_bottom
0
print.printer_HP_LaserJet_1022.print_unwriteable_margin_left
0
print.printer_HP_LaserJet_1022.print_unwriteable_margin_right
0
print.printer_HP_LaserJet_1022.print_unwriteable_margin_top
0
print.printer_Microsoft_XPS_Document_Writer.print_bgcolor
false
print.printer_Microsoft_XPS_Document_Writer.print_bgimages
false
print.printer_Microsoft_XPS_Document_Writer.print_command
print.printer_Microsoft_XPS_Document_Writer.print_downloadfonts
false
print.printer_Microsoft_XPS_Document_Writer.print_edge_bottom
0
print.printer_Microsoft_XPS_Document_Writer.print_edge_left
0
print.printer_Microsoft_XPS_Document_Writer.print_edge_right
0
print.printer_Microsoft_XPS_Document_Writer.print_edge_top
0
print.printer_Microsoft_XPS_Document_Writer.print_evenpages
true
print.printer_Microsoft_XPS_Document_Writer.print_footercenter
print.printer_Microsoft_XPS_Document_Writer.print_footerleft
&PT
print.printer_Microsoft_XPS_Document_Writer.print_footerright
&D
print.printer_Microsoft_XPS_Document_Writer.print_headercenter
print.printer_Microsoft_XPS_Document_Writer.print_headerleft
&T
print.printer_Microsoft_XPS_Document_Writer.print_headerright
&U
print.printer_Microsoft_XPS_Document_Writer.print_in_color
true
print.printer_Microsoft_XPS_Document_Writer.print_margin_bottom
0.5
print.printer_Microsoft_XPS_Document_Writer.print_margin_left
0.5
print.printer_Microsoft_XPS_Document_Writer.print_margin_right
0.5
print.printer_Microsoft_XPS_Document_Writer.print_margin_top
0.5
print.printer_Microsoft_XPS_Document_Writer.print_oddpages
true
print.printer_Microsoft_XPS_Document_Writer.print_orientation
0
print.printer_Microsoft_XPS_Document_Writer.print_page_delay
50
print.printer_Microsoft_XPS_Document_Writer.print_paper_data
9
print.printer_Microsoft_XPS_Document_Writer.print_paper_height
11,00
print.printer_Microsoft_XPS_Document_Writer.print_paper_size_type
0
print.printer_Microsoft_XPS_Document_Writer.print_paper_size_unit
1
print.printer_Microsoft_XPS_Document_Writer.print_paper_width
8,50
print.printer_Microsoft_XPS_Document_Writer.print_reversed
false
print.printer_Microsoft_XPS_Document_Writer.print_scaling
1,00
print.printer_Microsoft_XPS_Document_Writer.print_shrink_to_fit
true
print.printer_Microsoft_XPS_Document_Writer.print_to_file
false
print.printer_Microsoft_XPS_Document_Writer.print_unwriteable_margin_bottom
0
print.printer_Microsoft_XPS_Document_Writer.print_unwriteable_margin_left
0
print.printer_Microsoft_XPS_Document_Writer.print_unwriteable_margin_right
0
print.printer_Microsoft_XPS_Document_Writer.print_unwriteable_margin_top
0
privacy.clearOnShutdown.cookies
false
privacy.clearOnShutdown.downloads
false
privacy.clearOnShutdown.formdata
false
privacy.clearOnShutdown.history
false
privacy.clearOnShutdown.offlineApps
true
privacy.cpd.cookies
false
privacy.cpd.sessions
false
privacy.donottrackheader.enabled
true
privacy.item.downloads
false
privacy.item.formdata
false
privacy.item.history
false
privacy.item.offlineApps
true
privacy.item.sessions
false
privacy.sanitize.migrateFx3Prefs
true
privacy.sanitize.timeSpan
0
security.OCSP.disable_button.managecrl
false
security.disable_button.openCertManager
false
security.disable_button.openDeviceManager
false
security.warn_viewing_mixed
false
security.warn_viewing_mixed.show_once
false
Grafika
Opis adaptera
NVIDIA GeForce GTX 560 Ti
ID dostawcy
0x10de
ID urządzenia
0x1200
RAM adaptera
1023
Sterowniki adaptera
nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Wersja sterownika
9.18.13.697
Data sterownika
10-2-2012
Włączone Direct2D
true
Włączone DirectWrite
true (6.1.7601.17789)
Parametry ClearType
Gamma: 2200 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 50
Renderer WebGL
Google Inc. -- ANGLE (NVIDIA GeForce GTX 560 Ti ) -- OpenGL ES 2.0 (ANGLE 1.0.0.1242)
Okna ze sprzętowym przyspieszeniem grafiki
1/1 Direct3D 10
AzureCanvasBackend
direct2d
AzureFallbackCanvasBackend
cairo
AzureContentBackend
direct2d
JavaScript
Przyrostowy GC
1
Ułatwienia dostępu
Aktywne
0
Zablokuj ułatwienia dostępu
0
Wersje bibliotek
Oczekiwana wersja minimalna
Wersja w użyciu
NSPR
4.9.2
4.9.2
NSS
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS Util
3.13.6.0
3.13.6.0
NSS SSL
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS S/MIME
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC

Question owner

Here are two screenshots to compare:

FF16: http://i46.tinypic.com/qmxkq8.png

FF17: http://i50.tinypic.com/2qkm9up.png

Nothing has changed in my settings either in Windows or in Firefox. Just simple update from 16.0.2 to 17.0.

Notice how awful the word "mozilla" looks in address bar.

vertex11 0 solutions 1 answers

Exactly the same problem. Can't find the option to turn off FF messing with fonts.

forhike 0 solutions 11 answers

Helpful Reply

I noticed if I turn off the hardware acceleration in tools-options-advanced the fonts goes back to ordinary....but I shouldn't have to turn it off, I have a good graphic card so I want to have this options on

Modified by forhike

Question owner

Well disabling HW accel. helps, but only partially. Firefox itself looks good, but fonts on certain sites now looks even more unreadable for me than before.

Modified by guniu

forhike 0 solutions 11 answers

I have no problems with the fonts within the web sites, it looks as good as it did with FF 16.0.2 but I hope there is a solution because it looks terrible with the Hw enabled

Question owner

It's actually just one site with custom font that I'm on that looks bad. All other sites look like they should.

forhike 0 solutions 11 answers

I went back to 16.0.2...couldn't stand it :(

cor-el
  • Top 10 Contributor
  • Moderator
10746 solutions 96695 answers

Note that on the Windows platform such issues on a web page can also be caused by Firefox placing all members of a font family in one group and selecting a member in that group based on CSS font rules.

You can use this extension to see which fonts are used for text that is selected (right-click context menu: Show fonts in selection).

You can do a font test to see if you can identify corrupted font(s).

forhike 0 solutions 11 answers

My big issue is that firefox fonts on menu, bookmark toolbar etc looks really bad not on the sites. It looks all compact, blurry and thick. As guniu explained it looks like clear type is enabled...

I have disabled all plugins and extensions even reinstalled graphic drivers but the only thing that helps is to disable the HW acc so I went back to ff 16 for now,

Modified by forhike

Sugioh 0 solutions 3 answers

This is a big usability issue for me, since I do a great deal of reading in firefox and hardware acceleration resulting in blurry text makes reading for more than a few minutes induce a very high level of eye strain.

Of course, turning off hardware acceleration is a temporary workaround, but it is far from ideal.

cor-el
  • Top 10 Contributor
  • Moderator
10746 solutions 96695 answers

Note that using hardware acceleration means that Firefox uses the GPU instead of the CPU to do some (image) manipulations and that you may not notice any effect in Firefox if you disable hardware acceleration. If the GPU is used then specific operations like scrolling and font rendering that are performed internally by the graphics display driver can take more time (the GPU needs to do more if HA is enabled) and thus the graphics display card can respond less smoothly. There shouldn't be any reason to revert to an older Firefox version because of issues with hardware acceleration that can be fixed by disabling this feature.

See also:

Sugioh 0 solutions 3 answers

But Cor-el, this is an issue that was introduced specifically in this update and did not exist with HW rendering prior, so that isn't really relevant here.

Question owner

Why you moderators always respond like bots. Just read what we wrote, compare the screenshots I posted. There is something with font rendering in FF 17.0 that has changed since last version. And it looks like crap now.

Modified by guniu

ad_verbum 1 solutions 9 answers

Maybe source of this problem is hidden in this bug fix - https://bugzilla.mozilla.org/show_bug.cgi?id=777089

Ultro 0 solutions 2 answers

I have this problem too. Hate cleartype, so went back to FF 16.02. I think it's major issue that need to be fixed asap. Also noticed that FF safe mode don't have this problem. All this on Radeon 6950 with latest official drivers for Windows 7 SP1 64bit

ratsalad 0 solutions 3 answers

I too, have this problem, wasn't like it prior to the 17 update, I even went to extreme lengths of removing all add-ons and even reset FF back to default the result is the same, fonts look like cleartype is enabled - like others cleartype looks bad on my system. The fonts are as they should be if starting in safe mode or deselecting hardware acceleration.

For now I've turned off hardware acceleration, but I shouldn't have to.

Spiralgalaxy5 0 solutions 3 answers

Huge sense of disappointment when I upgraded to FF17 and this happened. It affected the Win7 PC I use at work but did not affect the XP SP3 PC at home - why would this be? I use "Classic" theme on the work PC and do not have Cleartype (aka. Fuzzytype) enabled.

Hoping someone will post a fix here - have bookmarked this topic for now!

Spiralgalaxy5 0 solutions 3 answers

I used the trick of unticking the hardware acceleration option for now - seems to do the trick. Am I fighting a losing battle in my preference for pin-sharp font rendering? We had to update to Office 2010 here recently and I spent time changing back from fonts like "Segoe" to something that didn't blur the edges...  :-(

I reckon people with poor eyesight probably prefer "Cleartype" rendering because it "bulks out" the characters. I try to focus on the unresolvable blur it generates and get a headache! I understand the rationale for "Cleartype" but it's not for me. PC power these days should mean everything is easily and quickly customisable to individual preference, IMO.

matthew_eli 0 solutions 4 answers

I have this problem too guys. I noticed this problem wouldn't happen in Win 7 and for me only on Win 8: could you confirm that?

Modified by matthew_eli

a587626 0 solutions 1 answers

Helpful Reply

On about:config, changing gfx.direct2d.disabled to true, resolve the problem.

Modified by a587626