X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox Tab Height under Windows 8 is double sized.

Posted

The Tab on my browser is double sized under Windows 8. I have already searched the forums for a solution and none worked.

Already tried: 1. Safe mode 2. Create new Profile 3. Reinstalled with NO extensions 4. Cleaned out everything entry in appdata/programdata/registry

After everything double sized tab persists.

So I am led to believe that this is some new setting for Firefox where it detects an unknown 'Tablet' mode and sets the default theme as having double sized tabs. -- And just FYI -- I am NOT using a touchscreen. So whatever it is detecting, it is faulty. If you are going to put this in as an option, please add an option to DISABLE it.

When I change to another theme, such as Mx3, it does fix the double sized.

Additional System Details

This happened

Every time Firefox opened

This started when...

Updated to the latest Synaptics TouchPad drivers.

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • A plugin to detect whether the Adobe Extension Manager is installed on this machine.
  • Next Generation Java Plug-in 10.9.2 for Mozilla browsers
  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Google Update
  • iTunes Detector Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • Sony Reader Application Detector Plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • 5.1.10411.0
  • Pando Web Plugin
  • Garmin Communicator Plug-In 4.0.1.0
  • AmazonMP3DownloaderPlugin 1.0.15
  • 1.96.0
  • 0.70.3
  • wpidetector
  • Windows Activation Technologies Plugin for Mozilla
  • IE Tab 2 Plug-in for Mozilla/Firefox
  • Detector for the Onlive Game Client
  • Enables the interaction of Mathematica content with the latest installed version of Mathematica.
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • 6.0.12.448
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/20100101 Firefox/16.0

More Information

Already tried:
1. Safe mode
2. Create new Profile
3. Reinstalled with NO extensions
4. Cleaned out everything entry in appdata/programdata/registry

iamjayakumars
  • Top 10 Contributor
412 solutions 4877 answers

Sorry, i'm linux user, please provide the snapshot of that.

damianh 0 solutions 5 answers

Am experiencing same problem on Win 8 latoptop (non-touch), both with installed version of FF (16.0.2) and the PortableApps version. Went through everything the OP did and nothing worked.

Screen shot: http://twitter.yfrog.com/h8qixwp

the-edmeister
  • Top 10 Contributor
  • Moderator
3195 solutions 24387 answers

Try the Firefox SafeMode to see how it works there.
A troubleshooting mode, which disables most Add-ons.
Troubleshoot Firefox issues using Firefox SafeMode

When in Safe Mode...

  • The status of plug-ins is not affected.
  • Custom preferences are not affected.
  • All extensions are disabled.
  • The default theme is used, without a persona.
  • userChrome.css and userContent.css are ignored.
  • The default toolbar layout is used.
  • The JIT Javascript compiler is disabled.
  • Hardware acceleration is disabled.


  • You can open the Firefox 15.0+ SafeMode by holding the Shft key when you use the Firefox desktop or Start menu shortcut.
  • Or use the Help menu item, click on Restart with Add-ons Disabled... while Firefox is running.


To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before using the Firefox shortcut (without the Shft key) to open it again.


If it is good in the Firefox SafeMode, your problem is probably caused by an extension, and you need to figure out which one.
http://support.mozilla.com/en-US/kb/troubleshooting+extensions+and+themes

When you figure out what is causing that, please let us know. It might help other user's who have that problem.

damianh 0 solutions 5 answers

Thanks for the stock response @the-edmister but I have to ask, did you actually read any of the posts?

Question owner

I also tried modifying userChrome.css for height -- to no avail.

RE: Safe mode did not work, here is a screenshot.

Screenshot

cor-el
  • Top 10 Contributor
  • Moderator
10740 solutions 96657 answers

Does it have any effect if you disable the favicons as a test?

Try to set these prefs to false on the about:config page.

  • browser.chrome.favicons
  • browser.chrome.site_icons
zoao 0 solutions 2 answers

To solve this problem, go to your profile folder, ex: "C:\Users\[USERNAME]\AppData\Roaming\Mozilla\Firefox\Profiles\[RANDOM STRING].default", create the folder "Chrome" and inside create the file "userChrome.css" with this content:


@namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul);

.tabbrowser-tabs *|tab {

   height:    30px !important;

}


ardofy 0 solutions 4 answers

I'm experiencing the same issue. I started with a clean profile; I removed the whole appdata/roaming/mozilla directory. Under windows 8 the tabs are double height and the icons on the tab bar (for example, the open new tab '+' icon) are double width.

I have access to 2 computers with win8 and this issue only occurs on one of them.

I've tried the test with firefox 17.0 and with the latest nightly, and I get the same results (large tabs) only on the one pc.

I also tried zoao's userChrome.css fix. That also didn't work.

setting:

   browser.chrome.favicons
   browser.chrome.site_icons 

to false also does not work.

I tried Fdiio's suggestion and changed the theme to Mx3, and that fixed things for me also.

any other suggestions to get this working correctly?

Modified by ardofy

ardofy 0 solutions 4 answers

Update, I've tried using another theme 'fxChrome' and the tab height issue doesn't appear. The default theme or with a personas demostrates the issue.

What's strange is that is doesn't appear on every win8 machine.

cor-el
  • Top 10 Contributor
  • Moderator
10740 solutions 96657 answers

What are the DPI settings of both computers?

Are the screen dimensions of the monitor and the Windows theme the same?

damianh 0 solutions 5 answers

Changing browser.chrome.favicons browser.chrome.site_icons settings did not work.

userChrome.css 30px suggestion did not work.

Changing theme to fxChrome / mx3 did work.

damianh 0 solutions 5 answers

Ok couple of interesting things happened. I RDP'd into 2 other computer to verify DPI settings, computer that weren't experiencing this issue and when I launch firefox, this double hight issue occured on those machines. This suggests to me that it's a windows setting.

Checking my DPI settings (Control Panel\All Control Panel Items\Display), under 'Change only the text size' I have Palette titles set to size 9. Resetting this back to 11 (windows 8 default setting), logging off/on, appears to have fixed the problem. http://imgur.com/JXCgl

Changing the Palette titles back to 9 and restarting firefox (without logging off/on) and the issue returned http://imgur.com/nAVSN

Changing the Palette titles back to 11 continued to display the issue until I logged off/on

Question owner

userChrome will not affect it. Seems like Firefox is triggered to double size the tabs if it detects touch interface - see attachment.

Whereas touch interface is is artificially simulated by the latest Synaptics TouchPad drivers for Windows 8, causing the double sized tabs. Nothing I've tried so far have fixed it, userChrome, about:config, uninstalling, safe mode, except for installing a forced standard sized theme.

Mozilla really need to add an option in to toggle this instead of having it be automatic with no option to turn it off. I was able to repeat problem by removing the drivers completely, then Firefox turned normal, when I reinstalled the Synaptics drivers, it turned double sized again.

Edit: My DPI settings is at 100%

Modified by Fdiio

ardofy 0 solutions 4 answers

Helpful Reply

It does look like this issue is related to the touch interface. For me, the PC that has a touch screen displays larger tabs etc. The PC without displays normal tabs.

This must be a feature as you might want larger tabs/icons to tap using a touch interface. I agree it would be nice to have the ability to disable this.

Modified by ardofy

phillnet 0 solutions 1 answers

Same goes for the new Logitech t620 mouse and its drivers. Please provide an option to turn this off.

bradavon 0 solutions 9 answers

I had the same problem with Synaptics drivers on Windows 8 with a non-touchscreen laptop.

I've discovered they activate the touch element in Windows and it's this causing the problem.

The height trick in userChrome.css let me increase the tab height but not decrease it (I tried 30, 10, 1).

Opening Services I noticed the "Touch Keyboard and Handwriting Panel Service" was running and set to Automatic. I changed it to Disabled, reset my laptop and problem fixed.

System Properties did say I had a Pen or Touch Input (same as "Fdiio" above) but it now says "No Pen or Touch Input is available" again.

urbanalloy 0 solutions 2 answers

I found a solution to this problem without messing with settings in windows:

in about:config set gestures.enable_single_finger_input to false

This fixed the problem for me; tabs are back to normal and sites no longer direct me to tablet sites on occasion

bradavon 0 solutions 9 answers

Interesting, thanks.

I can find very little about this gesture, just this really:

http://forums.mozillazine.org/viewtopic.php?f=3&t=1568455

It's very old but the three post has a link which says they're for Mac. I wonder if they're supported on Windows too?

Windows/Windows laptops have trackpads that support gestures now too.

They don't seem to work for me.

I imagine that is precisely the Firefox config setting causing the trouble. I've got around it another way by telling Firefox I don't have touch support by disabling it in Windows.

ardofy 0 solutions 4 answers

Thanks urbanalloy,

But setting gestures.enable_single_finger_input to false had no effect for me. I have win8 with a touchscreen.

I'm surprised that there's not a solution to this yet as win8 has been out for 4 months, I would have thought this would have come up with others.

1) Do any of the developers know why the tabs are larger?

2) Can they reference a setting to disable this?

Thanks.

damianh 0 solutions 5 answers

@bradavon's solution, disabling the "Touch Keyboard and Handwriting Panel Service" worked for me.

I have recently updated my synaptic drivers (v 8.x) and just to see, I re-enabled this service and the issue didn't show.

Unfortunately the new synaptic drivers have a new edge swipe feature that shows the charms menu. Here is how to disable it: http://blogs.msdn.com/b/scicoria/archive/2013/01/29/disable-swipe-on-synaptics-touchpad-in-windows-8.aspx