X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Videos on youtube are choppy and skippy, yet this only happens on firefox, other browsers work fine..

Posted

I started my computer this morning and everything seemed normal, yet once I got on youtube, every video i tried to watch wouldn't play properly, even though yesterday things were fine, and I've never encountered this problem before.. I hadn't updated, installed or otherwise changed anything between the two days and everything else works just fine.. Whenever i start a video the sound chops up and skips/lags like it can't keep up.. It's hard to describe.. Kinda like if one listens to a CD with lots of scratches... I initially assumed that it was a Flash Player issue.. But after updating both Flash Player and Firefox to the latest versions the problem still persists.. I now assume it is a Firefox issue, as I have tried viewing the videos in other browsers, and they play just fine.. I have no idea what is causing it.. And I would appreciate any help or solutions you could give me.. I'm also not that big of a computer expert, so please forgive me for anything seemingly obvious I might have overlooked.. Thanks in advance..

Chosen solution

I know this is a couple months old but one thing I noticed trying to deal with this problem. Youtube is automatically having certain users using certain browsers use HTML5 videos.

Next time you get that choppy video, right click it, and click on "About HTML5"

It will tell you that youtube has automatically enrolled you in their beta testing and to opt out you click the link on the bottom to stop seeing HTML5 videos.

I hope this helps you, it helped me.

Read this answer in context 4

Additional System Details

This happened

Every time Firefox opened

This started when...

I turned on my computer this morning..

Installed Plug-ins

  • Shockwave Flash 11.4 r402
  • Google Update
  • VLC media player Web Plugin 2.0.2
  • 5.1.10411.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.1.629
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • np-mswmp
  • Adobe PDF Plug-In For Firefox and Netscape

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:16.0) Gecko/20100101 Firefox/16.0

More Information

Application Basics
Name
Firefox
Version
16.0.2
User Agent
Mozilla/5.0 (Windows NT 6.0; rv:16.0) Gecko/20100101 Firefox/16.0
Profile Folder
Show Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Crash Reports
about:crashes
Memory Use
about:memory
Extensions
Name
Version
Enabled
ID
CodecC
1.0
true
info@allpremiumplay.info
Greasemonkey
1.4
true
{e4a8a97b-f2ed-450b-b12d-ee082ba24781}
NoScript
2.5.9
true
{73a6fe31-595d-460b-a920-fcc0f8843232}
Save Session
1.3.1.6
true
savesession@noasobi.net
Conduit Engine
3.3.3.2
false
engine@conduit.com
DivX HiQ
2.1.0.900
false
{6904342A-8307-11DF-A508-4AE2DFD72085}
DivX Plus Web Player HTML5 <video>
2.1.0.900
false
{23fcfd51-4958-4f00-80a3-ae97e717ed8b}
FBPhotoZoom
2.2
false
fbphotozoom@installdaddy.com
McAfee SiteAdvisor
3.5.0
false
{4ED1F68A-5463-4931-9384-8FFF5ED91D92}
Microsoft .NET Framework Assistant
1.2.1
false
{20a82645-c095-46ed-80e3-08825760534b}
Skype extension for Firefox
4.2.0.5198
false
{AB2CE124-6272-4b12-94A9-7303C7397BD1}
Veoh Web Player Community Toolbar
3.15.1.0
false
{cd90bf73-20f6-44ef-993d-bb920303bd2e}
Important Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.cache.disk.capacity
1048576
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size_cached_value
532480
browser.places.smartBookmarksVersion
4
browser.startup.homepage
http://www.google.dk/
browser.startup.homepage_override.buildID
20121024073032
browser.startup.homepage_override.mstone
16.0.2
browser.tabs.warnOnClose
false
dom.max_chrome_script_run_time
40
dom.max_script_run_time
40
extensions.lastAppVersion
16.0.2
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1351196091
places.history.expiration.transient_current_max_pages
53421
plugin.disable_full_page_plugin_for_types
privacy.sanitize.migrateFx3Prefs
true
security.warn_viewing_mixed
false
Graphics
Adapter Description
Mobile Intel(R) 965 Express Chipset Family
Vendor ID
0x8086
Device ID
0x2a02
Adapter RAM
Unknown
Adapter Drivers
igdumd32
Driver Version
7.14.10.1318
Driver Date
8-20-2007
Direct2D Enabled
Blocked for your graphics driver version.
DirectWrite Enabled
false (0.0.0.0)
ClearType Parameters
ClearType parameters not found
WebGL Renderer
Blocked for your graphics driver version. Try updating your graphics driver to version 7.15.10.1666 or newer.
GPU Accelerated Windows
0. Blocked for your graphics driver version. Try updating your graphics driver to version 7.15.10.1666 or newer.
JavaScript
Incremental GC
1
Accessibility
Activated
0
Prevent Accessibility
0
Library Versions
Expected minimum version
Version in use
NSPR
4.9.2
4.9.2
NSS
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS Util
3.13.6.0
3.13.6.0
NSS SSL
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS S/MIME
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC

ideato
  • Top 25 Contributor
617 solutions 4263 answers

Hi MadsBuus,

try to Turn off hardware acceleration in Firefox and "disable the hardware acceleration" in the Flash Player too :

http://helpx.adobe.com/flash-player/kb/video-playback-issues.html

http://www.macromedia.com/support/documentation/en/flashplayer/help/help01.html


thank you

Question owner

Hello ideato

Did that, didn't work..

ideato
  • Top 25 Contributor
617 solutions 4263 answers

Hello again, other solution is to Downgrade to Flash 10.3, try step by step, and the important(in this) is to uninstall Flash with uninstaller provided by Adobe ! (it is in the link).

it is not so easy, as disable hard.acc. but not so difficult too, you can do it.

thanks again

Question owner

That didn't work either..

cor-el
  • Top 10 Contributor
  • Moderator
10760 solutions 96841 answers

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do not click the Reset button on the Safe mode start window or otherwise make changes.

Question owner

Hi cor-el!

The problem still persists in safe mode, and I was already using the default theme..

cor-el
  • Top 10 Contributor
  • Moderator
10760 solutions 96841 answers

Try to boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps.

Question owner

I can't really say if that helps.. Since safe mode with networking turns off the sound as well, I can't tell whether the audio still stuttering.. However.. the video does appear to be running a lot smoother, but I can't tell for certain without the sound.. Another strange thing was that I was unable to pause the video, as the "Play" icon at the bottom hadn't turned into a "Pause" icon as it normally does when video playback starts.. No matter how many times I clicked, it didn't respond, though all the other features on the youtube player such as sound, quality and video size did respond when clicked on those..

Modified by MadsBuus

ideato
  • Top 25 Contributor
617 solutions 4263 answers

If you do not already done try to Disabling Protected Mode in Flash (the link is for 11.3, do the same for 11.4), see the same in "Last resort" in the next adobe link http://forums.adobe.com/thread/1018071?tstart=0


thank you

Helpful Reply

Nope.. disabling protected mode didn't seem to work either..

AntiBling 1 solutions 1 answers

Chosen Solution

I know this is a couple months old but one thing I noticed trying to deal with this problem. Youtube is automatically having certain users using certain browsers use HTML5 videos.

Next time you get that choppy video, right click it, and click on "About HTML5"

It will tell you that youtube has automatically enrolled you in their beta testing and to opt out you click the link on the bottom to stop seeing HTML5 videos.

I hope this helps you, it helped me.

Question owner

That worked!! Thank you so much, AntiBling!

PonchoLebo 0 solutions 2 answers

I had similar issues with choppy/slow Adobe Video. I took all steps from above to no avail. My antimalware and antivirus software seemed to catch most things so I didn't feel I had a problem there either. Then, i ran the Kaspersky TDSS killer. I found I had a rootkit issue. After this fix, my Flash Video on Firefox ran as fine. Hope this is a helpful last ditch alternative to those, like me, that seemed like they had tried everything. I actually my rootkit issue when updating microsoft and gettiing an FFFFFFFE error code.