X
Tap here to go to the mobile version of the site.

Support Forum

When opening a second window, Firefox switches me back to the first one and it's driving me crazy. Why is this happening?

Posted

When opening a second window, Firefox switches me back to the first one and it's driving me crazy. Why is this happening?

When opening a second window, Firefox switches me back to the first one and it's driving me crazy. Why is this happening?

Additional System Details

This happened

Every time Firefox opened

This started when...

Firefox last updated

Installed Plug-ins

  • Google Update
  • Shockwave Flash 11.4 r402
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.6.636
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • GEPlugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • RealPlayer Enterprise(tm) LiveConnect-Enabled Plug-In
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 4.1.10329.0
  • iTunes Detector Plug-in
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Virtual Earth 3D 4.00100226006 plugin for Mozilla
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0.1

More Information

bffquestion 0 solutions 4 answers

I, too, have had this problem for quite some time. I believe it was when I updated to 15.01. I get the problem intermittently but frequently when I right-click on Open New Link in Window. I get it much less frequently when I just click on a link. There's some consistency to it. Seems to happen with Google Mail on just the normal left button link-clicking. Seems to happen almost always when I open IMDb in a new window using right-click and the menu.

I tried downgrading to v15.0, but that didn't help. I've read this thread, and there appears to be other threads on the same topic, i.e., [question].

The only "solution" I've seen discussed so far is to disable Shockwave Flash. I haven't tried it yet. One thing I've noticed: I have cookies set up to prompt me before setting a cookie. If the website I'm opening in a new window wants to set a cookie immediately, I get the standard little window asking me what to do. That seems to prevent Firefox from switching back to the parent window, and everything works normally.

If it matters, I am using Windows Home 64-bit and the latest version of Firefox, 16.0.2.

Finally, although not actually relevant, I'm confused. I didn't know this "ask a question" place existed. What's the difference between this and the Firefox forums at forums.mozillazine.org?

I, too, have had this problem for quite some time. I believe it was when I updated to 15.01. I get the problem intermittently but frequently when I right-click on Open New Link in Window. I get it much less frequently when I just click on a link. There's some consistency to it. Seems to happen with Google Mail on just the normal left button link-clicking. Seems to happen almost always when I open IMDb in a new window using right-click and the menu. I tried downgrading to v15.0, but that didn't help. I've read this thread, and there appears to be other threads on the same topic, i.e., [[https://support.mozilla.org/en-US/questions/936004|this question]]. The only "solution" I've seen discussed so far is to disable Shockwave Flash. I haven't tried it yet. One thing I've noticed: I have cookies set up to prompt me before setting a cookie. If the website I'm opening in a new window wants to set a cookie immediately, I get the standard little window asking me what to do. That seems to prevent Firefox from switching back to the parent window, and everything works normally. If it matters, I am using Windows Home 64-bit and the latest version of Firefox, 16.0.2. Finally, although not actually relevant, I'm confused. I didn't know this "ask a question" place existed. What's the difference between this and the Firefox forums at forums.mozillazine.org?
sonnyboy1 0 solutions 17 answers

I had the same problem. I disabled RealDownloader Plugin and the RealJukebox NS plugin and lo and behold....the problem is gone. Why in the world they would cause firefox open in new window problem, is beyond me. Let me know if this works for you.

I had the same problem. I disabled RealDownloader Plugin and the RealJukebox NS plugin and lo and behold....the problem is gone. Why in the world they would cause firefox open in new window problem, is beyond me. Let me know if this works for you.
bffquestion 0 solutions 4 answers

I don't have either of the two plugins mentioned by sonnyboy1. However, I disabled Shockwave Flash a couple of days ago, and since then, the problem has not recurred.

I don't have either of the two plugins mentioned by sonnyboy1. However, I disabled Shockwave Flash a couple of days ago, and since then, the problem has not recurred.
readyben 0 solutions 6 answers

Open a page with a new window (keyboard or mouse, doesn't matter) and if it has a Flash element it will revert to the prior window. If there's no Flash element it works fine.

My workaround is to mouse to the taskbar and click the window I just opened! What a pain! It's a bad bug that requires you to do this!

Disable the Shockwave Flash plugin and it never happens.

There are 4 possible "Solutions."

1) Go back to Firefox 13

2) Disable the Flash plugin (but a lot of the time this will stop you from seeing what you want to see on the page - Flash is too common and too useful)

3) Mouse to the taskbar icon of the window you just opened and click to refocus it

4) Use a different browser like Opera or Chrome which don't have this Flash bug

Seems like it's a bug of both programs, Firefox (v14 or 15 and higher) and Flash. But the Flash plugin works fine in Firefox 13, so how much of it is Flash and how much of it is Firefox?...

My guess is that this will not be fixed. That's right, they won't fix it. Too much time has gone by (4 Firefox versions!) and a lot of users don't have the problem. Look at the top of this page - it's only been reported by about 60 people. What's the other factor that we have that the unaffected users don't have? Hard to tell. On another thread (https://support.mozilla.org/en-US/questions/936004) someone suggested that tab users don't see it, only "new window" users. Maybe. But whatever the reason it's not enough outrage for Mozilla programmers to fix the code.

Back to the four workarounds above...

Open a page with a new window (keyboard or mouse, doesn't matter) and if it has a Flash element it will revert to the prior window. If there's no Flash element it works fine. My workaround is to mouse to the taskbar and click the window I just opened! What a pain! It's a bad bug that requires you to do this! Disable the Shockwave Flash plugin and it never happens. There are 4 possible "Solutions." 1) Go back to Firefox 13 2) Disable the Flash plugin (but a lot of the time this will stop you from seeing what you want to see on the page - Flash is too common and too useful) 3) Mouse to the taskbar icon of the window you just opened and click to refocus it 4) Use a different browser like Opera or Chrome which don't have this Flash bug Seems like it's a bug of both programs, Firefox (v14 or 15 and higher) and Flash. But the Flash plugin works fine in Firefox 13, so how much of it is Flash and how much of it is Firefox?... My guess is that this will not be fixed. That's right, they won't fix it. Too much time has gone by (4 Firefox versions!) and a lot of users don't have the problem. Look at the top of this page - it's only been reported by about 60 people. What's the other factor that we have that the unaffected users don't have? Hard to tell. On another thread (https://support.mozilla.org/en-US/questions/936004) someone suggested that tab users don't see it, only "new window" users. Maybe. But whatever the reason it's not enough outrage for Mozilla programmers to fix the code. Back to the four workarounds above...
lkaven 0 solutions 6 answers

This problem definitely happens for "open in new tab" cases and not just "open in new window" cases.

This problem definitely happens for "open in new tab" cases and not just "open in new window" cases.
Snoops 0 solutions 2 answers

I've now downgraded to FF 13 and am happy to keep using it until this problem is fixed.

Apart from this annoying problem I'd still like to say 'Thanks Mozilla' for a great browser and I hope to see a solve with the next upgrade.

Cheers Snoops

I've now downgraded to '''FF 13''' and am happy to keep using it until this problem is fixed. Apart from this annoying problem I'd still like to say 'Thanks Mozilla' for a great browser and I hope to see a solve with the next upgrade. Cheers Snoops
lkaven 0 solutions 6 answers

After six weeks of this, I"m starting to lose it. Tried upgrading flash twice, Firefox twice.

After six weeks of this, I"m starting to lose it. Tried upgrading flash twice, Firefox twice.
jls1890 0 solutions 3 answers

I also downgraded to FF13 with some better results. However, it still happens with some sites. Disabling Flash did not help me.

It is disappointing the Mozilla has been silent on this. I guess they are happy to lose users a few at a time. I've been trying out other browsers and will eventually switch when I find a good match.

I also downgraded to FF13 with some better results. However, it still happens with some sites. Disabling Flash did not help me. It is disappointing the Mozilla has been silent on this. I guess they are happy to lose users a few at a time. I've been trying out other browsers and will eventually switch when I find a good match.
sonnyboy1 0 solutions 17 answers

Please let me know when you've settled on another browser. I may try your recommendation. Disabling flash worked for 2 days and now It's back to the old switching to the original window. Mozzilla must know this is happening. Why don't they fix it?

Please let me know when you've settled on another browser. I may try your recommendation. Disabling flash worked for 2 days and now It's back to the old switching to the original window. Mozzilla must know this is happening. Why don't they fix it?
bffquestion 0 solutions 4 answers

Just another report that Firefox (latest version, although I just upgraded to 17.0.1 this morning) continues to work fine with Adobe Flash (Shock Wave Flash) disabled. The only downside is I can't watch certain video. Fortunately, I don't watch much video compared to the average person, but if I really need to see something, I use IE.

I tried searching Adobe's website to see if they acknowledge the bug. I couldn't find anything, but I haven't tried their forums. Has anyone else?

Just another report that Firefox (latest version, although I just upgraded to 17.0.1 this morning) continues to work fine with Adobe Flash (Shock Wave Flash) disabled. The only downside is I can't watch certain video. Fortunately, I don't watch much video compared to the average person, but if I really need to see something, I use IE. I tried searching Adobe's website to see if they acknowledge the bug. I couldn't find anything, but I haven't tried their forums. Has anyone else?
bronco99 0 solutions 3 answers

Well, I downloaded the most recent update to Firefox and they still have not addressed this issue. I am done, and going to uninstall Firefox and stick with Internet Explorer. I would like to import my bookmarts into Internet Explorer from Firefox, but am having trouble finding the file after selecting "IMPORT" on Explorer. Can anyone point me to the file I need to import?

Thanks, and good luck with this @sshole Firefox browser in the future!

Well, I downloaded the most recent update to Firefox and they still have not addressed this issue. I am done, and going to uninstall Firefox and stick with Internet Explorer. I would like to import my bookmarts into Internet Explorer from Firefox, but am having trouble finding the file after selecting "IMPORT" on Explorer. Can anyone point me to the file I need to import? Thanks, and good luck with this @sshole Firefox browser in the future!
sonnyboy1 0 solutions 17 answers

Just disabled shockwave flash again and now the problem is gone. Now of course each time I want to watch a video, I have to unable it. Pain in the butt!

Just disabled shockwave flash again and now the problem is gone. Now of course each time I want to watch a video, I have to unable it. Pain in the butt!
sonnyboy1 0 solutions 17 answers

I just emailed Adobe about our problem. Maybe they can help as Mozilla certainly doesn't care.

I just emailed Adobe about our problem. Maybe they can help as Mozilla certainly doesn't care.
sjonnievanderkist 0 solutions 14 answers

@readyben i found your suggestion interesting but does not work for me, what did work was a new profile. here is the link for making a new profile in firefox: https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles

by default "Don't ask at startup" is active, make sure that you deactivate this as it will give you the choice at startup which profile to use.

i exported all the bookmarks from my first profile to the desktop and when i had created the second profile imported all my bookmarks.

the second profile works perfectly and now i have just used imported my passwords using "Password Exporter" a very usefull add-on. here is the link: https://addons.mozilla.org/en-US/firefox/addon/password-exporter/?src=search

so far so good.

i am convinced that it is some thing inside firefox but the dead silence from their side and ignoring this page, .....well let them stew in their own juice.

i also ran firefox again in the "Firefox Safe Mode" which when you use it disables all your add-on's. here is the link: https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

but the result was as always: jumping back to the other window. conclusion: it is NOT a clash with one of the add-ons, it is something that is deeply hidden in your firefox profile.

well it worked for me, the best of luck to all of you.

@readyben i found your suggestion interesting but does not work for me, what did work was a new profile. here is the link for making a new profile in firefox: https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles by default "Don't ask at startup" is active, make sure that you deactivate this as it will give you the choice at startup which profile to use. i exported all the bookmarks from my first profile to the desktop and when i had created the second profile imported all my bookmarks. the second profile works perfectly and now i have just used imported my passwords using "Password Exporter" a very usefull add-on. here is the link: https://addons.mozilla.org/en-US/firefox/addon/password-exporter/?src=search so far so good. i am convinced that it is some thing inside firefox but the dead silence from their side and ignoring this page, .....well let them stew in their own juice. i also ran firefox again in the "Firefox Safe Mode" which when you use it disables all your add-on's. here is the link: https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode but the result was as always: jumping back to the other window. conclusion: it is NOT a clash with one of the add-ons, it is something that is deeply hidden in your firefox profile. well it worked for me, the best of luck to all of you.
Tyler Downer
  • Top 25 Contributor
  • Administrator
  • Moderator
1370 solutions 9194 answers

Can anyone see this with the following settings:

Firefox 17.0.1 Flash 11.5 and a fresh unmodified profile? Use the Profile Manager to create and remove Firefox profiles

If you can, please let me know

Can anyone see this with the following settings: Firefox 17.0.1 Flash 11.5 and a fresh unmodified profile? [[Use the Profile Manager to create and remove Firefox profiles]] If you can, please let me know
sjonnievanderkist 0 solutions 14 answers

@tylerdowner. yes i can see it, no problem.

and i had to update firefox to 17.0.1 and flash to 11.5, although 11.5 is still marked as beta. but before updating and after updating i can open and see the link, what is your point or question ?

@tylerdowner. yes i can see it, no problem. and i had to update firefox to 17.0.1 and flash to 11.5, although 11.5 is still marked as beta. but before updating and after updating i can open and see the link, what is your point or question ?
Tyler Downer
  • Top 25 Contributor
  • Administrator
  • Moderator
1370 solutions 9194 answers

Do you still see the issue in Firefox switching your windows after updating Firefox, Flash and creating a new profile?

Do you still see the issue in Firefox switching your windows after updating Firefox, Flash and creating a new profile?
sjonnievanderkist 0 solutions 14 answers

sorry, i obiviously was not clear in my entry above your answer where i gave all the links.

i concluded that if i started in firefox safe mode, which means that all the add-on's are deactivated, and i still had the problem of jumping back to window 1, than it was not a problem with add-on's because they were not working, therefor it must be a problem within firefox.

to test that i created a new profile and now it is working fine, therefor somewhere in my old profile something clashes, but i do not know what or where.

i also used "about:config" , and changed a few things around, but it had no effect.

earlier on, i also uninstalled firefox 16 and installed 15 and after that tried 14 and after that 13 and all the time the problem of jumping back to window 1 remained. as soon there was a flash element in a page, it jumps back. if i now update to 17.01 and flash 11.5 in my old profile i still have this problem, therefor i think it sits some where deep in firefox.

earlier on i thought it was cookies and used ccleaner to clean up but it was still the same. maybe if i had used revo uninstaller and wiped firefox completely from my hard disk it would have cleaned things up as well but installing an old or new version of firefox on what remained in the firefox folder on my c drive meant that the problem remained behind.

so, to cut a long story short, the only thing that worked for me was a new profile with the same bookmarks and pass words imported.

thanks for your time, much appreciated.

sorry, i obiviously was not clear in my entry above your answer where i gave all the links. i concluded that if i started in firefox safe mode, which means that all the add-on's are deactivated, and i still had the problem of jumping back to window 1, than it was not a problem with add-on's because they were not working, therefor it must be a problem within firefox. to test that i created a new profile and now it is working fine, therefor somewhere in my old profile something clashes, but i do not know what or where. i also used "about:config" , and changed a few things around, but it had no effect. earlier on, i also uninstalled firefox 16 and installed 15 and after that tried 14 and after that 13 and all the time the problem of jumping back to window 1 remained. as soon there was a flash element in a page, it jumps back. if i now update to 17.01 and flash 11.5 in my old profile i still have this problem, therefor i think it sits some where deep in firefox. earlier on i thought it was cookies and used ccleaner to clean up but it was still the same. maybe if i had used revo uninstaller and wiped firefox completely from my hard disk it would have cleaned things up as well but installing an old or new version of firefox on what remained in the firefox folder on my c drive meant that the problem remained behind. so, to cut a long story short, the only thing that worked for me was a new profile with the same bookmarks and pass words imported. thanks for your time, much appreciated.
sjonnievanderkist 0 solutions 14 answers

never stops, does it. so, my new profile was working fine and i had imported bookmarks and pass words, all still fine.

time to start adding add-on's or extensions as some people call them, after my dictionaries and wot, it was time for adblock plus and to my surprise the trouble started again. normally i have 3 filters installed and i took them out one by one, but it made no differense. deleted all 3 filters, and you get a warning from adblock that it can not work that way. ignore this and test. result: firefox works fine and the moment i add filters to adblock plus, it starts again.

well here you are, you what i have decided adblock is important for me to cut out all these jumpy flash adverts, so i will just have to learn to live with this.

greetings to all, over and out.

never stops, does it. so, my new profile was working fine and i had imported bookmarks and pass words, all still fine. time to start adding add-on's or extensions as some people call them, after my dictionaries and wot, it was time for adblock plus and to my surprise the trouble started again. normally i have 3 filters installed and i took them out one by one, but it made no differense. deleted all 3 filters, and you get a warning from adblock that it can not work that way. ignore this and test. result: firefox works fine and the moment i add filters to adblock plus, it starts again. well here you are, you what i have decided adblock is important for me to cut out all these jumpy flash adverts, so i will just have to learn to live with this. greetings to all, over and out.
plover 0 solutions 2 answers

I erased my Firefox profile, and I still have windows switching after creating new profile.

Firefox 17.0.1 on Windows7 Flash ActiveX Version: 11.1.102.63 Flash Plug-in Version: 11.5.502.110

It drives me crazy, too...

I erased my Firefox profile, and I still have windows switching after creating new profile. Firefox 17.0.1 on Windows7 Flash ActiveX Version: 11.1.102.63 Flash Plug-in Version: 11.5.502.110 It drives me crazy, too...