X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox Opening new windows reverts to original Window

Posted

Just started with this problem, when I open a new window which is my preference rather than Tabs I find that whereas it used to open the new window and that was active, it is now opening a new window and then reverting to the original one.

Any ideas?

Additional System Details

This happened

Every time Firefox opened

This started when...

This week

Installed Plug-ins

  • Google Update
  • Shockwave Flash 11.4 r402
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 10.5.1 for Mozilla browsers
  • VLC media player Web Plugin 2.0.2
  • Garmin Communicator Plug-In 4.0.3.0
  • 5.1.10411.0
  • iTunes Detector Plug-in
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • Shockwave Flash 9.0 r45

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:15.0) Gecko/20100101 Firefox/15.0

More Information

Application Basics
Name
Firefox
Version
15.0
User Agent
Mozilla/5.0 (Windows NT 6.1; rv:15.0) Gecko/20100101 Firefox/15.0
Profile Folder
Show Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Crash Reports
about:crashes
Memory Use
about:memory
Extensions
Name
Version
Enabled
ID
Adblock Plus
2.1.2
true
{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
Autofill Forms
0.9.8.3
true
autofillForms@blueimp.net
British English Dictionary
1.19.1
true
en-GB@dictionaries.addons.mozilla.org
DownloadHelper
4.9.9
true
{b9db16a4-6edc-47ec-a1f4-b86292ed211d}
Easy YouTube Video Downloader
6.5
true
{c0c9a2c7-2e5c-4447-bc53-97718bc91e1b}
FoxLingo
2.7.5
true
{ef62e1ce-d2a4-4cdd-b7ec-92b120366b66}
Garmin Communicator
4.0.3
true
{195A3098-0BD5-4e90-AE22-BA1C540AFD1E}
Imgur Uploader
1.0.3
true
giorgio@gilestro.tk
MP4 Downloader
1.3.2
true
mp4downloader@jeff.net
Textarea Cache
0.8.7
true
{578e7caa-210f-4967-a0d3-88fe5b59a39f}
Themes Menu
1.14
true
{84625510-7e5d-11e0-a411-0800200c9a66}
Important Modified Preferences
Name
Value
accessibility.typeaheadfind
true
accessibility.typeaheadfind.flashBar
0
browser.cache.disk.capacity
1048576
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size_cached_value
1048576
browser.link.open_newwindow
2
browser.places.smartBookmarksVersion
4
browser.startup.homepage
file:///S:/wisdom_site/index.html
browser.startup.homepage_override.buildID
20120824154833
browser.startup.homepage_override.mstone
15.0
browser.tabs.loadInBackground
false
extensions.lastAppVersion
15.0
gfx.direct3d.prefer_10_1
true
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1346049357
places.history.expiration.transient_current_max_pages
80513
privacy.sanitize.migrateFx3Prefs
true
security.warn_viewing_mixed
false
Graphics
Adapter Description
ATI Radeon HD 4550
Vendor ID
0x1002
Device ID
0x9540
Adapter RAM
512
Adapter Drivers
aticfx32 aticfx32 atiumdag atidxx32 atiumdva
Driver Version
8.850.0.0
Driver Date
4-19-2011
Direct2D Enabled
true
DirectWrite Enabled
true (6.1.7601.17789)
ClearType Parameters
ClearType parameters not found
WebGL Renderer
Google Inc. -- ANGLE (ATI Radeon HD 4550 ) -- OpenGL ES 2.0 (ANGLE 1.0.0.1041)
GPU Accelerated Windows
2/2 Direct3D 10
AzureBackend
direct2d
JavaScript
Incremental GC
0
Library Versions
Expected minimum version
Version in use
NSPR
4.9.1
4.9.1
NSS
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS Util
3.13.6.0
3.13.6.0
NSS SSL
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC
NSS S/MIME
3.13.6.0 Basic ECC
3.13.6.0 Basic ECC

Marc Sances 22 solutions 242 answers

That's such an strange problem. I didn't understand it at all. Do you mean that when you choose to open a new window, Firefox opens it and closes it again inmediately?

Anyway, the problem may be caused by an add-on. Try the Firefox Safe Mode to see how it works there. The Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open the Firefox 4.0+ Safe Mode by holding the Shift key when you use the Firefox desktop or Start menu shortcut.
  • Or use the Help menu item and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Don't select anything right now, just use "Continue in Safe Mode." To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before using the Firefox shortcut (without the Shift key) to open it again. If it is good in the Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one.

Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

cor-el
  • Top 10 Contributor
  • Moderator
10762 solutions 96861 answers

You you mean that the new window stays open, but that the focus switches to the (parent) window from which you opened that new window?

How do you open the new window?

With a keyboard shortcut (Ctrl+N) or via a menu (Firefox > New Tab > New Window)?

mhmaddog 0 solutions 4 answers

I've tried starting Firefox in safe mode, but the problem is still there. I noticed it after an update to iGoogle, and this is where most of the problems happen, when opening (in a new window using the mouse) news stories. It also happens when I left click on a link directly which also opens in a new window.

I notice this happens for new windows where there is some other activity (e.g. a flash item)

Modified by mhmaddog

powow 0 solutions 3 answers

I'm getting the same issue, and it's very annoying.

Should I reinstall the browser with the previous version until this bug is fixed?

slam5 0 solutions 18 answers

Well, I have the same problem BUT it only happens when FF first launched. Subsequent launching of websites from right click menu works properly and don't stick to old window. Has anybody got this behavior?

Marc Sances 22 solutions 242 answers

Are all of you sure this is a Firefox issue and not a site concrete issue? I think you're trying to tell us Firefox did that on iGoogle . Please try the following. Open Notepad and type the HTML code I attach on Pastebin:

Paste HTML code from RAW Paste Data on this page.

Save the file as link.html. Open it on Firefox and click the "Click" link. It should work as expected.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

slam5 0 solutions 18 answers

Hi, I'm sure it is add-on related as if I start FF w/o any add-on and the behavior disappears. Enable all my add-on's and the problem came back. Now I have to diag which one of them is the problem. I have the follow add-on:

Ad-Block Plus 2.1.2 Ad-Block Plus Popup addon 0.4 Certificate patrol 2.0.14 Download Helper 4.19.10 Evernote web-clipper 5.1.0.252437 Lastpass 2.0.0 Logitech device detection 1.24.0.9 McAfee Siteadvisor 3.5.0 New Tab Homepage 0.4.3 Noscript 2.5.5 No squint 2.1.6 Re-load 13.0.0 Skype click to call 6.2.0.10687

Anybody see a pattern here? BTW, it isn't New Tab Homepage as i disabled it and still have the same result.

HaterOfAdware 0 solutions 4 answers

I have this problem as well. The only extension I have is McAfee Scriptscan. Could it be a plug-in rather than an Add-on?

slam5 0 solutions 18 answers

I have siteadvisor from mcafee and disabling it doesn't solve the problem. it is not life and death and very annoying! btw, do you have a logitech mouse and installed their software?

mhmaddog 0 solutions 4 answers

I have a logitech M501 and I do wonder - the problem started around the time I replaced my IBM mouse (can't be exactly sure it was coincidental, though)

slam5 0 solutions 18 answers

well, my mouse do have that fancy button which you press and all the windows show as a series of icons on the screen. it emulate a function of OS X on Mac. Somehow, I don't think that's the problem. Keep on looking!

niekkouwenberg 0 solutions 3 answers

Helpful Reply

I have the same issue. When opening a new window and opening either gmail.com or facebook.com, the original window gets focus once the website is finished loading.

This is not an add-on issue, as it also occurs when running in safe mode.

After also disabling all plug-ins, I noticed the problem was gone. I have found the problematic plug-in after re-enabling the plugins one-by-one. The problem is Shockwave Flash.

My plug-in was out-of-date, so I installed the most recent version (11.4.402.287) but the problem still occurs. The only solution is to disable the plug-in altogether.

P.S. Possibly the problem only occurs on some systems. I am running Windows 7 Enterprise N, x64, and on an SSD.

wstco 0 solutions 3 answers

I have had the same issue, and it is quite annoying. It started when I updated to firefox 15.0.1 After a google search, using "open link in new window" caused many pages to start opening on top, then move underneath the search list window, hiding themselves.

It happens only the first time you visit the problematic web sites. it also happens in safe mode, but as the user above (niekkouwenberg) suggested, disabling the shockwave flash plug-in stops the incorrect new window behavior.

Many sites exhibit the problem, but one which is repeatable for me is as follows: 1. restart firefox 2. go to google and search on "lovenox instructions" 3. right-click on the top link "LOVENOX®-- Patient Information" 4. the window starts to open on top, as it should, then immediately hides underneath the search window.

Only the first time you do this will the problem be evident. Opening the same link a second time, or the second link on the same list, going to a different page on the same domain's website, it works OK. The problem is not present with Explorer or Chrome, only Firefox.

It does work properly when the shockwave extension is disabled. I also just updated to the newest shockwave 11.4.494.287 but the problem persists.

It happens on both my work and home computers, both Win-7 home-premium 64 bit.

Modified by wstco

Question owner

Sorry for not responding sooner, I have been snowed under.

I prefer links to open in a new window, call me old fashioned but that's the way I work.

I have a custom Start Page for our internal intranet at home and it is repeatable every time when I open Facebook or eBay.

niekkouwenberg 0 solutions 3 answers

The issue seems to be resolved after updating to Firefox 16. Can you confirm?

Update: this problem is indeed not resolved. I however found that the problem no longer occurs for gmail.com, but it still does for facebook.com.

Modified by niekkouwenberg

Question owner

Nope not for me the problem is exactly the same.

wstco 0 solutions 3 answers

Nope, Firefox-16 (just updated) behaves the same way. The problem has not been fixed for me. The search result links I mentioned above still give the whack-a-mole behavior for opening a link in a new window.

slam5 0 solutions 18 answers

Ok, I know this is a bit old but I figured out a way how not to switch back to the first window. I notice that if I open three tabs in a row before I open a new site on a 2nd windows, it will stay at the 2nd window. Can anybody verify that for me?

HaterOfAdware 0 solutions 4 answers

That seems far more annoying than the original problem.

slam5 0 solutions 18 answers

well, this isn't a solution. I really wish FF don't push out version THAT quick!