X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

When opening a second window, Firefox switches me back to the first one and it's driving me crazy. Why is this happening?

Posted

When opening a second window, Firefox switches me back to the first one and it's driving me crazy. Why is this happening?

Additional System Details

This happened

Every time Firefox opened

This started when...

Firefox last updated

Installed Plug-ins

  • Google Update
  • Shockwave Flash 11.4 r402
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.6.636
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.4
  • GEPlugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • RealPlayer Enterprise(tm) LiveConnect-Enabled Plug-In
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 4.1.10329.0
  • iTunes Detector Plug-in
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Virtual Earth 3D 4.00100226006 plugin for Mozilla
  • Office Authorization plug-in for NPAPI browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0.1

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10747 solutions 96720 answers

Are there any pages open in the first window that auto-refresh or otherwise need attention?


Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do not click the Reset button on the Safe mode start window or otherwise make changes.

Question owner

Yes, usually Twitter. Can I make this stop happening?

cor-el
  • Top 10 Contributor
  • Moderator
10747 solutions 96720 answers

Did you try Safe mode?

Question owner

Yes. Still happening.

blairville 0 solutions 5 answers

I work at home, I have one window open all the time where there is a refresh about every 15 minutes. When it refreshes it automatically goes there, even if I am active on the other window or typing. Sometimes when I open a new tab on the other window and scroll, it will automatically change to the old window. This did not happen before upgrading to FF15.

Question owner

Yep, exactly what is happening to me. A solution to this would be great, it's so frustrating.

TexasTrophy 0 solutions 1 answers

I'm in the same boat as the original poster and the only thing that has changed is the last FF update.

Zibs 0 solutions 3 answers

Is this official mozzila support site ?

Because I can´t see anyone responsible answering this problem ...

This is so annoying bug !

sjonnievanderkist 0 solutions 10 answers

Helpful Reply

same here and it is a bug.

sorry cor-el, nothing to do with extensions or hardware acceleration, i have tested it in safe mode. nothing doing.

but it seems to happen more if the link in the new window has a flash element in it. even if you open a third or fourth window it switches back to the first window you opened. and it has been doing this since 15.0

and indeed where are the other moderators to let us know if the developers are aware of this bug.

jls1890 0 solutions 3 answers

I am having the same problem with no success in finding a solution. Prior to the update Firefox worked to just fine to open links in a new window and switch to them. Now it reverts to the original page.

This is enough of a hassle to make me switch to another browser.

Mozilla - where is the fix?

Snoops 0 solutions 2 answers

Same thing here. Not sure when it started, maybe a few updates ago.

It is SOOOO annoying! 

Hubby says to simply use tabs but I don't like tabs so I always open a link in a new window. Lately, I've been holding down the left mouse button on the top of the new window until its fully loaded just to keep it from disappearing behind the original window.

Fix please good people?

blairville 0 solutions 5 answers

One solution is to download the previous version, use it and turn off updates, which I have done, but not installed due to the troublesome issues I have to go through to install a toolbar I have to use for working. I hate IE and can't get used to chrome. What I have been doing is minimizing the window that refreshes. It has stopped the changing to the old window but there is another problem, when it refreshes and needs me to revert back to it and I am typing on the other open window, it will freeze my current window for about a second, then continues. Hate that when I am typing because it stops typing, have to retype it again. The best solution would be an option to turn that off in the settings. To me, a simple solution because they actually put the code in to automatically change to the new window when it refreshes, it should be an easy option to have the option to turn it on or off. But really, I know I have to revert back to the old version, and will do soon, but this should be addressed.

Zibs 0 solutions 3 answers

Why would I change my browsing habits just because of some ...... developer who caused this bug and he has no balls to fix it for weeks already


Edited by a moderator due to language. See the Rules & Guidelines .

Modified by the-edmeister

sjonnievanderkist 0 solutions 10 answers

at the top of this page is says: MOZILLA support.

as Zibs says above, somebody changed a line of code somewhere and 16.0.2 has come and gone and it is still there.

so where are these mozilla people who can clarify and that they are aware of this and are working on it.

this silence is just silly.

sjonnievanderkist 0 solutions 10 answers

and i got news.

i installed firefox 17.0 Beta 5 via filehippo.com and that bloody jump is still there, it sure does not look good for the future.

i am going to try Chrome again if the silence from mozilla continues.

gltech 0 solutions 2 answers

I'll betcha flash has more to do with it than you think. Flash developers ought to be shot. I can't believe there's not net-wide outrage over Flash's behavior. Anybody ever notice that almost all of the Windows shortcut keys don't work when a page with Flash on it is active? Such as alt-D for getting to the address bar. I'm a veteran software developer, and I can tell you why. Some idiot developer(s) have hooked into some Windows notifications (for you techies, ProcessDialogKey or something related), and are not implementing the overload correctly. The page switch problem could easily be caused by some dumbass flash developer calling something like BringWindowToTop, etc. Hard to believe that such beginner programming mistakes have been in such a widely-used piece of software for years. Well, I guess it's really not that hard to believe given the fact that just about everybody ignorantly uses the mouse to do everything, and people who use the keyboard when possible (in other words, the people who do things 100 times faster) are very few.

bronco99 0 solutions 3 answers

I've about had it with this problem. I've heard Flash might be the issue but I have tried with everything blocked using no-script and I still get sent back to the original window. Three versions and these clowns havent resolved this issue, makes you wonder what type of other issues we are not aware of, such as security. Seems to be a lot of incompetance. I guess its back to Explorer for me.

smushybird 0 solutions 1 answers

I'm having this same problem and I've had about enough of it. I'm switching to another browser if this problem can't be fixed. Can anyone recommend a good browser? I would like one as basic as possible. That's the reason I went with Firefox to begin with, but I'm starting to really hate Firefox now.

Zibs 0 solutions 3 answers

yet they see this topis because moderator edited my post. Maybe this is a big issue, they work 2 months on it already... lol

lkaven 0 solutions 6 answers

I have had this problem for 6 weeks. I tried updates of both Firefox and Flash, but to no avail. Even FF16 has this. Whenever I open pages such as NY Times, Weather.com, Gmail, Facebook, DailyKos, it sends the current window behind. It seems to favor flash-heavy windows.

Is there any information from Firefox forthcoming? Acknowledgement of a major usability issue?