Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cannot open youtube with firefox, but can with IE9. I have disabled all add-ons but still can't open that web page.

  • 4 replies
  • 2 have this problem
  • 1834 views
  • Last reply by cor-el

more options

I have deleted all cookies and history, turned off all add-ons, but I can't navigate to youtube. I have no problem getting there with IE9.

All Replies (4)

more options

you have many custom network settings, this might be a problem - please go into about:config and reset all custom entries (the ones that are shown in bold) that start with network. or try to reset firefox altogether.

more options

You can also check for problems caused by extensions.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do not click the Reset button on the Safe mode start window or otherwise make changes.
more options

Well, I've done all those things, even turned off my anti-malware and anti-virus software. I still can't load videos from YouTube nor click through email to view the videos. This is really frustrating, especially since my wife can't go there either, and she is set up a lot simpler than I am.

more options

Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

There may be extensions and plugins installed by default in a new profile, so check that in "Tools > Add-ons > Extensions & Plugins" in case there are still problems.

If the new profile works then you can transfer some files from the old profile to that new profile, but be careful not to copy corrupted files.

See:

You can also try to reset Firefox: