X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Blurry text in Firefox 15

Posted

After the update to Firefox 15 the text looks really bad on some pages, like Facebook.

I made a comparison of screen dumps to show the differences in Firefox (FF), Google Chrome (CH) and Internet Explorer (IE)

See comparison screen dump

The only way I can get normal text i Facebook is by unchecking the Firefox option to let pages set their own fonts - but that is no solution as it makes a lot of other pages look crappy

So : What to do to get the types in Facebook, look good?

/fl.

(texts are in Swedish, if you might wonder)

Chosen solution

Aha, I don't have Lucida Grande, so I'm seeing Tahoma (like most Windows users). Did you get the font with an old version of Safari? If the font isn't blurry on Mac, the problem might be too rarely seen to get fixed (or even properly diagnosed...).

Read this answer in context 0

Additional System Details

This happened

Every time Firefox opened

This started when...

after update to Firefox15

Installed Plug-ins

  • Next Generation Java Plug-in 10.7.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.4 r402
  • Google Talk Plugin Video Accelerator version:0.1.44.16
  • Version 3.5.1.8982
  • NPWLPG
  • Google Update
  • VLC media player Web Plugin 2.0.2
  • SiteAdvisor
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • McAfee Virtual Technician plugin for Mozilla (Gecko Version: 1.8b1)
  • 5.1.10411.0
  • McAfee MSC FF plugin DLL
  • Nexus Personal Plug-Ins
  • GEPlugin
  • Unifaun WebPrinter ActiveX/Plugin Component
  • Zeon PDF Plugin For Mozilla
  • Windows Activation Technologies Plugin for Mozilla
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • 1.9.0042.0
  • Adobe PDF Plug-In For Firefox and Netscape
  • np-mswmp
  • Office Plugin for Netscape Navigator

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:15.0) Gecko/20100101 Firefox/15.0

More Information

Tried different Firefox font settings - not solving the problem
Tried to unable Firefox setting for hardware acceleration - no difference

cor-el
  • Top 10 Contributor
  • Moderator
10740 solutions 96657 answers

Try to tune the appearance with this extension:

Helpful Reply

  1. cor-el

Thanks. Could be a soloution. But that i guess is for kind of font experts. : ) I tried some different settings but could not figure out how to handle all the options.

There must be a more simple way ...

As this occured after the latest update I am inclined to believe it is a Firefox bug.

NEW INFORMATION: When loading the Facebook page, at first for about 2 seconds, the head banner text is looking better, but then when all is loaded the extra "boldness" appears again.

I tried Firefox Safe Mode to exclude any extension causing the problem - but all was just the same

Modified by mandragor

Question owner

An other example comparing my Firefox 15 and latest Google Chrome. Se how messy the Firefox page is displayed!

/fl.

Update : This link shows the screen dump picture in better resolution.

https://dl.dropbox.com/u/4105623/FF-CH-2-Text.png

Modified by mandragor

cor-el
  • Top 10 Contributor
  • Moderator
10740 solutions 96657 answers

Which font is Firefox using?

You can use this extension to see which fonts are used for selected text.

Question owner

Thanks.

I installed the extension and for the Facebook Page it says LucidaGrande for most of the texts I selected (the most blurry ones)

Se uploaded screen dump image for the Page info font panel

/fl

jscher2000
  • Top 10 Contributor
2348 solutions 20818 answers

In your More system details it says you tried enabling hardware graphics acceleration. For best results, keep that setting disabled, i.e., make sure the checkbox is unchecked.

orange Firefox button or classic Tools menu > Options > Advanced

On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available"

You usually need to restart Firefox in order for that to take effect.

Question owner

Hardware acceleration is now disabled. I cleared cache and restarted Firefox - unfortunately I still have the same blurry Facebook text.

/fl

cor-el
  • Top 10 Contributor
  • Moderator
10740 solutions 96657 answers

It is best to check the font by selecting some text and open the right-click context menu to check the font in that selection. You posted that it works better if you disable the website font and that is clearly an indication that there is a problem with one or more fonts font.

You can do a font test to see if you can identify corrupted font(s).

You can try different default fonts and temporarily disable website fonts to test the selected default font.

  • Tools > Options > Content : Fonts & Colors > Advanced
  • [ ] "Allow pages to choose their own fonts, instead of my selections above"

You can also check for display driver issues by booting the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that works.

Question owner

Thank you.

I did the right click thing on some different types and sizes of the Facebook text. But every time it said LucidaGrande. Only strange thing is that it says "LucidaGrande" and not "Lucida Grande".

See screen dump of the popup window.

I Could not see any corrupt fonts testing the link : http://browserspy.dk/fonts-flash.php?detail=1

See screen dump excerpt from that page.

I tried to set all the default fonts in Firefox Tools > Options > Content : Fonts & Colors > to Lucida Grande and disabled the "Allow pages to choose their own fonts, instead of my selections above"

Checking the Facebook page this setting produces exactly the same look as my default Firefox font setting (=Times New Roman / Arial / Courier, and allowing pages to pages to choose their own fonts)

Finally I tested this page in Firefox with font settings : Lucida Grande on everything, not allowing web pages to chose font, which produces a strange look.

Please see screen dumps to see results, and a Google Chrome comparison for a Facebook page

My conclusion is there is a bug in my Firefox rendering of the Lucida Grande font (and not any other fonts). So I tried downloading and installing the Lucida Grande font manually - but that did not change anything at all.

 : ((

/fl

Screendump 3 original file : https://dl.dropbox.com/u/4105623/FF-FF-CH.png

Modified by mandragor

Question owner

One more angle on this:

I tried my old Firefox 3,6 portable version and the Facebook page clearly renders better (but not as good as Chrome!)

I downloaded Firefox portable version 15. Result is he same font rendering as in my installed version

Se the result in the screen dump comparison

https://dl.dropbox.com/u/4105623/Comparison%20Portable%20Firefox%20versions.png

Conclusion : Firefox made some change in the version 15 that causes the problem on my PC

I maybe just should start using Google Chrome for my Facebook visits  ; )

/fl

jscher2000
  • Top 10 Contributor
2348 solutions 20818 answers

I don't know whether you've tried Firefox's Safe Mode. It is a standard diagnostic step to bypass interference by extensions (and some custom settings).

First, I recommend backing up your Firefox settings in case something goes wrong. See Back up and restore information in Firefox profiles. (You can copy your entire Firefox profile folder somewhere outside of the Mozilla folder.)

Next, restart Firefox in Firefox's Safe Mode (Troubleshoot Firefox issues using Safe Mode) using

Help > Restart with Add-ons Disabled

In the dialog, click "Start in Safe Mode."

To go further and disable nonessential plugins, you can try here:

orange Firefox button or classic Tools menu > Add-ons > Plugins category

Do fonts look any different?

Question owner

Thank you for engaging.

I did all you suggested, and disabled all addons and also all plugins in safe mode - But unfortunately the look of my Facebook page is exactly same as before : (

So, maybe I just have to learn to live with the blurry Lucida Grande rendering, and hope Firefox will fix it in some coming update ...

/fl

jscher2000
  • Top 10 Contributor
2348 solutions 20818 answers

Chosen Solution

Aha, I don't have Lucida Grande, so I'm seeing Tahoma (like most Windows users). Did you get the font with an old version of Safari? If the font isn't blurry on Mac, the problem might be too rarely seen to get fixed (or even properly diagnosed...).

azuous01 0 solutions 2 answers

Hi jscher2000

That worked for me, thanks a lot.

azuous01 0 solutions 2 answers

Helpful Reply

My reply was referring to the option:

orange Firefox button or classic Tools menu > Options > Advanced On the "General" mini-tab, uncheck the box for "Use hardware acceleration when available"

Question owner

Yes! There was the solution!

I just removed the Lucida Grande font from my windows system and now the facebook page displays so much better. ( I do not know how I got this font in the first place though)

Thank you jscher2000 once again for your kind help!

/fl

Modified by mandragor

Question owner

removed...

Modified by mandragor