X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I get rid of 'start.search.us.com' always making itself my 'Home Page' on Firefox? And no, the obvious actions will not work.

Posted

I just installed WINDOWS 7. This problem is only on FireFoxm, not on IE or Chrome.

Additional System Details

Installed Plug-ins

  • Google Update
  • 4.1.10329.0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:14.0) Gecko/20100101 Firefox/14.0.1

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10742 solutions 96657 answers

If you do not keep changes after a restart then see:


Are you referring to the search engine on the about:home page?

If there is a problem with searching via the default about:home page then try to reset the search engine used on the about:home page.

Reset the browser.startup.homepage_override.mstone pref via the right-click context menu to the default on the about:config page and close and restart Firefox to restore the about:home page to its default.

  1. Open the about:config page via the location bar
  2. Type in the Filter bar: mstone
  3. Right-click the browser.startup.homepage_override.mstone line and select: Reset
  4. Close and restart Firefox

If this didn't help then delete the delete the chromeappsstore.sqlite file in the Firefox Profile Folder and repeat the above.

Question owner

cor-el, I have a real hard time understand much of anything you wrote. I have no idea what it means 'if you do not keep changes after a restart'. Always in the past when I have made a changed to what website i want as my home page I have never had to do anything else.

I never said anything about the search engine. I have no idea what 'on the about:home page?' is supposed to mean. It is not part of any proper English sentence.

I have no idea what the 'context menu' is. I looked all over FireFox browser and there is no label any where with the word 'context'.

Here is what I see every time I start FireFox. sorry, it looks like I can't put an image in this post box. So the second pic is what I always get for the home page, no matter how many times I might set it to a different web site.

Question owner

i kind of figured out what you were writing and typed in the address bar 'about:config'. Even after doing the reset as you suggested the cursed 'start.search.us' still took over as my home page. See image.

cor-el
  • Top 10 Contributor
  • Moderator
10742 solutions 96657 answers

Are you able to make the change during a session?

Did you check these articles in case you do not keep changes after a restart?

Did you try to start in Safe mode to see if you keep the change there?

If it does work in Firefox Safe-mode then disable all extensions and then try to find which is causing it by enabling one at a time until the problem reappears.

  • Use "Disable all add-ons" on the Safe Mode start window to disable all extensions.
  • Close and restart Firefox after each change via "File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit")

You can use one of these to start Firefox in Safe mode:

  • Help > Restart with Add-ons Disabled
  • On Windows, hold down the Shift key while starting Firefox with a double-click on the Firefox desktop shortcut
  • On Mac, hold down the Options key while starting Firefox

Question owner

Amir 988 wrote "Try to remove the application download it from mozilla.org and reinstall it," I wonder if Amir meant "Try to remove the application you download from mozilla.org and reinstall it,"

If so I don't remember which one it was. I even tried removing and reinstalling FF but that did no good. The home page in IE now is set to this site I do not want. Only Chrome is not affected.

jscher2000
  • Top 10 Contributor
2349 solutions 20825 answers

Hi Rod_Hittle, if you change your home page and it changes back, this usually indicates an unwanted add-on. Could you check the following tabs and disable ALL NONESSENTIAL ADD-ONS, then restart Firefox and see whether you've defeated it?

orange Firefox button or classic Tools menu > Add-ons > Plugins category
orange Firefox button or classic Tools menu > Add-ons > Extensions category

jscher2000
  • Top 10 Contributor
2349 solutions 20825 answers

On another forum, this was mentioned as a "freebie" that might be included in some installs of OpenOffice.org. Usually in that case there is a separate entry for it in the Windows Control Panel > Programs and Features. The trick is figuring out how it's listed...

You also might try supplemental scanners if your security software doesn't pick it up. These two tools are highly regarded:

Malwarebytes Anti-malware : http://www.malwarebytes.org/products/malwarebytes_free

SUPERAntiSpyware : http://www.superantispyware.com/

Tyler Downer
  • Administrator
  • Moderator
1164 solutions 6634 answers

Helpful Reply

This should easily fix this issue and avoid too many steps:

Go to start, then Control Panel, then programs and features. Uninstall anything related to Mystart, start.com, etc. Anything that looks suspicious.

Then, run

After doing all that, Reset Firefox. Firefox reset is the easiest and best way to fix nearly all problems in Firefox:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.

Question owner

Well I went into Plugins and the only thing there was the following: Adobe Acrobat, Citrix ICA Client, Google Update, Java Deployment Toolkit, Java Platform, Silverlight Plugin. I know all of these and believe them to be legit.

Question owner

I looked in control panel/uninstall a program but only found about 22 programs - all legit. But the clue may be with Open Office as I down loaded and installed the latest.

Question owner

jscher2000, I also checked extensions, nothing there. For Anti-virus I use Avast. I am relucted to add and use another.

Question owner

Well, Tylerdowner, you win! You suggested: After doing all that, Reset Firefox. Firefox reset is the easiest and best way to fix nearly all problems in Firefox:

   Go to Firefox > Help > Troubleshooting Information.
   Click the "Reset Firefox" button.
   Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
   Firefox will open with all factory defaults applied. 

I swear I did this before and it did not work. But this time it did. BIG THANKS. I can go back to using FF now.

2 Hawks 0 solutions 2 answers

Well, it worked for you, but not for me. My problem began on Aug 20, 2012 I've tried resetting the home page. I've tried running AVG anti-virus. I've tried running Malwarebytes I've removed the program from my installed programs I've removed the FF Add-Ons I've removed the FF Extensions

This piece of (*&+!!! seems to have arrived when I updated my JRE. However, I also updated OpenOffice to 3.4 at the same time (program name http://sourceforge.net/projects/openofficeorg.mirror/files/stable/3.4.1/Apache_OpenOffice_incubating_3.4.1_Win_x86_install_en-US.exe)

The search thing still re-installs when I launch FF. Only work-around I have discovered is to set the prefs to show a blank page instead of a Home page.

jscher2000
  • Top 10 Contributor
2349 solutions 20825 answers

Hi 2hawks, if you change the home page, but the next time you start it changes back -- and it isn't explained by an add-on -- then you might need to make the fixes described in this article: How to fix preferences that won't save.

2 Hawks 0 solutions 2 answers

It took some effort. The SOLUTION was to use the AddOn SearchReset 0.2 by Gavin Sharp.

Thank you for taking the time to contact me.

2hawks

TimIndy 0 solutions 1 answers

Replacing the search engine search.us.com was simple. However, the browser always going back to search.us.com as the START-UP (HOME PAGE) for the browser was not as easy. After a couple of hours trying numerous recommended fixes, none of which worked. I simply uninstalled FireFox and then reinstalled it and now it's fresh again. Fortunately, this is a new installation and I didn't have very many bookmarks.

jscher2000
  • Top 10 Contributor
2349 solutions 20825 answers

Hi TimIndy, can you take note of what appears on these tabs now (when you do not have the problem) and what appears later if the problem returns?

orange Firefox button or classic Tools menu > Add-ons > Extensions category
orange Firefox button or classic Tools menu > Add-ons > Plugins category

blueridge9 0 solutions 1 answers

Helpful Reply

I got it from updating to Firefox 15! I was ok, updated, and then had it. Resetting to factory default got rid of it. Thanks for that advice, Rod!

mastrkeith 0 solutions 1 answers

I have figured it out and want to share.

After you uninstall and disable the search.us plugins and have run all your antivirus boot scans do this.

1) Open firefox. 2) Look at your address bar and copy the part in bold. www.start.search.us.com/?guide={2C595CC25-35CE-9XTDect ect ect} 3) Start>Search>Find Files or Folders> Search for Phrase> "Paste Copied text"

I found 4 entries in the first 5 min of the search and deleted them. Problem solved. The start page is being directed by those files but, if you have IE troubles do the same search in your regedit because that's where IE stores the offending commands.

HTH


I had this problem begin last week and just figured it out yesterday.

LynnSmith 0 solutions 2 answers

I had this problem too and the easiest way to get rid of this is to first check in your control panel-programs/programs and features - add/remove programs and scroll down the list to search.us ...highlight it and click remove. When asked if you want to restore IE and Firefox to default settings click yes.

If it is not listed in your control panel, open your web browser so the page loads in the search box type anything example firefox when the search page loads scroll down a little and look for the blue link "Download to reinstall" after it downloads reinstall it then go to your control panel and remove as detailed above and the problem will be solved.  :) then go to your downloads and delete it.