X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Since I updated Flash Player to 11.3.300.257 today(06.09.2012), it freezes on launch.

Posted

On today's morning(06.09.2012) I updated my Flash Player to 11.3.300.257 and then launched Firefox. As soon as a site started to appear in browser, Firefox frozen.

So I launched with all add-ons disabled and managed to confirm that Firefox freezes only when Shockwave Flash plugin is enabled

I tried to uninstall and install Flash Player, tried to mess with plugin container, but nothind helped

Chosen solution

Does it help if you disable protected mode in the Flash player?

Read this answer in context 16

Additional System Details

Installed Plug-ins

Adobe Acrobat IE Tab Microsoft Office 2010 Silverlight Shockwave Flash

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20100101 Firefox/13.0

More Information

Application Basics
Name
Firefox
Version
13.0
User Agent
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20100101 Firefox/13.0
Profile Folder
Show Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Crash Reports
about:crashes
Memory Use
about:memory
Extensions
Name
Version
Enabled
ID
Adblock Plus
2.0.3
true
{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}
Add to Search Bar
2.0
true
add-to-searchbox@maltekraus.de
Easy YouTube Video Downloader
6.1
true
{c0c9a2c7-2e5c-4447-bc53-97718bc91e1b}
FireFTP
2.0.4
true
{a7c6cf7f-112c-4500-a7ea-39801a327e5f}
IE Tab 2 (FF 3.6+)
4.1.3.1
true
{1BC9BA34-1EED-42ca-A505-6D2F1A935BBB}
PDF Download
3.0.0.2
true
{37E4D8EA-8BDA-4831-8EA1-89053939A250}
QuickFox Notes
2.7.3
true
amin.eft_bmnotes@gmail.com
SQLite Manager
0.7.7
true
SQLiteManager@mrinalkant.blogspot.com
Undo Closed Tabs Button
3.7.1
true
undoclosedtabsbutton@supernova00.biz
Web Developer
1.1.9
true
{c45c406e-ab73-11d8-be73-000a95be3b12}
CoolPreviews
3.5
false
{CE6E6E3B-84DD-4cac-9F63-8D2AE4F30A4B}
Important Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
accessibility.warn_on_browsewithcaret
false
browser.cache.disk.capacity
1048576
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size_cached_value
1048576
browser.places.smartBookmarksVersion
3
browser.startup.homepage
http://www.itstactical.com/
browser.startup.homepage_override.buildID
20120601045813
browser.startup.homepage_override.mstone
13.0
browser.tabs.warnOnClose
false
dom.event.contextmenu.enabled
false
dom.ipc.plugins.enabled.npietab2.dll
true
extensions.lastAppVersion
13.0
font.internaluseonly.changed
true
gfx.direct2d.disabled
true
layers.acceleration.disabled
true
network.cookie.prefsMigrated
true
permissions.default.image
0
places.database.lastMaintenance
1338561938
places.history.expiration.transient_current_max_pages
104858
places.history.expiration.transient_optimal_database_size
167772160
plugin.disable_full_page_plugin_for_types
application/pdf
privacy.cpd.cookies
false
privacy.cpd.offlineApps
true
privacy.cpd.sessions
false
privacy.donottrackheader.enabled
true
privacy.sanitize.migrateFx3Prefs
true
privacy.sanitize.timeSpan
0
security.enable_tls
false
security.warn_viewing_mixed
false
Graphics
Adapter Description
NVIDIA GeForce 9800 GTX/9800 GTX+
Vendor ID
0x10de
Device ID
0x0612
Adapter RAM
512
Adapter Drivers
nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Driver Version
8.17.12.7533
Driver Date
5-20-2011
Direct2D Enabled
false
DirectWrite Enabled
false (6.1.7601.17789)
ClearType Parameters
DISPLAY1 [ Gamma: 2200 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 50 ] DISPLAY2 [ Gamma: 2200 Pixel Structure: BGR ClearType Level: 0 Enhanced Contrast: 50 ]
WebGL Renderer
Google Inc. -- ANGLE (NVIDIA GeForce 9800 GTX/9800 GTX+) -- OpenGL ES 2.0 (ANGLE 1.0.0.963)
GPU Accelerated Windows
0
JavaScript
Incremental GC
1
Library Versions
Expected minimum version
Version in use
NSPR
4.9
4.9
NSS
3.13.4.0 Basic ECC
3.13.4.0 Basic ECC
NSS Util
3.13.4.0
3.13.4.0
NSS SSL
3.13.4.0 Basic ECC
3.13.4.0 Basic ECC
NSS S/MIME
3.13.4.0 Basic ECC
3.13.4.0 Basic ECC

cor-el
  • Top 10 Contributor
  • Moderator
10740 solutions 96657 answers

Does it have any effect if you disable all extensions (Tools > Add-ons > Extensions) ?

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance/Themes).

Question owner

I disabled all add-ons and themes. Altough it didn't freeze immediately after launch but with small time after, it froze again.

cor-el
  • Top 10 Contributor
  • Moderator
10740 solutions 96657 answers

Chosen Solution

Does it help if you disable protected mode in the Flash player?

Question owner

Thank you, it worked. However, are there any downsides of that solution?

cor-el
  • Top 10 Contributor
  • Moderator
10740 solutions 96657 answers

You will have less protection against malicious Flash files.

See:

Question owner

Any thoughts on that? Will there be fixes for this issue?

kuopiofi 0 solutions 22 answers

As someone with less experience with these things I have to ask about the instructions: To disable, add the following line to your mms.cfg file - ProtectedMode = 0

Should that read as mms.cfgProtectedMode = 0 or mms.cfg ProtectedMode = 0 ?

Question owner

1. Locate the file "mms.cfg" on your hard disk at specified path. If it doesn't exists then create one. Make sure you specify proper extension. 2. Add "ProtectedMode = 0" in the end of the file.

cor-el
  • Top 10 Contributor
  • Moderator
10740 solutions 96657 answers

You also need Administrator permissions to be able to edit the file in that location.

kuopiofi 0 solutions 22 answers

so is it mms.cfgProtectedMode = 0 *or* mms.cfg ProtectedMode = 0 ?

Stupid question but I'm not that good with computers.

Question owner

Why would you add "mms.cfg" in the string? It is the name of the file, not something you write inside it.

knives 0 solutions 2 answers

Helpful Reply

you dont change the name of the file it will still look like mms.cfg what u have to do is open the file with notepad as administrator and you will see this

AutoUpdateDisable=0
SilentAutoUpdateEnable=1

then type in the "ProtectedMode = 0" under that so it looks like this

AutoUpdateDisable=0
SilentAutoUpdateEnable=1
ProtectedMode = 0

then go file save and click save if it says access denied its because ur not running notepad as administrator

click on the windows button go to the search bar and type "notepad" right click notepad and select run as administrator then go to file, open, and type mms.cfg in the bar next to filename click open add the ProtectedMode = 0 line and save it

Modified by cor-el

kuopiofi 0 solutions 22 answers

Thanks, that helped a lot. I suppose it's all too obvious to you smart people, but the rest of us need it in small and simple words. :)

knives 0 solutions 2 answers

alternately if you download the latest version of firefox that works too, i just found out! and it wasnt obvious to me either i just figured it out all these guys and their technical terms didnt help me at all either, is a step by step instructions in plain english so hard? i say no.

Modified by knives

mimihiwatari 0 solutions 1 answers

johnathan6060 > Thanks it worked for me ! I was desperate.

jessbee 2 solutions 25 answers

Here is what happened to me. I downloaded the latest flash player as of June 21. 2012. My firefox was also the latest model. I found the following: On jumble the puzzle did not print, just got a blank blue page and also had system freeze. On sites where I had listened to conference calls I could no longer connect to the calls or hear or see anything except a blank screen. I attempted to reach a site to watch the European bridge championships, and couldn't connect to the site. (You can see I am retired and have a lot of time on my hands.) I fixed the problem by using system restore and going back to June 3, to flash 11 and firefox yahoo 1.9. I am not going to apply any updates to firefox or flash until I hear that the latest editions of each are working together. Chrome worked with the latest adobe flash as far as I can tell, but I prefer firefox. Can anyone find an easy way to use the newest flash and firefox together. The protected disable mode mumbo jumbo was over my head. A place to test the fix would be at jumble . If you don't play the game, you should give it a try. .

Modified by jessbee

kuopiofi 0 solutions 22 answers

Has this problem been solved on latest Firefox update (13.0.1)? I'd rather not risk having to go over this mess again...

http://forums.adobe.com/thread/1022066?tstart=0 explains how to remove the latest flash, worked for me at least.