X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Problem with Flash Player plugin has materialised Firefox 13.0

Posted

Sometime ago i was looking for help with the Flash Plugin crashes. The problem was eased by uninstalling the flash player on the pc and relying on the one built in with Firefox, so that only plugin-container was running. Today, the Flash Player update program appeared and i assumed it was something to do with Firefox. It installed the latest version but then Flash Player Plugin 11_***_*_*_*_** appeared in Task Manager using up loads of memory. Has something changed ? I've tried resetting Firefox and reinstalling it but i cannot get Flash Player without installing the software from Adobe. Windows Vista 32x. Firefox 13.0

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:13.0) Gecko/20100101 Firefox/13.0

More Information

Tyler Downer
  • Top 25 Contributor
  • Administrator
  • Moderator
1166 solutions 6651 answers

Firefox does not have a flash player built into it, so you've been using the Adobe one all along most likely. There are some issues with Flash right now (after their newest update). You can try to reset Firefox and see if that helps. Reset Firefox – easily fix most problems

alexwent 0 solutions 8 answers

Yes, there certainly are issues with Flash right now. But no-one at Adobe has put out any notices, explanations, or apologies about this. I am using a VAIO with 4GB Ram and an Nvidia 230M card. For the last month videos have worked only by disabling hardware acceleration. Even then they are incredibly jerky. I have expert household management and the machine is fast, as is the wifi connexion. This really is not good enough. I appreciate this is not a Firefox problem, but it would be useful for Firefox users to be alerted before they start tinkering needlessly with their setup.

Matt_G
  • Administrator
  • Moderator
380 solutions 1848 answers

In your Tools > Add-ons (or Firefox > Add-ons) do you have RealPlayer Browser Record or do you use any other similar tools that download videos from the web?

If so, can you disable them and restart Firefox to see if that helps. If not, try disabling Protected Mode in Flash with the following steps: http://forums.adobe.com/thread/1018071?tstart=0

We are working with Adobe right now to find out what exactly is happening.

alexwent 0 solutions 8 answers

That was a bizarrely quick reply. Do you see me typing in real time by any chance?! I'll check out what you have suggested. Thanks.

Matt_G
  • Administrator
  • Moderator
380 solutions 1848 answers

I can't see you typing, I'm just lightning fast ;)

alexwent 0 solutions 8 answers

Hi Matt. I do not have the plugin you mentioned. The problem is only with streaming video. I rewrote the cfg file as instructed and note the following. 1) Hardware acceleration still has to be turned off in order to prevent the 'green line of death' (oh, and incidentally I have the latest graphics driver). 2) The jerkiness I spoke of before was intermittent, so although videos are playing OK right now I cannot guarantee that they will do so tomorrow morning. I'm off to bed now (2am here in Europe) so I'll try again tomorrow and let you know. Many thanks for help so far. Alex

Question owner

@Tylerdowner

I had uninstalled Flash Player and i don't have it now. I have downloaded and copied two files , Flashplayer.xpt and NPSWF32.dll , into the plugins folder and now i can view Flash videos again and there is no flash plugin visible in Task Manager. The only Flash videos not working are on the BBC News website, which states i do not have the correct version.

Modified by uk-ok

Question owner

One common problem with Flash Player :

Watching videos on Youtube and at the end of every video, links appear to other videos. At this point, Firefox often stops working and the " Not Responding " graphic appears. Plugin-Container will then use more and more memory until i have to end the process in Task Manager. A similar problem transpires if i have been watching a video and then try to navigate away from the page.

Since Plugin-Container was introduced, the problems with Firefox have increased enormously, although i think much of this is due to Flash being such a greedy piece of software.

Never used to have these problems a few years ago

k6ka 0 solutions 3 answers

I have this problem too; I've noticed that instead of the Flash Player running only in the plug-in container it's now using three processes - plug-in container, and two applications of the Flash Player. If I end any of the three processes the plugin crashes. It was weird. Oh, and the player sucks up processor power like a hummer guzzles gas and the plugin container isn't doing anything at all.

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96959 answers

You see a plugin container process and two Flash plugin processes as the consequence of the Flash plugin now running in a protected sandbox environment.

See:

mysdyva 0 solutions 4 answers

I have also been experiencing problems, but it is not just with video feeds. I play a lot of online flash games, and the flash player frequently crashes. It seems to lock up randomly for about 30 seconds before finally displaying an error message. I will try to investigate it further when it happens again.

Update: I did have a plugin for the VLC media player. I disabled it, and, so far, I have not experienced any issues. It is too early to tell, though.

Modified by mysdyva

Question owner

Thanks for replies, everyone.

I am now experiencing freezes of the Flash plugin and plugin container. Firefox appears to open up another window, which you cannot click on, and the whole browser freezes, usually resulting in the plugin crashing.

Bloody Adobe. Can someone not release a competitor to this ridiculous but essential piece of software ?

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96959 answers

Which version of the Flash player do you have?

Question owner

11,3,300,257

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96959 answers

Try to update to Flash.

Adobe has released a Flash 11.3.300.262 update for Windows, so you can try that Flash version.

You can find the latest Flash player for Firefox on this page.

eric286 0 solutions 1 answers

Helpful Reply

I'm having this problem as well and 11.3.300.262 did not fix it.

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96959 answers

If you can't get Flash 11.3 to work then you can try to revert to Flash 11.2.

You can download the Flash 11.2 player via this direct link:

You need to uninstall the Flash 11.3 version if you downgrade Flash.

freelynn 0 solutions 6 answers

Has anyone loaded the new "Fix" ? from Adobe 6/21/12 Today, the Windows Flash Player plug-in for Firefox, Mozilla, Netscape, Opera and other browsers was updated to 11.3.300.262.

This release addresses stability issue found in Mozilla Firefox. This build does not address the audio issues reported by some customers but we continue to focus on these problems and will continue to do so until they are resolved.

jcanth 3 solutions 35 answers

I updated to 11.3.300.262, but for some reason in my addons manager, it remains as 11.3.300.257. When I go to the Flash site to try and update again, it tells me that I have 257 installed.

But trying to update from the addons manager it says there's no newer version available.

Looking closer, in my Windows/Win32.Macromed/Flash directory, the FlashPlayer Plugin Executable is 11.3.300.262, and right clicking on Flash Content and checking the Plug-in version in the Advanced tap, it comes up as 11.3.300.262 as well.

So I'm guessing that the plug-in has updated, but FF isn't showing it on the Plug-ins Page, and the Flash site isn't recognising it either.

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96959 answers

Helpful Reply

You can check the path of the Flash plugin on the about:plugins page.

Set the plugin.expose_full_path pref to true on the about:config page to see the full path of plugins on the about:plugins page.
It is best not to leave that pref set to true as it exposes that full path to web servers, so reset that pref to false after you are done with the about:plugins page.