X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

WHY do images suddenly not appear or display in my gmail messages using Firefox 12.0 AND 13.0 but I can see them fine in IE9?

Posted

WHY do images suddenly not appear or display in my personal gmail messages using Firefox 12.0 AND 13.0 but I can see them fine in IE9? This is not a problem with images being seen on websites or within the emails from various websites such as Amazon, Bloomies, etc. This is a problem with images copied and pasted while composing emails both in GMAIL and in other email accounts from Windows Live, etc. This started suddenly yesterday when I still had the Firefox 12.0 version. (possibly a few days ago but I hadn't been reading emails too much for a few days due to time constraints). This morning I was trying to find some fix for this by searhcing endlessly through the web and through the Firefox forums here. I checked my version of Firefox and also checked for updates after about 2 hours of searching the forums with no success and I was about to just get rid of Firefox 12 since some people were doing just that out of frustration with finding no solution, when I suddenly got an update message from Firefox 'strongly urging' me to update to Firefox 13. This was AFTER I'd just checked an hour earlier to see if there was any update! I did that update to version 13.0 BUT I still do not receive emails containing images with those images displaying (messages sent from my other email account to myself, and also emails sent from a friend - both containing images). However, I can send and receive those same emails through IE9 in my gmail account and see all the images FINE through IE9. What gives? I am so tired of this happening. It happened before about a year or so ago but I do not recall how it was ever remedied. I believe it was resolved by a Firefox fix and no action on our part. And this 4+ hours of working on this is just insane. WHO has this kind of time to spend fixing these glitches that happen every time Firefox updates? I can't even find any mention of the same issue. Now I'm seriously behind. Talk about Time-constraints! Anyone else having this issue? Anyone found a remedy yet?

Chosen solution

If images are missing then check that you aren't blocking images from some domains.

  • Check the permissions for the domain in the current tab in "Tools > Page Info > Permissions"
  • Check that images are enabled: Tools > Options > Content: [X] Load images automatically
  • Check the exceptions in "Tools > Options > Content: Load Images > Exceptions"
  • Check the "Tools > Page Info > Media" tab for blocked images (scroll through all the images with the cursor Down key).

If an image in the list is grayed and there is a check-mark in the box "Block Images from..." then remove that mark to unblock the images from that domain.

Make sure that you do not block third-party images, the permissions.default.images pref should be 1.

There are also extensions (Tools > Add-ons > Extensions) and security software (firewall, anti-virus) that can block images.

Read this answer in context 0

Additional System Details

This happened

A few times a week

This started when...

Recently - within the past day, possibly the past week.

Installed Plug-ins

All have been checked & rechecked and are Up To Date: Active Touch General Plugin 2.7.0.7, Adobe Acrobat 10.1.3.23, Coupons Inc. Printer Manager 4.0.1.3, Google Update 1.3.21.111, Java Deployment Toolkit 6.0.310.5, Java Platform SE 6 U31 6.0.310.5, Microsoft Windows Media Player Firefox Plugin 1.0.0.8, Quick Time Plugin 7.7.2 7.7.2.0, Shockwave Flash 11.2.202.235, Silverlight Plugin 5.1.10411.0, Windows Genuine Advantage 1.9.42.0, Windows Live Photo Gallery 14.0.8117.416.

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:13.0) Gecko/20100101 Firefox/13.0

More Information

This happened in Firefox 12.0 first, and now, after just updating this morning, it is happening in Firefox 13.0.
It does not happen when I view my gmail account through IE9.
Emails come through normally and all pictures are viewable. I can also paste pictures into emails in IE9 and they go through fine but I cannot paste images into Gmail messages again today.

cor-el
  • Top 10 Contributor
  • Moderator
10761 solutions 96850 answers

Chosen Solution

If images are missing then check that you aren't blocking images from some domains.

  • Check the permissions for the domain in the current tab in "Tools > Page Info > Permissions"
  • Check that images are enabled: Tools > Options > Content: [X] Load images automatically
  • Check the exceptions in "Tools > Options > Content: Load Images > Exceptions"
  • Check the "Tools > Page Info > Media" tab for blocked images (scroll through all the images with the cursor Down key).

If an image in the list is grayed and there is a check-mark in the box "Block Images from..." then remove that mark to unblock the images from that domain.

Make sure that you do not block third-party images, the permissions.default.images pref should be 1.

There are also extensions (Tools > Add-ons > Extensions) and security software (firewall, anti-virus) that can block images.

Question owner

Thank you for your prompt email. I have thoroughly checked and double-checked all the factors below. On two different computers. Unfortunately, nothing has helped yet.

I can assure you that each item listed below has been checked several times during all my searching today and ALSO again right now. There are no problems with Plugins, Themes or Extensions found. No permissions blocked, No media blocked images, No third-party permissions blocked. No images blocked from any domains. And images are 'Enabled'. There are no exceptions in place to the loading images. No exclusions in my security software settings.

AND I have checked all of this on a second computer that is also having this same problem. That person is using a different security software than I am but they are having the same problem with images in only their Gmail account also - but NOT when using IE9. Only when signing in through Firefox. And we both think it started yesterday or this morning.

That pc is still on Firefox version 12.0. I updated earlier today to version 13.0 but the problem is still ongoing for both of us.

Any further help will be greatly appreciated. I have to get something accomplished. WAY behind now. Thank you, ElaineB.

cor-el
  • Top 10 Contributor
  • Moderator
10761 solutions 96850 answers

Clear the cache and the cookies from sites that cause problems.

"Clear the Cache":

  • Tools > Options > Advanced > Network > Offline Storage (Cache): "Clear Now"

"Remove Cookies" from sites causing problems:

  • Tools > Options > Privacy > Cookies: "Show Cookies"

Question owner

All cache and ALL Cookies have been cleared. Done AGAIN right now too.

There are no particular 'sites' that are causing problems that we know of yet other than google gmail. ONLY GMAIL problems with images in messages not displaying and the problem of not being able to paste an image into a message when composing an email in Gmail. Gmail messages arrive without the images. However, the same emails DO SHOW All Images when received in Gmail accounts through IE9.

No problems viewing images within Gmail email messages from websites like Amazon, Staples, etc. Appreciate any input. Thanks, ElaineB.