Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Master Password AFTER the fact

  • 18 replies
  • 3 have this problem
  • 859 views
  • Last reply by rocketmouse

more options

http://input.mozilla.org/en-US/feedback#sad: For several versions now (I think since 10) the password request doesn't come up until I'm done with, in this case, banking. In other words, Firefox let me sign in to the banking site and complete my transactions never once asking for the password. It wasn't until I quit Firefox that the boxed-in request for the password came up. I shudder to think what would happen if somebody (not necessarily bad or evil, but of course that) sat down in front of my computer and proceeded to launch Firefox, never once getting a password request until quitting. I imagine they would just walk away, (evil) deed accomplished. Is there another way to lock Firefox?

Firefox 12.0 in OS X 10.6.8 on MacBook Pro (model 5,1)

Submit Feedback in Firefox doesn't work! The only things blocked by Ghostery were WebTrends and New Relic, but when I unblocked them Submit still didn't work. Using Camino now to post this.

Chosen solution

Make sure that your text isn't too long if the submit button isn't working on the input.mozilla.org site.

Read this answer in context 👍 1

All Replies (18)

more options

You can Disable remembering your Usernames & Passwords in Firefox, as described in this article -> Security and passwords settings

  • Remove checkmark from Remember passwords for sites -> click OK

Check and tell if its working.

more options

But, but... The whole point of using a master password would be to protect the other ones, no? If I don't even use the feature (by disabling it) what's the point?

more options

Oh, and, I don't think that will solve the feedback problem.

more options

Instead of Disabling the Remember Password for sites feature, you can do the following:

  1. Set Cookies to Ask me everytime as described in this article -> Settings for privacy, browsing history and do-not-track
  2. Perform the suggestions mentioned in the following articles:

Check and tell if its working.


For Submit Feedback button not working, Start Firefox in -> Diagnose Firefox issues using Troubleshoot Mode to check if your add-ons/extensions are causing the problems.

Check and tell if its working normally while using Firefox in Diagnose Firefox issues using Troubleshoot Mode.

Modified by NoahSUMO

more options

Are you seriously suggesting I reset all my Firefox settings for cookies (in which case I'd have to change the browsing history setting,) browsing history (set to never remember,) do-not-track (checked,) and the master password in order to "solve" the fact that Firefox doesn't ask for my master password until I close it?

Running Firefox in Safe Mode, with no add-ons/extensions, did not enable the Submit Feedback button.

more options

It will not Reset all your Firefox settings, just change the Cookies setting and try.

You can revert the settings back to your preferred state if it doesn't fulfil your requirement.

Modified by Hasan

more options

Is the password manager used to fill the name and password?

If you type the name and password yourself then the password manager isn't involved.

The master password is only needed when the password manager is used to save or retrieve a name/password from the password manager.

On Mac you may also be using the Keychain services.

more options

In order to change the Cookies settings I had to change the browsing history setting to customize, then I had to allow third party cookies so that the Ask option would come up, and after that the Enter Password box still didn't come up until I ended the session. I even signed in to my bank's online banking site to make absolutely sure, and while it asked to set some 20+ cookies (excessive to my mind) Firefox still didn't ask for my master password like it used to in the past.

I also tried Submit Feedback with those settings. That didn't work either.

more options

If you still have cookies set that make the website remember you then try to clear the cookies from those sites.

If clearing the cookies doesn't help then it is possible that the file cookies.sqlite that stores the cookies is corrupted.
Rename (or delete) cookies.sqlite (cookies.sqlite.old) and delete other present cookie files like cookies.sqlite-journal in the Firefox Profile Folder in case the file cookies.sqlite got corrupted.

more options

That (both links, but especially the first one) was some heady reading! I searched (using part of the URL) my Keychain Access to see if my bank's password was stored there. It was not, at least not based on that search. Am I to understand (sorry, some of that was way over my head) that this explains why the master password request doesn't come up until after the session?

more options

Do you get the master password prompt if you access the password manager to view the passwords?

  • Firefox > Preferences > Security: Passwords: "Saved Passwords" > "Show Passwords"
more options

Can you try disabling the InFormEnter addon and let me know if that helps? I have a gut feeling its responsible for the master password prompt problem.

Go to:
Tools > Add-ons > Extensions, then click on it & choose Disable. Then restart Firefox.

For the submit button issue, I can only guess another addon is responsible. Maybe Adblock Plus is blocking a script there?

Modified by NoahSUMO

more options

cor-el: After I renamed the cookies.sqlite (there was no cookies.sqlite-journal) I don't get a password prompt even when I quit Firefox. I had already cleared all the cookies earlier.

I did get the password prompt when accessing the password manager to view the passwords--as a matter of fact, twice, which is a good thing.

Noah_SUMO: Isn't (Wasn't) the InFormEnter add-on disabled in Safe Mode? And also any other add-on (including Adblock Plus?) Just to be certain, I re-started Firefox in Safe Mode and looked in Tools. Sure enough, they're all disabled, including both InFormEnter and Adblock Plus.

I went to http://input.mozilla.org/en-US/feedback#sad again in Safe Mode and the Submit Feedback button really doesn't work. I must conclude that none of my add-ons/extensions are blocking it.

mha007, cor-el, Noah_SUMO: Thank you for all you help! I think the safest action for me right now is to go to my online banking site in Safe Mode(?) In any case, I didn't know that I could use Safe Mode in Firefox 12 by merely launching it with the option key held down. That's nice.

more options

Hey rocketmouse
You're right. Sorry about repeating a step you already tried. All add-ons are disabled in Safe Mode. I thought you only tested the broken submit button problem when you were in Safe Mode.

At first I thought you had Javascript disabled. But I checked with that off and the Submit button still worked. If you're curious: Tools > Options > Content - Enable Javascript.

I also tried searching the Firefox bugs reports about the master pass prompt to see if maybe a bug has popped up where this happens. It's super strange. I'm wondering do you have any AV software installed on your mac? I know macs hardly ever get viruses. But I'm wondering if another program is monitoring Firefox and possibly conflicting with it. Like another password manager like KeePass.

Another idea is that the prompt is somehow hidden off screen somewhere. After you login to your bank site or any site, can you attempt to view all open windows & see if the master password prompt appears? This article has ways of accessing hidden windows on Mac: Access hidden minimized windows - Macworld

I'm thinking the master password prompt appears but gets stuck in a hidden state. By chance is there more than one Firefox.app running? You can check with Activity Monitor: How to View Running Processes on Mac OS X.

Seems like we're all grasping at straws. I'll give this some more thought and get back to you.

Modified by NoahSUMO

more options

Chosen Solution

Make sure that your text isn't too long if the submit button isn't working on the input.mozilla.org site.

more options

Re: Submit Feedback. "Make sure that your text isn't too long if the submit button isn't working on the input.mozilla.org site." That's it! Thank you core-el! Somebody over there is going to be puzzled by a message that reads "Testing, one, two, three..." It would have been nice to have had some feedback myself on the text being too long, other than the button not working. From now on I will know to keep it "short and sweet," but what about somebody else?

Re: Master Password Prompt. Yes, I have AV software installed. It's ClamXav. Normally the only thing running from it is the Sentry, which I have set to watch over my downloads folder, three different transfer-to-Windows folders, and Mail. No other password manager. A very (very!) long time ago, on another machine from which this OS installation was transferred, I had tried out 1password, but the only remnant of it I could find was an icon (jpg.) Also I have tried LastPass (in 2010) for which I now found an Uninstall.app which I promptly ran (with meager results.) I suspect I uninstalled LastPass a long time ago already.

If the prompt is hidden off screen somewhere Activity Monitor doesn't know about it. I could only see one instance of Firefox. And while I have never hidden Firefox itself, the second method (in the article) of finding hidden windows in the dock also yielded nothing.

more options

I had a similar problem. I have been using Gmail for several years. (Quite happily too, until the recent mandatory change, but that's another tirade for another day.)

When I discovered what a simple matter it was for anyone to walk up to my computer and, in less than 15 seconds, see all my saved passwords, I got a little freaked out. So I did some research and learned about master passwords. This worked quite well for me, until about a week ago.

Since one of my homepages is my email inbox, the normal behavior for Firefox is to ask for my master password as soon as I open firefox. But last week I noticed that launching Firefox went straight to my private inbox, and it wasn't until I tried to go to some other site requiring a password that Firefox asked for my Master PW.

After reading most of this thread, I decided that my issue must be with cookies. So this is what I did, and what happened.

I opened Firefox, which instantly exposed my email inbox. Then I opened Firefox>Tools>Options>Privacy, then clicked the "Remove individual cookies" option. In the search field I typed Gmail, and I started removing cookies that looked unnecessary. Then I noticed that the URL for my Gmail inbox doesn't actually have the word Gmail in it, it says mail.google.com. So I changed my search criteria to Gmail, and started deleting everything UNLESS it looked like a site I visit often, or one where I probably created an account. Finally, I was deleting a long string of cookies titled: support.google.com, and after I deleted about the 6th one, something exciting happened: My inbox disappeared, replaced by the login screen for gmail, with the request for master password over them all. I finished off the other support.google.com cookies, and shut down firefox. When I re-launched Firefox, it went back to the way I wanted it: asking for the master PW before launching my private email account.

I don't know if this is helpful to you, but I wanted you to know that your thread helped me find my way "home."

Thanks!

Rev. Tie-Dye

(FYI: I'm running on a Win 7 machine, always with current Firefox.)

more options

When I decided to follow through on your (RevTieDye) reply about cookies (sounded reasonable) I discovered another problem with Firefox (now v 15.0.1 on my Mac in OS X 10.6.8). The box (under The following cookies are stored on your computer:) in the window that opens when you click on Show Cookies, in Privacy, is so small (i.e. short) I can just barely see the first two entries. There doesn't seem to be any way to lengthen/enlarge it. Also, after I clicked Remove All Cookies (which seemed to work--I did have to do it twice) and then checked again they, at least the two top ones I could partially see, were back again.

I again tackled the issue of renaming sqlite, having previously forgotten and had my banking site remember my user name.

None of this seems to have done anything for the Master Password issue I was having--and still have. I just don't feel as safe doing my banking online as I used to. It was a nice feeling to think that nobody else could try to access my online banking without being asked for a Master Password. I noticed they updated the Password Manager today (after I did my banking) so perhaps that will help. As they say, hope springs eternal <g>

-rocketmouse