X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

firefox added a "search bar" as a tab. I don't want it. How do I get rid of it?

Posted

This was solved a long time ago. I previously flagged it as solved. I continue to get suggestions.. I don't need them. I've tried "unsubscribe" too, but I still get answers. NO FURTHER ANSWERS ARE NEEDED. Thank you. recently Firefox installed a search bar in line with my tabs. I don't want it and can't find how to get rid of it.

Modified by jnoecker

Chosen solution

I tried all the manual removals only to be left with Funmoods showing up as intermittent search engine. Firefox version 15 Go to Help: Troubleshooting Information; Reset Firefox

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 1.6.0_31 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Shockwave Flash 11.1 r102
  • iTunes Detector Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.2
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • wpidetector
  • np-mswmp
  • Office Plugin for Netscape Navigator

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:11.0) Gecko/20100101 Firefox/11.0

More Information

Vivek 310 solutions 2084 answers

Hi,

Please check if this happens in Safe Mode.

Problematic Extensions

Troubleshooting Extensions and Themes

Uninstalling Add-ons

Uninstalling Toolbars

Safe mode disables the installed Extensions, and themes (Appearance) in Tools (Alt + T) > Add-ons. Hardware acceleration is also temporarily disabled - the manual setting is Tools > Options > Advanced > General > Use hardware acceleration when available. Options > Advanced. All these settings/add-ons can also be individually or collectively disabled/enabled/changed in Firefox normal mode to check if an extension, theme or hardware acceleration is causing issues.

Options

Question owner

I think perhaps you misread my question, or I didn't state it very well. During the last firefox update a new tab showed up on my tab (always on) line. It's a moderately long tab with green, blue, red, and yellow dots (one each) and the words "search here" Next to it is a little box with an "i" inside a circle. If I click on that I get this "Search faster with the updated search bar" no other identification of the, I presume, add on. You can see it in the partial screen shot in the attached image. I have looked through add ons and managing, but I can not identify this as being enabled. I want to get rid of it.

jscher2000
  • Top 10 Contributor
2348 solutions 20818 answers

Is that Firefox's built-in search box, or something from an add-on?

Assuming it's Firefox's search box, can you use the Customize feature to move that search box back to the Navigation toolbar?

Alt+v (displays classic View menu) > Toolbars > Customize

If it's from an add-on, perhaps you can identify the culprit from the search engine it uses?

Question owner

The last item in your suggestions tells me it's from Yahoo. I've gone through add-ons manager and tools, options, but can't find it, let alone how I get rid of it.

Vivek 310 solutions 2084 answers

You can try to check in the Windows Control Panel Programs and Features for anything related to Yahoo, other than the main applications. Please note that though the search may be going to Yahoo, it could have been installed by a completely different application. You can try to click on the small down arrow on the left side of the search bar. It may have a settings option or a name. If it's still present in Safe Mode, it may not be an addon.

Question owner

It is still there in Safe Mode. I am not able to find any identifying information on it. It definitely has been made part of the tabs. If I move the tabs around (on top or not) it moves with them. There was nothing in the Programs and Features that was any help.

Vivek 310 solutions 2084 answers

Please also check if this is present in a new profile.

Profiles Howto

dpackard 0 solutions 2 answers

Helpful Reply

It seems to part of the add-ons. I was able to remove it by going to the add-ons in the Firefox menu, and taking to following steps:

Add-ons menu, Extensions, Default tab, Click "remove" (I tried just disabling it, but it didn't seem to work, so I removed it.)

It should then ask if it's ok to restart and when it opens up again, the search box should be gone. Hope this helps, it worked for me.

Modified by dpackard

Kittylost 0 solutions 1 answers

Helpful Reply

Thank you so very much for the information on getting rid of that search tab ....I have been trying to figure it out since yesterday when it popped up. I was getting aggravated with it. Nothing I tired worked, again thank you for the help...

losttherace 0 solutions 5 answers

I have the same problem, but the 'search here' came with a nasty little virus from funmoods, which hijacked my browserS. I've been everywhere in searching for an answer, I've run Hijackthis, Malwarebytes,, Spybot S&D, CCleaner,, Hitman Pro, Ultrablue Reg cleaner, defragged 'C', RogueKiller....now the actual virus seems to be gone, but the 'search here' box is still the second tab, no matter. I even searched the registry and deleted all keys related to start.funmoods.com...I still have the box. I also did the easy things, like removing the add-on, etc from firefox. I'm thoroughly stumped. Any help is more than appreciated. :)

jscher2000
  • Top 10 Contributor
2348 solutions 20818 answers

Hi losttherace, you have a search box on your tab bar? If you click the icon in the search box, do you get a drop-down list with Manage Search Engines at the bottom? If so, try removing the unwanted search plugin there.

If you already removed it but you want to move the box itself to another location, try the Customize feature:

Alt+v (displays classic View menu) > Toolbars > Customize

You should be able to drag the search box to another bar, or back into the Customize dialog (to remove it from all toolbars, including the tab bar).

If that doesn't help, could you post a screen shot of the box you have on your tab bar?

If it's a tab with an actual web page, rather than a toolbar item, you might have multiple home pages. You can check that here:

(WIN) orange Firefox button or classic Tools menu > Options > General
(MAC) Firefox > Preferences > General

losttherace 0 solutions 5 answers

Well, I hate to say, that didn't work. I've done most of that, yet this morning, 'search here' I had to delete from the 'manage search engines' (again) on the right side of the browser, where google search is. I tried to drag it into the customize area and it wouldn't go; it took google search and my URL bar instead. I've almost decided this is a royal fubar that I'll never get repaired. I can't just click, as I used to, on a + to add a new tab, I have to go 'file', new tab. :( I can't do the 'manage search engines from the 'pinwheel' 'search here'.....it doesn't show the option. Pulling my hair out, but surely appreciate your attempt. Oh, one more thing, each time I reboot the computer, it returns in the 'manage search options' list and I have to remove it, yet the orange pinwheel search area stays. Thanks

Modified by losttherace

jscher2000
  • Top 10 Contributor
2348 solutions 20818 answers

I recommend backing up your Firefox settings in case something goes wrong with the following operation. See Back up and restore information in Firefox profiles. (You can copy your entire Firefox profile folder somewhere outside of the Mozilla folder.)

Please disable ALL nonessential extensions here:

orange Firefox button or classic Tools menu > Add-ons > Extensions category

See below for updated procedure
Next, restart Firefox in Firefox's Safe Mode (Troubleshoot Firefox issues using Safe Mode) using

Help > Restart with Add-ons Disabled

In the Safe Mode dialog, check the box for "Reset Toolbars and Controls" and click Make Changes and Restart. This should clear customizations to your toolbars that may have been injected by the add-on.

Is it clean and does it stay clean?


Note: The Safe Mode dialog has changed in Firefox 15, so the above-referenced checkbox is no longer there.

To do the same thing in Firefox 15 and later, you can manually rename or delete the file that stores the toolbar customizations. Here's how:

(1) Open your personal settings (AKA Firefox profile) folder

Help > Troubleshooting Information > "Show Folder" button

(2) Switch back to Firefox and exit the program (e.g., Firefox > Exit or File > Exit)

(3) Wait a few moments for Firefox to finish updating files in your settings folder, then rename localstore.rdf to something else, like localstore-bad.rdf or localstore.old. Alternately, you can delete the file.

(4) You're done with your profile folder and you can restart Firefox now.

Modified by jscher2000

losttherace 0 solutions 5 answers

If you were here I'd kiss you! Did exactly as you said, then rebooted system, too, and it is gone. Now I have to replace my add ons but no biggie. If it returns after being off all night.....I'll be back. Thank you oh so much!!!

cor-el
  • Top 10 Contributor
  • Moderator
10740 solutions 96657 answers

See also http://www.funmoods.com/english/faq#a6

losttherace 0 solutions 5 answers

I had done all that prior, and the only one who could tell me how to remove it was jscher2000..I had to safe mode Firefox. :) Thanks !

ejypt101 0 solutions 3 answers

I did what you said and the disabling worked for me but I think I will remove it anyway so it (hopefully) doesn't happen again. As far as I know, I didn't ask for it and I don't want it.

jscher2000
  • Top 10 Contributor
2348 solutions 20818 answers

Hi ejypt101, could you post the name of the bad extension so people searching for it find this thread? Thanks.

ejypt101 0 solutions 3 answers

It was named "Default Tab" in my extensions.

ejypt101 0 solutions 3 answers

"Default Tab" put an unwanted search tab in the space where the actual tabs are and I couldn't get rid of it and I saw dpackard's post, tried it, and it worked for me. Some might have to remove it completely to get it to go away, but, thankfully, just disabling it helped.