X
Tap here to go to the mobile version of the site.

Support Forum

Flat Buttons on the Firefox

Posted

When i play certain Text based games using Firefox 7 , I see that all clickable buttons in that game are flattened , eg .. the button is like ""Try again"" "Do now" ""Attack"" "Run" "Do Crime"" all these clickable icons are as flat as the whole page . But when i use my Friend PC , he is using old firefox like 3.6 , there i saw all these clickable buttons or icons are distinctly elevated ones . So i totally have no idea how can i play my games with these old style elevated clickable link . Is it something to do with about:config or what ? Do think about my problem here . Thank you so much for the help.

PS...I added 2 links for the icons i mentioned to make you all see clearly.

1.This is the flat button that i dont like. http://img845.imageshack.us/img845/5690/flatbutton.jpg

2.This is the elevated button that i want to use. http://img266.imageshack.us/img266/2159/elevated.jpg

When i play certain Text based games using Firefox 7 , I see that all clickable buttons in that game are flattened , eg .. the button is like ""Try again"" "Do now" ""Attack"" "Run" "Do Crime"" all these clickable icons are as flat as the whole page . But when i use my Friend PC , he is using old firefox like 3.6 , there i saw all these clickable buttons or icons are distinctly elevated ones . So i totally have no idea how can i play my games with these old style elevated clickable link . Is it something to do with about:config or what ? Do think about my problem here . Thank you so much for the help. PS...I added 2 links for the icons i mentioned to make you all see clearly. 1.This is the flat button that i dont like. http://img845.imageshack.us/img845/5690/flatbutton.jpg 2.This is the elevated button that i want to use. http://img266.imageshack.us/img266/2159/elevated.jpg

Additional System Details

Installed Plug-ins

  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 1.6.0_29 for Mozilla browsers
  • Shockwave Flash 11.1 r102
  • Google Update
  • Version 2.5.8.4958
  • Google Talk Plugin Video Accelerator version:0.1.44.14
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • Plug-in for detecting Nero Kwik Media.
  • Adobe PDF Plug-In For Firefox and Netscape 10.0.0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:7.0.1) Gecko/20100101 Firefox/7.0.1

More Information

Question owner

Can someone sort it out this problem please?

Can someone sort it out this problem please?
Swarnava Sengupta
  • Locale Leader
493 solutions 3273 answers

upgrade your browser to Firefox 8 and check

upgrade your browser to Firefox 8 and check * getfirefox.com

Question owner

I' m afraid some of my add-ons cant be compatible with Firefox 8.

even with Firefox 7 , there are some add-ons still not compatible.

I' m afraid some of my add-ons cant be compatible with Firefox 8. even with Firefox 7 , there are some add-ons still not compatible.
Swarnava Sengupta
  • Locale Leader
493 solutions 3273 answers

can you tell me which addon do you use?

can you tell me which addon do you use?

Question owner

1.Adobe Acrobat x 2.Java console 6.0.29 (if that is not necessary , how can i remove it ?)

1.Adobe Acrobat x 2.Java console 6.0.29 (if that is not necessary , how can i remove it ?)
Swarnava Sengupta
  • Locale Leader
493 solutions 3273 answers
both are compatible with Firefox 8, <br> See * http://support.mozilla.com/en-US/kb/Uninstalling%20add-ons#w_how-to-remove-extensions-and-themes

Question owner

i installed firefox 8 but my above problem is the same.

i installed firefox 8 but my above problem is the same.
cor-el
  • Top 10 Contributor
  • Moderator
17571 solutions 158915 answers

Make sure that you allow pages to choose their colors and that you haven't enabled High Contrast in the Accessibility settings.

  • Tools > Options > Content : Fonts & Colors > Colors : [X] "Allow pages to choose their own colors, instead of my selections above"

See also:

Make sure that you allow pages to choose their colors and that you haven't enabled High Contrast in the Accessibility settings. *Tools > Options > Content : Fonts & Colors > Colors : [X] "Allow pages to choose their own colors, instead of my selections above" See also: *http://kb.mozillazine.org/Website_colors_are_wrong *http://kb.mozillazine.org/Websites_look_wrong

Question owner

cor-el ! I have checked that color ..and yes it allowed pages to choose their own colors .

1 clue i observed after reading ur links , i changed View -->Page Style ---> No style and yes these buttons turn as elevated ones but i cant use ""No style "" only for the sake of Elevated button coz page is too ugly..:P

2nd clue i found out is .... it is nothing to do with Windows 7 or XP (already tested) Flat buttons has changed since Firefox 4. (Elevated buttons on old firefox)

3rd clue is ....when i refresh that page which contains these buttons , i just quickly saw Elevated Buttons (in the middle of page loading) But once page loading has complete , it turns to Flat buttons.

I will be so much impressed with the one who can find out this problem.

cor-el ! I have checked that color ..and yes it allowed pages to choose their own colors . 1 clue i observed after reading ur links , i changed View -->Page Style ---> No style and yes these buttons turn as elevated ones but i cant use ""No style "" only for the sake of Elevated button coz page is too ugly..:P 2nd clue i found out is .... it is nothing to do with Windows 7 or XP (already tested) Flat buttons has changed since Firefox 4. (Elevated buttons on old firefox) 3rd clue is ....when i refresh that page which contains these buttons , i just quickly saw Elevated Buttons (in the middle of page loading) But once page loading has complete , it turns to Flat buttons. I will be so much impressed with the one who can find out this problem.

Question owner

2 printscreen of the buttons

2 printscreen of the buttons
cor-el
  • Top 10 Contributor
  • Moderator
17571 solutions 158915 answers

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

Start Firefox in <u>[[Safe Mode]]</u> to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes). *Don't make any changes on the Safe mode start window. *https://support.mozilla.com/kb/Safe+Mode