Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I get rid of Coupons Browser update?


How do I get rid of the Coupons Browser pop-up? It's annoying.

Additional System Details

This happened

Every time Firefox opened

This started when...

about 1 month ago

Installed Plug-ins

  • Plug-in for detecting Nero Kwik Media.
  • Google Update
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 10.3 r181
  • iTunes Detector Plug-in
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 1.6.0_25 for Mozilla browsers
  • Zeon PDF Plugin For Mozilla
  • Adobe PDF Plug-In For Firefox and Netscape 10.0.0
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • 3.0.40624.0


  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0.1) Gecko/20100101 Firefox/7.0.1

More Information

asgz 0 solutions 1 answers

I fixed the problem I think, somehow some browser toolbar loaded to my ff and I uninstall it. Than this pop-up gone.

kenc1 0 solutions 2 answers

I have the same problem. I first encountered the pop up 2/22/2012 while visiting coupons.com. I updated to Firefox 10.0.2 plus all add-ons. I am still searching for the source of the problem. If disable add-ons, and restart it does not occur.

I have just a few add-ons , which are the basics.

Modified by kenc1

kenc1 0 solutions 2 answers

disable startnow toolbar

jsmonger1 0 solutions 1 answers

Helpful Reply

It is in Tools>Add Ons>Extensions

There is an extension called Start Now Toolbar.....just remove it.

giancarlosp7 0 solutions 1 answers

After investigating, the pop up seems to be coming from www.dropinsavings.com.

To opt-out go to http://www.dropinsavings.com/optout.php.

Their site also gives you instruction to uninstall the add-on. Check out the picture I uploaded.

Modified by giancarlosp7

gggcc 2 solutions 11 answers

Helpful Reply

You have to kill it in two places. FF must be generating revenue from this.

Goto Add-ons

1) Click on the Plug Ins tab.

   Disable both "Coupon Inc" addons.  For some reason I had two.

2) Click on the Extensions tab

   Disable the "Start Now toolbar"

What a pain.