X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do I disable the "Text Enhance" affiliate platform that is present on all my web surfing

Posted

When I use the Firefox browser to surf the web, on nearly every web page I visit an invasive advertising platform creates anchor links on the web pages (anchor keywords with two hyperlinks under the anchor word) which when clicked takes the viewer to an advertisement. Most of the links seem to be part of an advertising platform owned by "Text Enhance," which I have contacted to complain about. They sort of played dumb. I said I thought it was the result of some malware from which they were the sole beneficiary and they assured me they didn't instigate it. I went to the Warrior Forum and some members suggested it sounded like it came from one of your extensions or plugins. My security and technology consultant scrubbed my computer and they deleted some of your extensions and plugins and the problem went away. But two weeks later, it's back and it's pervasive. Even words in my online banking accounts are showing these text links.

Aside from security concerns, my biggest fear is that they are stealing traffic from the websites I publish--websites where I'm trying to sell either my own or affiliate products. And that upsets me greatly.

I'm sure I'm not the only web user experiencing this problem. If other web publishers are also getting their traffic stolen and directed to a competing site, you can bet that there will be a class action lawsuit on the horizon for Mozilla. So I suggest you get to the bottom of this situation and rectify it, because a lawsuit will be the inevitable result.

I don't mean to alarm you because I use Firefox as my primary browser. However, I checked IE and Chrome and Chrome is exhibiting the same situation. So I'm not really sure how this is happening, and that's why I'm contacting you about it.

Please let me know if you know how to de-activate this invasive pest.

Regards, Tom O'Boyle toboyle9@yahoo.com

Modified by toboyle9

Chosen solution

I eliminated it by removing the StartNow toolbar via: Tools > Add-Ons > Extensions


Edit: Please also see these great answers by EmailyDesarno

EmailyDesarno's post on page 2:
I searched Google and forums and they all say to go here to remove text enhance.

Most also say opting out will only bring you more spam, so I would not do that if experts are saying not to.

Sooo.. go to this website, it has the most info on this and I found it useful, I have no connection to them it's just to help. http://botcrawl.com/how-to-remove-text-enhance/


EmailyDesarno's post on page 3
DO NOT OPT OUT

That will cause more spam, it is not a solution.

I've already said it, all the solutions you need to remove Text Enhance are here:

http://botcrawl.com/how-to-remove-text-enhance/

Read this answer in context 37

Additional System Details

This happened

A few times a week

This started when...

about six weeks ago

Installed Plug-ins

  • Shockwave Flash 11.0 r1
  • Google Update
  • 4.0.60831.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • RealJukebox Netscape Plugin
  • RealNetworks(tm) RealPlayer Chrome Background Extension Plug-In
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 12.0.1.660
  • Adobe Shockwave for Director Netscape plug-in, version 11.6
  • iTunes Detector Plug-in
  • Adobe PDF Plug-In For Firefox and Netscape "9.4.5"
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 1.6.0_26 for Mozilla browsers
  • NPWLPG
  • np-mswmp
  • Office Plugin for Netscape Navigator

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:7.0.1) Gecko/20100101 Firefox/7.0.1

More Information

UPDATE!!!! 10/16/11
This situation is caused by an advertising company whose adverting platform places cookies on browsers who allow cookies. The cookies enable the Text Enhance platform to convert keywords it finds on the websites' content into text links for its own affiliates. In other words, it is stealing traffic from websites and re-directing it to its own list of affiliates. They enable viewers who are savvy enough to figure it out to de-activate the program on their own sites and tell them to add a Text Enhance id name to the "do not accept cookies from" their site and give the user the code to insert into his or her browser settings. However, 99% of the people visiting websites have no vested interest in this abuse, don't realize one anchor link from another and don't have any inclination to change their browser settings. Bottom line: Web Publishers who are making their living selling advertising, products, and services on their websites are losing the traffic they works so hard for to this traffic theft. I think the only solution is for legal action, most likely in the form of a class action lawsuit, preceded by a court injunction getting Text Enhance to stop using this software until it is resolved in a court.

cor-el
  • Top 10 Contributor
  • Moderator
10776 solutions 96976 answers

See [/questions/871383]

mcchucker 0 solutions 1 answers

You can click on the ? mark in the the ad that pops-up to opt out. Or just go this link http://optout.textsrv.com/optout.php which remembers your ip address to opt-out and disable the ads. After opting out close your browser and reopen again ads should no longer be showing.

If that does not work just block the url http://textsrv.com in internet options tool settings.

You can do that by clicking on tools in your toolbar then click on internet options/security/retricted sites/sites and then place the url http://textsrv.com in the add to the restricted sites field and your done

Modified by mcchucker

MaryPat 0 solutions 5 answers

internet options/security/retricted sites/sites does not exist.

? mark in the the ad that pops-up has no effect at all

I can't help but think that mcchucker works for Text Enhance. This is a dreadful, harrassing, intrusive popup and the only solution I can think of is to NOT even try to open the underlined link once you see the popup because the originator of the text never did put in a hyperlink ... there is nothing there to see except the ad the popup wants you to respond to.

dalegarvey 0 solutions 3 answers

I run an E-commerce website and it is not fun to have people directed away from my site by this malicious nonsense who do I blame the perpetrators or the browser suppliers who allow these people to steal my business by directing people away from my site to competitors and non-associated sites? I hope Mozilla has a solution like Google. But the present version comes in a little download bundle of notepad ++ so avoid this like the plaugue.

Modified by dalegarvey

dalegarvey 0 solutions 3 answers

No Because even if you opt out, that doesn't stop these people from directing others away from a legitimate E-commerce site trying to sell products online.

MaryPat 0 solutions 5 answers

Exactly. I have quickly closed some interesting websites because I thought there was a real hyperlink to some real information, only to get the aggravating message that I have won something that I have to provide my email address to receive. At least now I know that, (if I'm right), the Text Enhance gremlin has simply chosen a random word in an otherwise innocent website and turned it into a link to itself, and I am not missing anything by simply ignoring the pop-up and moving on to the rest of the website's information.

Yes, I would love it if this pop-up could be eliminated altogether, but I don't have the skill or the patience to carry out some of the fixes suggested by those more technically inclined.
BigOrienteer 0 solutions 2 answers

Helpful Reply

In my case it was Codec-C causing the problem - go to Tools|add ons in Firefox and delete Codec-C (100% malware - won't affect anything else apart from solving this problem).

Good luck

Giles

Browser69 0 solutions 2 answers

I went to control panel add or remove programs, and i found JetMP3, which I did not install. I removed it from my computer, and text enhance problems went away. So just search like I did and remove any unknown programs.

Modified by Browser69

NUGGETRON 0 solutions 1 answers

What happened to me was that this malware came with an audio converter, and installed itself as something called "I Want This!" It showed up in all my browsers, so I googled it. Here's what I found: http://wafflesatnoon.com/2011/10/05/seeing-unwanted-text-enhance-ads/ It solved the problem for me, hopefully for you too.

MaryPat 0 solutions 5 answers

I, too, got rid of the text enhance problem by removing something on Add/Remove, just can't recall what it was I removed. No problems since then.

Modified by MaryPat

Wynter 1 solutions 10 answers

Removing CodecC worked for me. Thanks BigOrienteer! :)

Browser69 0 solutions 2 answers

I went to add or remove programs,and found what was called Jp3. I dont know what it was,but i removed it and the text enhance stopped.

shelleyowens 1 solutions 9 answers

Chosen Solution

I eliminated it by removing the StartNow toolbar via: Tools > Add-Ons > Extensions


Edit: Please also see these great answers by EmailyDesarno

EmailyDesarno's post on page 2:
I searched Google and forums and they all say to go here to remove text enhance.

Most also say opting out will only bring you more spam, so I would not do that if experts are saying not to.

Sooo.. go to this website, it has the most info on this and I found it useful, I have no connection to them it's just to help. http://botcrawl.com/how-to-remove-text-enhance/


EmailyDesarno's post on page 3
DO NOT OPT OUT

That will cause more spam, it is not a solution.

I've already said it, all the solutions you need to remove Text Enhance are here:

http://botcrawl.com/how-to-remove-text-enhance/

Modified by Noah_SUMO

macfox111 0 solutions 2 answers

Helpful Reply

In addition to "codec C" there's also a "codec M". I had M but not C. Disable or uninstall it in the "Add-ons" window, then restart firefox and the damn thing is GONE, GONE ! HOORAY! ANOTHER WAY FOR GNOMES TO SAY "HOOOOOOOORAY"(pink floyd's first album-ha!)

Modified by macfox111

garret27 0 solutions 1 answers

I joined the support page here at Mozzilla to say I had the exact same problem with the same maleware. Cheers!

ChrissiMoon 0 solutions 3 answers

I found that if I disable Shockwave Flash - it is gone - but then I cannot watch certain videos until I enable it or download update. When I do... TextEnhance is back! WTF.. It is really annoying me now! I do not have any of the other add-ons that people are suggesting to use. Help! :(

glendene 0 solutions 3 answers

I would love to know if there is a way that we can all band together and recruit as many people as we can through our contact lists, article submission, blogs etc and blast the hell out of these @#$%^ pirates and bring down their servers. I opted out but it did not go away. They are STEALING potential customers from my affiliate sites and I am really p'd off.

danana 0 solutions 1 answers

yes chrissimoon, i took that same advice - and suffered the same conciquence

THEN i switched to the 'extention' tab on my add-ons manager, and removed something called 'bflix 5.0'

that seems to have worked, also i swithched 'shockwave flash' back on, and all ok

hope this works for you?

ChrissiMoon 0 solutions 3 answers

I think I've sorted it out! I've downloaded THIS (AdBlock Plus)

https://addons.mozilla.org/en-US/firefox/addon/adblock-plus/

And then this also Element Hiding Helper:

http://adblockplus.org/en/elemhidehelper

My problem was in Flash/Shockwave.. but if I disabled it I couldn't watch or view many things. This has sorted my problem with Text Enhance AND I can keep Flash enabled! :D

beaky01 0 solutions 1 answers

i found an extention by going into tools then add ons in msn ,mozilla and chrome called i want this disable or remove and the problem (so far) seems to have gone away, no more text enhance !