X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

problems with localhost

Posted

Just after updating to Firefox 7 I can no longer move around in localhost as usual. I type in an url and get a Google search instead of the page I'm looking for. How can I get the previous version back so that I can get some work done? And why are you hiding the http://? It seems to me that you might be trying to emulate Microsoft to the point of working (not working) like Microsoft.

Main page I get to.. localhost/Taste cow/

need to get to.. localhost/Taste cow/backend/

Just get Google search.

Chosen solution

Hi, I also have this issue.

Until there is a official update to fix this you can get around it by changing an about:config option.


Get the Full URL Back in Firefox 7

1. In Firefox's URL bar, type in: about:config and agree to the pop-up message.

2. Search for: browser.urlbar.trimURLs.

3. Double-click or right-click and select "toggle" to change the value to false. Now you'll get the full HTTPS or HTTP in the URL so you won't be confused on whether you're viewing a secure site.


This will enable you to visit localhost again.

Source: http://lifehacker.com/5844471/get-the-full-url-back-in-firefox-7

Fusey

Read this answer in context 12

Additional System Details

This happened

Not sure how often

This started when...

Upgraded to Firefox 7

Installed Plug-ins

  • Shockwave Flash 10.3 r183
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 1.7.0 for Mozilla browsers
  • GEPlugin
  • Wacom Dynamic Link Library
  • Adobe PDF Plug-In For Firefox and Netscape
  • 6.0.12.69
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • 6.0.12.1040

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:7.0) Gecko/20100101 Firefox/7.0

More Information

Fusey 1 solutions 1 answers

Chosen Solution

Hi, I also have this issue.

Until there is a official update to fix this you can get around it by changing an about:config option.


Get the Full URL Back in Firefox 7

1. In Firefox's URL bar, type in: about:config and agree to the pop-up message.

2. Search for: browser.urlbar.trimURLs.

3. Double-click or right-click and select "toggle" to change the value to false. Now you'll get the full HTTPS or HTTP in the URL so you won't be confused on whether you're viewing a secure site.


This will enable you to visit localhost again.

Source: http://lifehacker.com/5844471/get-the-full-url-back-in-firefox-7

Fusey

Question owner

Thanks for the reply. I did find Firefox 6 and reinstalled and am a bit gun shy about using V7 after reading about the issues people are having. It's good to have more in one's artillery to be able to cope with such issues. Didn't even have a clue about being able to get deeper into Firefox's config, awesome.

Spambanjo 0 solutions 2 answers

Thanks for the solution, this worked for me. I can't believe 7 actually went live like this and hasn't been immediately hotfixed :(

cvwillegen 0 solutions 1 answers

It's also in FF8 beta...

Question owner

Sh!t, version 8 and they still haven't fixed this. Where are their heads at? Maybe it's time to switch browsers. :(