Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

localhost not working

  • 3 replies
  • 1 has this problem
  • 22 views
  • Last reply by TyDraniu

more options

Hi, I'm using wampserver for web development and need to access localhost in order to view/debug my pages. FF redirect http://localhost to https://localhost and then shows "Unable to connect" error. After wrestling with Wamp/Apache/PHP settings and googling for a day I just noticed that this only happens on Firefox and all other browser working normally. Is there any solution for this?

All Replies (3)

more options

Hmm, could this be caused by the "HTTPS Only" feature? You can toggle that off on the Settings page. More info: HTTPS-Only Mode in Firefox.

Helpful?

more options

Could be right hint but I checked and see its not enabled on my side

Helpful?

more options

This is strange. On my side, when Apache is providing anything on that port, there's no redirect. When Apache is off, it goes to https.

Check browser.fixup.fallback-to-https and dom.security.https_first preferences in about:config.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.